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NATIONAL CYBERSECURITY CENTER OF EXCELLENCE 1 

The National Cybersecurity Center of Excellence (NCCoE), a part of the National Institute of Standards 2 

and Technology (NIST), is a collaborative hub where industry organizations, government agencies, and 3 

academic institutions work together to address businesses’ most pressing cybersecurity issues. This 4 

public-private partnership enables the creation of practical cybersecurity solutions for specific 5 

industries, as well as for broad, cross-sector technology challenges. Through consortia under 6 

Cooperative Research and Development Agreements (CRADAs), including technology partners—from 7 

Fortune 50 market leaders to smaller companies specializing in information technology security—the 8 

NCCoE applies standards and best practices to develop modular, easily adaptable example cybersecurity 9 

solutions using commercially available technology. The NCCoE documents these example solutions in 10 

the NIST Special Publication 1800 series, which maps capabilities to the NIST Cybersecurity Framework 11 

and details the steps needed for another entity to re-create the example solution. The NCCoE was 12 

established in 2012 by NIST in partnership with the State of Maryland and Montgomery County, 13 

Maryland. 14 

To learn more about the NCCoE, visit https://www.nccoe.nist.gov. To learn more about NIST, visit 15 

https://www.nist.gov. 16 

NIST CYBERSECURITY PRACTICE GUIDES 17 

NIST Cybersecurity Practice Guides (Special Publication 1800 series) target specific cybersecurity 18 

challenges in the public and private sectors. They are practical, user-friendly guides that facilitate the 19 

adoption of standards-based approaches to cybersecurity. They show members of the information 20 

security community how to implement example solutions that help them align more easily with relevant 21 

standards and best practices, and provide users with the materials lists, configuration files, and other 22 

information they need to implement a similar approach. 23 

The documents in this series describe example implementations of cybersecurity practices that 24 

businesses and other organizations may voluntarily adopt. These documents do not describe regulations 25 

or mandatory practices, nor do they carry statutory authority. 26 

ABSTRACT 27 

Mobile devices provide access to workplace data and resources that are vital for organizations to 28 

accomplish their mission while providing employees the flexibility to perform their daily activities. 29 

Securing these devices is essential to the continuity of business operations.  30 

While mobile devices can increase organizations’ efficiency and employee productivity, they can also 31 

leave sensitive data vulnerable. Addressing such vulnerabilities requires mobile device management 32 

tools to help secure access to the network and resources. These tools are different from those required 33 

to secure the typical computer workstation.  34 

https://www.nccoe.nist.gov/
https://www.nist.gov/
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To address the challenge of securing mobile devices while managing risks, the NCCoE at NIST built a 35 

reference architecture to show how various mobile security technologies can be integrated within an 36 

enterprise’s network.  37 

This NIST Cybersecurity Practice Guide demonstrates how organizations can use standards-based, 38 

commercially available products to help meet their mobile device security and privacy needs. 39 

KEYWORDS 40 

Bring your own device; BYOD; corporate-owned personally-enabled; COPE; mobile device management; 41 

mobile device security, on-premise. 42 
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1 Introduction 292 

The following volumes of this guide show information technology (IT) professionals and security 293 

engineers how we implemented this example solution. We cover all of the mobile device security 294 

products employed in this reference design. We do not re-create the product manufacturers’ 295 

documentation, which is presumed to be widely available. Rather, these volumes show how we 296 

incorporated the products together in our environment. 297 

Note: These are not comprehensive tutorials. There are many possible service and security configurations 298 

for these products that are out of scope for this reference design. 299 

1.1 Practice Guide Structure 300 

This National Institute of Standards and Technology (NIST) Cybersecurity Practice Guide demonstrates a 301 

standards-based reference design and provides users with the information they need to replicate 302 

addressing mobile device security (MDS) implementation challenges. This reference design is modular 303 

and can be deployed in whole or in part. 304 

This guide contains three volumes: 305 

▪ NIST SP 1800-21A: Executive Summary 306 

▪ NIST SP 1800-21B: Approach, Architecture, and Security Characteristics – what we built and why 307 

▪ NIST SP 1800-21C: How-To Guides – instructions for building the example solution (you are 308 
here) 309 

Depending on your role in your organization, you might use this guide in different ways: 310 

Business decision makers, including chief security and technology officers, will be interested in the 311 

Executive Summary, NIST SP 1800-21A, which describes the following topics: 312 

▪ challenges that enterprises face in securely deploying mobile devices within their organization 313 

▪ example solution built at the National Cybersecurity Center of Excellence (NCCoE) 314 

▪ benefits of adopting the example solution 315 

Technology or security program managers who are concerned with how to identify, understand, assess, 316 

and mitigate risk will be interested in NIST SP 1800-21B, which describes what we did and why. The 317 

following sections will be of particular interest: 318 

▪ Section 3.4, Risk Assessment, describes the risk analysis we performed. 319 

▪ Section 4.3, Security Control Map, discusses the security mappings of this example solution to 320 
cybersecurity standards and best practices. 321 
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You might share the Executive Summary, NIST SP 1800-21A, with your leadership team members to help 322 

them understand the importance of adopting standards-based solutions when addressing MDS 323 

implementation challenges. 324 

IT professionals who want to implement an approach like this will find this whole practice guide useful. 325 

You can use this How-To portion of the guide, NIST SP 1800-21C, to replicate all or parts of the build 326 

created in our lab. This How-To portion of the guide provides specific product installation, configuration, 327 

and integration instructions for implementing the example solution. We do not recreate the product 328 

manufacturers’ documentation, which is generally widely available. Rather, we show how we 329 

incorporated the products together in our environment to create an example solution. 330 

This guide assumes that IT professionals have experience implementing security products within the 331 

enterprise. While we have used a suite of commercial products to address this challenge, this guide does 332 

not endorse these particular products. Your organization can adopt this solution or one that adheres to 333 

these guidelines in whole, or you can use this guide as a starting point for tailoring and implementing 334 

parts of this guide’s example solution for on-premises mobile device security management. Your 335 

organization’s security experts should identify the products that will best integrate with your existing 336 

tools and IT system infrastructure. We hope that you will seek products that are congruent with 337 

applicable standards and best practices. Section 3.6, Technologies, lists the products that we used and 338 

maps them to the cybersecurity controls provided by this reference solution. 339 

A NIST Cybersecurity Practice Guide does not describe “the” solution, but a possible solution. This is a 340 

draft guide. We seek feedback on its contents and welcome your input. Comments, suggestions, and 341 

success stories will improve subsequent versions of this guide. Please contribute your thoughts to 342 

mobile-nccoe@nist.gov. 343 

1.2 Build Overview 344 

When a business is on the go, mobile devices can serve as a temporary workstation replacement. They 345 

provide convenience of use, portability, and functionality. However, in many ways, mobile devices are 346 

different from the common computer workstation, and alternative management tools are required to 347 

secure their interactions with the enterprise. To address this security challenge, the NCCoE worked with 348 

its Community of Interest and build team partners and developed a real-world scenario for mobile 349 

deployment within an enterprise. The scenario presents a range of security challenges that an enterprise 350 

may experience when deploying mobile devices. 351 

The lab environment used in developing this solution includes the architectural components, 352 

functionality, and standard best practices, which are described in Volume B. The build team partners 353 

provided the security technologies used to deploy the architecture components and functionality. The 354 

standard best practices are applied to the security technologies to ensure the appropriate security 355 

controls are put in place to meet the challenges presented in the devised scenario. 356 
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This section of the guide documents the build process and discusses the specific configurations used to 357 

develop a secure mobile deployment. 358 

Note: Android for Work has been re-branded as Android Enterprise. At the time of writing this 359 

document, it was named Android for Work. 360 

1.3 Typographic Conventions 361 

The following table presents typographic conventions used in this volume. 362 

Table 1-1 Typographic Conventions 363 

Typeface/Symbol Meaning Example 

Italics file names and path names; 
references to documents that 
are not hyperlinks; new 
terms; and placeholders 

For detailed definitions of terms, see 
the NCCoE Glossary. 

Bold names of menus, options, 
command buttons, and fields 

Choose File > Edit. 

Monospace command-line input, 
onscreen computer output, 
sample code examples, and 
status codes 

mkdir 

Monospace Bold command-line user input 
contrasted with computer 
output 

service sshd start 

blue text link to other parts of the 
document, a web URL, or an 
email address 

All publications from NIST’s NCCoE 
are available at 
https://www.nccoe.nist.gov. 

1.4 Logical Architecture Summary 364 

The following graphic illustrates the main components of this example implementation and provides a 365 

simplified view of how they interact. 366 

https://www.nccoe.nist.gov/
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Figure 1-1 Logical Architecture Summary 367 

 

2 Product Installation Guides 368 

This section of the practice guide contains detailed instructions for installing and configuring key 369 

products used for the architecture illustrated below. 370 

In our lab environment, the example solution was logically separated by a virtual local area network 371 

(VLAN) wherein each VLAN represented a separate mock enterprise environment. The network 372 

perimeter for this example implementation was enforced by a Palo Alto Networks virtual private 373 

network (VPN)/firewall appliance. It maintains three zones: one each for the internet/wide area network 374 

(WAN), a demilitarized zone (DMZ), and the organizational local area network (LAN). 375 

2.1 Appthority Mobile Threat Detection 376 

Appthority contributed a test instance of its Mobile Threat Detection service. Contact Appthority 377 

(Symantec) (https://www.symantec.com/) to establish an instance for your organization. 378 

https://www.symantec.com/
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2.2 Kryptowire EMM+S 379 

Kryptowire contributed a test instance of its EMM+S application-vetting service. Contact Kryptowire 380 

(https://www.kryptowire.com/mobile-app-security/) to establish an instance for your organization. 381 

2.3 Lookout Mobile Endpoint Security 382 

Lookout contributed a test instance of its Mobile Endpoint Security (MES) service. Contact Lookout 383 

(https://www.lookout.com/products/mobile-endpoint-security) to establish an instance for your 384 

organization. 385 

2.4 MobileIron Core 386 

MobileIron Core is the central product in the MobileIron suite. The following sections describe the steps 387 
for installation, configuration, and integration with Active Directory (AD).  388 

2.4.1 Installation of MobileIron Core and Stand-Alone Sentry 389 

Follow the steps below to install MobileIron Core: 390 

1. Obtain a copy of the On-Premise Installation Guide for MobileIron Core, Sentry, and 391 

Enterprise Connector from the MobileIron support portal. 392 

2. Follow the MobileIron Core predeployment and installation steps in Chapter 1 of the On-393 

Premise Installation Guide for MobileIron Core, Sentry, and Enterprise Connector for the 394 

version of MobileIron being deployed in your environment. In our lab implementation, we 395 

deployed MobileIron Core 9.5.0.0 as a Virtual Core running on VMware 6.0. Post-396 

installation, we performed an upgrade to MobileIron Core 9.7.0.1 following guidance 397 

provided in CoreConnectorReleaseNotes9701_Rev12Apr2018. Direct installations to 398 

MobileIron Core 9.7.0.1 will experience slightly different results, as some added features in 399 

this version are not used with earlier versions of configuration files. 400 

2.4.2 General MobileIron Core Setup 401 

The following steps are necessary for mobile device administrators or users to register devices with 402 

MobileIron. 403 

1. Obtain a copy of MobileIron Core Device Management Guide for iOS Devices from the 404 

MobileIron support portal. 405 

2. Complete all instructions provided in Chapter 1, Setup Tasks. 406 

https://www.kryptowire.com/mobile-app-security/
https://www.lookout.com/products/mobile-endpoint-security
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2.4.3 Upgrade MobileIron Core 407 

The following steps were used to upgrade our instance of MobileIron Core from 9.5.0.0 to 9.7.0.1. Note 408 

there was no direct upgrade path between these two versions; our selected upgrade path was 9.5.0.0 > 409 

9.5.0.1 > 9.7.0.1. 410 

1. Obtain upgrade credentials from MobileIron Support. 411 

2. In MobileIron Core System Manager, navigate to Maintenance > Software Updates. 412 

3. In the Software repository configuration section: 413 

a. In the User Name field, enter the username provided by MobileIron Support. 414 

b. In the Password field, enter the password provided by MobileIron Support. 415 

c. In the Confirm Password field, reenter the password provided by MobileIron Support. 416 

d. Select Apply. 417 

Figure 2-1 MobileIron Repository Configuration 418 

 

4. In the Software Updates section: 419 

a. Select Check Updates; after a few seconds, the available upgrade path options will 420 

appear. 421 

b. Select the Core 9.5.0.1 status: Not Downloaded option. 422 
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c. Select Download Now. After a delay, the Software Download dialogue will appear. 423 

Figure 2-2 MobileIron Core Version 424 

 

5. In the Download Software dialogue, select OK. 425 
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Figure 2-3 MobileIron Download Status 426 

 

6. In the Software updates section: 427 

a. Select the Core 9.5.0.1 status: Downloaded option. 428 

b. Select the Validate Database Structure and Data option. 429 

c. Select Validate. 430 

Figure 2-4 Validating Database Data 431 

 

7. In the Confirm dialogue, select Yes to validate database structure and data. 432 
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Figure 2-5 Validating Database Data Confirmation 433 

 

8. In the Validate Update dialogue, select OK. 434 

Figure 2-6 Database Data Validation Initiation Confirmation 435 

 

9. In the Software updates section, select Stage for Install; the Download Updates dialogue 436 

will appear. 437 
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Figure 2-7 Database Data Validation Status 438 

 

10. In the Download Updates dialogue, select Reboot Now; a series of dialogues will appear. 439 

Figure 2-8 Software Updates Reboot Prompt 440 

 

11. In the Confirm dialogues: 441 

a. Select Yes to confirm reboot of the appliance. 442 
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Figure 2-9 Software Update Reboot Confirmation 443 

 

b. Select Yes to confirm saving the current configuration. 444 

Figure 2-10 Reboot Configuration Save Prompt 445 

 

12. The Upgrade Status website hosted by Core will automatically open. 446 

Figure 2-11 Upgrade Status 447 

 

13. Once the upgrade is complete, System Manager > Maintenance > Software Updates > 448 

Software Updates now shows the capability to upgrade to 9.7.0.1. 449 
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Figure 2-12 Ability to Upgrade to 9.7.0.1 450 

 

14. Repeat Steps 4b through 11 above, replacing 9.5.0.1 with 9.7.0.1 during Steps 4b and 6; 451 

this will complete the upgrade path from MobileIron Core 9.5.0.0 to 9.7.0.1. 452 

2.4.4 Integration with Microsoft Active Directory 453 

In our implementation, we chose to integrate MobileIron Core with Active Directory using lightweight 454 

directory access protocol (LDAP). This is optional. General instructions for this process are covered in the 455 

Configuring LDAP Servers section in Chapter 2 of On-Premise Installation Guide for MobileIron Core, 456 

Sentry, and Enterprise Connector. The configuration details used during our completion of selected steps 457 

(retaining the original numbering) from that guide are given below: 458 

1. From Step 4 in the MobileIron guide, in the New LDAP Server dialogue: 459 

a. Directory Connection: 460 
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Figure 2-13 LDAP Settings 461 

 

b. Directory Configuration—OUs: 462 

Figure 2-14 LDAP OUs 463 

 

c. Directory Configuration—Users:  464 
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Figure 2-15 LDAP User Configuration 465 

 

d. Directory Configuration—Groups:  466 

Figure 2-16 LDAP Group Configuration 467 
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e. LDAP Groups:  468 

i. As a preparatory step, we used Active Directory Users and Computers to create 469 

a new security group for mobile-authorized users on the Domain Controller for 470 

the govt.mds.local domain. In our example, this group is named Mobile Users. 471 

ii. In the search bar, enter the name of the LDAP group for mobile-authorized 472 

users. 473 

iii. Select the magnifying glass button; the group name should be added to the 474 

Available list. 475 

iv. In the Available list box: 476 

1) Select the Mobile Users list item. 477 

2) Select the right-arrow button; the Mobile Users list item should move to 478 

the Selected list box. 479 

v. In the Selected list: 480 

1) Select the default Users group list item. 481 

2) Select the left-arrow button; the Users list item should move to the 482 

Available list box. 483 

Figure 2-17 Selected LDAP Group 484 

 

f. Custom Settings: Custom settings were not specified. 485 

g. Advanced Options: Advanced options were configured as shown in Figure 2-18. 486 
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Figure 2-18 LDAP Advanced Options 487 

 

Note: In our lab environment, we did not enable stronger Quality of Protection or enable the Use of 488 

Client Transport Layer Security Certificate or Request Mutual Authentication features. However, we 489 

recommend that implementers consider using those additional mechanisms to secure communication 490 

with the LDAP server. 491 

2. From Steps 19 through 21 from the MobileIron guide, we tested that MobileIron can 492 

successfully query LDAP for Derived Personal Identity Verification Credential (DPC) Users. 493 

a. In the New LDAP Setting dialogue, click the Test button to open the LDAP Test dialogue. 494 

b. In the LDAP Test dialogue, enter a User ID for a member of the DPC Users group, then 495 

click the Submit button. A member of the Mobile Users group in our environment is 496 

gema.  497 
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Figure 2-19 Testing LDAP Configuration 498 

 

c. The LDAP Test dialogue indicates the query was successful:  499 

Figure 2-20 LDAP Test Result 500 
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2.4.5 Create a Mobile Users Label 501 

MobileIron uses labels to link policies and device configurations with users and mobile devices. Creating 502 

a unique label for each category of authorized mobile user allows mobile device administrators to apply 503 

a consistent set of controls applicable to users with a common mobile use case. Our limited usage 504 

scenario only required a single MobileIron label to be created. 505 

1. In the MobileIron Core Admin Portal, navigate to Devices & Users > Labels.  506 

2. Select Add Label. 507 

Figure 2-21 MobileIron Device Labels 508 

 

3. In the Name field, enter a unique name for this label (Mobile Users in this example). 509 

4. In the Description field, enter a meaningful description to help others identify its purpose. 510 

5. Under the Criteria section: 511 

a. In the blank rule: 512 

i. In the Field drop-down menu, select User > LDAP > Groups > Name. 513 

ii. In the Value drop-down menu, select the Active Directory group created to 514 

support mobile user policies (named Mobile User in this example). 515 

b. Select the plus sign icon to add a blank rule. 516 

c. In the newly created blank rule:  517 

i. In the Field drop-down menu, select Common > Platform. 518 

ii. In the Value drop-down menu, select Android. 519 
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Figure 2-22 Adding a Device Label 520 

 

d. The list of matching devices will appear below the specified criteria. 521 

e. Select Save. 522 

Figure 2-23 Device Label Matches 523 

 

6. Navigate to Devices & Users > Labels to confirm the label was successfully created. 524 
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Figure 2-24 MobileIron Label List 525 

 

2.5 Integration of Palo Alto Networks GlobalProtect with MobileIron 526 

The following steps detail how to integrate MobileIron Core, Microsoft Certificate Authority (CA), and 527 

Palo Alto Networks GlobalProtect to allow mobile users to authenticate to the GlobalProtect gateway  528 

using user-aware device certificates issued to mobile devices by Microsoft CA during enrollment with 529 

MobileIron Core. 530 

2.5.1 MobileIron Configuration 531 

The following steps create the MobileIron Core configurations necessary to support integration with 532 

Palo Alto GlobalProtect and Microsoft CA. 533 

2.5.1.1 Create Simple Certificate Enrollment Protocol (SCEP) Configuration 534 

1. In the MobileIron Admin Portal, navigate to Policies & Configs > Configurations. 535 

2. Select Add New > Certificate Enrollment > SCEP; the New SCEP Configuration Enrollment 536 

Setting dialogue will open. 537 

3. In the New SCEP Certificate Enrollment Setting dialogue: 538 

a. For the Name field, enter a unique name to identify this configuration. 539 

b. Enable the Device Certificate option. 540 

c. In the URL field, enter the URL where SCEP is hosted within your environment. 541 

d. In the CA-Identifier (ID) field, enter the subject name of the Microsoft CA that will issue 542 

the device certificates. 543 

e. In the Subject drop-down menu, select $DEVICE_IMEI$. 544 
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Figure 2-25 MobileIron SCEP Configuration 545 

 

f. In the Fingerprint field, enter the fingerprint of the Microsoft CA that will issue the 546 

device certificates. 547 

g. For the Challenge Type drop-down menu, select Microsoft SCEP. 548 

h. Below the Subject Alternative Names list box, select Add; a new list item will appear. 549 

i. For the new list item: 550 

i. For the Type drop-down menu, select NT Principal Name. 551 

ii. For the Value drop-down menu, select $USER_UPN$. 552 

j. Select Issue Test Certificate; the Certificate dialogue should indicate success. 553 

k. In the Certificate dialogue, select OK. 554 
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Figure 2-26 Test SCEP Certificate 555 

 

4. Select Save. 556 
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Figure 2-27 Test SCEP Certificate Configuration 557 

 

2.5.1.2 Create Palo Alto Networks GlobalProtect Configuration 558 

The GlobalProtect configuration instructs the mobile client to connect to use the provisioned device 559 

certificate and to automatically connect to the correct VPN URL; mobile users will not need to manually 560 

configure the application. The following steps will create the GlobalProtect configuration. 561 

1. In the MobileIron Admin Portal, navigate to Policies & Configs > Configurations. 562 

2. Select Add New > VPN; the Add VPN Setting dialogue will appear. 563 

3. In the Add VPN Setting dialogue: 564 

a. In the Name field, enter a unique name to identify this VPN setting. 565 

b. In the Connection Type drop-down menu, select Palo Alto Networks GlobalProtect. 566 

c. In the Server field, enter the fully qualified domain name (FQDN) of your Palo Alto 567 

Networks appliance; our sample implementation uses vpn.govt.mdse.nccoe.org. 568 
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d. For the User Authentication drop-down menu, select certificate. 569 

e. For the Identity Certificate drop-down menu, select the SCEP enrollment profile created 570 

in the previous section. 571 

f. Select Save. 572 

Figure 2-28 MobileIron VPN Configuration 573 

 

2.5.2 Basic Palo Alto Networks Configuration 574 

During basic configuration, internet protocol (IP) addresses are assigned to the management interface, 575 
domain name system (DNS), and network time protocol (NTP). The management interface allows the 576 
administrator to configure and implement security rules through this interface. 577 
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2.5.2.1 Configure Management Interface 578 

The following steps will configure the Palo Alto Networks appliance management interface. 579 

1. In the Palo Alto Networks portal, navigate to Device > Setup > Interfaces. 580 

2. On the Interfaces tab, enable the Management option; the Management Interface Setting 581 

page will open. 582 

Figure 2-29 Palo Alto Networks Management Interface Enabled 583 

 

3. On the Management Interface Setting screen: 584 

a. In the IP Address field, enter the IP address for the Palo Alto Networks appliance. 585 

b. In the Netmask field, enter the netmask for the network. 586 

c. In the Default Gateway field, enter the IP address of the router that provides the 587 

appliance with access to the internet. 588 

d. Under Administrative Management Services: Enable the Hypertext Transfer Protocol 589 

(HTTP), Hypertext Transfer Protocol Secure (HTTPS), Secure Shell (SSH), and Ping 590 

options. 591 

e. Click OK. 592 
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Figure 2-30 Management Interface Configuration 593 

 

4. To verify the configuration, navigate to Palo Alto Networks Portal > Dashboard; the 594 

General Information section should reflect the applianceʼs network configuration. 595 
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Figure 2-31 Palo Alto Networks Firewall General Information 596 

 

2.5.2.2 Configure DNS and NTP 597 

1. In the Palo Alto Networks Portal, navigate to Device > Setup > Services. 598 

2. In the Services tab, select the settings icon. 599 
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Figure 2-32 Palo Alto Networks Services Configuration 600 

 

3. On the Services > Services tab: 601 

a. For the Primary DNS Server field, enter the primary DNS server IP address. 602 

b. For the Secondary DNS Server field, enter the secondary DNS server IP address, if 603 

applicable. 604 

4. Select the NTP tab. 605 
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Figure 2-33 DNS Configuration 606 

 

5. On the NTP tab: 607 

a. For the Primary NTP Server > NTP Server Address field, enter the IP address of the 608 

primary NTP server to use. 609 

b. For the Secondary NTP Server > NTP Server Address field, enter the IP address of the 610 

backup NTP server to use, if applicable. 611 

6. Select OK. 612 
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Figure 2-34 NTP Configuration 613 

 

2.5.3 Palo Alto Networks Interfaces and Zones Configuration 614 

Palo Alto Networks firewall model PA-220 has eight interfaces that can be configured as trusted (inside) 615 

or untrusted (outside) interfaces. This section describes creating a zone and assigning an interface to it. 616 

2.5.3.1 Create Ethernet Interfaces and Addresses 617 

Our example implementation uses three interfaces: 618 

▪ LAN: Orviliaʼs LAN, which hosts intranet web and mail services 619 

▪ DMZ: Orviliaʼs DMZ network subnet, which hosts MobileIron Core and MobileIron Sentry 620 

▪ WAN: provides access to the internet and is the inbound interface for secure sockets layer (SSL) 621 
VPN connections 622 

To create and configure Ethernet interfaces: 623 

1. Navigate to Palo Alto Networks Portal > Network > Ethernet > Interfaces > Ethernet. 624 

Figure 2-35 Ethernet Interfaces 625 
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2. In the Ethernet tab, select the name of the interface to configure; the Ethernet Interface 626 

dialogue will appear. 627 

3. In the Ethernet Interface dialogue: 628 

a. In the Comment field, enter a description for this interface. 629 

b. For the Interface Type drop-down menu, select Layer3. 630 

Figure 2-36 Ethernet Interface Configuration 631 

 

c. Select the IPv4 tab. 632 

d. On the IPv4 tab:  633 

i. In the IP list box, select Add; a blank list item will appear. 634 

ii. In the blank list item, select New Address; the Address dialogue will appear. 635 



DRAFT 

 
NIST SP 1800-21C: Mobile Device Security: Corporate-Owned Personally-Enabled 32 

Figure 2-37 WAN Interface IPv4 Configuration 636 

 

iii. In the Address dialogue: 637 

1) For the Name field, enter a unique name to identify this address. 638 

2) For the Description field, enter a meaningful description of the purpose of 639 

this address. 640 

3) In the unnamed field following the Type drop-down menu, enter the IPv4 641 

address that this interface will use in Classless Inter-Domain Routing 642 

notation. This example uses 10.6.1.2/24 for the WAN interface in our lab 643 

environment. 644 

4) Select OK. 645 
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Figure 2-38 WAN Interface IP Address Configuration 646 

 

e. The address should now appear as an item in the IP list box; select OK; the Address 647 

dialogue will close. 648 

Figure 2-39 Completed WAN Interface Configuration 649 

 

4. Select OK. 650 

5. Repeat Steps 2 and 3 for each of the additional Ethernet/Layer3 interfaces. 651 
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2.5.3.2 Create Security Zones 652 

The PA Security Zone is a collection of single or multiple interfaces that have the same security rules. For 653 

this setup, four different zones have been configured: 654 

▪ Mobile_Lab_GOVT: inside (trusted) interface connecting to the government (GOVT) segment  655 

▪ Mobile_Lab_DMZ: inside (trusted) interface connecting to the DMZ segment 656 

▪ Mobile_Lab_WAN: outside (untrusted) interface to permit trusted inbound connections (e.g., 657 
Lookout cloud service) from the untrusted internet and allow internet access to on-premises 658 
devices 659 

▪ Mobile_Lab_SSLVPN: outside (untrusted) interface for VPN connections by trusted mobile 660 
devices originating from untrusted networks (e.g., public Wi-Fi) 661 

To configure each zone: 662 

1. Navigate to Palo Alto Networks Portal > Network > Zones. 663 

Figure 2-40 Security Zone List 664 

 665 

2. In the Zones pane, select Add; the Zones page will open. 666 

3. On the Zones page: 667 

a. For the Name field, provide a unique name for the zone. 668 

b. For the Type drop-down menu, select Layer 3. 669 

c. Under Interfaces, select Add; a blank drop-down menu will appear. 670 

d. In the drop-down menu, select the interface to assign to this zone; this example shows 671 

selection of ethernet 1/3, which is associated with the LAN interface. 672 
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e. Select OK. 673 

Figure 2-41 LAN Security Zone Configuration 674 

 

f. Repeat Step b for each zone. 675 

2.5.4 Configure Router 676 

Palo Alto Networks uses a virtual router to emulate physical connectivity between interfaces in different 677 

zones. To permit systems to reach systems in other zones, the following steps will create a virtual router 678 

and add interfaces to it. The router also sets which of these interfaces will act as the local gateway to 679 

the internet. 680 

1. In the Palo Alto Networks Portal, navigate to Network > Virtual Routers. 681 

2. Below the details pane, select Add; the Virtual Router form will open. 682 
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3. In the Virtual Router form, on the Router Settings tab: 683 

a. For the Name field, enter a unique name to identify this router. 684 

b. On the Router Settings > General tab: 685 

i. Under the Interfaces list box, select Add; a new list item will appear. 686 

ii. In the new list item drop-down menu, select an existing interface. 687 

iii. Repeat Steps 3a and 3b to add all existing interfaces to this router. 688 

4. Select the Static Routes tab. 689 

5. On the Static Routes > IPv4 tab: 690 

a. Below the list box, select Add; the Virtual Router - Static Route - IPv4 form will open. 691 

b. In the Virtual Router—Static Route—IPv4 form: 692 

i. For the Name field, enter a unique name to identify this route. 693 

ii. For the Destination field, enter 0.0.0.0/0. 694 

iii. For the Interface drop-down menu, select the interface that provides access to 695 

the internet. 696 

iv. For the Next Hop drop-down menu, select IP Address. 697 

v. In the field below Next Hop, enter the IP address of the gateway that provides 698 

access to the internet. 699 

vi. Select OK. 700 
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Figure 2-42 Virtual Router Configuration 701 

 

6. Select OK. 702 
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Figure 2-43 Virtual Router General Settings 703 

 

2.5.5 Configure Tunnel Interface 704 

The SSL VPN uses a tunnel interface to secure traffic from the external zone to the internal zone where 705 

organizational resources available to mobile users are maintained. To configure the tunnel interface: 706 

1. Navigate to Palo Alto Networks Portal > Network > Ethernet > Interfaces > Tunnel. 707 

2. Below the details pane, select Add; the Tunnel Interface form will open. 708 

3. In the Tunnel Interface form on the Config tab: 709 

a. In the Assign Interface To section: 710 

i. For the Virtual Router drop-down menu, select the virtual router created in the 711 

previous section. 712 

ii. For the Security Zone drop-down menu, select the security zone created for the 713 

SSL VPN. 714 

b. Select OK. 715 
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Figure 2-44 SSL VPN Tunnel Interface 716 

 

2.5.6 Configure Applications and Security Policies 717 

Security policies work similarly to firewall rules; they block or allow traffic between defined zones 718 

identified by a source, destination, and application(s) (contextually, Palo Alto Networks’ objects define 719 

network protocols and ports). Palo Alto Networks has built-in applications for a large number of 720 

standard and well-known protocols and ports (e.g., LDAP and Secure Shell), but we defined custom 721 

applications for MobileIron-specific traffic. 722 

2.5.6.1 Configure Applications 723 

The following steps will create an application: 724 

1. In the Palo Alto Networks Portal, navigate to Objects > Applications. 725 
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Figure 2-45 Application Categories 726 

 727 

2. On the Applications screen: 728 

3. Select Add; the Application form will open. 729 

4. On the Application > Configuration screen: 730 

a. In the General > Name field, provide a unique name to identify this application. 731 

b. In the General > Description field, enter a meaningful description of its purpose. 732 

c. For the Properties > Category drop-down menu, select a category appropriate to your 733 

environment; our sample implementation uses networking. 734 

d. For the Properties > Subcategory drop-down menu, select a subcategory appropriate to 735 

your environment; our sample implementation uses infrastructure. 736 

e. For the Properties > Technology drop-down menu, select a technology appropriate to 737 

your environment; our sample implementation uses client-server. 738 

5. Select the Advanced tab. 739 
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Figure 2-46 MobileIron Core Palo Alto Networks Application Configuration 740 

 741 

6. On the Application > Advanced screen: 742 

a. Select Defaults > Port. 743 

b. Under the Ports list box, select Add; a blank list item will appear. 744 

c. In the blank list item, enter the port number used by the application; this example uses 745 

9997. 746 

7. Select OK. 747 
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Figure 2-47 MobileIron Application Port Configuration 748 

 

8. Repeat Steps 2 through 7 with the following modifications to create an application for 749 

MobileIron Core system administration console: 750 

a. Configuration > General > Name is MobileIron8443. 751 

b. Configuration > Default > Category is business-systems. 752 

c. Configuration > Default > Subcategory is management. 753 

d. Advanced > Defaults > Ports > entry_1 is 8443. 754 

2.5.6.2 Configure Security Policies 755 

Security policies allow or explicitly deny communication within, between, or (externally) to or from Palo 756 

Alto Networks zones. For this sample implementation, several security policies were created to support 757 

communication by other components of the architecture. The first subsection covers the steps to create 758 

a given security policy. The second subsection provides a table illustrating the security policies we used; 759 

these policies would need to be adapted to host names and IP addresses specific to your network 760 

infrastructure. 761 
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2.5.6.2.1 Create Security Policies 762 
To create a security policy: 763 

1. In the Palo Alto Networks Portal, navigate to Policies > Security. 764 

2. Select Add; the Security Policy Rule form will open. 765 

3. In the Security Policy Rule form: 766 

a. In the Name field, enter a unique name for this security rule. 767 

b. For the Rule Type drop-down menu, select the scope of the rule. 768 

Figure 2-48 DMZ Access to MobileIron Firewall Rule Configuration 769 

 

4. Select the Source tab. 770 

5. On the Source tab: 771 

a. If the security rule applies to a specific source zone: 772 

i. Under the Source Zone list box, select Add; a new entry will appear in the list box. 773 

ii. For the new list item, select the source zone for this rule. 774 

b. If the rule applies to only specific source IP addresses: 775 
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i. Under the Source Address list box, select Add; a new list item will appear. 776 

ii. For the new list item, select the source address for this rule. 777 

Figure 2-49 DMZ Access to MobileIron Security Rule Source Zone Configuration 778 

 

6. Select the Destination tab. 779 

7. On the Destination tab: 780 

a. If the security rule applies to a specific destination zone: 781 

i. Under the Destination Zone list box, select Add; a new destination list item will 782 

appear. 783 

ii. For the new Source Zone list item, select the destination zone for this rule. 784 

b. If the rule applies to only specific destination IP addresses:  785 

i. Under the Destination Address list box, select Add; a new list item will appear. 786 

ii. For the new list item, select the destination address for this rule. 787 
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Figure 2-50 DMZ Access to MobileIron Security Rule Destination Address Configuration 788 

 

8. Select the Application tab. 789 

9. On the Application tab: 790 

a. Under the Applications list box, select Add; a new list item will appear. 791 

b. For the new Applications list item, select the application representing the protocol and 792 

port combination of the traffic to control. 793 

c. Repeat Steps 9a and 9b for each application involving the same source and destination 794 

that would also have its traffic allowed or explicitly blocked (if otherwise allowed by a 795 

more permissive security rule). 796 
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Figure 2-51 DMZ Access to MobileIron Security Rule Application Protocol Configuration 797 

 

10. Select the Actions tab. 798 

11. On the Actions tab: Unless explicitly blocking traffic permitted by a more permissive 799 

security rule, ensure that the Action Setting > Action drop-down menu is set to Allow. 800 
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Figure 2-52 DMZ Access to MobileIron Security Rule Action Configuration 801 

 

12. Select OK. 802 

2.5.6.2.2 Implemented Security Policies 803 
The implemented security policies are provided in Table 2-1, Table 2-2, and Table 2-3. Configuration 804 

options that aren’t shown were left as their default values. 805 

Table 2-1 Implemented Security Policies 806 

Name Tags Type Source Zone Source Address 

DMZAccessVirtualIPCore none universal Mobile_lab_WAN any 

CoretoAppleSrvs none universal Mobile_Lab_DMZ MI_Core 

AdminAccessToMI none interzone Mobile_Lab_GOVT MDS.govt.admin 

AppthorityConnectorAccessToMI-
Core 

none interzone Mobile_Lab_GOVT govt.appthority 

MICoreObtainDeviceCERT none interzone Mobile_Lab_DMZ MI_Core 

MICoreAccessDNS none interzone Mobile_Lab_DMZ MI_Core 

MICoreRelaySMSNotifications none interzone Mobile_Lab_DMZ MI_Core 

MICoreSyncLDAP none interzone Mobile_Lab_DMZ MI_Core 
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Table 2-2 Implemented Security Policies 807 

Name 

Source 
User 

Source Host  
Information 
Protocol  
Profile 

Destination Zone Destination  
Address 

DMZAccessVirtualIPCore any any any 10.6.1.120 

CoretoAppleSrvs any any any 17.0.0.0/8 

AdminAccessToMI any any Mobile_Lab_DMZ MI_Core;MI_Sentry 
AppthorityConnectorAccessToMI-
Core 

any any Mobile_Lab_DMZ MI_Core 

MICoreObtainDeviceCERT any any Mobile_Lab_GOVT SCEP_server 

MICoreAccessDNS any any Mobile_Lab_GOVT DNS_Server 
MICoreRelaySMSNotifications any any Mobile_Lab_GOVT SMTP_Relay 

MICoreSyncLDAP any any Mobile_Lab_GOVT LDAP_Server 

 
Table 2-3 Implemented Security Policies 808 

Name Application Service Action Profile Options 

DMZAccessVirtualIPCore 
dns;ping;ssl;web
-browsing 

any allow none none 

CoretoAppleSrvs any any allow none none 

AdminAccessToMI 
AdminAccessMI;
ssh;ssl 

any allow none none 

AppthorityConnectorAccessToMI-
Core 

AdminAccessMI;
ssl;web-
browsing 

any allow none none 

MICoreObtainDeviceCERT 
scep;web-
browsing 

application-
default 

allow none none 

MICoreAccessDNS 
dns application-

default 
allow none none 

MICoreRelaySMSNotifications 
smtp application-

default 
allow none none 

MICoreSyncLDAP 
ldap application-

default 
allow none none 

 

2.5.7 Network Address Translation (NAT) 809 

To allow communication with external networks over the internet, the appliance also needs to be 810 

configured with NAT rules. To configure NAT: 811 
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1. In the Palo Alto Networks Portal, navigate to Policies > NAT. 812 

2. Below the details pane, select Add; the NAT Policy Rule form will open. 813 

3. In the NAT Policy Rule form, on the General tab: 814 

a. In the Name field, provide a unique name for this NAT policy rule. 815 

b. Ensure the NAT Type drop-down menu is set to ipv4. 816 

Figure 2-53 Outbound NAT Rule 817 

 

4. Select the Original Packet tab. 818 

5. On the Original Packet tab: 819 

a. Under the Source Zone list box, select Add; a new Source Zone list item will appear. 820 

b. For the new Source Zone list item, select the zone that represents your LAN subnet; in 821 

this sample implementation, that is Mobile_Lab_GOVT. 822 

c. Repeat Steps 5a and 5b to add the zone that represents your DMZ; in this sample 823 

implementation, that is Mobile_Lab_DMZ. 824 

d. Repeat Steps 5a and 5b to add the zone that represents your SSL VPN; in this sample 825 

implementation, that is Mobile_Lab_SSLVPN. 826 

e. For the Destination Zone drop-down menu, select the zone that represents the 827 

internet; in this sample implementation, that is Mobile_lab_WAN. 828 

f. For the Destination Interface, select the adapter that is physically connected to the 829 

same subnet as your internet gateway; in this sample implementation, that is 830 

ethernet1/1. 831 
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g. Under the Source Address list box, select Add; a new Source Address list item will 832 

appear. 833 

h. For the new Source Address list item, select the address that represents the subnet (IP 834 

address range) for the LAN. 835 

i. Repeat Steps 5f and 5g to add the address representing the DMZ subnet. 836 

j. Repeat Steps 5f and 5g to add the address representing the SSL VPN subnet. 837 

Figure 2-54 Outbound NAT Original Packet Configuration 838 

 839 

6. Select the Translated Packet tab. 840 

7. On the Translated Packet tab, under Source Address Translation: 841 

a. For the Translation Type drop-down menu, select Dynamic IP and Port. 842 

b. For the Address Type drop-down menu, select Interface Address. 843 

c. For the Interface drop-down menu, select the same interface selected in Step 5e. 844 

d. For the IP Address drop-down menu, select the IPv4 address on the same subnet as 845 

your internet gateway. 846 
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Figure 2-55 Outbound NAT Translated Packet Configuration 847 

 848 

8. Select OK. 849 

2.5.8 Configure SSL VPN 850 

The SSL VPN enables remote mobile device users to create an encrypted connection to the enterprise 851 

from unencrypted networks (e.g., public Wi-Fi hot spots). 852 

2.5.8.1 Configure End-User Authentication 853 

The following steps establish the integrations and configurations related to mobile user identification 854 

and authentication. 855 

2.5.8.1.1 Configured Server Profile 856 
The following steps integrate this appliance with Microsoft Active Directory Domain Services to manage 857 

mobile user permissions via AD groups and roles. 858 

1. In the Palo Alto Networks Portal, navigate to Devices > Server Profiles > LDAP. 859 

2. Below the details pane, select Add; the LDAP Server Profile form will open. 860 

3. In the LDAP Server Profile form: 861 

a. In the Profile Name field, enter a unique name to identify this profile. 862 

b. Under the Service List box, select Add; a new Server List item will appear. 863 

c. In the new Service List item: 864 

i. In the Name column, enter a name to identify the server. 865 

ii. In the LDAP Server column, enter the IP address of the LDAP server. 866 
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iii. The value in the Port column defaults to 389; change this if your LDAP server 867 

communicates over a different port number. 868 

iv. Repeat Steps 3ci through 3ciii for each LDAP server that you intend to use. 869 

d. Under Server Settings: 870 

i. In the Type drop-down menu, select active-directory. 871 

ii. In the Base DN drop-down menu, select the DN for your Active Directory domain 872 

users who will use the SSL VPN. 873 

iii. In the Bind DN field, enter the Active Directory domain user account that will 874 

authenticate to LDAP to perform queries. 875 

iv. In the Password field, enter the password for the Active Directory user account 876 

specified in the previous step. 877 

v. In the Confirm Password field, reenter the password entered in the previous step. 878 

4. Select OK. 879 

Figure 2-56 LDAP Profile 880 

 



DRAFT 

 
NIST SP 1800-21C: Mobile Device Security: Corporate-Owned Personally-Enabled 53 

2.5.8.2 Configure Authentication Profile 881 

1. In the Palo Alto Networks Portal, navigate to Device > Authentication Profile.  882 

2. Under the details pane, select Add; the Authentication Profile form will open. 883 

3. In the Authentication Profile form: 884 

a. In the Name field, provide a unique name to identify this authentication profile. 885 

b. On the Authentication tab: 886 

i. For the Type drop-down menu, select LDAP. 887 

ii. For the Server Profile drop-down menu, select the name of the LDAP Server 888 

Profile created in the previous section. 889 

iii. For the Login Attribute field, enter userPrincipalName. 890 

iv. For the User Domain, enter the name of your enterprise domain; our sample 891 

implementation uses govt. 892 
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Figure 2-57 Authentication Profile 893 

 

c. Select the Advanced tab. 894 

d. On the Advanced tab: 895 

i. Under the Allow List box, select Add; this will create a new list item. 896 

ii. In the new list item, select the Active Directory group for your mobile users. 897 

iii. Repeat Steps 3di and 3dii for any additional groups that should authenticate to 898 

the SSL VPN. 899 

e. Select OK. 900 
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Figure 2-58 Advanced Authentication Profile Settings 901 

 

2.5.8.3 Configure User Identification 902 

1. In the Palo Alto Networks Portal, navigate to Device & User Identification. 903 

2. In the details pane, select the Group Mapping Settings tab. 904 

3. Below the details pane, select Add the Group Mapping form will open. 905 

4. In the Group Mapping form: 906 

a. In the Name field, enter a unique name to identify this group mapping. 907 

b. In the Server Profile tab: 908 
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i. For the Server Profile drop-down menu, select the LDAP Server Profile created 909 

previously. 910 

ii. For Domain Setting > User Domain, enter the name of your Active Directory 911 

domain; this sample implementation uses govt. 912 

Figure 2-59 LDAP Group Mapping 913 

 
c. Select the Group Includes List tab. 914 

d. On the Group Includes List tab: 915 

i. In the Available Groups list box, expand the Active Directory domain to reveal 916 

configured user groups. 917 

ii. For each Active Directory group to be included in this User Identification 918 

configuration: 919 

1) Select the Active Directory group. 920 
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2) Select the plus icon to transfer the group to the Included Groups list box. 921 

Figure 2-60 LDAP Group Include List 922 

 
5. Select OK. 923 

2.5.8.4 Configure Authentication Policy Rule 924 

1. Navigate to Policies > Authentication. 925 

2. Click Add. 926 

3. Give the policy a name. In this implementation, Mobile_Lab_Auth_Rule was used. 927 

4. Click Source. 928 

5. Under Source Zone, click Add. Select the SSL VPN zone. 929 

6. Under Source Zone, click Add. Select the WAN zone. 930 
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Figure 2-61 Authentication Policy Source Zones 931 

 932 

7. Click Destination. 933 

8. Under Destination Zone, click Add. 934 

9. Select the LAN zone. 935 
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Figure 2-62 Authentication Policy Destination Zones 936 

 

10. Click Service/URL Category. 937 

11. Under service, click Add. 938 

12. Select service-http. 939 

13. Under service, click Add. 940 

14. Select service-https. 941 

15. Click Actions. 942 

16. Next to Authentication Enforcement, select default-web-form. 943 

17. Leave Timeout and Log Settings as their default values. 944 
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Figure 2-63 Authentication Profile Actions 945 

 

18. Click OK and commit the changes. 946 

2.5.9 Import Certificates 947 

Certificates need to be imported into the appliance to configure certificate profiles that will affect how 948 

they are used in supporting communication with other systems. In particular, device certificates issued 949 

to mobile devices will be used to identify and authenticate mobile users. 950 

Note: The certificate private keys must be password-protected to import them into the firewall. 951 

1. In the Palo Alto Networks Portal, navigate to Device > Certificate Management > 952 
Certificates. 953 

2. Under the details pane, select Import; the Import Certificate form will open. 954 

3. In the Import Certificate form: 955 

a. For the Certificate Type, select Local. 956 

b. For the Certificate Name field, enter a unique name to identify this certificate. 957 

c. Next to the Certificate File field, Select Browse... to specify the full path to the file 958 

containing the certificate. 959 

d. For the File Format drop-down menu, select the certificate encoding appropriate to the 960 

certificate file; this example assumes the certificate and private key are in separate files, 961 

and select PEM. Note: The certificate’s private key must be password-protected to 962 

import it into Palo Alto Networks appliances. 963 
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e. If the certificate identifies the Palo Alto Networks appliance: 964 

i. Enable the Import private key checkbox. 965 

ii. Next to Key File, select Browse... to specify the full path to the file containing the 966 

private key for the uploaded certificate. 967 

iii. For the Passphrase field, enter the pass phrase protecting the private key. 968 

iv. For the Confirm Passphrase field, re-enter the pass phrase protecting the private 969 

key. 970 

Figure 2-64 Import MobileIron Certificate 971 

 
f. Select OK. 972 

4. Repeat Step 3 for each certificate to import into the Palo Alto Networks appliance. This will 973 

include all certificates that the appliance will use to identify itself or authenticate to remote 974 

systems, all certificates in the chain of trust for each such certificate, and any chain-of-trust 975 

certificates supporting identity verification for remote systems to which this appliance will 976 
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require certificate-based identification and authentication. This sample implementation 977 

uses certificates for the following systems: 978 

▪ server certificate for this appliance issued by DigiCert 979 

▪ DigiCert root CA certificate 980 

▪ DigiCert subordinate CA certificate 981 

▪ Microsoft CA enterprise root certificate 982 

▪ Microsoft CA enterprise subordinate CA certificate 983 

2.5.10 Configure Certificate Profile 984 

1. In the Palo Alto Networks Portal, navigate to Device > Certificate Management > 985 

Certificate Profile. 986 

2. Under the details pane, select Add; the Certificate Profile form will open. 987 

3. In the Certificate Profile form: 988 

a. In the Name field, enter a unique name to identify this certificate profile. 989 

b. In the Username Field drop-down menu, select Subject Alt. 990 

c. Select the Principal Name option. 991 

d. In the User Domain field, enter the Active Directory domain name for your enterprise; 992 

this sample implementation uses govt. 993 

e. Under the CA Certificate list box, select Add; a secondary Certificate Profile form will 994 

appear. 995 

f. In the secondary Certificate Profile form, in the CA Certificate drop-down menu, select 996 

the Microsoft Active Directory Certificate Services root certificate uploaded in Section 997 

2.5.6. 998 

g. Select OK. 999 

h. Repeat Step 3f for each intermediary certificate in the trust chain between the root 1000 

certificate and the subordinate CA certificate that issues certificates to mobile devices. 1001 

i. Select OK. 1002 
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Figure 2-65 Internal Root Certificate Profile 1003 

 
4. Select OK. 1004 

Figure 2-66 Certificate Profile 1005 

 

2.5.11 Configure SSL/TLS Service Profile 1006 

The following steps will configure the SSL/TLS profile, which determines what certificates to trust when 1007 

mobile devices are connecting to the VPN and what certificate to use when establishing outbound 1008 

SSL/TLS connections. 1009 

1. In the Palo Alto Networks Portal, navigate to Device > Certificate Management > SSL/TLS 1010 

Service Profile. 1011 
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2. Below the details pane, select Add; the SSL/TLS Service Profile form will open. 1012 

3. In the SSL/TLS Service Profile form: 1013 

a. In the Name field, enter a unique name to identify this service profile. 1014 

b. For the Certificate drop-down menu, select the certificate to use for this SSL/TLS service 1015 

profile; our sample implementation uses a client certificate obtained from a Microsoft 1016 

enterprise CA via SCEP. 1017 

c. For the Min Version drop-down menu, select TLSv1.2. 1018 

d. Select OK. 1019 

Figure 2-67 SSL/TLS Service Profile 1020 

 
4. Repeat Step 3 to add an identical SSL/TLS service profile for this applianceʼs server 1021 

certificate issued through DigiCert. 1022 

2.5.12 URL Filtering Configuration 1023 

1. Navigate to Objects > Custom Objects > URL Category. 1024 

2. Click Add. 1025 

3. Give the category a name and description. 1026 

4. Add sites to be blocked. For this example, *.example.com was used. 1027 
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Figure 2-68 Custom URL Category 1028 

 

5. Click OK. 1029 

6. Navigate to Objects > Security Profiles > URL Filtering. 1030 

7. Check the box next to default and click Clone. 1031 

8. Select default from the window that appears. 1032 

9. Click OK. 1033 

10. Click the newly created profile, default-1. 1034 

11. Give the policy a meaningful name and description. 1035 

12. Scroll to the bottom of the list. The name of the created category will be last on the list. 1036 

13. Click the option below Site Access and next to your created URL category. 1037 

14. Set the Site Access option to block. 1038 
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Figure 2-69 URL Filtering Profile 1039 

 

15. Click OK. 1040 

16. Navigate to Policies > Security. 1041 

17. Click the default outbound policy for the internal network (not VPN). 1042 

18. Click Actions. 1043 

19. Next to Profile Type, select Profiles. 1044 

20. Next to URL Filtering, select the newly created profile. 1045 

21. Click OK. 1046 

22. Repeat Steps 18 through 21 for the SSL VPN outbound traffic. 1047 
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Figure 2-70 URL Filtering Security Policy 1048 

 

23. Commit the changes. 1049 

2.5.13  GlobalProtect Gateway and Portal Configuration 1050 

The SSL VPN configuration requires creation of both a GlobalProtect gateway and a GlobalProtect portal, 1051 

the latter of which could be used to manage VPN connections across multiple gateways. In this sample 1052 

implementation, only a single gateway and portal are configured. 1053 

2.5.13.1 Configure GlobalProtect Gateway 1054 

The GlobalProtect gateway provides remote users with secure access to internal resources based on 1055 

their Microsoft AD group. To configure the GlobalProtect gateway:  1056 

1. In the Palo Alto Networks Portal, navigate to Network > GlobalProtect > Gateways. 1057 

2. Below the details pane, select Add; the GlobalProtect Gateway Configuration form will 1058 

open. 1059 
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3. In the GlobalProtect Gateway Configuration form, on the General tab: 1060 

a. In the Name field, enter a unique name to identify this GlobalProtect Gateway. 1061 

b. Under Network Settings: 1062 

i. In the Interface drop-down menu, select the physical interface connected to the 1063 

subnet on which the internet gateway device is located. 1064 

ii. In the IPv4 Address drop-down menu, select the IP address associated with the 1065 

physical interface specified in the previous step. 1066 

Figure 2-71 General GlobalProtect Gateway Configuration 1067 

 
c. Select the Authentication tab. 1068 

d. In the Authentication tab: 1069 

i. For the Server Authentication > SSL/TLS Service Profile drop-down menu, select 1070 

the TLS/SSL profile associated with the publicly trusted server certificate for this 1071 

appliance. 1072 

ii. For the Client Authentication > Certificate Profile drop-down menu, select the 1073 

client TLS/SSL profile associated with the internally trusted client certificates 1074 

issued to mobile devices. 1075 
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Figure 2-72 GlobalProtect Authentication Configuration 1076 

 
e. Select the Agent tab. 1077 

f. On the Agent > Tunnel Settings tab: 1078 

i. Select the Tunnel Mode checkbox. 1079 

ii. Select the Enable IPSec checkbox to disable IPSec. 1080 

Figure 2-73 GlobalProtect Tunnel Configuration 1081 

 
g. Select the Agent > Client IP Pool tab. 1082 

h. On the Agent > Client IP Pool tab:  1083 

i. Below the IP Pool list box, select Add; a new list item will appear. 1084 

ii. For the new IP Pool list item, enter the network address for the IP address pool 1085 

from which connected devices will be allocated an IP address. 1086 
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Figure 2-74 VPN Client IP Pool 1087 

 
i. Select the Agent > Client Settings tab. 1088 

j. On the Agent > Client Settings tab: 1089 

i. Under the Client Settings list box, select Add; the Configs form will open. 1090 

Figure 2-75 VPN Client Settings 1091 

 
ii. In the Configs form on the Authorization Override tab, enter a unique name to 1092 

identify this client configuration. 1093 
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Figure 2-76 VPN Authentication Override Configuration 1094 

 
iii. Select the User/User Group tab. 1095 

iv. On the User/User Group tab: 1096 

1) Below the Source User list box, select Add; a new list item will appear. 1097 

2) In the Source User list item, select the Microsoft AD user group to grant 1098 

access to internal resources through this GlobalProtect gateway. 1099 

Figure 2-77 VPN User Group Configuration 1100 
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v. Select the Split Tunnel tab. 1101 

vi. On the Split Tunnel tab, on the Access Route tab: 1102 

1) Under the Include list box, select Add; a new list item will appear. 1103 

2) In the new Include list item, enter 0.0.0.0/0. This enforces full tunneling. 1104 

Figure 2-78 VPN Split Tunnel Configuration 1105 

 
vii. Select OK. 1106 

k. Select OK. 1107 

2.5.13.2 Configure GlobalProtect Portal 1108 

1. In the Palo Alto Networks Portal, navigate to Network > GlobalProtect > Portal. 1109 

2. Below the details pane, select Add; the GlobalProtect Portal Configuration form will open. 1110 

3. In the GlobalProtect Portal Configuration form, on the General tab: 1111 

a. In the Name field, enter a unique name to identify this GlobalProtect portal. 1112 



DRAFT 

 
NIST SP 1800-21C: Mobile Device Security: Corporate-Owned Personally-Enabled 73 

b. In the Interface drop-down menu, select the physical interface connected to the subnet 1113 

on which the internet gateway device is located.  1114 

c. In the IP Address Type drop-down menu, select IPv4 Only. 1115 

Figure 2-79 GlobalProtect Portal Configuration 1116 

 
4. Select the Authentication tab. 1117 

5. In the Authentication tab: 1118 

a. For the Server Authentication > SSL/TLS Service Profile drop-down menu, select the 1119 

SSL/TLS service profile based on your third-party server certificate. 1120 

b. For the Certificate Profile drop-down menu, select the client TLS/SSL profile associated 1121 

with the internally trusted client certificates issued to mobile devices. 1122 

c. Click Add. 1123 

d. Enter a profile name. In this example implementation, Client Authentication was used. 1124 

e. For the Authentication Profile drop-down menu, select the previously created 1125 

authentication profile. 1126 

f. Click OK. 1127 
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Figure 2-80 GlobalProtect Portal SSL/TLS Configuration 1128 

 
6. Select the Agent tab. 1129 

7. On the Agent tab: 1130 

a. Below the Agent list box, select Add; the Configs form will open. 1131 

b. In the Configs form: 1132 

i. In the Authentication tab, below Components that Require Dynamic Passwords, 1133 

check the box next to Portal. 1134 

ii. In the External tab, under the External Gateways list box select Add; the External 1135 

Gateway form will open. 1136 

iii. In the External Gateway form: 1137 

1) In the Name field, enter a unique name to identify this external gateway. 1138 

2) For the Address option, enter the FQDN for this appliance; in this sample 1139 

implementation, the FQDN is vpn.govt.mdse.nccoe.org. 1140 

3) Below the Source Region list box, select Add; a new list item will appear. 1141 
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4) In the new Source Region list item, select Any. 1142 

5) Select the Manual checkbox. 1143 

6) Select OK. 1144 

Figure 2-81 GlobalProtect External Gateway Configuration 1145 

  
iv. Below the Trusted Root CA list box, select Add; a new list item will appear. 1146 

v. In the new Trusted Root CA list item, select your internal CA root certificate. 1147 

vi. Repeat Steps 7biii and 7biv to add each certificate in your internal or third-party 1148 

certificate trust chains used when mobile devices contact the GlobalProtect 1149 

portal. 1150 

c. Click App. Ensure that Connect Method is set to User-logon (Always On). 1151 



DRAFT 

 
NIST SP 1800-21C: Mobile Device Security: Corporate-Owned Personally-Enabled 76 

Figure 2-82 GlobalProtect Portal Agent Configuration 1152 

 
d. Select OK. 1153 

2.5.14 Configure Automatic Threat and Application Updates 1154 

1. In the PAN-OS portal, navigate to Device > Dynamic Updates. 1155 

2. Click Check Now at the bottom of the page. 1156 

3. Under Applications and Threats, click Download next to the last item in the list, with the 1157 

latest Release Date. It will take a minute to download the updates. 1158 

4. When the download completes, click Done. 1159 

5. Click Install next to the downloaded update. 1160 

6. Click Continue Installation. 1161 

7. When installation completes, click Close. 1162 

8. Next to Schedule, click the link with the date and time. 1163 
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Figure 2-83 Schedule Link 1164 

 

9. Select the desired recurrence. For this implementation, Weekly was used. 1165 

10. Select the desired day and time. For this implementation, Saturday at 23:45 was used. 1166 

11. Next to Action, select download-and-install. 1167 

Figure 2-84 Threat Update Schedule 1168 

 1169 

12. Click OK. 1170 

13. Commit the changes. 1171 

2.6 Integration of Kryptowire EMM+S with MobileIron 1172 

Kryptowireʼs application vetting service uses the MobileIron application programming interface (API) to 1173 

regularly pull current device application inventory information from MobileIron Core. Updated analysis 1174 

results are displayed in the Kryptowire portal. 1175 
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2.6.1 Add MobileIron API Account for Kryptowire 1176 

The following steps will create an administrative account that will grant Kryptowire the specific 1177 

permissions it requires within MobileIron. 1178 

1. In the MobileIron Admin Portal, navigate to Devices & Users > Users. 1179 

2. On the Users page: 1180 

a. Select Add > Add Local User; the Add New User dialogue will open. 1181 

Figure 2-85 MobileIron Users 1182 

 

b. In the Add New User dialogue: 1183 

i. In the User ID field, enter the user identity that the Kryptowire cloud will 1184 

authenticate under; our implementation uses a value of kryptowire. 1185 

ii. In the First Name field, enter a generic first name for Kryptowire. 1186 

iii. In the Last Name field, enter a generic last name for Kryptowire. 1187 

iv. In the Display Name field, optionally enter a displayed name for this user 1188 

account. 1189 

v. In the Password field, provide the password that the Kryptowire identity will use 1190 

to authenticate to MobileIron. 1191 

vi. In the Confirm Password field, enter the same password as in the preceding step. 1192 

vii. In the Email field, provide an email account for the Kryptowire identity; this could 1193 

be used in configuring automatic notifications and should be an account under 1194 

the control of your organization.  1195 

viii. Select Save 1196 
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Figure 2-86 Kryptowire API User Configuration 1197 

 

3. In the MobileIron Admin Portal, navigate to Admin > Admins. 1198 

4. On the Admins page: 1199 

a. Enable the account you created for Kryptowire during Step 2. 1200 

b. Select Actions > Assign to Space; this will open the Assign to Space dialogue for the 1201 

Kryptowire account. 1202 
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Figure 2-87 MobileIron User List 1203 

 1204 

c. In the Assign to Space dialogue: 1205 

i. In the Select Space drop-down menu, select Global. 1206 

Figure 2-88 Kryptowire API User Space Assignment 1207 

 

ii. Enable each of the following settings: 1208 

Admin Roles > Device Management > View device page, device details 

Admin Roles > Device Management > View dashboard 
Admin Roles > Privacy Control > View apps and ibooks in device details  

Admin Roles > Privacy Control > View device IP and MAC address 

Admin Roles > App Management > View app 

Admin Roles > App Management > View app inventory 

Other Roles > Common Services Provider (CSP) 

Other Roles > API 

iii. Select Save. 1209 
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2.6.2 Contact Kryptowire to Create Inbound Connection 1210 

Once the MobileIron API account has been created, contact Kryptowire customer support to integrate 1211 

your instance of MobileIron Core. Note that this will require creation of firewall rules that permit 1212 

inbound connections from IP addresses designated by Kryptowire to MobileIron Core on port 443. Once 1213 

the connection has been established, the Kryptowire portal will populate with information on devices 1214 

registered with MobileIron. The EMM (Enterprise Mobility Management) ID presented by Kryptowire 1215 

will be the same as the Universally Unique ID assigned to a device by MobileIron Core. 1216 

Figure 2-89 Kryptowire Device List 1217 

 

2.7 Integration of Lookout Mobile Endpoint Security with MobileIron 1218 

Lookoutʼs Mobile Endpoint Security cloud service uses the MobileIron API to pull mobile device details 1219 

and app inventory from MobileIron Core. Following analysis, Lookout uses the API to apply specific 1220 

labels to devices to categorize them by the severity of any issues detected. MobileIron can be 1221 

configured to automatically respond to the application of specific labels per built-in compliance actions. 1222 

2.7.1 Add MobileIron API Account for Lookout 1223 

The following steps will create an administrative account that will grant to Lookout the specific 1224 

permissions it requires within MobileIron. 1225 

1. In the MobileIron Admin Portal, navigate to Devices & Users > Users. 1226 

2. On the Users page: 1227 

a. Select Add > Add Local User; the Add New User dialogue will open. 1228 
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Figure 2-90 MobileIron User List 1229 

 

b. In the Add New User dialogue: 1230 

i. In the User ID field, enter the user identity the Lookout cloud will authenticate 1231 

under. Our implementation uses a value of lookout. 1232 

ii. In the First Name field, enter a generic first name for Lookout. 1233 

iii. In the Last Name field, enter a generic last name for Lookout. 1234 

iv. In the Display Name field, optionally enter a displayed name for this user 1235 

account. 1236 

v. In the Password field, provide the password the Lookout identity will use to 1237 

authenticate to MobileIron. 1238 

vi. In the Confirm Password field, enter the same password as in the preceding step. 1239 

vii. In the Email field, provide an email account for the Lookout identity; since this 1240 

may be used for alerts, it should be an account under the control of your 1241 

organization.  1242 

viii. Select Save. 1243 
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Figure 2-91 MobileIron Lookout User Configuration 1244 

 

3. In the MobileIron Admin Portal, navigate to Admin. 1245 

4. On the Admin page: 1246 

a. Enable the account you created for Lookout during Step 2. 1247 

b. Select Actions > Assign to Space; this will open the Assign to Space dialogue for the 1248 

Lookout account. 1249 
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Figure 2-92 Lookout MobileIron Admin Account 1250 

 

c. In the Assign to Space dialogue: 1251 

i. In the Select Space drop-down menu, select Global. 1252 

Figure 2-93 Lookout Account Space Assignment 1253 

 

ii. Enable each of the following settings: 1254 

Admin Roles > Device Management > View device page, device details 
Admin Roles > Device Management > View dashboard 

Admin Roles > Label Management > View Label 

Admin Roles > Label Management > Manage Label 
Admin Roles > Privacy Control > View apps and ibooks in device details  

Admin Roles > Privacy Control > View device IP and MAC address 

Admin Roles > App Management > Distribute app 

Admin Roles > Logs and Event Management > View Audit logs 
Admin Roles > Logs and Event Management > View events 

Other Roles > CSP 

Other Roles > Connector 
Other Roles > API 

iii. Select Save. 1255 
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2.7.2 Add MobileIron Labels for Lookout 1256 

Lookout will dynamically apply MobileIron labels to protected devices to communicate information 1257 

about their current state. The following steps will create a group of Lookout-specific labels. 1258 

1. In the MobileIron Admin Portal, navigate to Devices & Users > Labels. 1259 

2. On the Labels page: 1260 

a. Select Add Label; the Add Label dialogue will appear. 1261 

Figure 2-94 MobileIron Label List 1262 

 
b. In the Add Label dialogue: 1263 

i. In the Name field, enter the name of the label. Note: future steps will use the 1264 

Label Names presented here but use of these names is optional. 1265 

ii. In the Description field, enter a brief description for this label. 1266 

iii. For the Type option, select Manual; this will hide all other form inputs. 1267 

iv. Select Save. 1268 
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Figure 2-95 MTP Low Risk Label Configuration 1269 

 

c. Complete Step 3 for each label in the following table:  

 

Label Name Purpose 

Lookout for Work Device enrollment 

MTP - Pending Lifecycle management: devices with 
Lookout not yet activated 

MTP - Secured Lifecycle management: devices with 
Lookout activated 

MTP - Threats Present Lifecycle management: devices with 
threats detected by Lookout 
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MTP - Deactivated Lifecycle management: devices with 
Lookout deactivated 

MTP - Low Risk Risk posture: devices with a low risk score 
in Lookout 

MTP - Moderate Risk Risk posture: devices with a moderate 
risk score in Lookout 

MTP - High Risk Risk posture: devices with a high risk 
score in Lookout 

 

Note: Administrators can choose to alter the label names to something more appropriate for their 1270 

environment. 1271 

2.7.3 Add Lookout for Work for Android to MobileIron App Catalog 1272 

The following steps will add the Lookout for Work app for Android to MobileIron. 1273 

1. In the MobileIron Admin Portal, navigate to Apps > App Catalog. 1274 

2. On the App Catalog page, select Add; this will start the workflow to add a new app to the 1275 

app catalog. 1276 

Figure 2-96 MobileIron App Catalog 1277 

 

3. On the App Catalog > Choose page: 1278 

a. Select Google Play; additional controls will be displayed. 1279 

b. In the Application Name field, enter Lookout for Work. 1280 

c. Select Search; search results will be displayed in the lower pane. 1281 
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d. In the list of search results, select the Lookout for Work app. 1282 

e. Select Next. 1283 

Figure 2-97 Adding Lookout for Work to the MobileIron App Catalog 1284 

 

4. On the App Catalog > Describe page: 1285 

a. In Category drop-down menu, optionally assign the app to a category as appropriate to 1286 

your MobileIron deployment strategy. 1287 

b. Select Next. 1288 
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Figure 2-98 Lookout for Work Application Configuration 1289 

 

5. On the App Catalog > App Configuration page: 1290 

a. In the Apps@Work Catalog section, Enable Feature this App in the Apps@Work 1291 

catalog. 1292 

Figure 2-99 Lookout for Work Application Configuration 1293 

 1294 

b. In the Android Enterprise (Android for Work [AFW]) section: 1295 
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i. Enable Install this app for Android enterprise; additional controls will be made 1296 

visible. 1297 

ii. Enable Auto Update this App. 1298 

iii. Ensure Silently Install is enabled. 1299 

c. Select Finish. 1300 

Figure 2-100 Lookout for Work AFW Configuration 1301 

 

6. The Lookout for Work app should now appear in the App Catalog with the AFW indicator. 1302 

2.7.4 Apply Labels to Lookout for Work for Android 1303 

1. On the App Catalog page: 1304 

a. Enable Lookout for Work. 1305 

b. Select Actions > Apply To Labels; the Apply To Labels dialogue will appear. 1306 
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Figure 2-101 Apply Lookout for Work to Android Devices 1307 

 

c. In the Apply To Labels dialogue: 1308 

i. Enable the Lookout for Work and Android labels, plus any other labels 1309 

appropriate to your organization's mobile security policies. 1310 

ii. Select Apply. 1311 
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Figure 2-102 Apply To Labels Dialogue 1312 

 

d. The Lookout for Work app should now appear with the Lookout for Work and Android 1313 

labels applied. 1314 
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Figure 2-103 Lookout for Work with Applied Labels 1315 

 

2.7.5 Add Lookout for Work app for iOS to MobileIron App Catalog 1316 

The following steps will add the Lookout for Work app for iOS to MobileIron, apply appropriate 1317 

MobileIron labels, and create and upload a configuration file for one-touch activation of the app. 1318 

2.7.5.1 Import Lookout for Work App 1319 

1. In the MobileIron Admin Portal, navigate to Apps > App Catalog. 1320 

2. On the App Catalog page, select Add; this will start the workflow to add a new app to the 1321 

app catalog. 1322 

Figure 2-104 MobileIron App Catalog 1323 

 

3. On the App Catalog > Choose page: 1324 
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a. Select iTunes; additional controls will be displayed. 1325 

b. In the Application Name field, enter Lookout for Work. 1326 

c. Select Search; search results will be displayed in the lower pane. 1327 

d. In the list of search results, select the Lookout for Work app. 1328 

e. Select Next.  1329 

Figure 2-105 Lookout for Work Selected From iTunes 1330 

 

4. On the App Catalog > Describe page: 1331 

a. In Category drop-down menu, optionally assign the app to a category as appropriate to 1332 

your MobileIron deployment strategy. 1333 

b. Select Next. 1334 
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Figure 2-106 Lookout for Work App Configuration 1335 

 

5. On the App Catalog > App Store page: 1336 

a. In the Apps@Work Catalog section: 1337 

i. Enable Allow conversion of app from unmanaged to managed (iOS 9 or later). 1338 

ii. Enable Feature this App in the Apps@Work catalog. 1339 

iii. Select Next. 1340 
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Figure 2-107 Lookout for Work App Configuration 1341 

 

b. In the App Catalog > App Configuration section: 1342 

i. Enable Send installation request or send convert unmanaged to managed app 1343 

request (iOS 9 and later) on device registration or sign-in. 1344 

ii. Enable Advanced Settings > Automatically update app when new version is 1345 

available. 1346 

c. Select Finish. 1347 
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Figure 2-108 Lookout for Work Managed App Settings 1348 

 

6. The Lookout for Work app should now appear in the App Catalog with AFW indicator. 1349 

Figure 2-109 App Catalog With Lookout for Work 1350 

 

2.7.5.2 Apply MobileIron Labels to Lookout for Work App 1351 

1. On the App Catalog page: 1352 

a. Enable Lookout for Work. 1353 



DRAFT 

 
NIST SP 1800-21C: Mobile Device Security: Corporate-Owned Personally-Enabled 98 

b. Select Actions > Apply To Labels; the Apply To Labels dialogue will appear. 1354 

Figure 2-110 Lookout for Work Selected 1355 

 

c. In the Apply To Labels dialogue: 1356 

i. Enable the Lookout for Work and iOS labels, plus any other labels appropriate to 1357 

your organization's mobile security policies. 1358 

ii. Select Apply. 1359 
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Figure 2-111 Apply To Labels Dialogue 1360 

 1361 

d. The Lookout for Work app should now appear with the Lookout for Work and iOS labels 1362 

applied. 1363 

Figure 2-112 App Catalog With Lookout for Work 1364 
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2.7.5.3 Create Managed App Configuration File for Lookout for Work 1365 

MobileIron can push a configuration file down to managed iOS devices to allow users easy activation of 1366 

Lookout for Work. The following steps will create and upload the necessary file.  1367 

1. Using a plain text editor, create the following text file by replacing the asterisks on line 13 1368 

with your organization's Global Enrollment Code. 1369 

 
<?xml version="1.0" encoding="UTF-8"?> 1370 
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" 1371 
"https://www.apple.com/DTDs/PropertyList-1.0.dtd"> 1372 
<plist version="1.0"> 1373 
  <dict> 1374 
    <key>MDM</key> 1375 
    <string>MOBILEIRON</string> 1376 
    <key>DEVICE_UDID</key> 1377 
    <string>$DEVICE_UDID$</string> 1378 
    <key>EMAIL</key> 1379 
    <string>$EMAIL$</string> 1380 
    <key>GLOBAL_ENROLLMENT_CODE</key> 1381 
    <string>*******</string> 1382 
  </dict> 1383 
</plist> 1384 

2. In the MobileIron Admin Portal, navigate to Policies & Configs > Configurations. 1385 

3. On the Configurations Page: 1386 

a. Select Add New > iOS and OS X > iOS Only > Managed App Config; the New Managed 1387 

App Config Setting dialogue will open. 1388 
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Figure 2-113 Importing Managed Application Configuration 1389 

 

b. In the Managed App Config Setting dialogue: 1390 

i. In the Name field, provide a name for this configuration; our implementation 1391 

used Activate Lookout. 1392 

ii. In the Description field, provide the purpose for this configuration. 1393 

iii. In the BundleId field, enter the bundle ID for Lookout at Work, which for our 1394 

version was com.lookout.work. 1395 

iv. Select Choose File... to upload the plist file created during Step 1. 1396 

v. Select Save. 1397 
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Figure 2-114 plist Import Configuration 1398 

 

2.7.5.4 Apply Labels to Managed App Configuration for Lookout for Work 1399 

The following steps will apply the managed app configuration created in the previous section to labels. 1400 

1. In the MobileIron Admin Portal, navigate to Policies & Configs > Configurations. 1401 

2. On the Configurations page: 1402 

a. Enable the Lookout Activation managed app configuration created in the previous 1403 

section. 1404 

b. Select Actions > Apply To Label; the Apply To Label dialogue will open. 1405 

Figure 2-115 Lookout Configuration Selected 1406 

 

c. In the Apply To Label dialogue: 1407 
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i. Enable the iOS and Lookout for Work labels. 1408 

ii. Select Apply. 1409 

Figure 2-116 Apply To Label Dialogue 1410 

 

d. The system should now reflect the Lookout for iOS and iOS labels have been applied to 1411 

the Activate Lookout configuration. 1412 
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Figure 2-117 Lookout Configuration With Labels 1413 

 

2.7.6 Add MDM Connector for MobileIron to Lookout MES 1414 

The following instructions will connect Lookout with your MobileIron instance and associate Lookout 1415 

device states with the MobileIron labels created previously. 1416 

1. Using the most-recent version of MDM Service IP Whitelisting available from the Lookout 1417 

support portal, configure your organization's firewalls to permit inbound connections from 1418 

the IP addresses provided on port 443 to your instance of MobileIron Core.  1419 

2. In the Lookout MES portal, navigate to Lookout > System > Connectors. 1420 

3. On the Connectors page: 1421 

a. Select Add Connector > MobileIron; this will open a new form. 1422 

Figure 2-118 Add Lookout Connector Display 1423 
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b. In the Connector Settings section of the form: 1424 

i. For the MobileIron URL field, enter the FQDN for your instance of MobileIron. In 1425 

our example implementation, the URL was mi-core.govt.mdse.nccoe.org.  1426 

ii. For the Username field, enter the User ID of the MobileIron admin account 1427 

created in 2.7.1. In our example implementation, the User ID is lookout. 1428 

iii. For the Password field, enter the password associated with that MobileIron 1429 

admin account. 1430 

iv. Select Create Connector; this will enable additional sections of the form. 1431 

Figure 2-119 Connector Settings 1432 

 

c. In the Enrollment Management section of the form:  1433 

i. Toggle Device Enrollment > Automatically drive Lookout for Work enrollment on 1434 

MobileIron managed devices to On.  1435 

ii. For the Device Enrollment > Use the following label to identify devices that 1436 

should have the Lookout for Work app activated drop-down menu, select the 1437 

Lookout for Work label. 1438 

iii. Toggle Device Enrollment > Automatically send activation emails to MobileIron 1439 

managed devices to On. 1440 
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iv. Select Save Changes. 1441 

Figure 2-120 Connector Enrollment Settings 1442 

 

d. In the State Sync section of the form:  1443 

i. Toggle State Sync > Synchronize Device Status to MobileIron to On. 1444 

ii. For each entry in the table below:  1445 

1) Toggle the control to On. 1446 

2) From the drop-down menu, select the MobileIron Label with the 1447 

associated Purpose from the table in Section 2.6.2 Add MobileIron Labels 1448 

for Lookout. We provide the Label Name we used for each Purpose in our 1449 

example implementation. 1450 

State Purpose Label Name 

Devices that have 
not activated 
Lookout yet 

Lifecycle management: 
devices with Lookout 
not yet activated 

MTP - Pending 
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Devices with 
Lookout activated 

Lifecycle management: 
devices with Lookout 
activated 

MTP - Secured 

Devices on which 
Lookout is 
deactivated 

Lifecycle management: 
devices with Lookout 
deactivated 

MTP - Deactivated 

Devices with any 
issues present 

Lifecycle management: 
devices with threats 
detected by Lookout 

MTP - Threats 
Detected 

Devices with Low 
Risk issues present 

Risk posture: devices 
with a low risk score in 
Lookout 

MTP - Low Risk 

Devices with 
Medium Risk issues 
present 

Risk posture: devices 
with a moderate risk 
score in Lookout 

MTP - Moderate 
Risk 

Devices with High 
Risk issues present 

Risk posture: devices 
with a high risk score in 
Lookout 

MTP - High Risk 

 
Note: Administrators can choose to alter the label names to something more appropriate for their 1451 

environment. 1452 

iii. Select Save Changes.  1453 
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Figure 2-121 Connector Sync Settings 1454 

 

2.7.7 Configure MobileIron Risk Response 1455 

The following steps will allow MobileIron to generate responses to various device states as assigned to 1456 

devices by Lookout (e.g. MTP - High Risk).  1457 

2.7.7.1 Add MobileIron App Control Rule 1458 

1. In the MobileIron Admin Portal, navigate to Apps > App Control. 1459 

2. Select Add; the Add App Control Rule dialogue will appear. 1460 

3. In the Add App Control Rule dialogue: 1461 

a. In the Name field, enter Threats Present Trigger. 1462 
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b. Of the Type options, select Required. 1463 

c. In the App Identifier/Name field enter app does not exist. 1464 

d. In the Device Platform drop-down menu, select All. 1465 

e. In the Comment field, optionally enter Forces non-compliant state. 1466 

f. Select Save. 1467 

Figure 2-122 MobileIron App Control Rule 1468 

 
4. The new app control rule should now appear on the Apps > App Control page. 1469 
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Figure 2-123 MobileIron App Control Rule 1470 

 

2.7.7.2 Add MobileIron Compliance Actions 1471 

A Compliance Action defines what actions MobileIron will take when an App Control policy, like the one 1472 

created in the previous section, is violated by a managed mobile device. The following steps will create 1473 

and configure an example Compliance Action in response to the MTP - High Risk App Control rule. Note 1474 

that a single Compliance Action can be associated with multiple App Control rules if the same response 1475 

would be configured for each. Otherwise, a new Compliance Action should be created.  1476 

1. In the MobileIron Admin Portal, navigate to Policies & Configs > Compliance Actions. 1477 

2. Select Add; the Add Compliance Action dialogue will open. 1478 

3. In the Add Compliance Action dialogue: 1479 

a. In the Name field, add a description of the compliance action; we recommend indicating 1480 

the kind of action taken. This example illustrates creating a compliance action that will 1481 

be associated with the MTP - High Risk label. 1482 

b. Select the Enforce Compliance Actions Locally on Devices check box. 1483 

c. Select the Send a compliance notification or alert to the user check box. 1484 

d. Select the Block email access and AppConnect apps check box. 1485 

e. Select the Quarantine the device check box. 1486 

f. Deselect the Remove All Configurations check box. 1487 

g. Select Save. 1488 
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Figure 2-124 MTP High Risk Compliance Action 1489 

 1490 

2.7.7.3 Create MobileIron Security Policy for Lookout MES 1491 

In addition to potentially defining other controls, such as password requirements, a Security Policy can 1492 

map a Compliance Action to an App Control rule, enabling MobileIron to execute the configured actions 1493 

whenever a device that applies the policy violates the App Control rule. The following steps will create a 1494 
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new Security Policy for Lookout MES High Risk devices using an existing policy as a baseline from which 1495 

to apply more stringent controls. 1496 

1. In the MobileIron Admin Portal, navigate to Policies & Configs > Policies. 1497 

2. On the Policies page: 1498 

a. Select the security policy to use as a baseline. 1499 

b. Select More Actions > Save As; this will open the New Security Policy dialogue. 1500 

Figure 2-125 Baseline Policy Selection 1501 

 1502 
 

c. In the New Security Policy dialogue: 1503 

i. In the Name field, rename the policy to MTP - High Risk. 1504 

ii. In the Priority drop-down menu, select the security policy this policy will be 1505 

prioritized in relation to; in this example, it is higher than the MTP Medium Risk 1506 

policy. Note: for ease of setting priority, it is recommended to add new security 1507 

policies in ascending order (lowest to highest priority). 1508 

Figure 2-126 MTP High Risk Policy 1509 

 1510 
 

iii. Under Access Control > For All Platforms section: 1511 
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1. For the when a device violates the following app control rules drop-down 1512 
menu, select the MTP - High Risk compliance action. 1513 

2. In the Available list of app control rules, highlight MTP High Risk Trigger. 1514 
3. Select the right arrow to move MTP High Risk Trigger item into the Enabled 1515 

List. 1516 
iv. Select Save. 1517 

Figure 2-127 Security Policy Trigger 1518 

 1519 

2.7.7.4 Apply Lookout MES Label to MobileIron Security Policy 1520 

The following steps will apply the MTP - High Risk label to the security policy created in the previous 1521 

section. As a result, once the Lookout cloud service applies the label to any device with a detected high-1522 

risk threat and such a device checks in with MobileIron, the security policy will automatically be applied 1523 

to it (provided it is of higher priority than the policy currently applied). In turn that will cause the MTP 1524 

High Risk Trigger App Control policy to be violated and the MTP - High Risk Compliance Action to be 1525 

taken. Once Lookout detects that the threat has been resolved, the Lookout service will remove the 1526 

MTP - High Risk label and on device check-in, MobileIron will then apply the next-lower-priority security 1527 

policy. 1528 

1. In the MobileIron Admin Portal, navigate to Policies & Configs > Policies. 1529 

2. On the Policies page: 1530 

a. Select the check box in the MTP High Risk security policy item. 1531 

b. Select More Actions > Apply to Label; the Apply to Label dialogue will open. 1532 
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Figure 2-128 Policy List 1533 

 1534 

c. In the Apply to Label dialogue: 1535 

i. Select the check box for the MTP - High Risk item. 1536 

ii. Select Apply. 1537 
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Figure 2-129 Apply To Label Dialogue 1538 

 1539 

2.8 Integration of Appthority Mobile Threat Detection with MobileIron 1540 

Appthority provides an on-premises connector for MobileIron that runs as a Docker container on RedHat 1541 

Linux. The connector uses the MobileIron API to obtain information on managed devices and their 1542 

installed apps, which is then synchronized with the cloud service instance to obtain app and device risk 1543 

scores, which are assigned to devices using custom attributes. The following sections provide the steps 1544 

to create a MobileIron API account and deploy and configure the Appthority connector. 1545 

2.8.1 Create MobileIron API Account for Appthority Connector 1546 

The following steps will create an administrative account that will grant Appthority the specific 1547 

permissions it requires within MobileIron. 1548 
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1. In the MobileIron Admin Portal, navigate to Devices & Users > Users. 1549 

2. On the Users page: 1550 

a. Select Add > Add Local User; the Add New User dialogue will open. 1551 

b. In the Add New User dialogue: 1552 

i. In the User ID field, enter the user identity the Appthority connector will 1553 

authenticate under. Our implementation uses a value of Appthority. 1554 

ii. In the First Name field, enter a generic first name for Appthority. 1555 

iii. In the Last Name field, enter a generic last name for Appthority. 1556 

iv. In the Display Name field, optionally enter a displayed name for this user 1557 

account. 1558 

v. In the Password field, provide the password the Appthority identity will use to 1559 

authenticate to MobileIron. 1560 

vi. In the Confirm Password field, enter the same password as in the preceding step. 1561 

vii. In the Email field, provide an email account for the Appthority identity; this 1562 

should be an account under the control of your organization.  1563 

viii. Select Save. 1564 
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Figure 2-130 Appthority User Settings 1565 

 1566 

1. In the MobileIron Admin Portal, navigate to Admin. 1567 

2. On the Admin page: 1568 

a. Enable the account you created for Appthority during Step 2. 1569 

b. Select Actions > Assign to Space; this will open the Assign to Space dialogue for the 1570 

Appthority account. 1571 
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Figure 2-131 Appthority Connector User 1572 

 1573 

c. In the Assign to Space dialogue: 1574 

i. In the Select Space drop-down menu, select Global. 1575 

Figure 2-132 Appthority Connector Space Assignment 1576 

 1577 

ii. Enable each of the following settings: 1578 

Device Management > View device page, device details 

Privacy Control > View apps and ibooks in device details  

App Management > Apply and remove application label 

Other Roles > API 

iii. Select Save. 1579 

2.8.2 Deploy Appthority Connector Open Virtualization Appliance  1580 

One deployment option for the Appthority connector is a pre-built RedHat virtual machine distributed as 1581 

an Open Virtualization Appliance (OVA). We imported the OVA into our virtual lab environment 1582 

following guidance provided in Connector On-Premises: Virtual Machine Setup available from the 1583 

Appthority support portal: https://support.appthority.com/. 1584 

https://support.appthority.com/


DRAFT 

 
NIST SP 1800-21C: Mobile Device Security: Corporate-Owned Personally-Enabled 119 

2.8.3 Run the Enterprise Mobility Management Connector Deployment Script 1585 

Once the Appthority docker container is running, the setup script will configure it to use the MobileIron 1586 
API account created previously. Detailed instructions on using the script are available on the Appthority 1587 
support portal at https://help-1588 
mtp.appthority.com/SetUp/EMM/EMM_Script/RunEMMDeployScript.html. The first two steps ask for 1589 
Appthority-supplied credentials necessary to verify your subscription and to link the connector with the 1590 
correct instance of their cloud service. In the third step you will provide details to integrate with your 1591 
on-premises instance of MobileIron core. Our results from completing the third step are shown below. 1592 

1. Obtain a copy of Run the EMM Connector Deployment Script from the Appthority support 1593 

portal at https://help-1594 

mtp.appthority.com/SetUp/EMM/EMM_Script/RunEMMDeployScript.html (authentication 1595 

to the portal is required). 1596 

2. Execute the script. The third step in the script involves providing settings to enable the 1597 

Appthority Connector to communicate with MobileIron Core. The results of our completion 1598 

of that step are provided below as a reference. 1599 

Figure 2-133 Appthority Connector CLI Configuration 1600 

 1601 
 1602 

3. Once the script has been completed, verify successful synchronization with the Appthority 1603 

cloud service by accessing the Appthority MTP portal and navigating to Admin > EMM and 1604 

viewing items under Connector Status. 1605 

https://help-mtp.appthority.com/SetUp/EMM/EMM_Script/RunEMMDeployScript.html
https://help-mtp.appthority.com/SetUp/EMM/EMM_Script/RunEMMDeployScript.html
https://help-mtp.appthority.com/SetUp/EMM/EMM_Script/RunEMMDeployScript.html
https://help-mtp.appthority.com/SetUp/EMM/EMM_Script/RunEMMDeployScript.html
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Figure 2-134 Appthority EMM Connector Status 1606 

 1607 

2.9 Registering Devices with MobileIron Core 1608 

In this scenario, the employee manages their own personal apps, data, and many device functions. The 1609 

organization manages work-related apps and data, and has control over specific device functions, such 1610 

as requiring a complex device unlock PIN or being able to remotely wipe a lost device. The mechanisms 1611 

to achieve similar security characteristics between iOS and Android devices differ. 1612 

2.9.1 Supervising and Registering iOS Devices 1613 

Many MDM-based security controls are only applicable to iOS devices that are running in Supervised 1614 

Mode. The following steps outline how to place an iOS device into this mode, and then register with 1615 

MobileIron Core. 1616 

2.9.1.1 Resetting the iOS Device 1617 

Before a device can be placed into Supervised Mode, it must be in a factory-reset state with the 1618 

Activation Lock on the device removed. If Activation Lock is in-place, Configurator 2 will be unable to 1619 

place the device into Supervised Mode. 1620 
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2.9.1.1.1 Reset an Unsupervised Device Using Settings App 1621 
If a device is not already in Supervised Mode, it is recommended to have the current device user 1622 

manually reset and activate the device to factory settings using the following steps: 1623 

1. Navigate to Settings > General > Reset. 1624 

2. Select Erase All Content and Settings. 1625 

Figure 2-135 iOS Reset Screen 1626 

 1627 

1. At the warning that this will delete all media and data and reset all settings, select Erase 1628 

iPhone. 1629 
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Figure 2-136 Erase iPhone Confirmation 1630 

 1631 

1. At the warning that all media, data, and settings will be irreversibly erased, select Erase 1632 

iPhone. Once the reset process is complete, the device will reboot and need to be 1633 

activated. 1634 
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Figure 2-137 Erase iPhone Final Confirmation 1635 

 1636 

1. Once the device displays the Hello screen, press the Home key. 1637 

2. At the Select Your Language screen, select English. 1638 

3. At the Select Your Country or Region screen, select United States. 1639 

4. At the Quick Start screen select Set up Manually. 1640 

5. At the Choose a Wi-Fi Network screen, select the Service Set Identifier (SSID) for the 1641 

network and authenticate to your on-premises SSID Wi-Fi network; the device should 1642 

indicate it is being activated. Note: you may need to attempt activation again if there is a 1643 

delay in the device establishing connectivity to the internet. 1644 

6. Stop at the Data & Privacy screen. At this point, the device should be placed into 1645 

Supervised Mode using Configurator 2. 1646 
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2.9.1.1.2 Reset a Supervised Device Using Configurator 2 1647 
1. Connect the iOS device with the system running Configurator 2 over Universal Serial Bus 1648 

(USB). 1649 

2. On the device at the Enter Passcode screen (if locked), enter the device unlock passcode. 1650 

Figure 2-138 Entering iOS Passcode 1651 

 1652 

3. At the Trust this Computer? dialogue, select Trust. Note that this step, along with step that 1653 

follows, is only encountered the first time a device is paired with a given system. 1654 
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Figure 2-139 iOS Trust Computer Confirmation 1655 

 1656 

4. At the Enter Device Passcode to Trust This Computer screen: 1657 

a. Enter the device unlock passcode. 1658 

b. Select OK. 1659 
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Figure 2-140 Entering Passcode to Trust Computer 1660 

 1661 

5. In Configurator 2, select the representation of the connected device. 1662 

6. From the context menu, select Advanced > Erase All Content and Settings. 1663 



DRAFT 

 
NIST SP 1800-21C: Mobile Device Security: Corporate-Owned Personally-Enabled 127 

Figure 2-141 Resetting iPhone in Configurator 2 1664 

 1665 

7. At the Are you sure you want to erase "<device name>"? dialogue, select Erase. 1666 

Figure 2-142 Configurator 2 Erase Confirmation 1667 

 1668 

8. At the License Agreement screen: 1669 

a. Review the license agreement. 1670 

b. Select Accept to agree to the license and continue using the software. 1671 
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Figure 2-143 Configurator 2 License Agreement 1672 

 1673 

9. Configurator 2 will take several minutes to restore the device to factory default settings. 1674 

Configurator 2 will also activate the device following restoration. 1675 

Figure 2-144 Restoring iPhone 1676 

 1677 
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2.9.1.2 Placing an iOS Device into Supervised Mode 1678 

iOS devices that have been factory reset and subsequently activated (the Activation Lock has been 1679 

removed) can be placed into Supervised Mode using software available from Apple, Configurator 2, by 1680 

the following steps: 1681 

1. Pair the target iOS device with the system running Configurator 2 over USB. 1682 

2. Navigate to Configurator 2 > Unsupervised; a representation of the connected device 1683 

should appear. 1684 

3. On the All Devices tab: 1685 

a. Select the representation of the paired device. 1686 

b. From the context menu, select Prepare; a wizard will open to guide the process. 1687 

Figure 2-145 Prepare Option in Configuration 2 1688 

 1689 

4. For the Prepare Devices step: 1690 

a. Enable Supervise Devices. 1691 

b. Select Next. 1692 
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Figure 2-146 Device Preparation Options 1693 

 1694 

5. For the Enroll in MDM Server step: 1695 

a. Ensure the Server drop-down menu has Do not enroll in MDM selected. 1696 

b. Select Next. 1697 
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Figure 2-147 Preparation MDM Server Selection 1698 

 1699 

6. For the Sign into the Device Enrollment Program step, select Skip. 1700 
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Figure 2-148 Signing into Apple Account 1701 

 1702 

7. For the Assign to Organization step: 1703 

a. If you have previously created your organization, select Next and continue with Step 9. 1704 

b. If you have not created your organization, from the Organization drop-down menu, 1705 

select New Organization... 1706 
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Figure 2-149 Organization Assignment Dialogue 1707 

 1708 

8. At the Create an Organization screen: 1709 

a. In the Name field, enter the name of your organization. 1710 

b. In the Phone field, enter an appropriate support number for your mobility program. 1711 

c. In the Email field, enter an appropriate support email for your mobility program. 1712 

d. In the Address field, enter the address for your organization. 1713 

e. Select Next. 1714 
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Figure 2-150 Creating an Organization 1715 

 1716 

9. If your organization has established a digital identity for placing devices into Supervised 1717 

Mode: 1718 

a. Continue with Step 10. Note: that the same digital identity must be used for any given 1719 

device. 1720 

b. Otherwise, continue with Step 14. 1721 

10. In the Create an Organization screen: 1722 

a. For the Generate or choose a supervision identity option, select Choose an existing 1723 

supervision identity. 1724 

b. Select Next. 1725 
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Figure 2-151 Supervisory Identity Configuration 1726 

 1727 

11. Select Choose... 1728 
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Figure 2-152 Organization Selection 1729 

 1730 

12. At the Choose a supervising identity for the organization dialogue: 1731 

a. Select the digital certificate from the list of those available to the system. 1732 

b. Select Choose. 1733 

Figure 2-153 Supervising Identity Selection 1734 

 1735 

13. At the Create an Organization screen, select Next. 1736 
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Figure 2-154 Selected Organization 1737 

 1738 

14. In the Create an Organization screen: 1739 

a. For the Generate or choose a supervision identity option, select Generate a new 1740 

supervision identity. 1741 

b. Select Next. 1742 
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Figure 2-155 Create an Organization Supervision Identity Configuration 1743 

 1744 

15. For the Configure iOS Setup Assistant step: 1745 

a. Ensure the Setup Assistant drop-down menu shows Show only some steps selected; 1746 

additional options will appear. 1747 

b. Enable each of the Privacy, Passcode, Apple ID, and Location Services check-boxes. 1748 

c. Select Prepare. 1749 
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Figure 2-156 Setup Assistant Configuration 1750 

 1751 

16. Configurator 2 will take several minutes to prepare the device and place it into Supervised 1752 

Mode. 1753 

Figure 2-157 Waiting for iPhone 1754 

 1755 

2.9.1.3 Registration with MobileIron Core 1756 

The following steps will register an iOS device in Supervised Mode with MobileIron Core, which uses a 1757 

web-based process rather than the Mobile@Work app. 1758 
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1. Using Safari, navigate to MobileIron Core page, substituting <FQDN> for that of your 1759 

organization's instance of MobileIron Core. In our example implementation, the resulting 1760 

URL is https://mi-core.govt.mdse.nccoe.org/go . 1761 

Figure 2-158 MobileIron Registration Page 1762 

 1763 

2. At the warning that the web site is trying to open Settings to show a configuration profile, 1764 

select Allow; the Settings built-in app will open. 1765 

https://mi-core.govt.mdse.nccoe.org/go
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Figure 2-159 Opening Settings Confirmation 1766 

 1767 

3. At the Settings > Install Profile screen: 1768 

a. Verify the Signed by field indicates the server identity is Verified. 1769 

b. Select Install. 1770 

Figure 2-160 Profile Installation 1771 

 1772 

4. At the Installing Profile screen, select Install. 1773 
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Figure 2-161 Profile Installation 1774 

 1775 

5. At the Warning screen: 1776 

a. Verify that information under Root Certificate and MDM is consistent with information 1777 

provided by your mobile device administrator. 1778 

b. Select Install. 1779 
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Figure 2-162 Profile Installation Warning 1780 

 1781 

6. In the Remote Management dialogue, select Trust. 1782 
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Figure 2-163 Profile Installation Trust Confirmation 1783 

 1784 

7. At the Profile Installed screen, select Done. The device is now registered with MobileIron. 1785 

Figure 2-164 Profile Installation Confirmation 1786 

 1787 

2.9.2 Activating Lookout for Work on iOS 1788 

The configuration of the Lookout for Work (iOS) app in the MobileIron app catalog causes a 1789 

configuration file to be included during automatic install. As a result, when a user first launches Lookout 1790 
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for Work, it should be activated without any user interaction. Additional action is required to grant 1791 

Lookout for Work the permissions necessary for it to provide optimal protection. 1792 

1. Launch the Lookout for Work app; activation occurs silently at the splash screen. 1793 

Figure 2-165 Lookout for Work Splash Screen 1794 

 1795 

2. At the welcome screen, select Continue. 1796 
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Figure 2-166 Lookout for Work Permission Information 1797 

 1798 

3. At the "Lookout Work" Would Like to Send You Notifications dialogue, select Allow. 1799 
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Figure 2-167 Notifications Permissions Prompt 1800 

 1801 

4. At the Allow "Lookout Work" To Access Your Location? dialogue, select Always Allow. 1802 
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Figure 2-168 Locations Permission Prompt 1803 

 1804 

5. Lookout for Work should automatically perform scans of device and app activity and 1805 

provide feedback to the user. 1806 



DRAFT 

 
NIST SP 1800-21C: Mobile Device Security: Corporate-Owned Personally-Enabled 149 

Figure 2-169 Lookout for Work Home Screen 1807 

 1808 

2.9.3 Provisioning Work-Managed Android Devices with a Work Profile 1809 

In this scenario, Android devices are deployed as work-managed with a work profile. Enabling this 1810 

feature for AFW-capable devices requires a change to the AFW configuration. It also requires that the 1811 

device user already has a personal Google account to provision the work profile; it is not created as part 1812 

of the workflow to register a device with MobileIron Core. 1813 

2.9.3.1 Enable Work Profile on Work-Managed Devices 1814 

1. In the MobileIron Admin Portal, navigate to Policies > Configs > Configurations. 1815 

2. Enable the check box in the row for the AFW configuration. 1816 

3. In the Configuration Details pane, select Edit. 1817 
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Figure 2-170 MobileIron AFW Configuration 1818 

 1819 

4. In the Edit Android enterprise (all modes) Setting dialogue: 1820 

a. Enable Enable Managed Devices with Work Profile on the devices. 1821 

b. Enable Add Google account. 1822 

c. In the Google Account text box, provide a valid Google domain account. The example in 1823 

our reference implementation will map a MobileIron user ID of gema to and email 1824 

address of mdse.gema@gmail.com. See MobileIron Core 9.4.0.0 Device Management 1825 

Guide for AFW for a list of variables to appropriately adapt this field to your existing 1826 

identity management strategy. 1827 

d. Select Save. 1828 
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Figure 2-171 AFW Configuration 1829 

 1830 

2.9.3.2 Registering Android Devices 1831 

The following steps can only be completed when working with an Android device that is still set to (or 1832 

has been reset to) factory default settings.  1833 

5. When prompted to sign in with your Google Account: 1834 

a. In the Email or phone field, enter afw#mobileiron.core. 1835 

b. Select Next. 1836 
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Figure 2-172 MobileIron Enrollment Process 1837 

 1838 

6. When AFW prompts you to install Mobile@Work, select Install; this will download the 1839 

Mobile@Work client to the device. 1840 
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Figure 2-173 AFW Enrollment 1841 

 1842 

7. At the prompt to install MobileIron, select Install. 1843 
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Figure 2-174 MobileIron Installation 1844 

 1845 

8. At the Set up your device screen, select Accept. 1846 
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Figure 2-175 Accepting AFW Terms and Conditions 1847 

 1848 

9. This screen notifies the user of the data that Mobile@Work collects and how it is used. 1849 

When this information has been reviewed, select Accept. Mobile@Work will minimize and 1850 

return to the operating system home screen. 1851 
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Figure 2-176 MobileIron Privacy Information 1852 

 1853 

10. When MobileIron sends a Configuration Required notification, select the notification. 1854 
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Figure 2-177 MobileIron Configuration Required Notification 1855 

 1856 

11. On the Device Status > Create Work Profile screen, select Continue. 1857 
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Figure 2-178 MobileIron Device Status 1858 

 1859 

12. At the AFW prompt, select Continue. 1860 
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Figure 2-179 AFW Configuration 1861 

 1862 

13. AFW will notify the user that it is creating the personal workspace. The next two screens 1863 

repeat Steps 7 and 8 as above. 1864 
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Figure 2-180 AFW Workspace Creation 1865 

 1866 

14. At the Device Status > Work Profile Lock Preferences screen, select Continue. 1867 
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Figure 2-181 MobileIron Work Profile Lock Preferences 1868 

 1869 

15. The user will be prompted to create a passcode to protect the AFW container. 1870 

16. At the Device Status > Add Google Account screen, select Continue. 1871 
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Figure 2-182 MobileIron Google Account Configuration 1872 

 1873 

17. The user will be prompted to authenticate to the same Google domain account mapped to 1874 

their MobileIron account based on the email address set in the AFW configuration in 1875 

MobileIron Core. In our example implementation, the mapped Google account is 1876 

mdse.gema@gmail.com. 1877 

18. Once the Mobile@Work app has been provisioned with the user's account, the Device 1878 

Status screen should appear; the device has now successfully been provisioned into 1879 

MobileIron. 1880 
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Figure 2-183 MobileIron Device Status 1881 

 1882 
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Appendix A List of Acronyms 
AD Active Directory 

AFW Android for Work 

API Application Programming Interface 

CA Certificate Authority 

CN Common Name 

CSP Common Service Provider 

DMZ Demilitarized Zone 

DN Distinguished Name 

DNS Domain Name System 

DPC Derived Personal Identity Verification Credential 

EMM Enterprise Mobility Management 

FQDN Fully Qualified Domain Name 

GOVT Government 

HTTP Hypertext Transfer Protocol 

HTTPS Hypertext Transfer Protocol Secure 

IMEI International Mobile Equipment Identity 

ID Identifier 

IP Internet Protocol 

LAN Local Area Network 

LDAP Lightweight Directory Access Protocol 

MDM Mobile Device Management 

MDS Mobile Device Security 

MES Mobile Endpoint Security 

MTP Mobile Threat Posture 

NAT Network Address Translation 

NCCoE National Cybersecurity Center of Excellence 

NIST National Institute of Standards and Technology 

NTP Network Time Protocol 

OU Organizational Unit 

OVA Open Virtualization Appliance 

PLIST Property List 
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SCEP Simple Certificate Enrollment Protocol 

SSH Secure Shell 

SSID Service Set Identifier 

SSL Secure Sockets Layer 

TLS Transport Layer Security 

URL Uniform Resource Locator 

USB Universal Serial Bus 

VLAN Virtual Local Area Network 

VPN Virtual Private Network 

WAN Wide Area Network 
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Appendix B Glossary 
Application 
Programming Interface 
(API) 

A system access point or library function that has a well-defined 
syntax and is accessible from application programs or user code 
to provide well-defined functionality [1] 

App-Vetting Process The process of verifying that an app meets an organization's 
security requirements. An app vetting process comprises app 
testing and app approval/rejection activities [2] 

Authenticate Verifying the identity of a user, process, or device, often as a 
prerequisite to allowing access to resources in an information 
system [3] 

Certificate A data structure that contains an entity’s identifier(s), the 
entity's public key (including an indication of the associated set 
of domain parameters) and possibly other information, along 
with a signature on that data set that is generated by a trusted 
party, i.e. a certificate authority, thereby binding the public key 
to the included identifier(s) [4] 

Certificate Authority 
(CA) 

A trusted entity that issues and revokes public key certificates 
[5] 

Demilitarized Zone 
(DMZ) 

An interface on a routing firewall that is similar to the interfaces 
found on the firewall’s protected side. Traffic moving between 
the DMZ and other interfaces on the protected side of the 
firewall still goes through the firewall and can have firewall 
protection policies applied. [6] 

Derived Personal 
Identity Verification 
(PIV)  

A credential issued based on proof of possession and control of 
the PIV Card, so as not to duplicate the identity proofing process 
as defined in [SP 800-63-2]. A Derived PIV Credential token is a 
hardware or software-based token that contains the Derived PIV 
Credential. [7] 

Hypertext Transfer 
Protocol (HTTP) 

A standard method for communication between clients and 
Web servers [8] 

Hypertext Transfer 
Protocol Secure (HTTPS) 

HTTP transmitted over TLS [9] 

Internet Protocol (IP) 
addresses  

Standard protocol for transmission of data from source to 
destinations in packet-switched communications networks and 
interconnected systems of such networks [10] 
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Lightweight Directory 
Access Protocol (LDAP) 

The Lightweight Directory Access Protocol, or LDAP, is a 
directory access protocol. In this document, LDAP refers to the 
protocol defined by RFC 1777, which is also known as LDAP V2. 
LDAP V2 describes unauthenticated retrieval mechanisms. [11] 

Local Area Network 
(LAN) 

A group of computers and other devices dispersed over a 
relatively limited area and connected by a communications link 
that enables any device to interact with any other on the 
network [12] 

Mutual Authentication  The process of both entities involved in a transaction verifying 
each other [13] 

Passphrase A passphrase is a memorized secret consisting of a sequence of 
words or other text that a claimant uses to authenticate their 
identity. A passphrase is similar to a password in usage, but is 
generally longer for added security. [14] 

Personal Identity 
Verification (PIV)  

A physical artifact (e.g., identity card, “smart” card) issued to a 
government individual that contains stored identity credentials 
(e.g., photograph, cryptographic keys, digitized fingerprint 
representation) so that the claimed identity of the cardholder 
can be verified against the stored credentials by another person 
(human readable and verifiable) or an automated process 
(computer readable and verifiable). PIV requirements are 
defined in FIPS PUB 201. [15] 

Risk Analysis  The process of identifying the risks to system security and 
determining the probability of occurrence, the resulting impact, 
and the additional safeguards that mitigate this impact. Part of 
risk management and synonymous with risk assessment. [16] 

Risk Assessment The process of identifying risks to organizational operations 
(including mission, functions, image, reputation), organizational 
assets, individuals, other organizations, and the Nation, resulting 
from the operation of an information system. [17] 

Root Certificate 
Authority (CA) 

In a hierarchical public key infrastructure (PKI), the certification 
authority (CA) whose public key serves as the most trusted 
datum (i.e., the beginning of trust paths) for a security domain 
[18] 
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