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NATIONAL CYBERSECURITY CENTER OF EXCELLENCE 1 

The National Cybersecurity Center of Excellence (NCCoE), a part of the National Institute of Standards 2 
and Technology (NIST), is a collaborative hub where industry organizations, government agencies, and 3 
academic institutions work together to address businesses’ most pressing cybersecurity issues. This 4 
public-private partnership enables the creation of practical cybersecurity solutions for specific 5 
industries, as well as for broad, cross-sector technology challenges. Through consortia under 6 
Cooperative Research and Development Agreements (CRADAs), including technology partners—from 7 
Fortune 50 market leaders to smaller companies specializing in information technology security—the 8 
NCCoE applies standards and best practices to develop modular, easily adaptable example cybersecurity 9 
solutions using commercially available technology. The NCCoE documents these example solutions in 10 
the NIST Special Publication 1800 series, which maps capabilities to the NIST Cybersecurity Framework 11 
and details the steps needed for another entity to re-create the example solution. The NCCoE was 12 
established in 2012 by NIST in partnership with the State of Maryland and Montgomery County, 13 
Maryland. 14 

To learn more about the NCCoE, visit https://www.nccoe.nist.gov/. To learn more about NIST, visit 15 
https://www.nist.gov. 16 

NIST CYBERSECURITY PRACTICE GUIDES 17 

NIST Cybersecurity Practice Guides (Special Publication 1800 series) target specific cybersecurity 18 
challenges in the public and private sectors. They are practical, user-friendly guides that facilitate the 19 
adoption of standards-based approaches to cybersecurity. They show members of the information 20 
security community how to implement example solutions that help them align more easily with relevant 21 
standards and best practices, and provide users with the materials lists, configuration files, and other 22 
information they need to implement a similar approach. 23 

The documents in this series describe example implementations of cybersecurity practices that 24 
businesses and other organizations may voluntarily adopt. These documents do not describe regulations 25 
or mandatory practices, nor do they carry statutory authority.  26 

ABSTRACT 27 

Medical imaging plays an important role in diagnosing and treating patients. The system that manages 28 
medical images is known as the picture archiving communication system (PACS) and is nearly ubiquitous 29 
in healthcare environments. PACS is defined by the Food and Drug Administration (FDA) as a Class II 30 
device that “provides one or more capabilities relating to the acceptance, transfer, display, storage, and 31 
digital processing of medical images.” PACS centralizes functions surrounding medical imaging 32 
workflows and serves as an authoritative repository of medical image information.  33 

https://www.nccoe.nist.gov/
https://www.nist.gov/
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PACS fits within a highly complex healthcare delivery organization (HDO) environment that involves 34 
interfacing with a range of interconnected systems. PACS may connect with clinical information systems 35 
and medical devices and may involve engaging with health professionals who may be both internal and 36 
external to the HDO. This complexity may introduce or expose opportunities that allow malicious actors 37 
to compromise the confidentiality, integrity, and availability of the PACS ecosystem. 38 

The NCCoE at NIST analyzed risk factors regarding the PACS ecosystem by using a risk assessment based 39 
on the NIST Risk Management Framework, and the NCCoE leveraged the NIST Cybersecurity Framework 40 
and other relevant standards to identify measures to safeguard the ecosystem. The NCCoE developed an 41 
example implementation that demonstrates how HDOs can use standards-based, commercially available 42 
cybersecurity technologies to better protect the PACS ecosystem. This practice guide will help HDOs 43 
implement current cybersecurity standards and best practices, to reduce their cybersecurity risk while 44 
maintaining the performance and usability of PACS. 45 

KEYWORDS 46 

Access control; auditing; authentication; authorization; behavioral analytics; DICOM; encryption 47 
microsegmentation; multifactor authentication; PACS; picture archiving and communication system; 48 
PAM; privileged account management; vendor neutral archive; VNA. 49 
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1 Introduction 107 

The following volumes of this guide show information technology (IT) professionals and security 108 
engineers how we implemented this example solution. We cover all of the products employed in this 109 
reference design. We do not recreate the product manufacturers’ documentation, which is presumed to 110 
be widely available. Rather, these volumes show how we incorporated the products together in our 111 
environment. 112 

Note: These are not comprehensive tutorials. There are many possible service and security configurations 113 
for these products that are out of scope for this reference design. 114 

1.1 Practice Guide Structure 115 

This National Institute of Standards and Technology (NIST) Cybersecurity Practice Guide demonstrates a 116 
standards-based reference design and provides users with the information they need to replicate all or 117 
parts of the example implementation that was built in the National Cybersecurity Center of Excellence 118 
(NCCoE) lab. This reference design is modular and can be deployed in whole or in part. 119 

This guide contains three volumes: 120 

NIST SP 1800-24A: Executive Summary 121 

NIST SP 1800-24B: Approach, Architecture, and Security Characteristics – what we built and why 122 

NIST SP 1800-24C: How-To Guides – instructions for building the example solution (you are here) 123 

Depending on your role in your organization, you might use this guide in different ways: 124 

Business decision makers, including chief security and technology officers, will be interested in the 125 
Executive Summary, NIST SP 1800-24A, which describes the following topics: 126 

challenges that enterprises face in securing the picture archiving and communication system (PACS) 127 

example solution built at the NCCoE 128 

benefits of adopting the example solution 129 

Technology or security program managers who are concerned with how to identify, understand, assess, 130 
and mitigate risk will be interested in NIST SP 1800-24B, which describes what we did and why. The 131 
following sections will be of particular interest: 132 

Section 3.4, Risk Assessment, describes the risk analysis we performed. 133 

Section 3.5, Security Control Map, maps the security characteristics of this example solution to 134 
cybersecurity standards and best practices. 135 
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You might share the Executive Summary, NIST SP 1800-24A, with your leadership team members to help 136 
them understand the importance of adopting standards-based, commercially available technologies that 137 
can help secure the PACS ecosystem. 138 

IT professionals who want to implement an approach like this will find this whole practice guide useful. 139 
You can use this How-To portion of the guide, NIST SP 1800-24C, to replicate all or parts of the build 140 
created in our lab. This How-To portion of the guide provides specific product installation, configuration, 141 
and integration instructions for implementing the example solution. We do not recreate the product 142 
manufacturers’ documentation, which is generally widely available. Rather, we show how we 143 
incorporated the products together in our environment to create an example solution. 144 

This guide assumes that IT professionals have experience implementing security products within the 145 
enterprise. While we have used a suite of commercial products to address this challenge, this guide does 146 
not endorse these particular products. Your organization can adopt this solution or one that adheres to 147 
these guidelines in whole, or you can use this guide as a starting point for tailoring and implementing 148 
parts of PACS security solution. Your organization’s security experts should identify the products that 149 
will best integrate with your existing tools and IT system infrastructure. We hope that you will seek 150 
products that are congruent with applicable standards and best practices. Section 3.6, Technologies, lists 151 
the products that we used and maps them to the cybersecurity controls provided by this reference 152 
solution. 153 

A NIST Cybersecurity Practice Guide does not describe “the” solution, but a possible solution. This is a 154 
draft guide. We seek feedback on its contents and welcome your input. Comments, suggestions, and 155 
success stories will improve subsequent versions of this guide. Please contribute your thoughts to 156 
hit_nccoe@nist.gov. 157 

Acronyms used in figures can be found in Appendix A. 158 

1.2 Build Overview 159 

The NCCoE built a hybrid virtual-physical laboratory environment to explore methods to effectively 160 
demonstrate the capabilities in securing the PACS ecosystem. While the project implemented PACS and 161 
vendor neutral archive (VNA) solutions, as well as implemented security controls, the environment 162 
leverages modality emulation to simulate medical image acquisition. The project also implemented an 163 
emulated radiology information system (RIS), used to generate modality work lists and therefore 164 
support common medical imaging workflows. The project then applied security controls to the lab 165 
environment. Refer to NIST SP 1800-24B, Approach, Architecture, and Security Characteristics, for an 166 
explanation of why we used each technology. 167 

mailto:hit_nccoe@nist.gov
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1.3 Typographic Conventions 168 

The following table presents typographic conventions used in this volume. 169 

Typeface/Symbol Meaning Example 

Italics file names and path names; 
references to documents that 
are not hyperlinks; new 
terms; and placeholders 

For language use and style guidance, 
see the NCCoE Style Guide. 

Bold names of menus, options, 
command buttons, and fields 

Choose File > Edit. 

Monospace command-line input, 
onscreen computer output, 
sample code examples, and 
status codes 

mkdir 

Monospace Bold command-line user input 
contrasted with computer 
output 

service sshd start 

blue text link to other parts of the 
document, a web URL, or an 
email address 

All publications from NIST’s NCCoE 
are available at 
https://www.nccoe.nist.gov. 

https://www.nccoe.nist.gov/
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1.4 Logical Architecture Summary 170 

Figure 1-1 depicts a reference network architecture, introduced in NIST SP 1800-24B, Section 4.2, Final 171 
Architecture, which performs groupings that would translate to network segments or zones. The 172 
rationale behind segmentation and zoning is to limit trust between areas of the network. In considering 173 
a hospital infrastructure, the NCCoE identified devices and usage and grouped them by usage. The 174 
grouping facilitated identification of network zones. Once zones are defined, infrastructure components 175 
may be configured so that those zones do not inherently have network access to other zones within the 176 
hospital network infrastructure. Segmenting the network in this fashion limits the overall attack surface 177 
posed to the PACS environment and considers the network infrastructure configuration as part of an 178 
overall defense-in-depth strategy.  179 

Figure 1-1 PACS Final Architecture 180 

 

2 Product Installation Guides 181 

This section of the practice guide contains detailed instructions for installing and configuring the 182 
products that the NCCoE used to build an instance of the example solution. 183 

The project implemented security capabilities across the laboratory infrastructure, to safeguard the 184 
emulated modalities, emulated RIS, viewer workstations, and PACS and VNA systems. Security control 185 
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products that align with capabilities were implemented for the environment. Products that align with 186 
the security capabilities are enumerated in NIST 1800-24B, Section 3.6, Technologies, Table 3-5. 187 

2.1 Picture Archiving and Communication System (PACS) 188 

This project implemented two separate PACS: Philips IntelliSpace solution and an open source PACS 189 
(DCM4CHEE). These PACS systems are used to emulate the case where healthcare delivery organizations 190 
(HDOs) may have different PACS vendors installed in their environment.  191 

2.1.1 Philips IntelliSpace PACS 192 

The project implements the Philips IntelliSpace PACS solution as a central component to the lab build. 193 
IntelliSpace includes several common features, such as the ability to integrate digital imaging and 194 
communication in medicine (DICOM) and non-DICOM images and provides the project team the ability 195 
to emulate common medical imaging workflow processes. The project deploys an IntelliSpace instance 196 
to receive images from an open source modality emulator tool, which allows the project to simulate 197 
working HDO environments. The project integrates IntelliSpace with the Hyland VNA solution also 198 
installed in the lab. 199 

System Requirements 200 

Philips IntelliSpace system consists of several components installed on different VMware virtual 201 
machines (VMs). Base configuration requirements to construct the IntelliSpace VMs are depicted in 202 
Table 2-1. 203 

Table 2-1 Base VM Configuration Requirements 204 

VM Name  Description  Central 
Processing 
Unit (CPU) 

Memory Storage Operating 
System 

Software 

DC1 Domain 
Controller 

4 8 gigabytes 
(GB) of 
random 
access 
memory 
(RAM) 

200 GB Microsoft 
Windows 
Server 
2012 

Microsoft 
Structured Query 
Language (SQL) 
2012, Internet 
Information 
Services (IIS) 7 

IntelliSpace 
Server 

Infrastructure, 
Integration, 
Rhapsody 
Health Level 7 
(HL7), DICOM 
processor, 
SQL Database 

4 8 GB RAM 200 GB Microsoft 
Windows 
Server 
2012 

Microsoft SQL 
2012, IIS 7 
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VM Name  Description  Central 
Processing 
Unit (CPU) 

Memory Storage Operating 
System 

Software 

(DB), 
Anywhere 
Viewer (web 
client) 

UDM  Universal Data 
Manager 
(UDM), WEB 
DICOM 
services 
Image 
Lifecycle 
Management 
Image pre 
fetching from 
VNA 

4 8 GB RAM 200 GB Microsoft 
Windows 
Server 
2012 

Microsoft SQL 
2012, IIS 7 

 

IntelliSpace PACS Client Installation 205 

The project team collaborated with a team of Philips Healthcare deployment engineers to install the 206 
environment. Based on the base VM configuration requirements, the NCCoE team created the VMs by 207 
using the open virtualization format (OVF) files provided by Philips Healthcare. Philips engineers 208 
deployed the applications on the VMs and created instances for DC1, IntelliSpace server, and UDM, as 209 
noted in Table 2-1. VM instances were deployed on respective servers. 210 

IntelliSpace PACS is a web-based distributed system. Clinicians, referring physicians, nurses, or 211 
bioengineers use web-based client application on workstations to view, analyze, and qualify medical 212 
images. Once the server components were installed, the web-based client installation was performed 213 
using the following procedures: 214 

1. Open Internet Explorer from a workstation and assign the IntelliSpace server with the internet 215 
protocol (IP) address 192.168.140.131. Enter the IntelliSpace server (IP) address in the address bar 216 
by using the following URL: https://192.168.140.131/clientweb/installers. 217 

2. Select InstelliSpacePACSEnterpriseSetup.exe under the Standalone Installers bullet list of available 218 
IntelliSpace PACS Installers screen to start the installation. 219 
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 220 

3. An option to choose setup language appears. Select the English (United States) from the pull-down 221 
and click OK. 222 

 223 

4. After the setup language has been set, the InstallShield Wizard begins the installation process. 224 
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 225 

5. Use the default setting for the Custom Setup and click on the Next > button that appears at the 226 
bottom of this window. 227 

 228 

6. On the Client Configuration Info window, enter 192.168.140.131 as the Server IP address, and click 229 
Install. 230 
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 231 

7. When installation is finished, the InstallShield Wizard provides a message indicating successful 232 
installation. Click Finish. 233 

 234 

8. Once the installation is done, the installer places an IntelliSpace PACS Enterprise icon on the 235 
desktop. Type Tester in the User Name field and the corresponding password in the Password 236 
field, then click OK to log in. 237 
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 238 

9. When the program launches, the default page launches the Patient Lookup screen. 239 

 240 

10. To view an exam, navigate to Exam Lookup, which lists a summary of a patient’s exams. Double-241 
click an exam in the list. If the exam has an image, it will be displayed. An example is shown below. 242 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 11 

 243 

IntelliSpace PACS Client Configuration 244 

Deployment and configuration were accomplished by Philips Deployment Engineers using PowerCLI and 245 
scripts. Other basic configurations can be implemented through the administration web page provided 246 
by the IntelliSpace PACS by using the URL https://192.168.140.131/PACSAdministration.  247 

1. Enter the admin as the User Name, enter the proper Password, select AD PACS from the Logon to 248 
drop-down list, select Password from the Logon Mode, then click OK. 249 

 250 
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2. On the admin home page, add a new user by navigating to Security, found on the far-left column of 251 
the Common Tasks screen. Click on Users and then click on Add a New User. 252 

 253 

3. To add a new user, navigate to SECURITY, found on the far-left column of the Common Tasks 254 
screen, and click on Users. 255 

a. Enter the User ID. 256 

b. Enter the user’s First Name. 257 

c. Enter the user’s Middle Name (optional). 258 

d. Enter the user’s Last Name. 259 

e. Enter the user’s Email Address (optional). 260 

f. Assign an IntelliSpace PACS AdminTool Password for the user (required). Enter the password 261 
again to confirm it. 262 

Configure Sources for User Authentication 263 

IntelliSpace supports either a locally hosted or an external authentication source. An authentication 264 
source provides a directory structure that authenticates and manages user and group accounts. The 265 
internal authentication source, called iSite, implements a local database of users and groups. 266 
IntelliSpace also supports a lightweight directory access protocol (LDAP) server connected to a Microsoft 267 
active directory (AD). The External User Authentication is used as the configuration source. The 268 
following steps describe how to create an LDAP authentication source: 269 

1. From the navigation bar, select the Security button and then click Authorities. 270 
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 271 

2. Click New to open the External Authentication Source wizard. 272 

 273 

3. On the External Authentication source page, set the following values and then click Next. 274 

 Set Authority Name to AD.PACS.HCLAB 275 

 Set the Display Name to AD PACS 276 

 Select HostName for Name Resolution 277 

 Check the box next to Enabled 278 
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 Check the box next to Show in Login Screen 279 

 280 

4. In the Advanced Directory Configuration, set DNS Host Name as ad.pacs.hclab and Port as 389. 281 

 282 

5. Navigate to the Edit External Authentication Source screen. In this project, the Directory Type is 283 
ActiveDirectory and the Supported Credentials is Password. Click Save to save the settings. 284 
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 285 

6. The interface provides a test feature to allow engineers to determine connectivity with the external 286 
authentication source. From the navigation bar, select the Security > Authorities. Click on the 287 
name of the External Authentication Source, and click Test. 288 

 289 

Configure Connection to Modality Emulator 290 

The open source DVTk Modality Emulator was used as a modality for testing the communication 291 
between IntelliSpace PACS and a modality. The installation of the DVTk Modality Emulator can be found 292 
in Section 2.4.1. Below are the configuration steps: 293 
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1. From the DVTk Modality application, click the Configure Emulator tab to set up a proper System 294 
Name, e.g., Modality; an application entity title (AE Title), e.g., DVTK_MODALITY; and a 295 
communication Listening Port, e.g., 104 for the emulator itself. 296 

 297 

2. From the DVTk Modality application, click the Remote Systems tab to configure the remote 298 
systems, including RIS System, MPPS Manager, and PACS/Workstation Systems. Information for 299 
each system’s IP address as well as the port number are needed. Particularly, the AE Title for the 300 
Philips IntelliSpace PACS is required for the AE Title field. These are the input values: 301 

RIS System 302 

 IP Address: 192.168.160.201 303 

 Remote Port: 105 304 

 AE Title: DVTK_RIS 305 

MPPS Manager 306 

 IP Address: 192.168.160.201 307 

 Remote Port: 108 308 

 AE Title: DVTK_MPPS 309 

PACS/Workstation Systems–Storage Config 310 

 IP Address: 192.168.140.131 311 
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 Remote Port: 104 312 

 AE Title: STENTOR_SCP 313 

PACS/Workstation Systems–Storage Commit Config 314 

 IP Address: 192.168.140.131 315 

 Remote Port: 104 316 

 AE Title: STENTOR_SCU 317 

 318 

3. To configure the Philips IntelliSpace PACS AE Title and communication port, log on to the iSite 319 
Administration web site using the URL https://192.168.140.131/ iSiteWeb. Select Configure > 320 
DICOM > General, set the following values, and then click Save to save the settings. 321 

 Normal AE Title: STENTOR_SCP 322 

 High-Priority AE Title: STENTOR_HI 323 

 Port: 104 324 

 Secure Port: 2762 325 
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 326 

4. To test the connectivity, go to the DVTk Emulator application, then go to the Modality Emulator 327 
home page as shown below. Click the Ping PACS/Workstation and DICOM Echo buttons to verify 328 
the success of the pings. You should receive Ping Successful and DICOM Echo Successful messages. 329 

 330 

Configure IntelliSpace PACS to Communicate with Hyland VNA  331 

Refer to Section 2.2.2 for detailed installation guidance for Hyland VNA. 332 

1. Obtain the Hyland VNA AE Title and port information for communication. Log in to the iSite 333 
Administration page by using the URL https://192.168.140.131/iSiteWeb 334 
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2. From the Configure drop-down list, select DICOM to open the DICOM configuration page. 335 

3. Fill in the known Hyland AE Title (e.g., RADIOLOGY), IP Address (e.g., 192.168.130.120), Port (e.g., 336 
114), and other necessary information.  337 

 338 

4. Log in to the IntelliSpace PACS Administration page using 339 
https://192.168.140.131/PACSAdministration. 340 

5. Click the Configuration button on the left panel to configure the Auto Export Rule. 341 

6. Click the New button to create a new rule named ForwardHylandVNA. 342 

 343 

7. Set the Trip Type as New Data Arrival. 344 
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8. Set the Receiving AE Title as Stentor_SCP, which is the AE Title for Philips IntelliSpace PACS. 345 

9. Choose Hyland VNA (RADIOLOGY) from the Selected Destination box. 346 

  347 

2.1.2 DCM4CHEE 348 

DCM4CHEE is a collection of open source applications that communicate with each other using DICOM 349 
and HL7 standards for clinical-image management and archiving. In this study, DCM4CHEE has JBoss and 350 
a web-based graphical user interface (GUI) application built in. JBoss is used to configure DCM4CHEE to 351 
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communicate with DVTk’s Modality Emulator to store images in a PostgreSQL database. The JBoss web 352 
interface allows an administrator to configure DCM4CHEE to listen for connection requests from specific 353 
application entities like DVTk’s Modality Emulator. DCM4CHEE also has web-based GUI that displays 354 
patient records sent from the Modality Emulator and stored in the PostgreSQL database.  355 

A 32-bit version of Java JDK6 [1], JBoss v4.2.3 [2], and PostgreSQL database v 9.4.23 [3], [4] were 356 
installed as the prerequisites for the DCM4CHEE. Refer to each installation guide for the installation 357 
procedures. 358 

System Requirements 359 

CPU: 4 360 

Memory: 512 megabyte (MB) RAM 361 

Storage: 200 MB 362 

Operating System: Microsoft Windows Server 2016 Datacenter 363 

Network Adapter: Virtual Local Area Network (VLAN) 1402 364 

DCM4CHEE Installation 365 

The installation guide can be found at [5].  366 

1. Go to https://www.dcm4che.org to download the software. 367 

2. In the left-hand side of the page, click the Wiki link under Community. 368 

3. Click the here link under Download Latest Version nest to dcm4chee DICOM Archive 2 (includes 369 
dcm4che toolkit 1.4) [6] link on the right-hand side of the screen. 370 

4. On the new web page, click 2.17.1 to download that version of DCM4CHEE. 371 

DCM4CHEE Audit Report Repository Installation 372 

Download the file relevant to PostgreSQL from the SourceForge site [7]. Once downloaded, go to the 373 
dcm4chee-2.17.1-psql\bin directory by using a command prompt, and execute this command: 374 
Install_arr.bat <path to the audit report file>. 375 

Test the DCM4CHEE Installation 376 

1. Go to dcm4chee-2.17.1-psql\bin directory by using a command prompt and run this command: 377 
Run.bat. 378 

2. Successful run will produce this output: 379 

https://www.dcm4che.org/
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 380 

DCM4CHEE Configuration Using the JMX Console 381 

1. Access the JMX Console GUI by navigating to http://localhost:8080/jmx-console/ and providing the 382 
following credentials: 383 

 Username: admin 384 

 Password: ***** 385 

2. Click the link group=ONLINE_STORAGE,service=FileSystemMgt under the dcmrchee.archive 386 
heading. 387 

 388 

3. Click the Invoke button under the addRWFileSystem() section to instantiate where archived data 389 
should be stored. If no specific file path is provided as a parameter, the default location is 390 
dcm4chee-2.7.1-psql\server\default\archive. 391 

 392 

4. Change the default AE Title: 393 
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 The default AE Title is DCM4CHEE. 394 

 Change the title by clicking the service=AE link under dcm4chee.archive heading. 395 

 396 

5. Under the updateAETitle section, provide the default AETitle and new AETitle as parameters, and 397 
click the Invoke button on the bottom left-hand side of the table. 398 

 399 

6. You can also change the port number that DCM4CHEE uses. Default port numbers are 104 and 400 
11112. Port 11112 was used for communicating with DVTk Modality Emulator. 401 

 402 

DVTk Modality to DCM4CHEE Configuration  403 

1. Open a web browser to access http://localhost:8080/dcm4chee-web3/ and provide the following 404 
credentials: 405 

 Username: admin 406 

 Password: ***** 407 

 408 
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2. Click the Application Entities tab in the ribbon on the top of the screen. 409 

 410 

3. Click the New AET button in the left-hand side of the AEs page and provide the following 411 
information:  412 

 Title: PACS 413 

 Type: - 414 

 Hostname: 192.168.141.206 415 

 Port: 11112 416 

 User Id: Admin 417 

 Password: ***** 418 

4. Click the Save button at the bottom center of the screen. 419 
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  420 

View Stored Data 421 

1. Click the Folder tab located on the top ribbon of the page on the left-hand side of the screen. 422 

2. Click the Search button on the right-hand side of the screen above the buttons Delete, Move, and 423 
Export. 424 

3. No parameters are needed if you want to see all documents stored. 425 

 426 
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DCM4CHEE to DVTk Modality Configuration 427 

1. In the Modality Emulator, click the Configure Remote Systems tab at the top of the window. 428 
2. Navigate to the PACS/Workstation Systems section and input the information with the following 429 

values: 430 

RIS System 431 

 IP Address: 192.168.160.201 432 

 Remote Port: 105 433 

 AE Title: RIS 434 

MPPS Manager 435 

 IP Address: 192.168.160.201 436 

 Remote Port: 106 437 

 AE Title: MPPS 438 

PACS/Workstation Systems–Storage Config 439 

 IP Address: 192.168.141.206 440 

 Remote Port: 11112 441 

 AE Title: PACS 442 

PACS/Workstation Systems–Storage Commit Config 443 

 IP Address: 192.168.141.206 444 

 Remote Port: 11112 445 

 AE Title: PACS 446 
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 447 

Oviyam Installation 448 

Once downloaded from the SourceForge [8] and unzipped, copy the oviyam.war file to the following 449 
directory: dcm4chee-2.7.1\server\default\deploy. Check if you successfully installed the software by 450 
visiting http://dcm4chee_ip:8080/oviyam2 and accessing a log in screen. 451 

Oviyam Configuration 452 

1. Using a browser, navigate to http://dcm4chee_ip:8080/oviyam2 and provide the following 453 
credentials: 454 

 Username: admin 455 

 Password: ***** 456 

 457 
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2. Navigate to the top right corner of the screen, click admin, and then click Settings. 458 

 459 

3. Under the Server tab, click Add. 460 

 461 

4. Fill in the PACS server parameters and click the Save button located to the far right of the 462 
parameters. 463 

 Description: PACS 464 

 AE Title: DCM4CHEE 465 

 Host Name: localhost 466 

 Port: 11112 467 

 Retrieve Type: WADO 468 

 WADO Context: wado 469 

 WADO Port: 8080 470 

 Image Type: JPEG 471 

 472 

5. Return to http://dcm4chee_ip:8080/oviyam2 to see query parameters now available. 473 

6. Click the Search button under the parameters on the right-hand side of the screen. 474 
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 475 

7. Double-click on a patient record. 476 

 477 

8. View images related to that patient record. 478 

 479 

2.2 VNA 480 

Hyland Acuo VNA features several different systems and applications, which include: 481 

Acuo VNA: core application server with services used to store, track, and retrieve digital assets stored in 482 
an archive 483 

PACSgear Core Server: image processing and routing server, and back-end services 484 

PACS Scan Mobile/Web: mobile device image acquisition and file-import application  485 

NilRead: enterprise image-viewing application 486 
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The diagram depicted in Figure 2-1 shows the connectivity between the Hyland Acuo VNA systems and 487 
applications. 488 

Figure 2-1 Hyland Systems and Applications Connectivity 489 

 490 

Installation procedures for the above Hyland products are described in the sections that follow. 491 

2.2.1 Hyland Database Server 492 

Hyland Database Server supports operations for other Hyland products, including Hyland Acuo VNA and 493 
Hyland NilRead. The installation and configuration procedures can be found below: 494 

System Requirements 495 

CPU: 4 496 

Memory: 12 GB RAM 497 

Storage: 498 

 Hard Drive (HD)1: 80 GB (Operating System Install) 499 

 HD 2: 20 GB (DB Drives) 500 

 HD 3: 10 GB (Tx Logs) 501 

Operating System: Microsoft Windows Server 2016 502 

Network Adapter: VLAN 1801 503 

Hyland Database Server Installation 504 
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Install the SQL Server 2017 according to the instructions detailed in Install SQL Server from the 505 
Installation Wizard (Setup) [9]. 506 

Hyland Database Configuration 507 

1. The installation creates default service accounts for each service. The project maintained use of 508 
these default service accounts. User and privileged log in accounts were created for the Hyland 509 
application suite and linked to unique Microsoft domain users. The project created the 510 
PACS\AcuoServiceUser and PACS\Administrator accounts. 511 

2. The project implemented Windows Authentication Mode for the SQL Server. 512 

3. Application database instances were created as needed automatically when product applications 513 
were installed. 514 

4. This project implemented the following database instances through the SQL Server Management 515 
Studio: AcuoMed, HUBDB, NILDB, and PGCORE. 516 

5. The project also implemented instances for OPHTHALMOLOGY, RADIOLOGY, and WOUND_CARE. 517 

2.2.2 Hyland Acuo VNA 518 

Hyland Acuo VNA provides access to medical images and documents through interactions with a variety 519 
of different PACS, modalities, and image viewers. Acuo VNA also supports various standards, including 520 
HL7 and DICOM. The installation and configuration procedures can be found below. 521 

System Requirements 522 

CPU: 6 523 

Memory: 12 GB RAM 524 

Storage: 525 

 HD 1: 80 GB (OS Install) 526 

 HD 2: 80 GB (Dilib Cache Drive) 527 

 HD 3: 500 GB (Image Cache Drive) 528 

Operating System: Microsoft Windows Server 2016 529 

Network Adapter: VLAN 1301 530 

Hyland Acuo VNA Installation 531 

1. In the NCCoE test environment, the Hyland Acuo VNA was installed on a VM preconfigured with the 532 
OS and network requirements provided by Hyland. The project leveraged engineers supplied by 533 
Hyland to perform the installation.  534 
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2. Upon completion of the installation, three Windows services were created: AcuoMed, AcuoAudit, 535 
and AcuoStore. AcuoMed is associated with a DICOM database containing the patient, study, and 536 
series record information that describes the images physically present on the Acuo VNA archive 537 
system. The AcuoStore also has its own database for storing information related to the bulk storage 538 
of digital images and related data, including information about the shares and about the applications 539 
that use those shares.  540 

3. The installation created a web application for the AcuoAdmin Portal, where a Secure Sockets Layer 541 
(SSL) certificate signed by DigiCert was created and assigned to the application for hypertext transfer 542 
protocol secure (HTTPS) enforcement. 543 

Hyland Acuo VNA Configuration 544 

Hyland engineers performed configurations using the Microsoft MMC console and the AcuoAdmin 545 
Portal (https://192.168.130.120:8099/vnaweb/#1/home). The screenshots of the console management 546 
for these administration approaches are shown below: 547 

 548 

To verify successful completion of the VNA installation, the Hyland engineers launched the Acuo 549 
Administrator Portal application from the VNA server (local host). The Acuo Administrator Portal screen 550 
sample is shown below. 551 
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 552 

2.2.3 PACSgear Core Server 553 

PACSgear Core Server is a capture and connectivity suite used to process DICOM and non-DICOM 554 
medical data, including patient demographics, images, videos, and HL7 messages. PACSgear Core Server 555 
can be accessed from a web browser to handle user accounts, security, and client connectivity 556 
configuration. Installation and configuration procedures are described below. 557 

System Requirements 558 

CPU: 4 559 

Memory: 8 GB RAM 560 

Storage: 561 

 HD 1: 80 GB (OS Install) 562 

 HD 2: 170 GB (Application) 563 

Operating System: Microsoft Windows Server 2016 564 

Network Adapter: VLAN 1501 565 

PACSgear Core Server Installation 566 

The installation of Hyland PACSgear Core Server was performed by Hyland engineers as listed below: 567 
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1. The installation of Hyland PACSgear Core Server was performed by Hyland engineers per their 568 
technical guidelines. 569 

2. The installation created a web application for the PACSgear Core Portal, where an SSL certificate 570 
signed by DigiCert was created and assigned to the application for HTTPS enforcement. 571 

PACSgear Core Server Configuration 572 

Configuration of the PACSgear Core Server was performed by the Hyland engineers. The basic 573 
configuration involves managing connection settings to external devices, lookup data sources, and event 574 
trace; managing departments for multi tenancy architecture; managing user access; and many more 575 
features. Each organization will configure the PACSgear based on its specific needs. 576 

During the database configuration, the Hyland engineers created instances for representative 577 
departments (e.g., ophthalmology, radiology, and departments that may see patients who need wound 578 
treatment). 579 

Add New Departments: To add the ophthalmology department, complete the following steps: 580 

1. The Hyland engineers logged on to the PACSgear Admin portal by using https:// hyland-581 
pgcore.pacs.hclab/PGAPPS/Admin. 582 

 583 

2. On the Settings menu, select Departments. 584 
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 585 

3. After selecting Departments from the Settings pull-down, the screen advances to a Departments 586 
screen. The Departments screen lists sample hospital departments created during the installation. 587 
The project then added a new department by clicking the + Add button. 588 

 589 

4. After clicking the + Add button, the Add/Edit Department screen opened and allowed the 590 
engineers to enter corresponding information. 591 
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 592 

5. In the Name text box, the engineers entered Ophthalmology to create a department that ties with 593 
the Ophthalmology database instance created during database configuration. Engineers also added 594 
the AE title as Ophthalmology and selected a CT Scan for the modality. 595 

 596 

6. On the Destinations and Lookup Sources tabs, the engineers set up the destination and lookup 597 
sources for each department. 598 

7. On the Client tab, the engineers set up the client access permissions to this department’s 599 
resources. 600 
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 601 

8. On the Series tab, click Add, type a description, click Save. 602 

9. Verify that the department has been added to the list, based on what is displayed. 603 

 604 

Add LDAP/Active Directory Server: - to use an LDAP/Active Directory server, configure these 605 
parameters: 606 

1. Create an LDAP_User account in Active Directory before proceeding. 607 

2. Using a browser, log on to the PACSgear Admin portal by using https://hyland-608 
pgcore.pacs.hclab/PGAPPS/Admin. 609 

3. On the Settings menu, select Users. 610 

https://hyland-pgcore.pacs.hclab/PGAPPS/Admin
https://hyland-pgcore.pacs.hclab/PGAPPS/Admin
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 611 

4. On the Users screen, navigate to Restrict access permissions to: and click on the LDAP Users 612 
button. Enter 192.168.120.100 to populate the Server text box, and then enter pacs.hclab for 613 
Domain. 614 

 615 

5. Click the Test button located under the Domain entry box. 616 

6. Enter the LDAP_User credentials to verify connectivity to the AD. 617 
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 618 

7. A message box appears indicating the test is successful. Click OK. 619 

 620 

PACS Scan Mobile Configuration—Install and configure the PACS Scan application to an Apple iPhone by 621 
applying these steps: 622 

1. On the iPhone, navigate to the App Store. Search for PACS Scan Mobile, from Perceptive Software. 623 
Perceptive Software is a Hyland business unit. Select the GET button to install the software, and 624 
then select the OPEN button. Select Allow to permit the software to send notifications. 625 

2. On a workstation, log in to PACSgear Core Server by using the administrator credentials; a 626 
dashboard will display and provide a Provision Device QR code. 627 

 628 

3. On the mobile device PACS Scan App, tap the QR code icon that appears under the Log In button. 629 
This will turn on the built-in camera on the iPhone. 630 
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 631 

4. Point the camera at the QR code on the PC screen until a message box appears indicating Setting 632 
Updated Your settings have been updated. This setting configures the mobile PACS Scan app to 633 
the address of its PACSgear Core Server instance. 634 

5. From a workstation, acquire the trusted root certificate from DigiCert. Further information for 635 
using DigiCert is described in Section 2.6.2.  636 

6. Download the root certificate to the workstation local drive and attach the certificate as an email 637 
attachment sent to the installer. 638 

7. The installer opens the email from the iPhone and double-clicks on the attachment to install the 639 
certificate to the device. 640 

8. To verify the certificate installation, go to Settings > General > Profiles & Device Management to 641 
list all the certificates profiles. 642 

9. Find the certificate you installed and click to display the detail. Below is an example: 643 
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 644 

10. To verify the PACS Scan Mobile App functionality, from the iPhone, double-click the PACS Scan 645 
App. The log in page will display. Use an account and password that has been associated with a 646 
clinical department to log in. Successful log in displays a patient information input page, as shown 647 
below: 648 

 649 
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2.2.4 Hyland NilRead 650 

Hyland NilRead provides image access and viewing from various devices including clinical viewing 651 
stations, tablets, and mobile devices. NilRead also provides image manipulation, interpretation, and 652 
collaboration across departments. The installation and configuration procedures are found below. 653 

System Requirements 654 

CPU: 6 655 

Memory: 12 GB RAM 656 

Storage: 657 

 HD 1: 80 GB (OS Install) 658 

 HD 2: 200 GB (Web Application) 659 

 HD 3: 100 GB (Image Cache) 660 

Operating System: Microsoft Windows Server 2016 661 

Network Adapter: VLAN 1301 662 

Hyland NilRead Installation 663 

1. The installation of Hyland NilRead was performed by Hyland engineers based on Hyland’s proprietary 664 
installation package and installation guides. NilRead has three services: the Hub Front End service, 665 
Nil Back End service, and Nil Front End service. The Hub Front End service is used to provide 666 
management service for multi-tenant configuration. The operation context is defined by the Nil 667 
database content and includes user accounts, data life-cycle rules, hanging protocols, DICOM 668 
connectivity setup, and cached DICOM data index. 669 

2. The installation created two web applications for the NilHub and NilRead Viewer, where SSL 670 
certificates signed by DigiCert were created and assigned to the applications for HTTPS enforcement. 671 

Hyland NilRead Configuration 672 

NilHub configuration is done from the NilHub web application. Launch a web browser from the NilHub 673 
server, and authenticate as admin, using the URL https://localhost:8080/, as follows: 674 
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 675 

1. To add a new site from the NilHub home page, click on the Sites tab in the top left-hand side of the 676 
screen. 677 

 678 

2. Click on the + icon on the right-hand side of the screen, to create a new Site for WOUND_CARE 679 
department, and provide the information below, and then click Save. 680 
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 Name: WOUND_CARE 681 

 Details: Wound Care Department 682 

 Code: 974 683 

 AE Title: WOUND_CARE 684 

 VNA Partition: WOUND_CARE 685 

 Database Name: WOUND_CARE 686 

 Email: none@hyland.com 687 

 688 

3. Log back in to NilHub specifying the WOUND_CARE Site in the top section of the log in screen. 689 

 690 

4. Click the Settings tab. Navigate to the User Management section and click on Accounts. 691 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 45 

 692 

5. Click Add on the bottom left-hand side of the screen and provide this information: 693 

 User Name: pacs\ptester 694 

 Last Name: Tester 695 

 First Name: Pacs 696 

 Role: User 697 

 E-Mail: ptester@hyland.pacs.com 698 

 Password: ***** 699 

6. Identify Member Groups the user needs access to and click the Add button. 700 

7. Specify the Granted Privileges the user needs to have and click the Grant button. 701 

8. Click the Save button on the bottom left-hand side of the screen. 702 
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 703 

Hyland engineers repeated the above steps to have multiple Sites that accessed different VNA 704 
partitions/tenants, such as Radiology with access to all VNA tenants and Ophthalmology with access to 705 
only the Ophthalmology VNA partition/tenant. 706 

2.3 Secure DICOM Communication Between PACS and VNA 707 

Hyland Acuo VNA and Philips IntelliSpace PACS support DICOM Transport Layer Security (TLS). DICOM 708 
TLS provides a means to secure data in transit. This project implements DICOM TLS between the Acuo 709 
VNA and IntelliSpace PACS via mutual authentication as part of the TLS handshake protocol [10]. 710 

2.3.1 Public Key Infrastructure (PKI) Certificate Creation 711 

Server/client digital certificates are created for the Hyland Acuo VNA and Philips IntelliSpace server. This 712 
project uses DigiCert for certificate creation and management. The procedures that follow assume 713 
familiarity with DigiCert. Refer to Section 2.6.2 for further detail. 714 
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2.3.1.1 Create PKI Certificate for Hyland Acuo VNA 715 

1. Use DigiCert Certificate Utility for Windows to generate a certificate signing request (CSR) for 716 
Hyland Acuo VNA. Information needed for requesting the certificate for Hyland Acuo VAN is shown 717 
below: 718 

 Common Name: Hyland-VNA.pacs.hclab 719 

 Subject Alternative Name: Hyland-VNA.pacs.hclab 720 

 Organization: NIST 721 

 Department: NCCoE 722 

 City: Rockville 723 

 State: Maryland 724 

 Country: USA 725 

 Key Size: 2048 726 

2. Submit the created CSR to DigiCert portal for certificate signing.  727 

3. Download and save the signed certificate along with its root Certificate Authority (CA) certificate in 728 
the .pem file format. 729 

4. Import the saved certificate to DigiCert Certificate Utility for Windows, and then export the 730 
certificate with its private key in the .pfx format. 731 

5. The certificate is ready for installation. 732 

2.3.1.2 Create PKI Certificate for Philips IntelliSpace PACS 733 

1. Use DigiCert Certificate Utility for Windows to generate a CSR for PACS server. Information 734 
needed for requesting the certificate is shown below: 735 

 Common Name: nccoess1.stnccoe.isyntax.net 736 

 Subject Alternative Name: nccoess1.stnccoe.isyntax.net 737 

 Organization: NIST 738 

 Department: NCCoE 739 

 City: Rockville 740 

 State: Maryland 741 

 Country: USA 742 

 Key Size: 2048 743 
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2. Submit the created CSR to DigiCert portal for certificate signing. 744 

3. Download and save the signed certificate along with its root CA certificate in the .pem  745 

4. Import the saved certificate to DigiCert Certificate Utility for Windows, and then export the 746 
certificate with its private key in the .pfx format. 747 

5. The certificate is ready for installation. 748 

2.3.2 PKI Certification Installation 749 

After creating the signed certificates for Acuo and IntelliSpace respectively, the certificates must be 750 
installed to the servers. The steps that follow describe how to install those certificates. Certificates must 751 
be applied per server instance and assume access to both. 752 

2.3.2.1 Install PKI Certificate for Hyland Acuo VNA 753 

Install the certificate on Hyland Acuo VNA server using the procedures below: 754 

1. From the Acuo server, click on Start > Run > mmc. 755 

2. Select File > Add/Remove Snap-in… 756 

 757 

3. Select Certificates and click Add. 758 

 Choose Computer Account 759 

 Choose Local Computer 760 

4. Click Finish, then click OK. 761 
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 762 

5. Once the snap-in has been added, navigate to Certificates (local computer)/Personal/Certificates. 763 

 764 

6. Right click and select All Tasks/Import. 765 

 Browse to the exported .pfx certificate. 766 

 Select the file and click Open. 767 
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 768 

7. Add the appropriate permissions to the newly generated certificate private key. 769 

 Navigate to Certificates > Personal > Certificates. 770 

 Right click on the certificate, select All Tasks > Manage Private Keys… 771 

 Add the AcuoServiceUser and grant full control permissions. Click OK. 772 

This procedure also installs the signing CA Root certificate (DigiCert Test Root CA SHA2) and its 773 
Intermediate Root certificate (DigiCert Test Intermediate Root CA SHA2) into the server computer. 774 

2.3.2.2 Install PKI Certificate for Philips IntelliSpace PACS 775 

Install the certificate on the PACS server using the procedures that follow: 776 

1. From the IntelliSpace server, click on Start > Run > mmc. 777 

2. Select File > Add/Remove Snap-in… 778 

 779 
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3. Select Certificates and click Add. 780 

 Choose Computer Account. 781 

 Choose Local Computer. 782 

 Click Finish; click OK. 783 

 784 

4. Once the snap-in has been added, navigate to Certificates (local computer)/Personal/Certificates. 785 

 786 
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5. Right click and select All Tasks/Import. 787 

 Browse to the exported .pfx certificate. 788 

 Select the file and click Open. 789 

 790 

This procedure also installs the signing CA Root certificate (DigiCert Test Root CA SHA2) and its 791 
Intermediate Root certificate (DigiCert Test Intermediate Root CA SHA2) into the server computer. 792 

2.3.3 TLS Secure DICOM Configuration 793 

With the signed certificates installed to the Acuo VNA and IntelliSpace PACS servers, proceed to 794 
configuring DICOM TLS. The set of procedures that follows describe TLS configuration that must be 795 
performed on both Acuo VNA and IntelliSpace PACS. This will enable DICOM TLS communications 796 
between these two endpoints, and secure data-in-transit communications bi-directionally between the 797 
VNA and PACS. 798 

2.3.3.1 TLS Configuration for Hyland Acuo VNA 799 

For receiving TLS DICOM message from IntelliSpace PACS, configure a new service-class provider (SCP) in 800 
Acuo VNA using Microsoft Windows Console. Configuration is done from the Acuo VNA server. 801 

1. Open Microsoft MMC to access the AcuoMed Image Manager (local): 802 

2. From the Console > AcuoMed Image Manager (local) > DICOM Configuration, right click Any Ip 803 
Address > New Scp … to create a new SCP for TLS encryption. 804 
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 805 

3. On the Connectivity tab of the SCP Properties page, provide the information below and click Add, 806 
Apply, and then Finish: 807 

 Port: 1443 808 

 Check the TLS checkbox 809 

 Client Certificate CN: nccoess1.stnccoe.issyntax.net 810 

 Server Certificate CN: HYLAND-VNA.pacs.hclab 811 

 Cipher Suite: TLS_RSA_WITH_AES_128_CBC_SHA 812 

 Check the Authenticate Client Certificate checkbox 813 
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 814 

4. To add the Called AE to the Scp, right click the created Scp [Listening Port:1443] and select New > 815 
Called AE …. to open the AE Properties form. 816 

 817 

5. Fill in the Called AE Name: e.g., RADIOLOGY and Default Route Name: e.g., RADIOLOGY. After 818 
populating the information, click Add. 819 
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 820 

For sending TLS DICOM message to IntelliSpace PACS, configure an External DICOM Device from the 821 
Acuo VNA by using Microsoft Windows Console. 822 

1. Open Microsoft MMC to access the Image Manager Server: 823 

2. Navigate to Image Manager Server > Router Configuration > External DICOM Devices, right click 824 
on External DICOM Devices and click New. 825 

 826 
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3. On the Main tab of the External DICOM Devices Properties page, provide the information below 827 
and click Apply, and then click Finish: 828 

 SCP Destination Name: PHILIPS 829 

 Called AE Name: STENTOR_SCP 830 

 IP Address: 192.168.140.131 831 

 SCP Listening Port: 2762 832 

 Enable TLS by clicking the TLS checkbox next to the listening port number. 833 

 Called AE Name: ACUO 834 

 Implementation UID: 1.2.840.114158.1.1.3 835 

 Client Certificate CN: HYLAND-VNA.pacs.hclab 836 

 Server Certificate CN: nccoess1.stnccoe.isyntax.net 837 

 Cipher Suite: TLS_RSA_WITH_AES_128_CBC_SHA 838 

 839 

4. Restart the AcuoMed service. 840 
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2.3.3.2 TLS Configuration for Philips IntelliSpace PACS 841 

Next, configure TLS on the IntelliSpace PACS server. The steps below would be taken to enable this 842 
feature on the PACS: 843 

1. Access the Philips iSite Administration web site https://192.168.140.131/iSiteWeb using 844 
administrator credentials. 845 

 846 

2. Click Configuration > DICOM, to navigate to DICOM configuration screen. 847 

 848 

3. On the top menu, click iExport to open the iExport screen. Provide the information below, and click 849 
Save: 850 

 AE Title: RADIOLOGY 851 

 Description: Hyland VNA 852 

 IP Address: 192.168.130.120 853 
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 Port: 1443 854 

 Use Secure Connection: checked 855 

 856 

4. Click Configuration > Advanced Security, perform these selections: 857 

 TLS 1.0 or higher: Selected 858 

 Enable Secure Web Services Communication 859 

 Enable Image Access in Secure Mode 860 

 Default Client Certificate: CN= nccoess1.stnccoe.isyntax.net 861 

 Default Server Certificate: CN=HYLAND-VNA.pacs.hclab 862 

 Click Save to save the settings 863 
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 864 

5. On the iSite Administration screen, click Next and click Next again to open the page that follows: 865 

a. Enable Validate Client Certificate for DICOM. 866 

b. Enable Validate Server Certificate for DICOM. 867 

c. Click Save to save the settings. 868 

 

 869 
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6. Restart the iSite Monitor Service. 870 

2.3.4 PACS and VNA TLS Integration Tests 871 

After implementing the above PKI-certification installation and TLS enabling configuration, both the 872 
Acuo VNA and IntelliSpace PACS servers are ready to perform the TLS secure DICOM communication 873 
tests. The secure DICOM communication tests were conducted for bi-direction data exchanges between 874 
Acuo VNA and IntelliSpace PACS to confirm: 875 

DICOM communication is still functional. 876 

DICOM communication is encrypted. 877 

The test proves the DICOM communication was successful, with the accurate data exchange between 878 
Acuo VNA and IntelliSpace PACS. 879 

The network flow and dataflows monitoring tool indicates that the mutual authentication between Acuo 880 
VNA and IntelliSpace PACS are established. Encrypted application data were exchanged. 881 

2.4 Modalities 882 

2.4.1 DVTk Modality Emulator 883 

DVTk Modality is a modality emulator that can be used to emulate all the DICOM functions of a modality 884 
system. It can simulate a real modality to test and verify communication with all the DICOM services. It 885 
uses DICOM files as input for Queries, modality performed procedure step (MPPS), and Storage actions. 886 
Consequently, this project chose to use the DVTk Modality as an emulator to test the connectivity, 887 
communication, workflow, and interaction between PACS and modality in the lab. 888 

System Requirements 889 

Operating System: Microsoft Window 7 (with Microsoft .NET 4.0 Framework) 890 

Network Adapter: VLAN 1402 891 

DVTk Modality Installation 892 

1. Download the installation software from the DVTK site [11]. 893 

2. Click the Modality Installation file (e.g., DVTk-Modality-Emulator-5.0.0.msi) to start the installation 894 
process. 895 
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 896 

3. Follow the wizard instruction to continue the installation until it reaches successful completion. 897 

 898 

4. Close the installation window. 899 

5. The DVTk Modality Emulator can be launched from the PC Start menu. The Modality Emulator 900 
interface is shown below. 901 
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 902 

DVTk Modality Configuration 903 

Configuration of the DVTk Modality involves the configuration of the communications with different 904 
external systems, including the RIS, which is the Worklist provider or a worklist broker connected to the 905 
RIS; the MPPS manager that handles the MPPS messages for status reporting; and the PACS and its 906 
database where the images will be stored. The information needed for these external systems should 907 
include the correct IP-Address, Port number, and Application Entity Title (AETitle). Input the information 908 
with these values: 909 

RIS System 910 

 IP Address: 192.168.160.201 911 

 Remote Port: 105 912 

 AE Title: RIS 913 

MPPS Manager 914 

 IP Address: localhost 915 

 Remote Port: 105 916 

 AE Title: RIS 917 

PACS/Workstation Systems–Storage Config 918 

 IP Address: localhost 919 
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 Remote Port: 106 920 

 AE Title: MPPS 921 

PACS/Workstation Systems–Storage Commit Config 922 

 IP Address: localhost 923 

 Remote Port: 107 924 

 AE Title: PACS 925 

Store Commit Config 926 

 IP Address: localhost 927 

 Remote Port: 107 928 

 AE Title: PACS 929 

 930 

The configuration of the modality itself is also needed to indicate its AE Title (e.g., DVTK_MODALITY), 931 
Local IP Address (e.g., 172.31.138.126), and Listen Port (e.g., 104) to be paired for association negation 932 
with other remote systems. The screenshot that follows indicates the options for the Modality Emulator 933 
configuration: 934 
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 935 

Several tabs exist for configuring the behavior of the emulator. They can be configured as needed or use 936 
the default settings. Once the configuration is done, the emulator front GUI interface provides some test 937 
buttons for verifying the connectivity, including RIS and PACS server Internet Control Message Protocol 938 
(ICMP) pings and DICOM echo: 939 

 940 
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2.4.2 DVTk RIS Emulator 941 

DVTk, the Health Validation Toolkit, is an open-source software. The DVTk RIS Emulator is an application 942 
that handles Modality Worklist and Modality Performance Procedure Step requests from remote 943 
applications and then responds with the emulated results using the DICOM files specified by the users. 944 

System Requirements 945 

Operating System: Microsoft Windows 7 (Microsoft .NET framework 2.0) 946 

DVTk RIS Emulator Installation 947 

1. Download the DVTk RIS Software installer RIS Emulator .msi file from http://www.dvtk.org. 948 

2. Start the installation procedure by double-clicking the .msi installation file. 949 

3. Follow the wizard screen instruction to continue the installation until the end of successful 950 
installation is displayed. 951 

4. Close the installation window and start to RIS Emulator. The User Interface of the RIS Emulator 952 
tool that follows is shown with the tabs that follow for selecting the modes: 953 

5. Worklist 954 

 MPPS 955 

 Edit DCM Files 956 

 Activity Logging 957 

 Validation results 958 

http://www.dvtk.org/
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 959 

DVTk RIS Emulator Configuration 960 

1. Worklist Configuration 961 

 Local AT title: AE title of the RIS Emulator 962 

 Local Port: The port of the RIS Emulator for incoming association 963 

 Remote AE title: AE title for the service class user paired with the RIS emulator 964 

 View Information Model: Information model used for sending the emulator response, default 965 
value is taken 966 

 Select Data Directory for sending WLM responses: Location for storing the emulated responses 967 
to the Worklist requests. A default setting can be used which is C:\Progam Files\DVTk\RIS 968 
Emulator\Data\Worklist\ 969 

2. The RIS Emulator also supports other parameter configuration such as MPPS and Store Files 970 
functionality. These can be done as needed. 971 

3. Configuration of the RIS Emulator and the Modality storage emulator should be done accordingly, so 972 
they can communicate with each other. 973 
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2.5 Asset & Risk Management 974 

2.5.1 Virta Labs BlueFlow 975 

Virta Labs BlueFlow is a medical asset management software that allows for the discovery and 976 
management of medical devices on the network. For this project, we used BlueFlow to create an 977 
organized inventory of the medical devices in the PACS architecture. 978 

System Requirements 979 

CPU: 2 980 

Memory: 8 GB RAM 981 

Storage: 100 GB (Thin Provision) 982 

Operating System: CENTOS 7 983 

Network Adapter: VLAN 1201 984 

Virta Labs BlueFlow Installation 985 

1. Run rpm -ihv blueflow-2.6.0-1.x86_64.rpm in the CentOS 7 terminal. 986 

 Wait for the package install process to complete. 987 

 Depending on your environment, you may need to install some dependencies before 988 
the BlueFlow package can be successfully installed. 989 

 990 

2. Run sysyemctl status blueflow.service in the CentOS 7 terminal. 991 

3. Ensure blueflow.service is active. 992 
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 993 

4. Visit https://localhost to verify BlueFlow web service is operating as expected, with a BlueFlow 994 
Login page. 995 

 996 

Virta Labs BlueFlow Network Groups Configuration 997 

1. Log in to the BlueFlow web console. 998 
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 999 

2. Navigate to the Inventory tab. 1000 

3. Under the Networks section, click on the gear icon. 1001 

 1002 

4. Enter Security Service as a Name for the new network group. 1003 

5. Enter 192.168.190.0/24 as a CIDR for the new network group. 1004 

6. Click create. 1005 
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 1006 

7. Verify that the new network group (Security Services) has been created. 1007 

8. Click on the name of the new network group. 1008 

 1009 

9. Assets will be listed on this page if they match the network group’s criteria. 1010 
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10. If there are no assets currently listed, you can manually add them by navigating to Inventory > Add 1011 
Inventory or by running an IP discovery scan (detailed in the next section). 1012 

 1013 

Running an IP Discovery Scan in Virta Labs BlueFlow 1014 

1. Log in to the BlueFlow web console. 1015 

 1016 
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2. Navigate to Connectors > Discovery. 1017 

 1018 

3. Under Discovery, click the gear icon. 1019 

 1020 
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4. Check the box next to allow_create_asset. 1021 

5. Click Save. 1022 

 1023 

6. Enter an IP (e.g., 192.168.190.0/24), host name or CIDR that you would like to scan. 1024 

7. Click Run. 1025 

8. Wait for the discovery scan to finish. 1026 

 1027 
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9. Click on the row of the completed scan to view more details. 1028 

Note: From this page, you can view the output of the scan, including how many devices were 1029 
discovered within the provided network range. 1030 

 1031 

2.5.2 Tripwire Enterprise 1032 

Tripwire Enterprise is a security configuration management software that monitors file integrity through 1033 
software-based agents. For this project, we used Tripwire Enterprise to monitor file changes on PACS 1034 
servers and the VNA database. 1035 

System Requirements 1036 

CPU: 1 1037 

Memory: 4 GB RAM 1038 

Storage: 120 GB (Thin Provision) 1039 

Operating System: Microsoft Windows Server 2016 1040 

Network Adapter: VLAN 1201 1041 
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Tripwire Enterprise Console Installation 1042 

1. In the tripwire install folder under java, double-click on the jre-8u202-windows-x64 application file. 1043 

 1044 

2. Click on Run. 1045 

 1046 

3. Click on Install >. 1047 

 1048 

4. Click OK. 1049 
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 1050 

5. Wait for the install process to complete. 1051 

 1052 

6. Click Close. 1053 

 1054 

7. With Java installed, double-click on the Tripwire install application, install-server-windows-amd64. 1055 
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 1056 

8. Select the version of Java, Oracle/Sun 1.8.0 64-bit, that was previously installed. 1057 

9. Click OK. 1058 

 1059 

10. Click Next >. 1060 

 1061 

11. Check I accept the agreement. 1062 
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12. Click Next >. 1063 

 1064 

13. Specify an installation directory, C:\Program Files\Tripwire\TE, for the Tripwire installation. 1065 

14. Click Next >. 1066 

 1067 

15. Verify the host name for the machine on which you’re installing Tripwire (e.g., WIN-1068 
RUQDO7KL8A7). 1069 

16. Click Next >. 1070 
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 1071 

17. Specify the HTTPS Web Services port as 6000, HTTP EMS Integration Port as 8080, and Tripwire 1072 
Enterprise RMI Port as 9898. 1073 

18. Click Next >. 1074 

 1075 

19. Create a password for Tripwire Enterprise services. 1076 

20. Click Next >. 1077 
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 1078 

21. Verify planned installation settings are correct. 1079 

22. Click Next >. 1080 

 1081 

23. Check Install Real-time Monitoring. 1082 

24. Specify Real-time Port as 1169 for monitoring. 1083 

25. Click Next >. 1084 
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 1085 

26. Click Next >. 1086 

 1087 

27. Wait for Tripwire Enterprise installation to complete. 1088 
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 1089 

28. Click Finish. 1090 

 1091 

29. Open SQL Server Configuration Manger. 1092 

30. Under SQL Server Network Configuration > Protocols for SQL Server ensure the TCP/IP protocol is 1093 
set to Enabled. 1094 
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 1095 

31. Open SQL Server Management Studio. 1096 

 1097 

32. In the Object Explorer expand the selection for your database, right click on Databases and select 1098 
New Database… 1099 

 1100 

33. On the left, under Select a page, select General. 1101 

34. Enter a Database name as TE_DB. 1102 

35. Under Database files, for the data file, set Initial Size to at least 2,000. 1103 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 84 

36. Click the button under Autogrowth. 1104 

 1105 

37. Check Enable Autogrowth, set File Growth to at least 20 MB, and set Maximum File Size to 1106 
Unlimited. 1107 

38. Click OK. 1108 

 1109 
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39. Under Database files, for the log file, set Initial Size to at least 500. 1110 

40. Click the button under Autogrowth. 1111 

41. Check Enable Autogrowth, set File Growth to at least 20 MB, and set Maximum File Size to 1112 
Unlimited. 1113 

42. Click OK. 1114 

 1115 

43. On the left, under select a page, select Options. 1116 

44. Set Collation to Latin1_General_CS_AI. 1117 

45. Set Recovery model to Simple. 1118 

46. Under Other Options > Miscellaneous set ANSI NULL Default to True. 1119 

47. Click OK. 1120 
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 1121 

48. In the Object Explorer, right click on your database and select New Query. 1122 

 1123 

49. Type out the following query: 1124 

ALTER DATABASE [TE_DB] SET READ_COMMITTED_SNAPSHOT ON 1125 
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50. Click Execute in the toolbar above the SQL Query window. 1126 

51. Under the SQL Query window, in the Messages window, verify the command was completed 1127 
successfully. 1128 

 1129 

52. Clear the SQL Query window, and then type out the following query. 1130 

SELECT name, is_read_committed_snapshot_on FROM sys.databases WHERE 1131 
name='<db_name>' 1132 

53. Click Execute in the toolbar above the SQL Query window. 1133 

54. Under the SQL Query window, in the Messages window, verify the value for 1134 
is_read_committed_snapshot_on is set to 1. 1135 
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 1136 

55. In the Object Explorer, expand the selection for your database, expand the Security section, right 1137 
click on Logins, and select New Login… 1138 

 1139 

56. On the left, under Select a page, select General. 1140 

57. Create a Login name. 1141 
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58. Select SQL Server authentication. 1142 

59. Create a password. 1143 

60. For Default database, select the database previously created. 1144 

61. For Default language, select English. 1145 

 1146 

62. On the left, under Select a page, select User Mapping. 1147 

63. Under the Users mapped to this login window, perform these actions for the row containing the 1148 
previously created database: 1149 

 Check the box in the Map column. 1150 

 In the Default Schema column, type the name of the new user being created. 1151 

64. Click OK. 1152 
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 1153 

65. In the Object Explorer, expand the selection for your database, expand the Databases section, right 1154 
click on the database created previously, and select Properties. 1155 

 1156 
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66. On the left, under select a page, select Permissions. 1157 

67. Under Permissions for user, check the box in the Grant column for the following permissions: 1158 

 Connect 1159 

 Create Function 1160 

 Create Procedure 1161 

 Create Table 1162 

 Create View 1163 

 Delete 1164 

 Insert 1165 

 Select 1166 

 Update 1167 

68. Click OK. 1168 

 1169 
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69. Open Internet Explorer and navigate to the webpage of the server on which Tripwire Enterprise 1170 
was installed. 1171 

70. Enter the services password created during the install process. 1172 

71. Click Login. 1173 

 1174 

72. Under Database Configuration Settings, provide the information that follows: 1175 

 Remote Database Type: Microsoft SQL Server 1176 

 Authentication Type: SQL Server 1177 

 Login Name: te_admin 1178 

 Password: ********* 1179 

 Database Host: WIN-RUQDO7KL8A7 1180 

 Database Name: TE_DB 1181 

 Instance Name: SCSP (Note: this may not be necessary, depending on how your SQL Server 1182 
Database is configured) 1183 

 SSL: Request 1184 
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 1185 

73. Click Test Database Login and verify the connection is successful. 1186 

74. Click Save Configuration and Restart Console. 1187 
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 1188 

75. Wait for Tripwire Enterprise to restart and redirect you to the log in page. 1189 

 1190 

76. Enter the services password created during the install process. 1191 

77. Click Login. 1192 
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 1193 

78. Under Create Administrator Password, create a password for the Tripwire Enterprise administrator 1194 
account. 1195 

79. Click Confirm and Continue. 1196 

 1197 

80. Enter the username and password for the Tripwire Enterprise administrator account. 1198 

81. Click Sign In. 1199 
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 1200 

82. Click Configure Tripwire Enterprise to begin the configuration process. 1201 

 1202 

Tripwire Enterprise Agent Installation 1203 

1. Run te_agent.msi. 1204 

2. Click Next >. 1205 

 1206 
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3. Check I accept the terms in the license agreement. 1207 

4. Click Next >. 1208 

 1209 

5. Specify an install directory for the Tripwire Enterprise Agent. 1210 

6. Click Next >. 1211 

 1212 

7. Enter the TE Server (e.g., WIN-RUQDO7KL8A7) of the server where Tripwire Enterprise is installed. 1213 

8. Enter 9898 as the Services Port established during the installation process of Tripwire Enterprise. 1214 

9. Check Start Agent, after installation. 1215 
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10. Check Install Real-Time Monitoring and specify a Monitoring Port. 1216 

11. Uncheck Enable FIPS. 1217 

12. Click Next >. 1218 

 1219 

13. Specify a Proxy Host and Proxy Port if necessary. 1220 

14. Click Next >. 1221 

 1222 

15. Enter the Services Password created during the installation process for Tripwire Enterprise. 1223 
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16. Click Next >. 1224 

 1225 

17. Click Install. 1226 

 1227 

18. Wait for the installation process to complete. 1228 
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 1229 

19. Click Finish. 1230 

 1231 

2.6 Enterprise Domain Identity Management 1232 

2.6.1 Domain Controller with AD, DNS, & DHCP 1233 

Within the PACS architecture, we established a Windows Server 2012 R2 Domain Controller to manage 1234 
AD, DNS, and Dynamic Host Configuration Protocol (DHCP) services for the enterprise. The following 1235 
section details how the services were installed. 1236 

System Requirements 1237 
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CPU: 1 1238 

Memory: 4 GB Ram 1239 

Storage: 120 GB (Thin Provision) 1240 

Operating System: Microsoft Windows Server 2012 R2 1241 

Network Adapter: VLAN 1201 1242 

Enterprise Domain Services Installation 1243 

Install the Domain Controller, AD, and DNS appliances according to the instructions detailed in Building 1244 
Your First Domain Controller on 2012 R2 [12]. 1245 

DNS Server Forward Lookup Zone Configuration 1246 

1. Open Server Manager. 1247 

 1248 

2. In the top right, click on Tools > DNS. 1249 

3. DNS forward lookup zone should have already been created during the DNS setup process 1250 
performed previously. If not, follow these instructions: 1251 
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 1252 

 Right click on your server’s name, and select Configure a DNS Server… 1253 

 1254 

 Click Next >. 1255 
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 1256 

 Click Next >. 1257 

 1258 

 Click Next >. 1259 
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 1260 

 Enter PACS.TEST as the Zone name, that was established previously during setup. 1261 

 Click Next >. 1262 

 1263 

 Select Allow only secure dynamic updates. 1264 

 Click Next >. 1265 
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 1266 

 Add Forwarders (8.8.8.8 and 8.8.4.4 are Google’s DNS servers). 1267 

 Click Next >. 1268 

 1269 

 Click Finish. 1270 
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 1271 

DNS Server Reverse Lookup Zone Configuration 1272 

1. Open Server Manager. 1273 

 1274 

2. In the top right, click on Tools > DNS. 1275 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 107 

 1276 

3. Right click on Reverse Lookup Zones folder and select New Zone… 1277 

 1278 

4. Click Next >. 1279 
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 1280 

5. Click Next >. 1281 

 1282 

6. Click Next >. 1283 
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 1284 

7. Choose Internet Protocol version 4 (IPv4), IPv4 reverse Lookup Zone option and click Next >. 1285 

 1286 

8. Establish which IP addresses should be included in reverse lookup (the example above 1287 
encompasses all devices in the 192.168.120.0/24 subnet), then click Next >. 1288 
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 1289 

9. Choose Allow only secure dynamic updates (recommended for Active Directory) option and then 1290 
click Next >. 1291 

 1292 

10. Click Finish. 1293 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 111 

 1294 

DHCP Server Installation 1295 

Install the DHCP server according to the instructions detailed in Installing and Configuring DHCP Role on 1296 
Windows Server 2012 [13]. 1297 

DHCP Server Configuration 1298 

1. Open Server Manager. 1299 

 1300 

2. In the top right, click on Tools > DHCP. 1301 
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 1302 

3. If you see a green checkmark on the IPv4 server, the DHCP server is up and running. 1303 

 1304 

DHCP Scopes Configuration 1305 

Performed on Windows Server 2012 R2. 1306 

1. Open Server Manager. 1307 
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 1308 

2. In the top right, click on Tools > DHCP. 1309 

 1310 

3. Right click on IPv4 and select New Scope… 1311 
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 1312 

4. Click Next >. 1313 

 1314 

5. Provide a Name as Radiology Devices and a Description as Collection of hospitals Radiology 1315 
equipment in the New Scope Wizard. 1316 

6. Click Next >. 1317 
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 1318 

7. Establish the IP range (192.168.120.200 – 192.168.120.254) from which the DHCP server should 1319 
hand out IPs for devices in this scope. 1320 

8. Click Next >. 1321 

 1322 

9. Click Next >. 1323 
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 1324 

10. Configure preferred Lease Duration (e.g., 8 days), and click Next >.  1325 

 1326 

11. Choose Yes, I want to configure these options now, and then click Next >. 1327 
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 1328 

12. Enter the subnet’s Default Gateway as 192.168.120.1. 1329 

13. Click Add. 1330 

 1331 

14. Click Next >. 1332 
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 1333 

15. Ensure IP address in bottom-right box is the IP address (192.168.120.101) for the DNS server 1334 
configured earlier. 1335 

16. Click Next >. 1336 

 1337 

17. Click Next >. 1338 
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 1339 

18. Choose Yes, I want to activate this scope now option and then click Next >. 1340 

 1341 

19. Click Finish. 1342 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 120 

 1343 

20. Scope should appear under IPv4 dropdown. Ensure Scope Options are correctly established with 1344 
these values: 1345 

 003 Router: 192.168.120.1 1346 

 006 DNS Servers: 192.168.120.101 1347 

 015 DNS Domain Name: PACS.TEST 1348 

 1349 

2.6.2 DigiCert PKI 1350 

DigiCert is a cloud-based platform designed to provide a full line of SSL certificates, tools, and platforms, 1351 
for optimal certificate life-cycle management. To use the service, an account must be established with 1352 
DigiCert. Once an account is established, access to a DigiCert dashboard is enabled. From the dashboard, 1353 
DigiCert provides a set of certificate management tools to issue PKI certificates for network 1354 
authentication and encryption for data-at-rest or data-in-transit as needed. 1355 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 121 

The instructions below describe the process used to obtain an SSL certificate on behalf of medical 1356 
devices using the DigiCert certificate signing services. 1357 

Create CSR 1358 

A CSR is represented as a block Base64 encoded PKCS#10 binary format text that will be sent to a CA for 1359 
digital signature when applying for an SSL Certificate. The CSR identifies the applicant’s distinguished 1360 
common name (domain name), organization name, locality, and country. It also contains the applicant’s 1361 
private key and the public key pair. The CSR is usually generated from the device where the certificate 1362 
will be installed, but it can also be generated using tools and utilities on behalf the device to generate a 1363 
CSR. Below is an instruction on how to use the Certificate Utility for Windows (DigiCertUtil.exe) provided 1364 
by DigiCert to generate CSRs for a medical device or a server. 1365 

Download and save the DigiCertUtil.exe from the DigiCert site [14].  1366 

1. Double-click DigiCertUtil.exe to run the utility. 1367 

2. Click the Create CSR link to open a CSR request window. 1368 

3. On the Create CSR window, fill in the key information (some of the information is optional). 1369 

 Certificate Type: Select SSL 1370 

 Common Name: HYLAND-VNA.pacs.hclab 1371 

 Subject Alternative Names: HYLAND-VNA.pacs.hclab 1372 

 Organization: NIST-NCCoE 1373 

 Department: HCLAB 1374 

 City: Rockville 1375 

 State: Maryland 1376 

 Country: USA 1377 

 Key Size: 2048 1378 

4. Click Generate to create a CSR. This will also generate a corresponding private key in the Windows 1379 
computer from which the CSR is requested. The Certificate Enrollment Request is stored under 1380 
Console Root\Certificates(Local Computer)\Certificate Enrollment Requests\Certificates. 1381 
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 1382 

5. A sample CSR is shown in the figure below: 1383 

 1384 

6. Select and copy the certificate contents to the clipboard or save it to an ascii text file. The text 1385 
contents will be used to paste into the DigiCert order form. 1386 
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7. Issue Signed Certificates. With a created applicant CSR, request a signed certificate using DigiCert 1387 
CertCentral portal, using these steps: 1388 

a. Log in to a DigiCert Dashboard (https://www.digicert.com/account/login.php) with your 1389 
account username and password. In the portal, select CERTIFICATES>Requests, then 1390 
navigate to Request a Certificate, select Private SSL to open a certificate request form. 1391 

b. Paste the CSR information to the area called Add Your CSR, including the -----BEGIN NEW 1392 
CERTIFICATE REQUEST----- and -----END NEW CERTIFICATE REQUEST----- tags. Once the 1393 
pasting is done, some of the fields will be populated automatically. 1394 

c. After filling in all the required information, scroll down to the bottom of the page, and select 1395 
the I Agree to the Certificate Services Agreement Above checkbox. Next, click the Submit 1396 
Certificate Request button at the bottom of the form to submit the certificate for signing 1397 
approval. 1398 

https://www.digicert.com/account/login.php
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 1399 

8. The certificate is listed under Orders. Once the order status changes to Issued, the certificate is 1400 
ready for download. 1401 
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 1402 

9. Click a specific order number to display the certificate details with a list of actions that can be 1403 
performed. Click Download Certificate As to download certificates with signed CA and Root CA 1404 
certificates. A variety of certificate formats can be downloaded, such as .crt, .p7b, .pem, etc. 1405 

10. Save the downloaded certificate in a location where it can be used for further processing if needed. 1406 

Import and Export the Signed Certification 1407 

After downloading the SSL Certificate from DigiCert, you can use the DigiCert Certificate Utility for 1408 
Windows to install it. With the DigiCert Utility tool, you can further manipulate the certificates to 1409 
combine with the private key and export the signed certificate to the certificate requesting device 1410 
server. 1411 

1. From the DigiCert Certificate Utility for Windows, click the Import button to load the downloaded 1412 
signed Certificate file to the utility. The downloaded file was saved in Step 10 of Section 2.6.2. Click 1413 
the Next button to import. 1414 

2. From the DigiCert Certificate Utility for Windows, click SSL to list all the imported files. 1415 

3. To export the certificate, select the certificate you want to export as a combined certificate file and 1416 
key file in a .pfx file, or separated as a certificate file and key file, and then click Export Certificate. 1417 
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 1418 

4. Click the Next > button and then follow the wizard instructions to save the certificate file and 1419 
private key file to a desired location in the device. 1420 

 1421 
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2.7 Network Control & Security 1422 

2.7.1 Cisco Firepower 1423 

Cisco Firepower, consisting of Cisco Firepower Management Center and Cisco Firepower Threat 1424 
Defense, is a network management solution that provides firewall, intrusion prevention, and other 1425 
networking services. For this project, Firepower was used to provide network segmentation and both 1426 
internal and external routing. Access control and intrusion prevention policies were also implemented. 1427 

Cisco Firepower Management Center Appliance Information 1428 

CPU: 8 1429 

RAM: 16 GB 1430 

Storage: 250 GB (Thin Provision) 1431 

Network Adapter 1: VLAN 1201 1432 

Operating System: Cisco Fire Linux 1433 

Cisco Firepower Management Center Virtual Installation Guide 1434 

Install the Cisco Firepower Management Center Virtual appliance according to the instructions detailed 1435 
in Cisco Firepower Management Center Virtual for VMware Deployment Quick Start Guide [15].  1436 

Cisco Firepower Threat Defense Appliance Information 1437 

CPU: 8 1438 

RAM: 16 GB 1439 

Storage: 48.5 GB (Thin Provision) 1440 

Network Adapter 1: VLAN 1201 1441 

Network Adapter 2: VLAN 1201 1442 

Network Adapter 3: VLAN 1099 1443 

Network Adapter 4: VLAN 1099 1444 

Network Adapter 5: Trunk Port 1445 

Network Adapter 6: Trunk Port 1446 

Network Adapter 7: VLAN 1101 1447 

Network Adapter 8: VLAN 1101 1448 

Network Adapter 9: VLAN 1701 1449 

Operating System: Cisco Fire Linux 1450 
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Cisco Firepower Threat Defense Virtual Installation Guide 1451 

Install the Cisco Firepower Threat Defense Virtual appliance, according to the instructions detailed at 1452 
Cisco Firepower Threat Defense Virtual for VMware Getting Started Guide [16]. 1453 

Adding Firepower Threat Defense (FTD) Appliance to Firepower Management Center (FMC) 1454 

1. Log in to the FMC Console. 1455 

2. Navigate to Devices > Device Management. 1456 

3. Click the Add drop-down button and select Add Device. 1457 

 1458 

4. Enter 192.168.120.141 as the IP address of the FTD appliance. 1459 

5. Enter FTD-PACS as a display name to identify the FTD appliance. 1460 

6. Enter the manager key created when configuring the manager on the FTD appliance. 1461 

7. Click the Access Control Policy drop-down and select Create New Policy. 1462 

 Create a name for the policy. 1463 

 Select Block All Traffic. 1464 

 Click Save. 1465 

8. Under Smart Licensing, check the boxes next to Malware, Threat, and URL. 1466 

9. Under Advanced check the box next to Transfer Packets. 1467 

10. Click Register. 1468 
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 1469 

11. The FTD appliance will be added to the FMC’s device list. 1470 

 1471 

FTD Interfaces for PACS Architecture Configuration 1472 

Each physical interface connected to the Cisco FTD will appear in the FMC device management section 1473 
under the interface tab. In order to configure the eight subnets needed for the PACS architecture while 1474 
also allowing for management, diagnostic, and Wide Area Network (WAN) traffic, we dedicated two 1475 
interfaces set up as a redundant pair for all internal subnet traffic. To accomplish this, a sub-interface 1476 
was created for each of the eight PACS subnets (Enterprise Services, Imaging Modalities, Security 1477 
Services, etc.), and established redundant interfaces for WAN traffic and traffic on VLAN 1101. The 1478 
following guidance describes how the redundant interfaces and sub-interfaces were created. 1479 
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1. Log in to the FMC Console. 1480 

2. Navigate to Devices > Device Management. 1481 

3. Find your FTD device and click the edit icon. 1482 

4. Navigate to Add Interfaces > Redundant Interface. 1483 

 1484 

5. Enter Internal-Network as the name for the redundant interface. 1485 

6. Create and/or add a security zone to the redundant interface. 1486 

7. Assign a Redundant ID (e.g., Internal-Network) to the redundant interface. 1487 

8. Select a primary interface and secondary interface for the redundant pair. 1488 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 131 

 1489 

9. Navigate to the IPv4 tab. 1490 

10. Assign an IP address and netmask (e.g., 192.168.100.101/24) to the interface. 1491 

11. Click OK. 1492 

 1493 
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12. Navigate to Add Interfaces > Sub Interface. 1494 

 1495 

13. Enter VNA as the name for the sub interface. 1496 

14. Create and/or add a security zone, VNA, to the sub interface. 1497 

15. Select an interface under which the sub interface will operate. 1498 

 Note: For our build, we placed each sub-interface under Redundant 2, the redundant interface for 1499 
GigabitEthernet0/2 and GigabitEthernet0/3. These two physical interfaces were the destination for 1500 
each VLAN’s traffic. 1501 

16. Assign 1403 as the Sub Interface ID to the sub interface. 1502 

17. Assign 1403 as the VLAN ID to the sub interface. 1503 
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 1504 

18. Navigate to the IPv4 tab. 1505 

19. Assign an IP address and netmask (e.g., 192.168.142.1/24) to the sub interface. 1506 

20. Click OK. 1507 

 1508 
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21. Click Save. 1509 

22. Click Deploy and wait for deployment to FTD to complete. 1510 

23. Refresh the page and confirm that the redundant interface and sub-interface are running (shown 1511 
with a green dot on the interface’s icon). 1512 

 1513 

DHCP Relay Through Cisco Firepower Management Center Configuration 1514 

1. Log in to the FMC Console. 1515 

2. Navigate to Devices > Device Management. 1516 

3. Find your FTD device and click the edit icon. 1517 
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 1518 

4. Navigate to the DHCP tab. 1519 

 1520 

5. Navigate to the DHCP Relay Agent section. 1521 
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 1522 

6. Under DHCP Relay Agent, click Add. 1523 

 1524 

7. Assign an FTD interface as LAN. 1525 
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8. Check the box next to Enable IPv4 Relay. 1526 

9. Check the box next to Set Route. 1527 

10. Click OK. 1528 

 1529 

11. Ensure the new relay, LAN, is shown in the DHCP Relay Agent list. 1530 

 1531 

12. Under DHCP Servers, click Add. 1532 
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 1533 

13. Click the green + button to create a new object for the DHCP server. 1534 

 1535 

14. Enter Test-DHCP-Server as a name for the DHCP server. 1536 

15. Enter 192.168.100.170 as an IP address for the DHCP server. 1537 

16. Click Save. 1538 
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 1539 

17. Select the newly created DHCP server. 1540 

18. Select an FTD interface through which the DHCP server can be connected. 1541 

19. Click OK. 1542 

 1543 

20. Ensure the new server is shown in the DHCP Server list. 1544 
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21. Click Save. 1545 

22. Deploy the new configuration settings to the FTD appliance. 1546 

 1547 

Network Address Translation (NAT) Rules Configuration 1548 

1. Navigate to Devices > NAT. 1549 

 1550 

2. Click New Policy > Threat Defense NAT. 1551 

 1552 

3. Give the new policy a Name as PACS NAT. 1553 

4. Assign the FTD appliance to the new NAT policy. 1554 

5. Click Save. 1555 
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 1556 

6. Click on the NAT policy’s edit icon. 1557 

7. Click Add Rule. 1558 

8. Set NAT Rule to Auto NAT Rule. 1559 

9. Set Type to Dynamic. 1560 

10. Under Interface Objects set Source Interface Object to one of the FTD appliance’s LAN interfaces. 1561 

11. Set Destination Interface Object to the FTD appliance’s WAN interface. 1562 
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 1563 

12. Under Translation, set Original Source to the network that corresponds with the source interface 1564 
object established in the previous step. 1565 

13. Set Translated Source to Destination Interface IP. 1566 

14. Click OK. 1567 
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 1568 

15. Ensure the new NAT Rule has been created. 1569 

16. Repeat these steps if needed for each LAN interface attached to FTD appliance. 1570 

17. Click Save. 1571 

18. Deploy changes to FTD appliance. 1572 
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 1573 

Access Control Policy Through Firepower Management Center Configuration 1574 

Firepower Management Center allows configuration of access control policies that can then be applied 1575 
to individual FTD appliances. The purpose of the access-control policy is to create rules that specify how 1576 
traffic is managed within the network. Each access-control policy contains multiple rules followed by a 1577 
default action established when the policy is created. For the PACS architecture, one access-control 1578 
policy was established to manage the traffic on each FTD interface. The steps below describe how the 1579 
policy and rules were created, as well as how to utilize an intrusion policy with the access-control policy. 1580 
There is additional information on Cisco Firepower access control list and intrusion prevention 1581 
configuration [17]. 1582 

1. Navigate to Policies > Access Control > Access Control. 1583 

 1584 
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2. Click New Policy. 1585 

3. Enter PACS Global Policy as the name for the access control policy. 1586 

4. For Select Base Policy select None. 1587 

5. For Default Action select Block all traffic. 1588 

6. Add the FTD appliance to the policy. 1589 

7. Click Save. 1590 

 1591 

8. Click the access-control policy’s edit icon. 1592 

Note: The policy in the screenshots that follow contain categories created during the process of 1593 
building out the PACS architecture. These categories are not pre-configured. 1594 
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 1595 

Creating a category: 1596 

1. Click Add Category. 1597 

2. Enter PACS as the name for the category. 1598 

3. Insert the category into the Mandatory section. 1599 

4. Click OK. 1600 

 1601 

Create a rule that allows application traffic between security zones 1602 
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1. Click Add Rule. 1603 

2. Enter PACS-VNA as the name for the rule. 1604 

3. Insert the rule into the category created in the previous step. 1605 

4. Set Action to Allow. 1606 

Note: Because we set the default action to block all traffic when creating the policy, all of the rules 1607 
we created were set to Allow. 1608 

5. Add security zone(s) to the Source Zone, and also add security zone(s) to the Destination Zone. 1609 

Note: The two primary methods for adding source and destination networks to an access control 1610 
rule are through security zones or networks. Security zones are objects that can contain multiple 1611 
FTD interfaces. Networks can be different types of network objects, including network segments 1612 
(192.168.1.0/24) or individual devices (192.168.1.1). 1613 

 1614 

6. Under Applications, add the application(s) you would like to allow between the specified zones. 1615 

Note: This can also be accomplished by specifying the port you would like to allow under the Ports 1616 
tab. By specifying a specific port, this will open the port to all traffic regardless the type of traffic 1617 
(e.g., DICOM) being sent. 1618 

7. Click Add. 1619 
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 1620 

8. Verify that the rule has been created. 1621 

 1622 

Create a rule that allows traffic on a specific port between networks 1623 

1. Click Add Rule. 1624 
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2. Enter PACS-Internet as the name for the rule. 1625 

3. Insert the rule into the category created previously. 1626 

4. Set Action to Allow. 1627 

5. Under Networks, add a source network(s) and destination network(s). 1628 

 1629 

6. Under Ports, add a port(s) to the Selected Destination Ports. 1630 

Note: Select from a group of pre-created ports or add your own port by filling out the protocol and 1631 
port boxes, then click Add under the selected destination ports. 1632 
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 1633 

7. Under URLs, add URL categories that will be allowed (or leave this section blank). 1634 

Note: The URL categories are generated by Cisco Firepower and updated regularly. Within each 1635 
URL category, you can specify the reputation level the URL must meet in order for the rule to 1636 
match. 1637 

 1638 

8. Under Inspection, add an intrusion policy or leave this section blank. 1639 
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Note: Intrusion policies are created separately from the access-control policy. Once created, an 1640 
intrusion policy can be applied to a specific access-control rule or an entire access-control policy. 1641 
See the link posted [17] at the beginning of this section for more information on how to create and 1642 
use intrusion policies in Cisco Firepower. 1643 

 1644 

9. Under Logging, select Log at End of Connection, or leave this section blank. 1645 

Note: If logging is enabled, select Event Viewer. 1646 

10. Click Add. 1647 

 1648 
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11. Verify that the access control rules have been created and placed in the proper category. 1649 

12. Click Save. 1650 

13. Deploy changes to the FTD appliance. 1651 

 1652 

2.7.2 Cisco Stealthwatch 1653 

Cisco Stealthwatch provides network visibility and analysis through the use of network telemetry. It 1654 
provides threat detection and remediation as well as network segmentation using machine learning and 1655 
behavioral modeling. This project integrates Cisco Stealthwatch with Cisco Firepower to allow Cisco FTD 1656 
to send NetFlow directly to Stealthwatch for analysis. 1657 

Cisco Stealthwatch Management Console Appliance Information 1658 

CPU: 3 1659 

RAM: 16 GB 1660 

Storage: 60 GB (Thin Provision) 1661 

Network Adapter 1: VLAN 1901 1662 

Operating System: Linux 1663 

Cisco Stealthwatch Management Console Virtual Edition Installation Guide 1664 

Install the Cisco Stealthwatch Management Console appliance according to the instructions detailed in 1665 
the Cisco installation guide [18]. 1666 
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Cisco Stealthwatch UDP Director Appliance Information 1667 

CPU: 1 1668 

RAM: 4 GB 1669 

Storage: 60 GB (Thin Provision) 1670 

Network Adapter 1: VLAN 1901 1671 

Network Adapter 2: VLAN 1901 1672 

Operating System: Linux 1673 

Cisco Stealthwatch UDP Director Virtual Edition Installation Guide 1674 

Install the Cisco Stealthwatch UDP Director appliance according to the instructions provided at the Cisco 1675 
installation guide [18]. 1676 

Cisco Stealthwatch Flow Collector Appliance Information 1677 

CPU: 2 1678 

RAM: 16 GB 1679 

Storage: 60 GB (Thin Provision) 1680 

Network Adapter 1: VLAN 1901 1681 

Operating System: Linux 1682 

Cisco Stealthwatch Flow Collector Virtual Edition Installation Guide 1683 

Install the Cisco Stealthwatch Flow Collector appliance according to the instructions provided at the 1684 
Cisco installation guide [18]. 1685 

Configure NetFlow Parameters for Cisco Firepower 1686 

1. Log in to the Cisco Firepower Management Console. 1687 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 154 

 1688 

2. Navigate to Objects. 1689 
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 1690 

3. Navigate to FlexConfig > Text Object. 1691 

 1692 
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4. Under the Name column, find netflow_Destination. 1693 

 1694 

5. Click the edit icon for netflow_Destination. 1695 

6. Set Variable Type to Multiple. 1696 

7. Set Count to 3. 1697 

8. For Row 1, enter Security-Service to set the name of the Cisco FTD interface to which the Cisco 1698 
Stealthwatch UDP appliance is connected. 1699 

9. For Row 2, enter 192.168.190.120 to set the IP address of the Cisco Stealthwatch UDP appliance. 1700 

10. For Row 3, enter 2055 to set a port from which the Cisco Stealthwatch UDP appliance will receive 1701 
NetFlow traffic. 1702 

11. Click Save. 1703 
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 1704 

12. Under the Name column, find netflow_Parameters. 1705 

 1706 
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13. Click the edit icon for netflow_Parameters. 1707 

14. Set Variable Type to Multiple. 1708 

15. Set Count to 3. 1709 

16. For Row 1, enter 1 as a number for minutes between flow update events. 1710 

17. For Row 2, enter 0 as a number for seconds to delay flow create. 1711 

18. For Row 3, enter 30 as a number for minutes for template timeout rate. 1712 

19. Click Save. 1713 

 1714 

20. Navigate to Devices > FlexConfig. 1715 

 1716 

21. Click New Policy. 1717 
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22. Enter a Name (e.g., Netflow) for the policy. 1718 

23. Under Selected Devices, add the Cisco FTD. 1719 

24. Click Save. 1720 

 1721 

25. Click the edit icon for the new policy. 1722 

 1723 

26. Under Available FlexConfig, find Netflow_Set_Parameters, and add it to Selected Append 1724 
FlexConfigs. 1725 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 160 

 1726 

27. Click the magnifier icon for Netflow_Set_Parameters. 1727 

28. Under Variables > Default Value, verify the minutes between flow data events, seconds to delay 1728 
flow create, and minutes for template timeout rate that were set for netflow_Parameters. 1729 

29. Click Close. 1730 

 1731 
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30. Under Available FlexConfig, find Netflow_Add_Destination, and add it to Selected Append 1732 
FlexConfigs. 1733 

31. Click the magnifier icon for Netflow_Add_Destination. 1734 

32. Under Variables > Default Value, verify the Cisco FTD interface name, IP address of the Cisco 1735 
Stealthwatch, and the NetFlow traffic port. 1736 

33. Click Close. 1737 

 1738 

34. Click Save. 1739 

35. Deploy changes to the Cisco FTD. 1740 

Forwarding Rules for Cisco Stealthwatch UDP Configuration 1741 

1. Log in to the web dashboard of the Cisco Stealthwatch Management Console. 1742 
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 1743 

2. Navigate to Settings > Central Management. 1744 

 1745 

3. Click on the ellipsis for the Cisco Stealthwatch UDP appliance and select Edit Forwarding Rules. 1746 
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 1747 

4. Click on the ellipsis for the Cisco Stealthwatch UDP appliance, select Configure Forwarding Rules. 1748 

 1749 

5. Under Forwarding Rules, select Add New Rule. 1750 
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 1751 

6. Enter a description (e.g., Firepower FTD) for the rule. 1752 

7. For source IP address and source port, enter the IP address, and port (e.g., 192.168.190.1:2055) of 1753 
the Cisco FTD interface sending the NetFlow traffic. 1754 

Note: These parameters were established in Cisco FTD, found in the previous section, for the 1755 
netflow_Destination object. 1756 

8. For destination IP address, enter the IP address (e.g., 192.168.190.122) of the Cisco Stealthwatch 1757 
Flow Collector. 1758 

9. For destination port, enter the port (e.g., 2055) of the Cisco Stealthwatch Flow Collector. 1759 

Note: This port was configured during the setup of the Flow Collector. 1760 
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 1761 

10. On the Cisco Stealthwatch Management Console dashboard, view the Flow Collection Trend graph 1762 
to verify that the Cisco Stealthwatch Flow Collector is receiving packets from the Cisco 1763 
Stealthwatch UDP. 1764 

 1765 

2.7.3 Tempered Networks Identity Defined Networking (IDN) 1766 

Tempered Networks IDN provides cryptographically defined host identifiers using the HIP protocol 1767 
rather than using IP addressing. Network traffic traverses an overlay network using HIP switches that 1768 
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effectively cloak that traffic from the production network. A notional architecture is depicted in Figure 1769 
2-2 below. 1770 

Figure 2-2 Architecture of Networks IDN 1771 

 1772 

Tempered Networks Conductor is the orchestration engine and intelligence behind an IDN. As shown in 1773 
the above figure, the Conductor is responsible for creating and executing security policies and overlays. 1774 
It is also responsible for issuing unique Cryptographic IDs (CIDs) to the IDN endpoints that enforce 1775 
explicit trust relationships through device-based whitelisting. 1776 

HIPswitches are typically deployed in front of devices or hosts that cannot protect themselves, like 1777 
medical devices such as modalities and other legacy systems and machines, or when customers are 1778 
unable to install the proper endpoint-protection applications. 1779 

Installation involves the deployments of the Tempered Networks Conductor and HIPswitches. A 1780 
Conductor open virtual appliance or application (OVA) file and a HIPswitches OVA file were provided by 1781 
Tempered Networks. 1782 

2.7.3.1 Conductor Installation 1783 

System Requirements 1784 

CPU: 4 1785 

Memory: 4 GB RAM 1786 

Storage: 120 GB 1787 

Operating System: Linux Red Hat 1788 
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Network Adapter: VLAN 1201 1789 

Tempered Networks Conductor Installation 1790 

1. Log in to the vSphere Client. 1791 

2. Select File > Deploy OVF Template. 1792 

3. Respond to the prompts with information specific to your deployment, including the ova package 1793 
location, name and location, storage, networking and provisioning, etc. 1794 

4. Click Power On After Deployment, and click Finish. 1795 

5. Once the installation is done, power on the Conductor server and log in with username macinfo 1796 
and the corresponding password to set up the necessary Mac address and IP address. 1797 

2.7.3.2 HIPswitch Installation 1798 

System Requirements 1799 

CPU: 4 1800 

Memory: 1 GB RAM 1801 

Storage: 1 GB 1802 

Operating System: Linux Red Hat 1803 

Network Adapter: VLAN 1201 1804 

HIPswitch Installation 1805 

1. Log in to the vSphere Client. 1806 

2. Select File > Deploy OVF Template. 1807 

3. Respond to the prompts with information specific to your deployment, including the ova package 1808 
location, name and location, storage, networking and provisioning, etc. 1809 

4. Click Power On After Deployment, and click Finish. 1810 

5. After the installation, use the username mapconfig and the corresponding password to connection 1811 
the HIPswitch the conductor. 1812 

6. Use the username underlayaddress and its corresponding password to setup the IP address, 1813 
netmask, gateway, and DNS for the HIPswitch. 1814 

7. Repeat the above installation procedures to install additional HIPswitches. 1815 

Tempered Networks Conductor and HIPswitch Configuration 1816 
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The configuration for the Conductor and HIPswitches is done through the browser connected to the 1817 
Conductor https://ConductorIP. Below is the log in page. 1818 

1. Enter the username and password to open the Dashboard. 1819 

 1820 

2. Click Settings tab. 1821 

 1822 

3. From this page, you can set up license and perform the system setup. Click the Setup button to 1823 
enter the system setup. 1824 
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 1825 

4. Enter the proper network parameters for the Conductor, including the IP address (e.g., 1826 
192.168.120.180), Netmask (e.g., 255.255.255.0), Default gateway (e.g., 192.168.120.1), and DNS 1827 
(e.g., 8.8.8.8, 4.4.8.8), then click Configure. 1828 

 1829 
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5. An Overlay is configured to support the microsegmentation. Click the Overlay tab to open the 1830 
following page, and you can add a new overlay by clicking the + New Overlay Network…. The page 1831 
below shows a configured overlay called PACS Systems. 1832 

 1833 

6. Two HIPswitches were installed to test for this project. These two HIPswitches are Model 1834 
HIPswtich-300v, and they are named HIPswitch Internal and HIPswitch Radiology. Both were 1835 
configured to participate in the PACS Systems overlay network. 1836 

 1837 

7. Two special VLANs were created for each of these two HIPswitches under PACS Systems overlay: 1838 

 VLAN 1302 for HIPswitch Internal 1101 1839 

 VLAN 1303 for HIPswitch Radiology 1501 1840 

8. Devices to be protected under the HIP network will be connected to these two HIPswitches 1841 
through the VLANs: 1842 

 PACS Servers are connected to VLAN 1302 under the HIPswitch Internal 1101 1843 

 Medical imaging devices are connected to VLAN 1303 under the HIPswitch Radiology 1501 1844 
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After creating a secure layer in the Conductor and adding those medical imaging devices and PACS 1845 
servers to that layer, the medical imaging device and PACS server can be set up as trusted, by selecting 1846 
the Enable button on the overlay page. Once they are trusted, communication between those medical 1847 
imaging devices and PACS servers will be established. All the communication will be encrypted. 1848 

The microsegmentation is achieved by using the HIPswitch. Other VMs will not be able to communicate 1849 
with these two devices unless they are configured to do so. 1850 

2.7.4 Zingbox IoT Guardian 1851 

Zingbox IoT Guardian consists of two separate components that work together to monitor and analyze 1852 
network traffic. The first component is a cloud-based platform called Zingbox Cloud, which aggregates 1853 
and analyzes data to provide insights into the devices on the local network. The second component is 1854 
Zingbox Inspector, a local appliance that receives network flows from devices on the local network and 1855 
sends specific metadata to Zingbox Cloud for further analysis. 1856 

Zingbox Cloud Setup 1857 

1. Visit https://zingbox.com and register for an account. 1858 

2. Log in to the Zingbox console and navigate to Administration > My Inspectors > Download 1859 
Inspector. 1860 

3. Download either the .ova or the .iso file, depending on your environment’s requirements. 1861 

System Requirements 1862 

CPU: 4 1863 

Memory: 8 GB RAM 1864 

Storage: 256 GB (Thin Provision) 1865 

Operating System: CentOS 7 1866 

Network Adapter 1: VLAN 1101 1867 

Network Adapter 2: Trunk Port 1868 

Zingbox Inspector Installation 1869 

1. Create a new virtual machine, and under configuration select Typical. 1870 

2. Click Next >. 1871 

https://zingbox.com/
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 1872 

3. Create a Name for the virtual machine and assign it an Inventory Location. 1873 

4. Click Next >. 1874 

 1875 
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5. Select a destination storage for the VM. 1876 

6. Click Next >. 1877 

 1878 

7. Check Linux and set version to CentOS 4/5/6/7 (64-bit). 1879 

8. Click Next >. 1880 
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 1881 

9. Connect 2 NICs to the virtual machine and assign them to a network. 1882 

10. Check Connect at Power On for both NICs. 1883 

11. Click Next >. 1884 

 1885 
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12. Set a Virtual disk size and Provisioning method. 1886 

13. Click Next >. 1887 

 1888 

14. Verify virtual machine settings are correct. 1889 

15. Check Edit the virtual machine settings before completion. 1890 

16. Click Continue. 1891 
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 1892 

17. Set memory to 8 GB. 1893 

18. Set CPUs to 4. 1894 

19. Under New CD/DVD (adding), set these parameters: 1895 

 Check Connect at power on. 1896 

 Select Datastore ISO File, then browse for the ZingOS.iso file in your datastore. 1897 

20. Click Finish. 1898 
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 1899 

21. Connect to the inspector console and follow the on-screen prompts to finish the configuration. 1900 

22. In a web browser, enter the URL of your Zingbox Cloud instance. 1901 

23. Enter your Zingbox Cloud credentials. 1902 

24. Click Login. 1903 

25. On the home page, navigate to Administration > My Inspectors. 1904 

26. Verify that the host name of the Zingbox Inspector set up previously is visible and connected 1905 
(shown by the green cloud icon). 1906 
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 1907 

2.7.5 Forescout CounterACT 8 1908 

Forescout CounterACT is a network access control tool that can perform device discovery and 1909 
classification, risk assessment, and control automation through passive and active techniques. For this 1910 
project, the intended use of Forescout is to manage device compliance and perform necessary 1911 
remediation when devices fall out of compliance. 1912 

System Requirements 1913 

CPU: 2 1914 

Memory: 8 GB RAM 1915 

Storage: 80 GB (Thin Provision) 1916 

Operating System: Linux Kernel 3.10 1917 

Network Adapter 1: VLAN 1201 1918 

Network Adapter 2: Trunk Port 1919 

Forescout Appliance Installation 1920 

1. To begin installation, obtain the Forescout ISO. Load the Forescout ISO into the VM’s CD/DVD drive. 1921 
Make sure the CD/DVD drive is set to Connect at Power On. 1922 

2. Boot up the VM and begin the installation process. 1923 

3. Select Install CounterACT. 1924 

4. Press Enter to reboot. 1925 

5. Select option 1 to configure CounterACT. 1926 
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6. Select option 1 for standard installation. 1927 

7. Press enter to proceed. 1928 

8. Select option 1 for CounterACT Appliance. 1929 

9. Select option 1 for Per Appliance Licensing Mode. 1930 

10. Enter appliance description. 1931 

11. Give appliance a password. 1932 

12. Enter forescoutCA and apply this as the appliance host name. 1933 

13. Assign the appliance an IP address 192.168.120.160. 1934 

14. Assign appliance a network mask 255.255.255.0. 1935 

15. Enter 192.168.120.1 as the appliance’s gateway. 1936 

16. Enter domain name pacs.hclab. 1937 

17. Enter DNS server address 192.168.120.100. 1938 

18. Review configuration and run test. 1939 

19. Once the test passes, select done. 1940 

Forescout CounterACT Console Installation 1941 

1. Run Install_Management.exe. 1942 

2. Click Next >. 1943 

 1944 

3. Verify Installation Directory as C:\Users\Administrator\ForeScout CounterACT 8.0.1; click Next >. 1945 
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 1946 

4. When the Ready to Install screen appears, click Next > to begin the installation process. 1947 

 1948 

5. An Installing screen will appear that provides a status bar indicating degree of installation 1949 
completion. Click the Next> button to allow the installation to proceed. 1950 
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 1951 

6. As the installation nears completion, a screen indicating Completing the ForeScout 8.0.1 Setup 1952 
Wizard appears. Check Create Desktop shortcut; click Finish. 1953 

 1954 

7. Launch Forescout CounterACT Console and enter the information that follows, then click Login: 1955 

a. Enter 192.168.120.160 in the IP/Name text box. 1956 

b. Select Password as the Login Method.  1957 

c. Enter Administrator in the User Name text box. 1958 

d. Enter the password in the Password box. 1959 
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 1960 

Forescout CounterACT Configuration 1961 

To use the full function offered by the Forescout CounterACT, proper network configuration is required, 1962 
which may include the monitor and response interface assignments at the data center, the network 1963 
VLAN and segmentation information, IP address range that the CounterACT appliance will protect, user 1964 
Directory account information, domain credentials, core switch IP address, and vendor and SNMP 1965 
parameters. 1966 

After completing the installation, log in to the CounterACT Console using the steps below: 1967 

1. Select the CounterACT icon from the server on which you installed the CounterACT Console. A log 1968 
on page appears, as depicted below. 1969 

 1970 
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2. Provide the following information and select Login to open the Console: 1971 

a. Enter the IP address 192.168.120.160 in the IP/Name field. 1972 

b. In the User Name field, enter admin. 1973 

c. In the Password field, enter the admin password which is defined during the installation. 1974 

 1975 

The console manager can be used to view, track, and analyze network activities detected by the 1976 
appliance. It can also be used to define the threat protection, firewall, and other polices. 1977 

The figure below shows the sample asset inventory page. (Further network configuration will be needed 1978 
for complete inventory information.) 1979 
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 1980 

The figure below shows the sample Policy Manager page. Further network configuration and policy 1981 
definition will be needed for complete policy information. 1982 

 1983 
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2.7.6 Symantec Endpoint Detection and Response (EDR) 1984 

Symantec Endpoint Detection and Response performs behavioral analytics on endpoint events from 1985 
Symantec Endpoint Protection, to identify potentially malicious behavior. It can sandbox impacted 1986 
endpoints, prioritize risks, and provide tailored remediation guides. 1987 

System Requirements 1988 

CPU: 12 1989 

Memory: 5 GB RAM 1990 

Storage: 500 GB (thin provisioned) 1991 

Operating System: CentOS 7 1992 

Network Adapter 1: VLAN 1901 1993 

Network Adapter 2: SPAN_PACS 1994 

Symantec EDR Installation 1995 

1. Launch the virtual appliance after deployment of the vendor-provided SEDR-4.0.0-483-VE.ova file. 1996 

2. Enter default username admin and default password. You will be required to change the default 1997 
password by entering a new password. 1998 

3. After changing the default password, the bootstrap will automatically launch. Enter the following 1999 
options during the bootstrap: 2000 

 IPv4 address []: 192.168.190.17 2001 

 IPv4 netmask []: 255.255.255.0 2002 

 Gateway []: 192.168.190.1 2003 

 Name server (IPv4) []: 192.168.120.100 2004 

 Configure another nameserver? [y/n]: n 2005 

 Configure IPv4 static routes? [y/n]: n 2006 

 What do you want to call this device?: EDR 2007 

 Set NTP server []: X.X.X.X 2008 

4. After verifying the correct details, enter Y to save changes. The appliance will restart. 2009 

 2010 

 2011 
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 2012 

5. Open a web browser and travel to the virtual appliance at https://192.168.190.170. Enter the 2013 
username setup and password *****. 2014 

6. Follow the prompts to create the initial admin account. 2015 
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 2016 

7. Select the Settings menu, and then select the Global sub-menu. 2017 

8. Ensure Enable Symantec Endpoint Protection Correlation is checked. 2018 

9. Select Add SEPM Database and enter the following options. 2019 

 2020 

10. Provide the information that follows, and click Save: 2021 
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 DB Type: Embedded DB 2022 

 Entry Name: SEPM 2023 

 Address: 192.168.190.172 2024 

 Port: 8081 2025 

 Connection Password: enter your connection password 2026 

 Enabled: Checked 2027 

 2028 

11. After completing the integration with SEPM, select the Settings menu, then select the Appliances 2029 
sub-menu. 2030 

12. Select Edit Default Appliance. 2031 

13. Select Add Internal Network to create and add a Subnet, Netmask, and Description for each 2032 
internal network listed below. Make sure to save after entering the network details. 2033 
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 2034 

 Subnet: 192.168.100.0 Netmask: 255.255.255.0 Description: VLAN 1101 2035 

 Subnet: 192.168.120.0 Netmask: 255.255.255.0 Description: VLAN 1201 2036 

 Subnet: 192.168.130.0 Netmask: 255.255.255.0 Description: VLAN 1301 2037 

 Subnet: 192.168.140.0 Netmask: 255.255.255.0 Description: VLAN 1401 2038 

 Subnet: 192.168.141.0 Netmask: 255.255.255.0 Description: VLAN1402 2039 

 Subnet: 192.168.150.0 Netmask: 255.255.255.0 Description: VLAN 1501 2040 

 Subnet: 192.168.160.0 Netmask: 255.255.255.0 Description: VLAN 1601 2041 

 Subnet: 192.168.180.0 Netmask: 255.255.255.0 Description: VLAN 1801 2042 

 Subnet: 192.168.190.0 Netmask: 255.255.255.0 Description: VLAN 1901 2043 

 2044 

14. Select Settings and then Global. 2045 
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15. Uncheck Enable ECC 2.0 under Endpoint Communication Channel, SEP Policies and Endpoint 2046 
Activity Recorder. 2047 

 2048 

16. Select Settings and then Appliances. 2049 

 2050 
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17. Select EDR from the appliances list. 2051 

18. Turn Scanning on under the Network Interface Settings. 2052 

Symantec EDR and SEP Correlation 2053 

1. Open a web browser and travel to the virtual appliance at https://192.168.190.170. Log in with 2054 
your administrator account. 2055 

2. From the settings menu, select global settings. 2056 

3. Select Download Synapse Log Collector for SEPM Embedded DB. 2057 

4. After the SEPMLogCollector.msi finishes downloading move to the SEP Manager (SEPM). 2058 

5. Launch the SEPMLogCollector.msi file from SEPM. 2059 

6. Continue through the setup wizard prompts by clicking Next to use the default settings. 2060 

7. After installation is complete, launch the Log Collection for SEPM embedded database 2061 
configuration utility, and enter the values below: 2062 

 Service Hostname (optional): Leave blank 2063 

 Service IP address: 192.168.190.172 2064 

 Service port: 8082 2065 

 Log Collector connection password: enter connection password 2066 

 Confirm connection password: enter connection password again 2067 

 SEPM embedded database configuration password: enter embedded database password 2068 

8. After entering values into configuration utility, click Confirm. 2069 
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 2070 

2.8 Endpoint Protection & Security 2071 

2.8.1 Symantec Data Center Security: Server Advanced (DCS:SA) 2072 

Symantec DCS:SA utilizes a software agent to provide various server protections, including application 2073 
whitelisting, intrusion prevention, and file integrity monitoring. For this project, a DCS:SA agent was 2074 
installed on both PACS servers in our architecture. 2075 

System Requirements 2076 

CPU: 4 2077 

Memory: 8 GB RAM 2078 

Storage: 120 GB (Thin Provision) 2079 

Operating System: Microsoft Windows Server 2016 Datacenter 2080 

Network Adapter: VLAN 1901 2081 

Symantec Data Center Security Installation 2082 

1. Launch server.exe. 2083 

2. Click Next >. 2084 
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 2085 

3. Check I accept the terms of the license agreement. 2086 

4. Click Next >. 2087 

 2088 

5. Verify install location. 2089 

6. Click Next >. 2090 
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 2091 

7. Review settings. 2092 

8. Click Install >. 2093 

 2094 

9. Wait for setup and install process to complete. 2095 
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 2096 

10. SQL Server will automatically be installed during the setup process. 2097 

 2098 

11. Provide the information below, and click on Next: 2099 

 Agent port: 443 2100 
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 Bridge port: 2443 2101 

 Console port: 4443 2102 

 Web server administration port: 8081 2103 

 Web server shutdown port: 8006 2104 

 2105 

12. Uncheck Enable CWP Bridge and click Next. 2106 

 2107 
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13. Verify settings for FQDN Hostname as WIN-RUQDO7KL8A7, Static IP Address as 192.168.120.207, 2108 
and Java Heap Size as 6144 and then click Next. 2109 

 2110 

14. Create a password for the database connection. 2111 

15. Click Next. 2112 

 2113 

16. Verify Unified Management Console connection settings. 2114 

17. Create a password for Unified Management Console connection. 2115 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 198 

18. Click Next. 2116 

 2117 

19. Verify configuration settings and click Next. 2118 

 2119 

20. Wait for configuration process to complete. 2120 

21. Click Finish. 2121 
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 2122 

22. Wait for install to complete and click OK. 2123 

 2124 

Symantec Datacenter Security Windows Agent Install 2125 

1. Run agent.exe. 2126 

2. Click Next >. 2127 
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 2128 

3. Check I accept the terms in the license agreement. 2129 

4. Click Next >. 2130 

 2131 

5. Verify installation and log files directories. 2132 

6. Click Next >. 2133 
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 2134 

7. Provide the information below, and click on Next>: 2135 

 Agent Name: WIN-RUQDO7KL8A 2136 

 Polling Interval (sec): 300 2137 

 Check Enable Intrusion Prevention 2138 

 Notification Port: 2222 2139 

 Agent Protocol: HTTPS 2140 

 2141 
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8. Provide the information below and click Next: 2142 

 Primary Management Server: 192.168.120.207 2143 

 Agent Port: 443  2144 

 Alternate Management Servers: 2145 

 Management Server Certificate: C:\User\Administrator\Desktop\agent-cert.ssh 2146 

 2147 

9. Specify a Server Security Group created through Symantec Datacenter Security Server or leave it 2148 
blank to use the default security group. 2149 

10. Click Next >. 2150 
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 2151 

11. Verify installation and configuration settings and click Install. 2152 

 2153 

12. Wait for the installation process to complete. 2154 
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 2155 

13. Click Finish. 2156 

 2157 

14. Click Yes to restart the agent machine. 2158 
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 2159 

2.8.2 Symantec Endpoint Protection 2160 

Symantec Endpoint Protection is an agent-based security solution that provides antivirus, intrusion 2161 
prevention, application whitelisting, and other capabilities. For this project Symantec SEP is used to 2162 
protect endpoints from malicious software and integrates with Symantec Endpoint Detection and  2163 
Response to detect suspicious behavior. 2164 

System Requirements 2165 

CPU: 4 2166 

Memory: 8GB RAM 2167 

Storage: 240GB (thin provisioned) 2168 

Operating System: Microsoft Windows Server 2016 2169 

Network Adapter: VLAN 1901 2170 

Symantec Endpoint Protection Manager Installation 2171 

1. Launch Symantec_Endpoint_Protection_14.2.0.MP1_Part1_Trialware_EN.exe file. 2172 

2. Select Install Symantec Protection Endpoint Manager option. 2173 
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 2174 

3. Proceed through the install wizard by clicking Next >. 2175 

 2176 

4. Check I accept the terms in the license agreement. 2177 

5. Click Next >. 2178 
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 2179 

6. Select the location you want to install Symantec Endpoint Protection Manger and click Next >. Keep 2180 
the default location of C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\. 2181 

 2182 

7. Select Install. 2183 
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 2184 

8. After installation is complete, click Next > to continue with configuration of the management 2185 
server. 2186 

 2187 

9. Select Default configuration for new installation; click Next >. 2188 
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 2189 

10. Provide the following information and click Next>. 2190 

 Company Name: NCCoE 2191 

 User name: admin 2192 

 Password: ******** 2193 

 Confirm password: ******** 2194 

 Email address: admin@nccoe.labs 2195 

mailto:admin@nccoe.labs
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 2196 

11. Confirm that Run LiveUpdate during installation is checked; click Next >. 2197 

 2198 
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12. Uncheck Send anonymous data to Symantec to receive enhanced threat protection intelligence 2199 
and click Next >. 2200 

 2201 

13. After installation is completed, check Launch the Symantec Endpoint Protection Manager to 2202 
configure your hosts; click Finish. 2203 
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 2204 

Symantec Endpoint Protection Host Windows Installation 2205 

1. Launch the Symantec Endpoint Protection Manager and log in as the admin. 2206 

 2207 

2. Select Install the client software on your computers from the Getting Started screen. 2208 
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 2209 

3. Confirm that New Package Deployment is checked and click Next >. 2210 

 2211 
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4. Confirm the settings Install Packages: Windows - Symantec Endpoint Protection version 2212 
14.2.1023.0100 - English, Group: My Company, Install Feature Sets: Full Protection for Clients, 2213 
Install Settings: Default Standard client installation settings for Windows. Click Next >. 2214 

 2215 

5. Confirm that Save Package is selected and click Next >. 2216 
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 2217 

6. Specify the location to save the installation files and click Next >. 2218 
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 2219 

7. Confirm details of custom installation files and click Next >. 2220 
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 2221 

8. Move the installation package to the Operating System on which you want to install Symantec 2222 
Endpoint Protection. 2223 

9. Launch the executable file and follow the prompts to install Symantec Endpoint Protection. 2224 

2.9 Data Security 2225 

No specific solution was implemented in the NCCoE lab to address data-at-rest encryption. 2226 

The NCCoE lab used several different solutions to address data-in-transit encryption. As described in 2227 
Section 2.6.2, DigiCert PKI, the lab implements SSL/TLS encryption using DigiCert-issued certificates. 2228 
Communications between modalities and clinical systems are secured using HIP, as described in Section 2229 
2.7.3, Tempered Networks Identity Defined Networking (IDN). 2230 
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2.10 Secure Remote Access 2231 

2.10.1  TDi Technologies ConsoleWorks 2232 

The NCCoE lab implemented a VendorNet using TDi ConsoleWorks, which is a browser interface that 2233 
enables HDOs to manage, monitor, and record activities from external vendors in the IT infrastructure. 2234 

System Requirements 2235 

CPU: 1 2236 

Memory: 8 GB RAM 2237 

Storage: 40 GB  2238 

Operating System: CentOS 7  2239 

Network Adapter: VLAN 1097 2240 

TDi ConsoleWorks Installation 2241 

The TDi ConsoleWorks installation in this PACS environment replicates the installation in the Wireless 2242 
Infusion Pumps project. For detailed installation guidance, please refer to the Section 2.1.8 TDi 2243 
ConsoleWorks External Remote Access in NIST SP 1800-8C, Securing Wireless Infusion Pumps [19]. 2244 

TDi ConsoleWorks Radius Authentication Configuration 2245 

In our project, we integrated TDi ConsoleWorks with the Symantec VIP, for two-factor authentication. 2246 
This section explains how to enable external authentications for ConsoleWorks. In the next section we 2247 
explain how we configured Symantec VIP to integrate with ConsoleWorks. 2248 

1. Download extern_auth_radius.so file from ConsoleWorks support site [20].  2249 

2. Move extern_auth_radius.so file to /opt/ConsoleWorks/bin directory. 2250 

3. Restart ConsoleWorks by executing cw_stop and cw_start scripts located in the 2251 
/opt/ConsoleWorks/bin directory. 2252 

4. From the ConsoleWorks web interface, navigate to Security and click External Authentication. 2253 

5. Click add to create a new external authentication source. 2254 

6. Fill out the required fields. Below is the setup we used: 2255 

 Record Name: Radius 2256 

 Ensure Enable is checked 2257 

 For Library select radius 2258 
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 Parameter 1: 192.168.120.190:1812/******* 2259 

 Parameter 2: 30 2260 

 Parameter 6: 15 2261 

 Template User: CONSOLE_MANAGER 2262 

7. Continue through the prompt by clicking Next; click Save on the final prompt. 2263 

 2264 

8. Ensure that Enable External Authentication is checked. 2265 

 2266 
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2.10.2 Symantec Validation and ID Protection (VIP) 2267 

Symantec Validation and ID Protection is an authentication service that provides various forms of 2268 
authentication such as push, SMS, and biometric. For this project, Symantec VIP is used as a second form 2269 
of authentication for remote access to the PACS architecture through TDi Technologies ConsoleWorks. 2270 

System Requirements 2271 

CPU: 4 2272 

Memory: 8192MB RAM 2273 

Storage: 240GB (thin provisioned) 2274 

Operating System: Microsoft Windows Server 2016 2275 

Network Adapter: VLAN 1201 2276 

Symantec VIP Installation 2277 

1. Right click on the setup.exe file for VIP Enterprise Gateway 9.8.0; select Run as administrator. 2278 

 2279 

2. Proceed through the install wizard by clicking Next >. 2280 
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 2281 

3. Check I accept the agreement. 2282 

4. Click Next >. 2283 

 2284 

5. Create a username as admin and password and click Next >. 2285 
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 2286 

6. Keep the default installation location by clicking Next >. 2287 

 2288 

7. Click Install. 2289 
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 2290 

8. Click Finish after installer is complete. 2291 

 2292 

9. On the Symantec VIP local machine, open a web browser and navigate to http://localhost:8232. 2293 
Sign in with the User Name as admin and corresponding Password specified during installation. 2294 
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 2295 

10. Select User Store from the menu bar. 2296 

 2297 

11. Add a user store with the following information: 2298 
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 Name: AD PACS 2299 

 Connection: ad-main 2300 

 Host: ad.pacs.hclab 2301 

 Port: 389 2302 

 User DN: CN=symantec, DC=pacs, DC=hclab 2303 

 Password: ********* 2304 

 Base DN: DC=pacs, DC=hclab 2305 

 User Filter: (&(&objectClass=user)(objectCategory=person))(sAMAcountName=%s)) 2306 

 2307 

12. Log into VIP Manager by navigating to https://manager.vip.symantec.com/vipmgr. Use the account 2308 
provided by Symantec. 2309 

13. Select Register Your VIP Credential. Provide the Credential ID and Security Code of your 2310 
credentials. Credentials can be downloaded by navigating to https://vip.symantec.com/.  2311 

https://vip.symantec.com/
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 2312 

14. After registering the credential, select Go to My Account. 2313 

 2314 

15. Select Account from menu bar, then select Manage VIP Credentials. 2315 
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 2316 

16. Select Request a Certificate. 2317 

 2318 

17. Provide a Certificate Name as NCCoE_VIP_Cert; click Submit Request. 2319 
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 2320 

18. Select PKCS#12 format and create a password for the requested certificate. Then select Download 2321 
Certificate. 2322 

 2323 

19. Save the certificate on the Symantec VIP local machine. 2324 
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20. Navigate to http://localhoat:8232. After logging, select Add VIP Certificate. 2325 

 2326 

21. Select Browse and upload the certificate from the previous step. Enter the correct password and 2327 
alias for the certificate, then click Submit. 2328 

 2329 

22. Select Validation from the menu bar, select Custom configuration, and provide the information that 2330 
follows: 2331 

 Server Name: vip 2332 

 Local IP: 192.168.120.190 2333 



DRAFT 

 

NIST SP 1800-24C: Securing Picture Archiving and Communication System (PACS) 230 

 Port: 1812 2334 

 RADIUS Shared Secret: ***** 2335 

 Confirm RADIUS Shared Secret: ***** 2336 

 Enable First Factor: Checked 2337 

 Authentication on: Enterprise 2338 

 Authentication Sequence: LDAP Password – VIP Authentication 2339 

 User Store: AD PACS 2340 

 2341 

23. Click Submit. 2342 
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 2343 

24. Ensure VIP Server Status is set to ON. 2344 

2345 
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Appendix A List of Acronyms 
 

AD Active Directory  

AES Advanced Encryption Standard  

AE Title Application Entity Title 

CA Certificate Authority 

CID Cryptographic ID 

CSR Certificate Signing Request 

CPU Central Processing Unit 

DB Database 

DC Domain Controller 

DCS:SA Data Center Security: Server Advanced 

DHCP Dynamic Host Configuration Protocol 

DICOM Digital Imaging and Communications in Medicine 

DNS Domain Name Service 

EDR Endpoint Detection and Response 

FMC Firepower Management Center 

FTD Firepower Threat Defense 

GB gigabyte 

GUI Graphical User Interface 

HD Hard Drive 

HDO Healthcare Delivery Organization 

HIP Host Identity Protocol 

HL7 Health Level 7 

HTTP Hypertext Transfer Protocol 

HTTPS Hyper Text Transfer Protocol Secure 
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ICMP Internet Control Message Protocol 

IDN Identity Defined Networking 

IHE Integrating Health Enterprise 

IIS Internet Information Services 

IoT  Internet of Things 

IP Internet Protocol 

IPv4 Internet Protocol version 4 

ISO International Standards Organization 

IT Information Technology 

JDK Java Development Kit 

LDAP Lightweight Directory Access Protocol  

MB megabyte 

MPPS Modality Performed Procedure Step 

NAT Network Address Translation 

NCCoE National Cybersecurity Center of Excellence 

NIC Network Interface Controller 

NIST Nation Institute of Standards and Technology 

NTP Network Time Protocol 

OS Operating System 

OVA Open Virtual Appliance or Application 

OVF Open Virtualization Format 

PACS Picture Archiving and Communication System 

PKI Public Key Infrastructure 

QR Code Quick Response Code 

RAM Random Access Memory 

RIS Radiology Information System 
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SCP Service Class Provider 

SCU Service Class User 

SEP Symantec Endpoint Protection 

SEPM Symantec Endpoint Protection Manager 

SNMP Simple Network Management Protocol 

SP Special Publication 

SQL Structured Query Language 

SSL/TLS Secure Socket Layer/Transport Layer Security 

TCP/IP Transmission Control Protocol/Internet Protocol 

UDM Universal Data Manager 

UDP User Datagram Protocol 

URL Uniform Resource Locator 

VLAN Virtual Local Area Network 

VM Virtual Machine 

VNA Vendor Neutral Archive 

WAN Wide Area Network 
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