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Certain commercial entities, equipment, products, or materials may be identified by name or company 2 
logo or other insignia in order to acknowledge their participation in this collaboration or to describe an 3 
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NATIONAL CYBERSECURITY CENTER OF EXCELLENCE 22 

The National Cybersecurity Center of Excellence (NCCoE), a part of the National Institute of Standards 23 
and Technology (NIST), is a collaborative hub where industry organizations, government agencies, and 24 
academic institutions work together to address businesses’ most pressing cybersecurity issues. This 25 
public-private partnership enables the creation of practical cybersecurity solutions for specific 26 
industries, as well as for broad, cross-sector technology challenges. Through consortia under 27 
Cooperative Research and Development Agreements (CRADAs), including technology partners—from 28 
Fortune 50 market leaders to smaller companies specializing in information technology security—the 29 
NCCoE applies standards and best practices to develop modular, easily adaptable example cybersecurity 30 
solutions using commercially available technology. The NCCoE documents these example solutions in 31 
the NIST Special Publication 1800 series, which maps capabilities to the NIST Cybersecurity Framework 32 
and details the steps needed for another entity to re-create the example solution. The NCCoE was 33 
established in 2012 by NIST in partnership with the State of Maryland and Montgomery County, 34 
Maryland. 35 

To learn more about the NCCoE, visit https://www.nccoe.nist.gov/. To learn more about NIST, visit 36 
https://www.nist.gov. 37 

NIST CYBERSECURITY PRACTICE GUIDES 38 

NIST Cybersecurity Practice Guides (Special Publication 1800 series) target specific cybersecurity 39 
challenges in the public and private sectors. They are practical, user-friendly guides that facilitate the 40 
adoption of standards-based approaches to cybersecurity. They show members of the information 41 
security community how to implement example solutions that help them align more easily with relevant 42 
standards and best practices, and provide users with the materials lists, configuration files, and other 43 
information they need to implement a similar approach. 44 

The documents in this series describe example implementations of cybersecurity practices that 45 
businesses and other organizations may voluntarily adopt. These documents do not describe 46 
regulations or mandatory practices, nor do they carry statutory authority.  47 

ABSTRACT 48 

Ransomware, destructive malware, insider threats, and even honest user mistakes present ongoing 49 
threats to organizations. Organizations’ data, such as database records, system files, configurations, 50 
user files, applications, and customer data, are all potential targets of data corruption, modification, and 51 
destruction. Formulating a defense against these threats requires two things: a thorough knowledge of 52 
the assets within the enterprise, and the protection of these assets against the threat of data corruption 53 
and destruction. The NCCoE, in collaboration with members of the business community and vendors of 54 
cybersecurity solutions, has built an example solution to address these data integrity challenges. 55 

https://www.nccoe.nist.gov/
https://www.nist.gov/
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Multiple systems need to work together to identify and protect an organization’s assets against the 56 
threat of corruption, modification, and destruction. This project explores methods to effectively identify 57 
assets (devices, data, and applications) that may become targets of data integrity attacks, as well as the 58 
vulnerabilities in the organization’s system that facilitate these attacks. It also explores methods to 59 
protect these assets against data integrity attacks using backups, secure storage, integrity checking 60 
mechanisms, audit logs, vulnerability management, maintenance, and other potential solutions 61 

KEYWORDS 62 

attack vector; asset awareness; data integrity; data protection; malicious actor; malware; ransomware. 63 
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1 Introduction 226 

The following volumes of this guide show information technology (IT) professionals and security 227 
engineers how we implemented this example solution. We cover all of the products employed in this 228 
reference design. We do not re-create the product manufacturers’ documentation, which is presumed 229 
to be widely available. Rather, these volumes show how we incorporated the products together in our 230 
environment. 231 

Note: These are not comprehensive tutorials. There are many possible service and security 232 
configurations for these products that are out of scope for this reference design. 233 

1.1 How to Use this Guide  234 

This National Institute of Standards and Technology (NIST) Cybersecurity Practice Guide demonstrates a 235 
standards-based reference design and provides users with the information they need to replicate the 236 
data integrity identify-and protect-solution. This reference design is modular and can be deployed in 237 
whole or in part. 238 

This guide contains three volumes: 239 

 NIST SP 1800-25A: Executive Summary 240 

 NIST SP 1800-25B: Approach, Architecture, and Security Characteristics – what we built and why 241 

 NIST SP 1800-25C: How-To Guides – instructions for building the example solution (you are 242 
here) 243 

Depending on your role in your organization, you might use this guide in different ways: 244 

Business decision makers, including chief security and technology officers, will be interested in the 245 
Executive Summary (NIST SP 1800-25A), which describes the following topics: 246 

 challenges that enterprises face in identifying assets and protecting them from data integrity 247 
events 248 

 example solution built at the NCCoE 249 

 benefits of adopting the example solution 250 

Technology or security program managers who are concerned with how to identify, understand, assess, 251 
and mitigate risk will be interested in NIST SP 1800-25B, which describes what we did and why. The 252 
following sections will be of particular interest: 253 
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 Section 3.4.1, Assessing Risk Posture, provides a description of the risk analysis we performed. 254 

 Section 3.4.2, Security Control Map, maps the security characteristics of this example solution 255 
to cybersecurity standards and best practices. 256 

You might share the Executive Summary, NIST SP 1800-25A, with your leadership team members to help 257 
them understand the importance of adopting standards-based data integrity solutions. 258 

IT professionals who want to implement an approach like this will find the whole practice guide useful. 259 
You can use this How-To portion of the guide, NIST SP 1800-25C, to replicate all or parts of the build 260 
created in our lab. This How-To portion of the guide provides specific product installation, configuration, 261 
and integration instructions for implementing the example solution. We do not recreate the product 262 
manufacturers’ documentation, which is generally widely available. Rather, we show how we 263 
incorporated the products together in our environment to create an example solution. 264 

This guide assumes that IT professionals have experience implementing security products within the 265 
enterprise. While we have used a suite of commercial products to address this challenge, this guide 266 
does not endorse these particular products. Your organization can adopt this solution or one that 267 
adheres to these guidelines in whole, or you can use this guide as a starting point for tailoring and 268 
implementing parts of a data integrity identify-and-protect solution. Your organization’s security experts 269 
should identify the products that will best integrate with your existing tools and IT system 270 
infrastructure. We hope that you will seek products that are congruent with applicable standards and 271 
best practices. Section 3.5 of Volume B, Technologies, lists the products we used and maps them to the 272 
cybersecurity controls provided by this reference solution. 273 

A NIST Cybersecurity Practice Guide does not describe “the” solution, but a possible solution. This is a 274 
draft guide. We seek feedback on its contents and welcome your input. Comments, suggestions, and 275 
success stories will improve subsequent versions of this guide. Please contribute your thoughts to ds-276 
nccoe@nist.gov.  277 

1.2 Build Overview 278 

The National Cybersecurity Center of Excellence (NCCoE) built a hybrid virtual-physical laboratory 279 
environment to explore methods to effectively identify assets and protect them against a data 280 
corruption event in various IT enterprise environments. The NCCoE also explored identifying 281 
vulnerabilities in advance of an incident. The servers in the virtual environment were built to the 282 
hardware specifications of their specific software components. 283 

mailto:ds-nccoe@nist.gov
mailto:ds-nccoe@nist.gov
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The NCCoE worked with members of the Data Integrity Community of Interest to develop a diverse but 284 
noncomprehensive set of use case scenarios against which to test the reference implementation. These 285 
are detailed in Volume B, Section 5.2. For a detailed description of our architecture, see Volume B, 286 
Section 4. 287 

Typographic Conventions 288 

The following table presents typographic conventions used in this volume. 289 

Typeface/Symbol Meaning Example 

Italics file names and pathnames; 
references to documents 
that are not hyperlinks; new 
terms; and placeholders 

For language use and style guidance, 
see the NCCoE Style Guide. 

Bold names of menus, options, 
command buttons, and 
fields 

Choose File > Edit. 

Monospace command-line input, on-
screen computer output, 
sample code examples, and 
status codes 

mkdir 

Monospace Bold command-line user input 
contrasted with computer 
output 

service sshd start 

blue text link to other parts of the 
document, a web URL, or an 
email address 

All publications from NIST’s NCCoE 
are available at 
https://nccoe.nist.gov. 

2 Product Installation Guides 290 

This section of the practice guide contains detailed instructions for installing and configuring all of the 291 
products used to build an instance of the example solution. 292 

http://nccoe.nist.gov/
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2.1 Active Directory and Domain Name System (DNS Server) 293 

As part of our enterprise emulation, we included an Active Directory server that doubles as a DNS 294 
server. This section covers the installation and configuration process used to set up Active Directory and 295 
DNS on a Windows Server 2012 R2 machine. 296 

2.1.1 Installing Features 297 

1. Open Server Manager.  298 

 

2. Click the link Add roles and features. 299 
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3. Click Next.  300 
4. Select Role-based or feature-based installation. 301 
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5. Click Next.  302 
6. Select Select a server from the server pool. 303 
7. Select the intended Active Directory server. 304 
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8. Click Next.  305 
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9. Check the box next to Active Directory Domain Services. 306 
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10. Click Add Features. 307 
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11. Click Next. 308 
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12. Click Next. 309 
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13. Click Next. 310 
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14. Click Install. 311 
15. Wait for the installation to complete. 312 
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16. Click Close. 313 

 
17. Click Promote this server to a domain controller. 314 
18. Select Add a new forest. 315 
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19. Enter a Root domain name.  316 

 
20. Click Next. 317 
21. Select Windows Server 2012 R2 for Forest functional level and Domain functional level. 318 
22. Check the box next to Domain Name System (DNS) server. 319 
23. Enter a password. 320 
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24. Click Next. 321 

 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 17 

25. Click Next. 322 
26. Verify the domain name. 323 

 
27. Click Next. 324 
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28. Click Next. 325 
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29. Click Next. 326 

 
30. Click Install. 327 
31. Wait for the installation to complete. 328 
32. The server automatically reboots. 329 

2.1.2 Creating a Certificate Authority 330 

1. Open Server Manager. 331 
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2. Click Add roles and features. 332 

 
3. Click Next. 333 
4. Select Role-based or feature-based installation. 334 
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5. Click Next. 335 
6. Select Select a server from the server pool. 336 
7. Select the intended Active Directory server. 337 
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8. Click Next. 338 

 
9. Check the box next to Active Directory Certificate Services. 339 
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10. Click Add Features. 340 

 
11. Click Next. 341 
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12. Click Next. 342 

 
13. Click Next. 343 
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14. Check the box next to Certification Authority. 344 

 
15. Click Next. 345 
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16. Click Install. 346 
17. Wait for the installation to complete. 347 

 
18. Click Close. 348 
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19. Click Configure Active Directory Certificate Services on the destination server. 349 

 

20. Click Next. 350 
21. Check the box next to Certification Authority. 351 
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22. Click Next. 352 
23. Select Enterprise CA. 353 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 29 

 

24. Click Next. 354 
25. Select Root CA. 355 

 
26. Click Next. 356 
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27. Select Create a new private key. 357 

 
28. Click Next. 358 
29. Select RSA#Microsoft Software Key Storage Provider. 359 
30. Set the Key length to 2048. 360 
31. Select SHA512 from the list. 361 
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32. Click Next. 362 
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33. Click Next. 363 
34. Set the time to 5 years. 364 

 
35. Click Next. 365 
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36. Click Next. 366 

 
37. Click Configure. 367 
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38. Click Close. 368 

2.1.3 Configure Account to Add Computers to Domain 369 

1. Open the Start menu. 370 
2. Enter dsa.msc and run the program. 371 
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3. Right-click on Users in the left panel. 372 

 
4. Click Delegate Control. 373 
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5. Click Next. 374 

 

6. Click Add to select users or groups. 375 
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7. Add users or groups. 376 

 
8. Click OK. 377 

 

9. Click Next. 378 
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10. Choose Create a custom task to delegate. 379 

 

11. Click Next. 380 
12. Choose Only the following objects in the folder. 381 
13. Check the box next to Computer objects. 382 
14. Check the box next to Create selected objects in this folder. 383 
15. Check the box next to Delete selected objects in this folder. 384 
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16. Click Next. 385 
17. Check the boxes next to Reset password, Read and write account restrictions, Validated write 386 

to DNS host name, and Validated write to service principal name. 387 
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18. Click Next. 388 

 
19. Click Finish. 389 
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2.1.4 Adding Machines to the Domain 390 

1. Right-click the network icon in the task bar on a computer that you wish to add to the domain. 391 
2. Click Open Network and Sharing Center. 392 

 
3. Click the name of the internet adapter. 393 
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4. Click Properties. 394 

 
5. Double-click Internet Protocol Version 4 (TCP/IPv4). 395 
6. Select Use the following DNS server addresses. 396 
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7. Enter the IP address of the DNS server. 397 

 398 
8. Click OK. 399 
9. Click OK. 400 

 401 
10. Click Close. 402 
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11. Navigate to This PC. 403 

 404 
12. Right-click in the window and click Properties. 405 

 406 
13. Click Change Settings. 407 
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 408 
14. Click Change. 409 
15. Select Domain. 410 
16. Enter the domain. 411 

 412 
17. Click OK. 413 
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18. Enter the username and password of an account with privileges to add computers to the 414 
domain. 415 

 416 
19. Click OK. 417 

 418 
20. Click OK when prompted to restart the computer. 419 

2.1.5 Configure Active Directory to Audit Account Activity 420 

1. Open the Start menu. 421 
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 422 
2. Enter “Local Security Policy” in the search bar and open the program. 423 
3. Navigate to Local Policies > Audit Policy. 424 
4. Right-click Audit account management. 425 

 426 
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5. Click Properties. 427 
6. Check the boxes next to Success and Failure. 428 

 429 
7. Click OK.  430 

2.1.6 Configure Reverse Lookup Zones 431 

1. Open DNS Manager by right-clicking the DNS server in Server Manager. 432 
2. Click Reverse Lookup Zones. 433 
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 434 
3. Click Action > New Zone. 435 

 436 

4. Click Next. 437 
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 438 
5. Click Next. 439 

 440 
6. Click Next. 441 
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 442 
7. Click Next. 443 
8. Enter the first three parts of the IP address of the Active Directory (AD)/DNS server (for 444 

example, 192.168.1). 445 

 446 
9. Click Next. 447 
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 448 
10. Click Next. 449 

 450 
11. Click Finish. 451 
12. Click on the newly created reverse lookup zone. 452 
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 453 

13. Right-click in the window and select New Pointer (PTR)…. 454 
14. Enter the IP address of the AD/DNS server. 455 
15. Enter the hostname of the AD/DNS server. 456 

 457 

16. Click OK. 458 
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 459 

2.2 Microsoft Exchange Server 460 

As part of our enterprise emulation, we include a Microsoft Exchange server. This section covers the 461 
installation and configuration process used to set up Microsoft Exchange on a Windows Server 2012 R2 462 
machine. 463 

2.2.1 Install Microsoft Exchange 464 

1. Run Exchange2016-x64.exe. 465 
2. Choose the directory for the extracted files. 466 

 467 
3. Click OK. 468 
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 469 

4. Enter the directory and run setup.exe.  470 
5. Select Connect to the Internet and check for updates. 471 
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 472 
6. Click Next. 473 
7. Wait for the check to finish. 474 
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 475 
8. Click Next. 476 
9. Wait for the copying to finish. 477 
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 478 
10. Click Next. 479 
11. Click I accept the terms in the license agreement. 480 
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 481 
12. Click Next.  482 
13. Click Use Recommended Settings. 483 
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 484 
14. Click Next.  485 
15. Check Mailbox role. 486 
16. Check Automatically install Windows Server roles and features that are required to install 487 

Exchange Server. 488 
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 489 
17. Click Next. 490 
18. Specify the installation path for MS Exchange. 491 
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 492 
19. Click Next.  493 
20. Specify the name for the Exchange organization, e.g., DI. 494 
21. Decide whether to apply split permissions based on the needs of the enterprise. 495 
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 496 
22. Click Next.  497 
23. Select No. 498 
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 499 
24. Click Next.  500 
25. Install any prerequisites listed. 501 
26. If necessary, restart the server and rerun setup.exe, following through steps 3–22 again. 502 
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 503 
27. Click Install.  504 

2.3 Windows Server Hyper-V Role 505 

As part of our simulated enterprise, we include a Windows Hyper-V server. This section covers the 506 
instructions for installing the Windows Server Hyper-V Role on a Windows Server 2012 R2 machine. 507 

The instructions for enabling the Windows Server Hyper-V Role are retrieved from 508 
https://technet.microsoft.com/en-us/library/hh846766(v=ws.11).aspx and are replicated below for 509 
preservation and ease of use. 510 

2.3.1 Production Installation 511 

1. In Server Manager on the Manage menu, click Add Roles and Features. 512 

https://technet.microsoft.com/en-us/library/hh846766(v=ws.11).aspx
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 513 
2. On the Before you begin page, verify that your destination server and network environment are 514 

prepared for the role and feature you want to install.  515 

 516 
3. Click Next. 517 
4. On the Select installation type page, select Role-based or feature-based installation. 518 
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 519 
5. Click Next. 520 
6. On the Select destination server page, select a server from the server pool. 521 

 522 
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7. Click Next. 523 
8. On the Select server roles page, select Hyper-V. 524 
9. To add the tools that you use to create and manage virtual machines, click Add Features. 525 

 526 
10. Click Next. 527 
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 528 
11. Click Next. 529 
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 530 
12. Click Next. 531 
13. On the Create Virtual Switches page, select the appropriate options. 532 
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 533 
14. Click Next.  534 
15. On the Virtual Machine Migration page, select the appropriate options. 535 

 536 
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16. Click Next. 537 
17. On the Default Stores page, select the appropriate options. 538 

 539 
18. Click Next.  540 
19. On the Confirm installation selections page, select Restart the destination server automati-541 

cally if required. 542 
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 543 

20. Click Install. 544 
21. When installation is finished, verify that Hyper-V installed correctly. Open the All Servers page 545 

in Server Manager, and select a server on which you installed Hyper-V. Check the Roles and 546 
Features tile on the page for the selected server. 547 

2.4 MS SQL Server 548 

As part of both our enterprise emulation and data integrity solution, we include a Microsoft SQL Server. 549 
This section covers the installation and configuration process used to set up Microsoft SQL Server on a 550 
Windows Server 2012 R2 machine. 551 

2.4.1 Install and Configure MS SQL 552 

1. Acquire SQL Server 2014 installation media. 553 
2. Locate the installation media in the machine and click on SQL2014_x64_ENU to launch SQL 554 

Server Installation Center. 555 
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 556 

3. On the left menu, select Installation. 557 

 558 
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4. Select New SQL Server stand-alone installation or add features to an existing installation. This 559 
will launch the SQL Server 2014 setup. 560 

5. In the Product Key section, enter your product key. 561 

 562 

6. Click Next. 563 
7. In the License Terms section, read and click I accept the license terms. 564 
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 565 

8. Click Next.  566 
9. In the Install Rules section, note and resolve any further conflicts.  567 
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 568 

10. Click Next. 569 
11. In the Setup Role section, select SQL Server Feature Installation.  570 
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 571 

12. Click Next. 572 
13. In the Feature Selection section, select the following options: 573 

a. Database Engine Services 574 
b. Client Tools Connectivity 575 
c. Client Tools Backwards Compatibility 576 
d. Client Tools SDK 577 
e. Management Tools – Basic 578 
f. Management Tools – Complete 579 
g. SQL Client Connectivity SDK 580 
h. Any other desired features 581 
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 582 

14. Click Next. 583 
15. In the Instance Configuration section, select Default instance. 584 
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 585 

16. Click Next. 586 

 587 
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17. In the Server Configuration section, click Next. 588 
18. In the Database Engine Configuration section, make sure Mixed Mode is selected. 589 
19. Add all desired users as Administrators under Specify SQL Server Administrators by pressing 590 

Add Current User. 591 
a. For Domain accounts, simply type in $DOMAINNAME\$USERNAME into Enter the 592 

object names to select text box. 593 
b. Click OK. 594 
c. For local computer accounts, click on locations and select the computer’s name. 595 
d. Click OK. 596 
e. Type the username into the Enter the object names to select text box. 597 
f. Once you are finished adding users, click Next. 598 

 599 

20. In the Ready to install section, verify the installation and click Install. 600 
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 601 

21. Wait for the installation to finish.  602 

 603 
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22. Click Close. 604 

2.4.2 Open Port on Firewall 605 

1. Open Windows Firewall with Advanced Security. 606 

 607 
2. Click Inbound Rules. 608 
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 609 
3. Click New Rule. 610 
4. Select Port. 611 
5. Click Next.  612 
6. Select TCP and Specific local ports. 613 
7. Type 1433 into the text field. 614 
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 615 
8. Click Next. 616 
9. Select Allow the connection. 617 
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 618 
10. Click Next. 619 
11. Select all applicable locations. 620 
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 621 
12. Click Next.  622 
13. Name the rule Allow SQL Access. 623 
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 624 
14. Click Finish. 625 

2.4.3 Add a New Login to the Database 626 

1. Open SQL Server Management Studio. 627 
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 628 
2. Click Connect to connect to the database. 629 
3. In the Object Explorer window, expand the Security folder. 630 

 631 
4. Right-click on the Logins folder and click New Login…. 632 
5. Input the desired user. 633 
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 634 
6. Click OK. 635 

2.5 Microsoft IIS Server 636 

As part of our enterprise emulation, we include a Microsoft IIS server. This section covers the 637 
installation and configuration process used to set up Microsoft Exchange on a Windows Server 2012 R2 638 
machine. This was conducted on the same machine as in Section 2.4.  639 

2.5.1 Install IIS 640 

1. Open Server Manager. 641 
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 642 
2. Click Add Roles and Features.643 

 644 

3. Click Next. 645 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 92 

4. Select Role-based or feature-based installation.646 

 647 
5. Click Next. 648 
6. Select MSSQL (or the correct Windows Server name) from the list.649 

 650 
7. Click Next. 651 
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 652 

8. Check the box next to Web Server (IIS).653 

 654 
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9. Click Add Features.655 

 656 
10. Click Next. 657 
11. Ensure that all desired features are selected.658 

 659 
12. Click Next. 660 
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 661 

13. Click Next.  662 
14. Ensure that Default Document, Directory Browsing, HTTP Errors, Static Content, HTTP Logging, 663 

and any other desired Role services are selected.664 

 665 
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15. Click Next. 666 

 667 

16. Click Install. 668 

 669 
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17. Wait for the installation to complete.670 

 671 
18. Click Close. 672 
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2.5.2 IIS Configuration 673 

1. Open Windows Explorer and click This PC.674 

 675 
2. Right-click and select Create Folder. 676 
3. Name the folder www.677 

 678 
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4. Open the Internet Information Services (IIS) Manager.679 

 680 
5. Click the arrow next to MSSQL (or the chosen name of the server). 681 
6. Click Sites. 682 

 683 

7. Click Add Website…. 684 
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 685 
8. Enter the desired site name. 686 

 687 
9. Click … under Physical path:. 688 
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 689 

10. Locate and select the folder created in step 3.690 

 691 

11. Click OK.  692 
12. Set Type to http and Port to 80. 693 
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13. Ensure that the IP address and Host name fields are filled in with the correct information for 694 
the machine. 695 

14. Ensure that Start Website immediately is selected.696 

 697 
15. Click OK. 698 

 699 

2.6 GreenTec WORMdisks 700 

See the Installation of GreenTec Command Line Utilities document, which should accompany the 701 
installation disk, for a detailed guide on how to install the GreenTec command line utilities. 702 
Furthermore, refer to the GT_WinStatus User Guide, which should also accompany the installation disk, 703 
for instructions on how to effectively use GreenTec WORMdisks to preserve data. Read these 704 
instructions carefully, as locking GreenTec WORMdisks can result in making some or all of the disk or 705 
the entire disk unusable. Having portions of the disk or the entire disk permanently locked is sometimes 706 
desirable, but it is dependent on the needs of your organization, e.g., if you want to store backup 707 
information or logs securely.  708 

The GT_WinStatus User Guide provides instructions for locking and temporarily locking disk sectors. In 709 
this practice guide, we will not include instructions on when to lock GreenTec WORMdisks. However, we 710 
will provide instructions detailing how to save data to these disks and various commands used in 711 
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manipulating the disks. Below, find descriptions of some commands useful for automation of GreenTec 712 
WORMdisks. Actual automation of these disks will vary per organization. 713 

2.6.1 Format GreenTec WORMdisks 714 

To format GreenTec WORMdisks for use, the following command can be used. 715 

> gt_format.exe <disk number> /parts:<number of parts> /label:<id> 716 

This command can be used to split a disk into a specified number of partitions, with each partition being 717 
labeled according to the label id specified. 718 

For example, this command will split drive 1 into four parts, labeled DI001, DI002, DI003, and DI004: 719 

> gt_format.exe 1 /parts:4 /label:DI 720 

Formatting drive 1 partition 1 file system NTFS label "DI001" 721 

Format successful 722 

Formatting drive 1 partition 2 file system NTFS label "DI002" 723 

Format successful 724 

Formatting drive 1 partition 3 file system NTFS label "DI003" 725 

Format successful 726 

Formatting drive 1 partition 4 file system NTFS label "DI004" 727 

Format successful 728 

2.6.2 Obtain Status Information About GreenTec WORMdisks 729 

To verify information about GreenTec WORMdisks, use the following command. 730 

> wvlist.exe <drive number> 731 

This command can be used to display basic information about a drive, such as the amount of space of 732 
each partition, whether it is a WORMdisk, whether they have been locked, and what drive letter to 733 
which they are mapped.  734 

For example, this command will list the characteristics of drive 1. 735 
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> wvlist.exe 1 736 

  WVLIST: List WORM Volume (WDV) Status on Physical WORMdisks(tm). 737 

    Copyright (C) 2015 GreenTec-USA, Inc. All rights reserved. 738 

          Drive#=1   Type=ATA    F/W=GT5G   Size=500{GB) 739 

              > IS WORM          > IS *NOT* Finalized 740 

             ****  WORMdisk Volume (WDV) Info  **** 741 
             WDV #   TB  ENFORCED  GREENTEC  TLOCKED 742 
             <---> <---> <------>  <------>  <-----> 743 
              001  0.125       NO       YES       NO G:\ 744 
              002  0.125       NO       YES       NO H:\ 745 
              003  0.125       NO       YES       NO I:\ 746 
              004  0.125       NO       YES       NO J:\ 747 

2.6.3 Map GreenTec WORMdisks to Drive Letters 748 

1. To unmap a partition from a drive letter, use the following command: 749 

> wvmap.exe <drive letter>: 750 

For example,  751 

> wvmap.exe H: 752 

will unmap H:, making it available for mapping to another partition. 753 

2. To map a partition to a drive letter, use the following command: 754 

> wvmap.exe <drive letter>: <drive number>.<partition number> 755 

For example,  756 

> wvmap.exe H: 1.2 757 

will map the second partition of drive 1 to H:, making files available through accessing that drive 758 
letter. 759 

3. To map the next partition to a drive letter, use the following command: 760 

> wvnext.exe <drive letter>: 761 
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For example, if H: is mapped to partition 2 of drive 1 (1.2) 762 

> wvnext.exe H: 763 

will attempt to map H: to partition 3 of drive 1 (1.3). 764 

2.6.4 Activate Write Protection in GreenTec WORMdisks 765 

1. Running GT_WinStatus.exe will open the Graphical User Interface (GUI), which displays various 766 
information such as drive mappings, partitions, total space, and space used, as well as a range 767 
of other options.  768 

 769 

2. More columns can be added by right-clicking anywhere in the Active window, opening the 770 
Settings window. 771 
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 772 

3. In the Settings window, User Field 1 and User Field 2 are for any metadata to be stored for a 773 
drive. Pre: runs a script prior to finalizing a drive, and Post: runs a script after finalizing a drive.  774 

4. Also, from the Settings window, right-clicking on Critical Threshold or Warning Threshold will 775 
allow the user to set up alert preferences for drives that are nearly full (at a configurable 776 
percent value). 777 
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 778 

5. To display the GUI with options to lock and enforce locks on drives, the following command 779 
must be used to start the GUI:  780 

> GT_WinStatus.exe /tlock /enf 781 
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6. This will add columns called TLock and Enforce (as well as the ability to use the Finalize 782 
column).783 

 784 
7. The TLock column temporarily locks/unlocks a partition of the drive. This is useful to prevent 785 

modification during times when modification should be disallowed. 786 

 787 

8. The Enforce column is a permanent incremental lock. This means that it permanently prevents 788 
modification for the selected volume of a drive as well as all volumes that come before that 789 
volume on the drive. Once these sections are enforced, they cannot be written to ever again. 790 
This functionality is particularly useful in protecting data or backups that must never be 791 
modified, but as the enforce function is permanent, it must be used carefully. 792 

9. The Finalize column permanently locks the entire drive. This is useful when a drive is full and no 793 
longer needs to be written to. Data can still be read and copied from this drive to other places, 794 
but no write actions will be possible after this is used, so it also must be used carefully. 795 

Important: The following functions in steps 8 and 9 will permanently lock portions of the 
drive, making them read-only. 

The Enforce function permanently locks all volumes up to the enforced volume. 

The Finalize function permanently locks the entire drive. 
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2.7 CryptoniteNXT 796 

See the CryptoniteNXT 2.6.2 Unified Installation Guide, which should accompany the device for a 797 
detailed guide on how to install CryptoniteNXT on the provided device. 798 

The CryptoniteNXT 2.6.2 Unified Installation Guide provides a full installation on both the 799 
CryptoniteNXT device and the management workstation. When finished, it should be possible to log in 800 
on the management workstation and interact with the CryptoniteNXT ACC GUI. Instructions are 801 
provided below for performing various useful functions, including adding new devices/users, as well as 802 
creating policy, but specific recommendations for policy are not provided, as those will be specific to the 803 
organization. Some integrations with other security products used in this guide will be provided, as 804 
exceptions for those products in CryptoniteNXT are often necessary for their functionality. 805 

2.7.1 Configure Cryptonite NXT  806 

2.7.1.1 Verify a New Device 807 

1. Open the CryptoniteNXT ACC GUI application. 808 

 809 
2. Click OK.  810 
3. Enter the password for the account created during the installation. 
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4. Click OK. 811 

 812 
5. Click Enable Editing at the top of the application.  813 
6. Click the Endpoints tab. 814 

 815 
7. Click the Unverified tab. Any new devices connected to the network should appear here, if 816 

configured to use Dynamic Host Configuration Protocol (DHCP). 817 
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 818 
8. Click the machine to verify. 819 
9. Enter a name.  820 
10. Enter a description of the machine. 821 
11. Select an owner if desired. If not selected, the owner will be the first user to log in to 822 

CryptoniteNXT on the machine. 823 
12. Leave Inbound gateway: as NOT SET to have it choose a default gateway. 824 
13. Leave External ingress (inbound) IPv4 Address: blank. 825 
14. Ensure the box next to Also use external ingress IP, if set, for egress (outbound) traffic is 826 

checked. 827 
15. Set Status: to Verified. 828 

 829 
16. Click Yes.  830 
17. Click Save. 831 
18. The machine should now appear in the Verified tab.  832 
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2.7.1.2 Create a New User 833 

1. Go to the Policy tab. 834 

 835 
2. Right-click in the Users window and select New User. 836 
3. Enter the username, and uncheck the box next to Auto-generate and distribute first user TOTP 837 

key to the portal. 838 
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 839 

4. Click OK. 840 

 841 
5. The new user should show up in the Users window. Click the key icon for the newly created user 842 

under Auth Type. 843 
6. Decide on an authentication method for the user. (Note: It is not recommended to use 844 

passwords, but as this authentication decision depends on the needs of the organization, 845 
passwords are used for the purposes of this practice guide.) 846 
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 847 
7. Click Save.   848 

 849 
8. On the client machine, the user should be required to sign in on the CryptoniteNXT portal to 850 

access the internet. Authenticate using the newly created user. 851 
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2.7.1.3 Create a New Policy 852 

Creating policy in CryptoniteNXT essentially requires specifying allowed types of traffic. To do this, 853 
source groups and destination groups are created.  854 

1. To create a source group, right-click in the Source Groups window and select New Source 855 
Group. 856 

2. Enter the name of the group.  857 

 858 

3. Click OK. 859 
4. The newly created group should appear in the Source Groups window. 860 
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5. In the Endpoints window, click the arrow button under the Source Groups column for any 861 
machines to be added to this Source Group. 862 

6. Select the newly created group (or groups). 863 
7. Click the >> button to add the endpoint to this group.  864 

 865 
8. Click Save. 866 
9. The group should show under the Source Groups column for those endpoints. 867 
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 868 

Destination groups are used to govern the allowed destinations of endpoints within certain source 869 
groups. While destination groups can be created according to organizational property, this example 870 
uses an existing group, all-traffic.  871 

1. To allow or prevent the use of ping, we add it to the all-traffic group. In the Access Control 872 
Policies window, right-click on the row labeled To: ‘all-traffic’ and select New Access 873 
Control Policy Entry. 874 

 875 
2. Click the arrow button under the Source Groups column. 876 
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3. Select the newly created source group. 877 
 878 

 879 
4. Click the >> button. 880 

 881 
5. Click Save. 882 
6. Select the Protocol. In this case, to prevent the machine from using ping, we choose ICMP.  883 
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 884 
7. Enter the port range that this traffic can operate on. 885 

 886 
8. Select INVISIBLE for the Action column. 887 
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 888 
9. This will prevent the members of this group from using ping. 889 
10. To allow the members of this group to use ping, delete this rule. Right-click the entry and 890 

select Delete Access Control Policy Entries. 891 

 892 
11. Add the newly created group to the existing policy entry by clicking the arrow for that entry 893 

under Source Groups.  894 
12. Select the newly created group. 895 
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 896 
13. Click the >> button. 897 

 898 
14. Click Save. 899 
15. Click Stop Editing when finished. 900 
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 901 
16. Now, the new machine should be allowed to use ping. With these policies it is possible to 902 

manage all traffic through the specification of groups, ports, and protocols. 903 

2.7.2 Integrate CryptoniteNXT with Active Directory 904 

In this section, devices listed in Active Directory will be imported into CryptoniteNXT. For this to be 905 
successful, the DNS server must have reverse lookup zones configured for the AD server. Please see 906 
Section 2.1.6 for setting up reverse lookup zones on the AD/DNS server. 907 

2.7.2.1 Generate a Keytab File 908 

1. Open Active Directory Users and Computers. 909 
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 910 

2. Right-click the Users folder in the left pane and select New > User. 911 
3. Enter a name for this user, such as nxtadmin. 912 

 913 
4. Click Next. 914 
5. Enter a password for this user, and set the password policy. 915 
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 916 
6. Click Next. 917 

 918 
7. Click Finish. 919 
8. Right-click the newly created user and select Add to a group…. 920 
9. Enter DnsAdmins. 921 
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 922 

10. Click OK. 923 
11. Right-click the Users folder in the left pane and select New > Group. 924 
12. Enter NXTAdmins as the group name. 925 

 926 

13. Click OK. 927 
14. Right-click the Users folder in the left pane and select New > Group. 928 
15. Enter NXTNodes as the group name. 929 
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 930 

16. Click OK. 931 
17. Click Computers in the left pane. 932 
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 933 

18. Right-click Computers in the left pane and select New > Computer. 934 
19. Enter the name of the acc server for CryptoniteNXT (Node A).  935 
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 936 

20. Click OK. 937 
21. Right-click the newly created computer and select Add to a group…. 938 
22. Enter NXTAdmins in the box labeled Enter the object names to select (examples):.  939 

 940 
23. Click OK. 941 
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 942 
24. Click OK. 943 
25. Open a new Administrator PowerShell window. 944 
26. Enter the following command, using the newly created user in the DnsAdmins group: 945 

> ktpass -princ DNS/<user>.<domain>@<DOMAIN> -mapuser 946 
<user>@<domain> -pass <user password> -out .\<keytab filename> 947 
-ptype krb5_nt_principal -crypto all 948 
 949 
For example: 950 
> ktpass -princ DNS/nxtadmin.di.ipdr@DI.IPDR -mapuser 951 
nxtadmin@di.idpr -pass password123 -out .\keytab.out -ptype 952 
krb5_nt_principal -crypto all 953 
 954 

27. This will produce a keytab file. Copy this file to the CryptoniteNXT Management 955 
workstation. 956 

2.7.2.2 Import Keytab File to ACC 957 

1. On the management workstation, open the CryptoniteNXT ACC GUI. 958 

 959 
2. Click OK. 960 
3. Enter the password configured during installation. 961 
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 962 
4. Click OK. 963 

 964 
5. Click Enable Editing. 965 
6. Click the Integration tab. 966 
7. Check the box next to Use Keytab file (for LDAP and/or DDNS):.  967 
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 968 
8. Click Select New Keytab. 969 

 970 
9. Click OK. 971 
10. Navigate to the keytab file. 972 

 973 

11. Click Choose.  974 
12. Click Save. 975 
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13. Under LDAP, enter the Domain name (such as DI.IPDR) and the Server name (such as ad-976 
dns). 977 

14. Check the box next to Enable Dynamic DNS:. 978 
15. Enter the fully qualified domain name of the DNS server (such as ad-dns.di.ipdr). 979 
16. Enter the Kerberos realm (such as DI.IPDR). 980 
17. Enter the domain suffix (such as di.ipdr). 981 

 982 

18. Click Save. 983 
19. Click the Policies tab. 984 

 985 
20. Right-click in the Access Control Policies Window and select New Destination Group. 986 
21. Enter kerberos. 987 
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 988 
22. Click OK. 989 
23. Select TCP under Action. 990 
24. Enter 53:53 under Port Range. 991 
25. Select VISIBLE under Action. 992 
26. Click the arrow under Source Groups. 993 
27. Select $NXT$Admins. 994 
28. Click the >> button. 995 

 996 

29. Click Save. 997 
30. Right-click the To: ‘kerberos’ destination group, and select New Access Control Policy 998 

Entry. 999 
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 1000 
31. Repeat steps 21–29, but replace 53:53 with 88:88.  1001 
32. In the Gateway Nodes window, click the arrow under Egress (Dest) Groups. 1002 
33. Select “kerberos”. 1003 
34. Click the >> button. 1004 

 1005 
35. Click Save. 1006 
36. In the Endpoints window, click the arrow under Source Groups associated with the 1007 

Administration Control Center (ACC).  1008 
37. Select $NXT$Admins. 1009 
38. Click the >> button. 1010 
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 1011 
39. Click Save.  1012 

 1013 
40. Return to the Integration tab. 1014 
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 1015 
41. Click Sync. 1016 

2.8 Backups 1017 

For this capability we use an integration of two open-source tools: Duplicati and FileZilla. FileZilla acts 1018 
as a File Transfer Protocol (FTP) (over TLS) server component, while Duplicati acts as an encrypted 1019 
backup client. This section details the installation and integration of both tools, as well as the process 1020 
for creating a backup schedule, but does not provide specific recommendations on backup frequency or 1021 
backup targets as those are specific to the organization. 1022 

2.8.1 FileZilla FTPS Server Setup 1023 

1. Run FileZilla_Server-0_9_60_2.exe. 1024 
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 1025 
2. Click I Agree. 1026 
3. Select Standard from the drop-down menu. 1027 

 1028 
4. Click Next. 1029 
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 1030 
5. Click Next. 1031 
6. Select Install as service, started with Windows (default) from the drop-down. 1032 
7. Specify a port (for the administrator interface to run on) if desired (the default is 14147). 1033 
8. Ensure the box next to Start Server after setup completes is checked. 1034 

 1035 

9. Click Next. 1036 
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 1037 
10. Click Install. 1038 

 1039 
11. Click Close. 1040 

2.8.2 FileZilla Configuration 1041 

1. When the administrator interface comes up, ensure that the port is correct and click Connect. 1042 
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2. Click Edit > Settings. 1043 

 1044 
3. Click FTP over TLS settings. 1045 

 1046 
4. Check the box next to Enable FTP over TLS support (FTPS). 1047 
5. Check the box next to Disallow plain unencrypted FTP. 1048 
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 1049 
6. Click Generate new certificate.  1050 

 1051 
7. Select 4096 bit for Key Size. 1052 
8. Enter the information for the certificate specific to your organization. 1053 
9. For the common name, enter the address of the server on which this is installed. 1054 
10. Click Browse and specify a file location for the certificate. 1055 
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 1056 

11. Click Generate certificate. (The file now contains both the private key and the certificate. These 1057 
can be separated, for ease of use, as long as the correct file locations are specified in the 1058 
settings.) 1059 

 1060 
12. Click OK. 1061 
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13. Enter a password for the key. 1062 
14. Ensure the box next to Force PROT P to encrypt file transfers when using FTP over TLS is 1063 

checked. 1064 
15. Ensure the box next to Require TLS session resumption on data connection when using PROT P 1065 

is checked. 1066 

 1067 
16. Click Passive mode settings. Check the box next to Use custom port range. (This is necessary in 1068 

cases of a local server behind Network Address Translation (NAT) or a firewall.) 1069 
17. Enter a range of ports for passive mode to use. Ensure that these ports are allowed through the 1070 

firewall. 1071 
18. Select Use the following IP. 1072 
19. Enter the server address. 1073 
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 1074 

20. Click OK. 1075 

2.8.3 Add a User to FileZilla 1076 

1. In the FileZilla administrator interface, click Edit > Users. 1077 

 1078 

2. Click Add. 1079 
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 1080 

3. Enter a name for the user. 1081 

 1082 

4. Click OK. 1083 
5. Check the box next to Password. 1084 
6. Enter a password for the user. 1085 

 1086 
7. Check the box next to Force TLS for user login. 1087 
8. Click Shared Folders. 1088 
9. Click Add, under Shared Folders. 1089 
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 1090 
10. Select a place for backups for this user to be stored. 1091 
11. Check the boxes next to Write and Append, under Files. 1092 
12. Check the box next to Create, under Directories. 1093 
13. Select this entry and click Set as home dir. 1094 

 1095 
14. Click OK. 1096 

2.8.4 Duplicati Client Installation (Windows) 1097 

1. On the client machine, run duplicati-2.0.3.3_beta_2018-04-02-x64.msi. 1098 
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 1099 
2. Click Next. 1100 
3. Check the box next to I accept the terms in the License Agreement. 1101 

 1102 
4. Click Next. 1103 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 148 

 1104 
5. Click Next. 1105 

 1106 
6. Click Install. 1107 
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 1108 
7. Click Finish. 1109 
8. Start Duplicati by going to localhost:8200. 1110 

2.8.5 Duplicati Client Installation (Ubuntu) 1111 

1. Install mono by using the following command: 1112 
 1113 
> sudo apt install mono-runtime 1114 
 1115 

2. Download the Duplicati package by running the following command: 1116 
 1117 
> wget 1118 
https://github.com/duplicati/duplicati/releases/download/v2.0.3.91119 
-2.0.3.9_canary_2018-06-30/duplicati_2.0.3.9-1_all.deb 1120 
 1121 

3. Install Duplicati by using the following command: 1122 
 1123 
> sudo dpkg -i duplicati_2.0.3.9-1_all.deb 1124 
 1125 

4. Run Duplicati as a service by running the following command: 1126 
 1127 
> sudo systemctl enable duplicati 1128 

 1129 
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2.8.6 Configure Duplicati 1130 

1. When it first starts, Duplicati will have a First run setup. 1131 

 1132 
2. Click Yes. 1133 
3. Check the box next to Password. 1134 

 1135 
4. Enter a password. 1136 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 151 

 1137 
5. Click OK. 1138 
6. On the home page, click Add backup. 1139 
7. Select Configure a new backup.  1140 

 1141 
8. Click Next. 1142 
9. Enter a name for the backup. 1143 
10. Select AES-256 encryption, built in from the drop-down menu. 1144 
11. Enter a password. 1145 
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 1146 
12. Click Next. 1147 
13. Select FTP for Storage Type. 1148 
14. Check the box next to Use SSL. 1149 
15. Enter the server name and port (default: 21) of the server running FileZilla. 1150 
16. Enter a path for the backup to be stored in (within the specified shared directory of the user). 1151 
17. Enter the username and password created for FileZilla. 1152 

 1153 
18. Click Test Connection (if the connection fails, ensure that the port is allowed in your server’s 1154 

firewall). 1155 
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19. If you receive an error about a certificate, you can go to Advanced Options, select accept-1156 
specified-ssl-hash, and enter the thumbprint from the server’s certificate. 1157 

 1158 
20. Click Next. 1159 
21. Select the folders on the local machine to be backed up to the server according to your 1160 

organization’s needs. 1161 

 1162 
22. Click Next. 1163 
23. Select a backup schedule according to your organization’s needs. 1164 
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 1165 

24. Click Next. 1166 
25. Select any other options according to your organization’s needs. 1167 

 1168 

26. Click Save. 1169 
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 1170 
27. When finished, you can choose to Run now to start a backup immediately.  1171 

2.9 Semperis Active Directory Forest Recovery 1172 

This section details the installation of Semperis Active Directory Forest Recovery (ADFR), a tool used 1173 
for backing up and restoring Active Directory forests. This installation requires both a copy of SQL Server 1174 
Express as well as the Semperis Wizard. See the Semperis ADFR v2.5 Technical Requirements 1175 
document for specifics on the requirements. For a Windows Server 2012 R2 installation, simply meet 1176 
the following requirements:  1177 

• .NET Framework Version 3.5 SP1 1178 
• .NET Framework Version 4.5.2 or later 1179 
• not joined to the Active Directory domain it is protecting 1180 
• SQL Express is not installed on the machine, but the installer SQLEXPR_x64_ENU.exe is 1181 

downloaded. 1182 

2.9.1 Install Semperis ADFR 1183 

1. Place the SQLEXPR_x64_ENU.exe installer in a directory called Setup, and ensure that the 1184 
Semperis Wizard is adjacent to the Setup folder (not inside it). 1185 
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 1186 
2. If prompted to restart the computer, do so. 1187 
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 1188 
3. Click I Agree. 1189 
4. Select Evaluation License. 1190 
5. Select Active Directory Forest Recovery. 1191 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 158 

 1192 
6. Click the > button. 1193 

 1194 
7. Click OK. 1195 
8. Wait for the installation to complete. 1196 
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 1197 
9. Click the > button. 1198 
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 1199 

10. Click Finish. 1200 
11. There should now be a shortcut on the desktop linking to the web console for Semperis ADFR. 1201 
12. On the login page, enter the full domain as well as the NetBIOS name. 1202 
13. Enter the username and password of an administrator on the domain. 1203 
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 1204 

14. Click Login. 1205 
15. Check the box next to any domain controllers that should be backed up. 1206 

 1207 
16. Click Run Action. 1208 
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17. Enter the password in the prompt. 1209 

 1210 
18. Click OK. 1211 

 1212 

19. Click Close. 1213 
20. After the installation finishes, click Login at the top of the page. 1214 
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21. Enter the login credentials for the domain. 1215 

 1216 
22. Click Login. 1217 
23. Create a recovery password. (Note: In the event of a restoration, Active Directory will 1218 

potentially be unavailable, so a separate password that is not domain-associated is needed here 1219 
for restorations.) 1220 
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 1221 
24. Set recovery questions for the password. 1222 
25. Click Set. 1223 

2.9.2 Create a Backup Schedule for the Domain Controller 1224 

1. Click the Backup Settings tab.  1225 
2. Enter a name for the rule.  1226 
3. Select the days and times that the domain controller should be backed up. 1227 
4. Enter the maximum number of backups that should be kept. (Note: The oldest backup will be 1228 

deleted upon creation of a new backup, which would exceed this maximum.) 1229 
5. Ensure that Encrypt and Rule enabled are both turned on. 1230 
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 1231 
6. Click Add Backup Group.  1232 

 1233 

7. Click Create new Backup Group. 1234 
8. Enter a name for the backup group. 1235 
9. Select the domain controllers to be part of the backup group. 1236 
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 1237 

10. Click OK. 1238 
11. Select the newly created backup group. 1239 

 1240 
12. Click OK. 1241 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 167 

 1242 
13. Click Create Rule. 1243 

2.9.3 Recover the Active Directory Forest from a Backup 1244 

1. Open the Semperis ADFR web console. 1245 
2. Select Recovery Panel from the drop-down. 1246 
3. Select the Domain that you wish to recover. 1247 
4. Enter the username and password. 1248 
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 1249 
5. Click Login.  1250 

 1251 
6. Select an action based on the recovery needs of the organization. In this example we select 1252 

Domain Controller Restore. 1253 
7. Provide the information for the restoration, namely the domain, the domain controller, and 1254 

which backup to use. 1255 
 1256 
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 1257 
8. Click Restore.  1258 

 1259 

9. Click Start Restore to begin the restoration process. 1260 
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 1261 
10. Click Next when the restoration finishes.  1262 

2.10  Semperis Directory Services Protector 1263 

This section details the installation of Semperis Directory Services Protector (DSP), a tool used for 1264 
monitoring Active Directory environments. This installation requires both a copy of SQL Server Express 1265 
as well as the Semperis Wizard. See the Semperis DS Protector v2.5 Technical Requirements document 1266 
for specifics on the requirements. For a Windows Server 2012 R2 installation, simply meet the following 1267 
requirements:  1268 

• .NET Framework Version 3.5 SP1 1269 
• .NET Framework Version 4.5.2 or later 1270 
• joined to the Active Directory domain it is protecting 1271 
• either the installer for SQL Express Advanced or connection information and credentials for a 1272 

full version of Microsoft SQL (MSSQL) 1273 

2.10.1  Configure Active Directory for Semperis DSP 1274 

1. Open Active Directory Users and Computers. 1275 
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 1276 
2. Right-click Users in the left pane and select New > User.  1277 
3. Enter the information for a new user for the DSP service.  1278 

 1279 
4. Click Next.  1280 
5. Enter a password twice for this user. 1281 
6. Set the password policy. 1282 
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 1283 
7. Click Next. 1284 
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 1285 
8. Click Finish. 1286 
9. Open Group Policy Management. 1287 
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 1288 
10. Right-click Domains > DI.IPDR > Domain Controllers > Default Domain Controllers Policy and 1289 

click Edit. 1290 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 175 

 1291 
11. Navigate to Computer Configuration > Policies > Windows Settings > Security Settings > 1292 

Advanced Audit Policy Configuration > Audit Policies > Account Management. 1293 
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 1294 

12. Edit the Audit User Account Management field by double-clicking it. 1295 
13. Check the box next to Configure the following audit events. 1296 
14. Check the box next to Success. 1297 
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 1298 
15. Click OK. 1299 
16. Go to Audit Policies > DS Access.  1300 
17. Double-click Audit Directory Service Changes. 1301 
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 1302 
18. Check the box next to Configure the following audit events. 1303 
19. Check the box next to Success. 1304 
20. Click OK. 1305 
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 1306 
21. Open Active Directory Users and Computers. 1307 
22. Ensure that View > Advanced Features is enabled. 1308 
23. Right-click the domain (for example, DI.IPDR) created earlier and click Properties. 1309 

 1310 
24. Click the Security tab. 1311 
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 1312 
25. Click Advanced. 1313 

 1314 
26. Click the Auditing tab. 1315 
27. Click Add. 1316 
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28. Enter Everyone. 1317 

 1318 
29. Click OK. 1319 

 1320 
30. Double-click Everyone. 1321 
31. Check the boxes next to Write all properties, Delete, Delete subtree, Modify permissions, 1322 

Modify owner, All validated writes, All extended rights, Create all child objects, Delete all 1323 
child objects. 1324 
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 1325 

32. Click OK. 1326 

 1327 
33. Click OK. 1328 
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2.10.2  Install Semperis DSP 1329 

1. If you are using a local SQL Express Advanced server, place the SQLEXPRADV_x64_ENU.exe 1330 
installer in a directory called Setup, and ensure that the Semperis Wizard is adjacent to the 1331 
Setup folder (not inside it). If an SQL Express Advanced server is not being used, no Setup folder 1332 
is required. 1333 

 1334 
2. If prompted to restart the computer, do so. 1335 
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 1336 

3. Click I Agree. 1337 
4. Select Evaluation License. 1338 
5. Select Active Directory State Management. 1339 
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 1340 
6. Click the > button. 1341 
7. Enter the username and password of the account created earlier.  1342 
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 1343 
8. Click the > button. 1344 

 1345 
9. Click OK. 1346 
10. Check the box next to Create the following group. 1347 
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 1348 
11. Click OK. 1349 

 1350 
12. Click the > button. 1351 
13. Select the appropriate database option, and enter any required information. 1352 
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 1353 
14. Click the > button. 1354 

 1355 
15. Click OK. 1356 
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 1357 

16. Click the > button after the installation completes. 1358 
17. There should now be a shortcut on the desktop linking to the web console for Semperis DS 1359 

Protector. 1360 
18. On the login page, enter the full domain as well as the NetBIOS name. 1361 
19. Enter the username and password of an administrator on the domain. 1362 
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 1363 
20. Click Login. 1364 
21. Check the box next to the domain controllers that should be monitored by DSP. 1365 

 1366 
22. Click Run Action. 1367 
23. Enter the password for the account. 1368 
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 1369 
24. Click OK. 1370 

 1371 
25. Click Close. 1372 
26. After the agent finishes deploying, click Login at the top of the page and log in. 1373 
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 1374 
27. Click Start Sync. 1375 
28. After this completes, click Settings at the top of the page. 1376 

 1377 
29. Click Audit. 1378 
30. Click Run. 1379 
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 1380 
31. Click Next. 1381 

 1382 
32. Click Next. 1383 
33. Check the boxes next to any Domain Controllers that should be monitored. 1384 
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 1385 
34. Click Run Action. 1386 
35. Enter the password. 1387 

 1388 
36. Click OK. 1389 
37. Wait for the deployment to finish. 1390 
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 1391 
38. Click Next. 1392 

 1393 
39. Click Finish. 1394 

2.11 Micro Focus ArcSight Enterprise Security Manager 1395 

Micro Focus ArcSight Enterprise Security Manager is primarily a log collection/analysis tool with 1396 
features for sorting, filtering, correlating, and reporting information from logs. It is adaptable to logs 1397 
generated by various systems, applications, and security solutions.  1398 
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This installation guide assumes a preconfigured CentOS 7 machine with Enterprise Security Manager 1399 
(ESM) already installed and licensed. This section covers the installation and configuration process used 1400 
to set up ArcSight agents on various machines, as well as some analysis and reporting capabilities. 1401 

Installation instructions are included for both Windows and UNIX machines, as well as for collecting 1402 
from multiple machines. Furthermore, integrations with other products in the build are included in later 1403 
sections. 1404 

2.11.1 Install the ArcSight Console 1405 

1. Run ArcSight-7.0.0.2436.1-Console-Win.exe. 1406 

 1407 
2. Click Next.  1408 
3. Check the box next to I accept the License Agreement. 1409 
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 1410 
4. Click Next. 1411 
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 1412 
5. Click Next. 1413 
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 1414 
6. Click Next. 1415 
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 1416 
7. Click Next. 1417 
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 1418 

8. Click Install. 1419 
9. Select No, I do not want to transfer the settings. 1420 
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 1421 
10. Click Next. 1422 
11. Select Run console in default mode. (This can be changed later according to your organization’s 1423 

compliance requirements.) 1424 

 1425 
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12. Click Next. 1426 

 1427 

13. Click Yes. 1428 
14. Select FIPS 140-2. 1429 

 1430 
15. Click Next. 1431 
16. Enter the hostname of the ESM server for Manager Host Name. 1432 
17. Enter the port that ESM is running on for Manager Port (default: 8443). 1433 
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 1434 
18. Click Next. 1435 
19. Select Use direct connection. 1436 

 1437 
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20. Click Next.  1438 

 1439 
21. Click Next.  1440 
22. Select your preferred browser.  1441 
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 1442 
23. Click Next. 1443 

 1444 
24. Click Next.  1445 
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25. Click Finish. 1446 

 1447 
26. Click Done. 1448 
27. Run ArcSight Console from the Start menu.  1449 
28. Enter the username and password.  1450 
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 1451 
29. Click Login. (If you are unable to connect, ensure that the hostname of the ESM server is 1452 

present in your DNS server.) 1453 
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 1454 
30. Click OK. 1455 

2.11.2  Install Individual ArcSight Windows Connectors 1456 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe. 1457 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 210 

 1458 
2. Click Next. 1459 
3. Enter C:\Program Files\ArcSightSmartConnectors\Windows. 1460 
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 1461 
4. Click Next.  1462 
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 1463 
5. Click Next. 1464 
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 1465 
6. Click Install. 1466 
7. Select Add a Connector. 1467 
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 1468 
8. Click Next. 1469 
9. Select Microsoft Windows Event Log–Native.  1470 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 215 

 1471 
10. Click Next. 1472 
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 1473 
11. Click Next. 1474 
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 1475 
12. Click Next.  1476 
13. Select ArcSight Manager (encrypted).  1477 
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 1478 
14. Click Next. 1479 
15. Enter the hostname, port, username, and password for the ArcSight ESM server.  1480 
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 1481 
16. Click Next. 1482 
17. Enter identifying details about the system (only Name is required). 1483 
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 1484 
18. Click Next.  1485 
19. Select Import the certificate to connector from destination. 1486 
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 1487 
20. Click Next.  1488 
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 1489 
21. Click Next.  1490 
22. Select Install as a service. 1491 
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 1492 
23. Click Next.  1493 
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 1494 
24. Click Next.  1495 
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 1496 
25. Click Next.  1497 
26. Select Exit. 1498 
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 1499 
27. Click Next.  1500 
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 1501 
28. Click Done.  1502 

2.11.3  Install Individual ArcSight Ubuntu Connectors 1503 

1. From the command line, run: 1504 
> sudo ./ArcSight-7.9.0.8084.0-Connector-Linux64.bin 1505 

2. Enter the password if prompted. 1506 
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 1507 
3. Click Next.  1508 
4. Enter /root/ArcSightSmartConnectors/Ubuntu. 1509 

 1510 
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5. Click Next.  1511 

 1512 

6. Click Next. 1513 

 1514 
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7. Click Install. 1515 
8. Select Add a Connector. 1516 

 1517 

9. Click Next.  1518 
10. Select Syslog File. 1519 
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 1520 

11. Click Next.  1521 
12. Enter /var/log/syslog for the File Absolute Path Name. 1522 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 232 

 1523 
13. Click Next.  1524 
14. Select ArcSight Manager (encrypted). 1525 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 233 

 1526 
15. Click Next.  1527 
16. Enter the hostname, port, username, and password for ArcSight ESM. 1528 
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 1529 
17. Click Next. 1530 
18. Enter identifying details about the system (only Name is required). 1531 
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 1532 
19. Click Next.  1533 
20. Select Import the certificate to connector from destination. 1534 
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 1535 
21. Click Next.  1536 
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 1537 
22. Click Next.  1538 
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 1539 
23. Click Next.  1540 
24. Select Exit. 1541 
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 1542 
25. Click Next.  1543 
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 1544 

26. Click Done.  1545 

2.11.4  Install a Connector Server for ESM on Windows 2012 R2 1546 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe. 1547 
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 1548 
2. Click Next. 1549 
3. Enter C:\Program Files\ArcSightSmartConnectors\Windows. 1550 

 1551 
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4. Click Next.  1552 

 1553 
5. Click Next. 1554 

 1555 
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6. Click Install. 1556 
7. Select Add a Connector. 1557 

 1558 
8. Click Next. 1559 
9. Select Microsoft Windows Event Log–Native.  1560 
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 1561 
10. Click Next. 1562 
11. Check the box next to Use Active Directory. 1563 
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 1564 

12. Click Next. 1565 
13. Enter information about your Active Directory server. (It is recommended to create a new 1566 

administrator account for ArcSight to use.) 1567 
14. Set Use Active Directory host results for to Replace Hosts. 1568 
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 1569 

15. Click Next.  1570 
16. Check the boxes under any event types that should be forwarded to this connector, for each 1571 

individual host, e.g., Security, System, Application. 1572 
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 1573 
17. Click Next. 1574 

 1575 
18. Click Next.  1576 
19. Select ArcSight Manager (encrypted).  1577 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 248 

 1578 
20. Click Next. 1579 
21. Enter the hostname, port, username, and password for the ArcSight ESM server.  1580 

 1581 
22. Click Next. 1582 
23. Enter identifying details about the system (only Name is required). 1583 
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 1584 
24. Click Next.  1585 
25. Select Import the certificate to connector from destination. 1586 

 1587 
26. Click Next.  1588 
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 1589 
27. Click Next.  1590 
28. Select Install as a service. 1591 

 1592 
29. Click Next.  1593 
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 1594 
30. Click Next.  1595 

 1596 
31. Click Next.  1597 
32. Select Exit. 1598 
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 1599 
33. Click Next.  1600 

 1601 
34. Click Done.  1602 
35. Note: Ensure that all machines selected do not block traffic from this device through their 1603 

firewalls.  1604 
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2.11.5  Install Preconfigured Filters for ArcSight 1605 

2.11.5.1  Install Activate Base 1606 

1. Go to the ArcSight Content Brain web application (https://arcsightcontentbrain.com/app/) and 1607 
log in. This page allows you to keep track of packages to be installed–what packages should be 1608 
installed depends on the needs of the organization, but the “Activate Base” is required for all 1609 
products.  1610 

 1611 
2. Click the Download link for the Activate Base. (Note: This package should be installed on the 1612 

ArcSight Console, not on the ESM.) 1613 
3. Copy the contents of the zip file to ARCSIGHT_HOME. The default for this is C:\arcsight\Con-1614 

sole\current, assuming a Windows Server. 1615 
4. In PowerShell, navigate to the ARCSIGHT_HOME directory (C:\arcsight\Console\current) and 1616 

run: 1617 
> .\ActivateBaseInstallAndUpdate2540.bat 1618 

https://arcsightcontentbrain.com/app/
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 1619 
5. Enter the hostname of the ArcSight machine, the port (default: 8443), and the username and 1620 

password used to connect to the ESM. 1621 
6. Delete Activate_Base_Updated_2.5.4.0.arb from the ARCSIGHT_HOME directory. 1622 
7. Log in to ArcSight Console.  1623 
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 1624 
8. Under Packages > Shared > All Packages > ArcSight Activate, right-click Activate Base Update 1625 

2.5.4.0, and select Delete Package.  1626 

2.11.5.2  Install Packages 1627 

Once the Activate Base is installed, packages can be installed to monitor for specific types of events. As 1628 
an example, find below instructions for the Malware Monitoring package. 1629 

1. Navigate to the ArcSight Content Brain web application. 1630 
2. Select the Level 1 box labeled Malware. 1631 

 1632 
3. In the Track Execution section, under Associated Packages, you can see the list of packages used 1633 

to address the challenge of Malware Monitoring. In this case, there is just one package, L1– 1634 
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Malware Monitoring–Indicators and Warnings. Click the link to be taken to a download page for 1635 
the package, and download it. (Note: This package should be installed on the ArcSight Console, 1636 
not on the ESM.) 1637 

4. Copy the contents of the zip file to ARCSIGHT_HOME. The default for this is C:\arcsight\Con-1638 
sole\current, assuming a Windows Server. 1639 

5. In PowerShell, navigate to the ARCSIGHT_HOME directory (C:\arcsight\Console\current) and 1640 
run: 1641 
> .\L1-Malware_Monitoring_1.1.0.1.bat 1642 

 1643 
6. Enter the hostname of the ArcSight machine, the port (default: 8443), and the username and 1644 

password used to connect to the ESM. 1645 

2.11.6  Apply Filters to a Channel 1646 

1. In the ArcSight Console, click File > New > Active Channel.  1647 
2. Enter a name for the channel. 1648 
3. Select a time frame.  1649 
4. For Filter, select one the filters that was imported from the packages you installed.  1650 
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 1651 
5. Click OK. All events that match the filter can be displayed in the newly created channel. Filters 1652 

from imported packages can be found under Filters > Shared > All Filters > ArcSight Activate > 1653 
Solutions. 1654 

2.12  Tripwire Enterprise 1655 

Notes: 1656 

This installation requires MSSQL to be installed on a remote server and configured according to the 1657 
instructions in the Tripwire Enterprise 8.6.2 Installation and Maintenance Guide. 1658 

2.12.1  Install Tripwire Enterprise 1659 

1. Ensure that you have an up-to-date version of Oracle Java. You must install both the Java 1660 
Runtime Environment (JRE) and the Java Cryptography Extension (JCE). 1661 

2. Download and run the JRE installer. 1662 
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 1663 
3. Click Install. 1664 
4. Download the JCE and extract the files. 1665 

 1666 
5. Copy the local_policy.jar and US_export_policy.jar files to /lib/security/Unlimited/ and 1667 

/lib/security/Limited in the Java installation directory. 1668 
6. Run install-server-windows-amd64. 1669 
7. Select the Java runtime that was just installed. 1670 

 1671 

8. Click OK. 1672 
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 1673 
9. Click Next.  1674 
10. Select I accept the agreement. 1675 

 1676 
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11. Click Next. 1677 

 1678 

12. Click Next. 1679 
13. The installer should automatically detect the hostname of the system on which Tripwire 1680 

Enterprise is being installed. If it does not, enter the hostname here. 1681 
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 1682 
14. Click Next.  1683 
15. Enter each port number to use for the HTTPS Web Services port, HTTP EMS Integration Port, 1684 

and Tripwire Enterprise RMI port. The RMI port is used for inbound communication from 1685 
Tripwire agents to the server, so ensure that it is allowed through the firewall. 1686 
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 1687 
16. Click Next.  1688 
17. Enter a passphrase to use. 1689 

 1690 
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18. Click Next.  1691 

 1692 

19. Click Next.  1693 
20. Check the box next to Install Real-time Monitoring.  1694 
21. Enter 1169 for Real-time Port. 1695 
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 1696 
22. Click Next.  1697 

 1698 
23. Click Next.  1699 
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24. Check the box next to Open a browser after clicking Finish to continue configuring Tripwire 1700 
Enterprise. 1701 

 1702 

25. Click Finish.  1703 
26. Once at the web address, enter the Services passphrase chosen earlier. 1704 

 1705 
27. Click Login. 1706 

 1707 
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28. Select Microsoft SQL Server for Remote Database Type. 1708 
29. Select SQL Server for Authentication Type. 1709 
30. Enter login details for the account created during the MSSQL setup. 1710 
31. Enter the hostname or IP of the database server. 1711 
32. Enter the port on which the database is operating. 1712 
33. Enter the name of the database to be used for Tripwire Enterprise. 1713 
34. Select the appropriate setting for SSL according to your organization’s needs. 1714 

 1715 
35. Click Test Database Login to ensure the connection is functional. 1716 

 1717 

36. Click Save Configuration and Restart Console.  1718 
37. After the reboot, enter a new administrator password. 1719 
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 1720 
38. Click Confirm and Continue. 1721 

 1722 
39. Click Configure Tripwire Enterprise. 1723 
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 1724 
40. Click Choose File and select the Tripwire Enterprise license file, which should be a .cert file. 1725 
41. Check the boxes next to Change Auditing and Policy Management. 1726 

 1727 
42. Select any available policies desired. 1728 

 1729 
43. Select all the operating systems that you wish to monitor with Tripwire Enterprise.  1730 

 1731 
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44. Set up a schedule for running checks and reports according to your organization’s needs. Leave 1732 
the box next to Enable Checks and Reports unchecked for now. 1733 

 1734 

45. Select Set up the email server at another time. 1735 

 1736 
46. Enter a username and password for a new administrator account for Tripwire Enterprise 1737 

Console. 1738 

 1739 

47. Click Preview Configuration. 1740 

 1741 
48. Click Apply Configuration. 1742 
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 1743 
49. Click Continue to Tripwire Enterprise when the installation finishes. 1744 

2.12.2  Install the Axon Bridge 1745 

1. Ensure that TCP traffic on port 5670 is allowed through the firewall. 1746 
2. Navigate to the Tripwire Enterprise Console installation directory to the /server/data/config 1747 

folder. Copy bridge_sample.properties to bridge.properties. 1748 
3. In the bridge.properties file, find the line that says: 1749 

#tw.cap.bridge.registrationPreSharedKey= 1750 
Remove the “#” character. After the “=” character, enter a password. The password has some 1751 
restrictions, so ensure that it meets the requirements in case the connection fails later. 1752 

4. Restart the TE console by running the following command from an administrative command 1753 
prompt, where <te_root> is the TE installation directory: 1754 

> <te_root>/server/bin/twserver restart 1755 

2.12.3  Install the Axon Agent (Windows) 1756 

1. Download the Axon Agent zip file from the Tripwire customer website 1757 
(https://tripwireinc.force.com/customers), under the Product Downloads tab. 1758 

2. Unzip the file.  1759 
3. To begin the installation, double-click the .msi file in the extracted folder. Note: No installation 1760 

wizard will appear; the installation happens automatically. 1761 

https://tripwireinc.force.com/customers
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4. After the Axon Agent is installed, navigate to C:\ProgramData\Tripwire\agent\config, and copy 1762 
twagent_sample.conf to twagent.conf. 1763 

 1764 
5. Open twagent.conf and find the line that says bridge.host. Remove the “#” character, and 1765 

enter the hostname or IP address of the Axon Bridge server. 1766 
6. In a file called registration_pre_shared_key, enter the value of the preshared key that was set 1767 

in the Axon Bridge.  1768 
7. Restart the Axon Agent Service by opening a command prompt and running the following 1769 

commands: 1770 
> net stop TripwireAxonAgent 1771 
> net start TripwireAxonAgent 1772 

 1773 

2.12.4  Install the Axon Agent (Linux) 1774 

1. Download the Axon Agent .tgz file from the Tripwire customer website 1775 
(https://tripwireinc.force.com/customers), under the Product Downloads tab. 1776 

2. To install the software, run the following commands: 1777 

https://tripwireinc.force.com/customers
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RHEL or CentOS: > rpm -ivh <installer_file> 1778 
Debian or Ubuntu: > dpkg -i <installer_file> 1779 

3. Navigate to /etc/tripwire/ and copy twagent_sample.conf to twagent.conf. 1780 
4. Open twagent.conf and find the line that says bridge.host. Remove the “#” character and 1781 

enter the hostname or IP address of the Axon Bridge server. 1782 
5. In a file called registration_pre_shared_key.txt, enter the value of the preshared key that was 1783 

set in the Axon Bridge.  1784 
6. Restart the Axon Agent Service by opening a command prompt and running the following 1785 

commands: 1786 
RHEL or CentOS: 1787 
> /sbin/service tripwire-axon-agent stop 1788 
> /sbin/service tripwire-axon-agent start 1789 
 1790 
Debian or Ubuntu:  1791 
> /usr/sbin/service tripwire-axon-agent stop 1792 
> /usr/sbin/service tripwire-axon-agent start 1793 

2.12.5  Configure Tripwire Enterprise 1794 

2.12.5.1  Terminology 1795 

Node: a monitored system, such as a file system, directory, network device, database, or virtual 1796 
infrastructure component 1797 

Element: a monitored object, which is a component or property of a node being audited by TE  1798 

Element Version: a record of an element’s state at specific points in time. Multiple element versions 1799 
create a historical archive of changes made to the element.  1800 

Rule: A rule identifies one or more elements to the TE Console. 1801 

Action: an object that initiates a response to either changes detected by TE or by failures generated 1802 
from policy tests  1803 

Task: a TE operation that runs on a scheduled or manual basis 1804 

TE Policy: a measurement of the degree to which elements comply with a policy  1805 
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Policy Test: a determination of whether elements comply with the requirements of a policy 1806 

Baseline: the act of creating an element that reflects the current state of a monitored object (also called 1807 
the current baseline). When a node’s baseline is promoted, TE saves the former baseline as a historic 1808 
baseline.  1809 

Version Check: a check on monitored objects/elements. It is a comparison of the current state of the 1810 
element against its already recorded baseline for changes. 1811 

2.12.5.2  Tags 1812 

In Tripwire Enterprise, tags can be used to label and target specific nodes. Tags are not required but 1813 
allow for targeting nodes more granularly than by the operating system. This section describes how to 1814 
create and assign tags. 1815 

1. Navigate to the TE Console in your browser.  1816 
2. Click Asset View.  1817 

 1818 
3. Click the Manage Tagging tab. 1819 
4. Enter the name of a tag set, or use one of the four existing ones (Location, Owner, Platform 1820 

Family, Primary Function). Click Add if adding your own tag set. 1821 

 1822 
5. Under the tag set to which you wish to add a tag, enter the name of the tag. 1823 
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 1824 

6. Click Add.  1825 
7. Navigate to Nodes > Asset View > Filter Assets. 1826 
8. Check the boxes next to the nodes to which you wish to add this tag. 1827 
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 1828 
9. Click Edit Tags. 1829 
10. Check the boxes next to any tags you wish to add to these nodes. 1830 

 1831 
11. Click Close.  1832 

2.12.5.3  Rules 1833 

This section describes how to create a rule. 1834 

1. Click Rules. 1835 
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 1836 
2. Select or create a rule group into which the new rule should be put.  1837 

 1838 
3. Click New Rule. 1839 
4. Select the type of rule. For monitoring Windows file systems, we choose Windows File System 1840 

Rule.  1841 
 1842 

 1843 
5. Click OK. 1844 
6. Enter a name and description for the rule. 1845 
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 1846 
7. Click Next. 1847 

 1848 
8. Click New Start Point. 1849 
9. For Path, enter a directory that represents the scope of the scan. It can be limited to the 1850 

documents folder or be wide enough to encompass all the files on a system. Note that the latter 1851 
will take much longer to scan. 1852 

10. Check the box next to Recurse directory if you also wish to scan all subfolders.  1853 
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 1854 
11. Click Next. 1855 
12. Select Windows Content and Permissions. 1856 

 1857 
13. Click Finish. 1858 
14. Click New Stop Point.  1859 
15. Enter the path of any folders or files that should not be included in the scan, and indicate 1860 

whether they should end the recursion. 1861 
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 1862 

16. Click Finish. 1863 
17. Click Next. 1864 
18. Click Next. 1865 
19. Click Finish. 1866 

2.12.5.4  Tasks 1867 

This section describes how to create a task on a schedule. These tasks can also be run manually if 1868 
necessary. 1869 

1. Click Tasks. 1870 

 1871 
2. Select a folder for a new task, or create one. 1872 
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 1873 
3. Click New Task. 1874 
4. Select Baseline Rule Task or Check Rule Task. (Note: Both are needed–baseline creates the 1875 

initial state of the monitored object, and check updates the state and reports any changes.) 1876 

 1877 
5. Click OK. 1878 
6. Enter a name and description for the task. 1879 
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 1880 
7. Click Next. 1881 
8. Select whether you want all baselines to be updated or to only create new baselines. 1882 

 1883 
9. Click Next. 1884 
10. Select the systems to be included in the task. You can use tags or select by operating system (or 1885 

other defaults). 1886 
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 1887 
11. Click Next. 1888 
12. Select the rule created earlier. 1889 

 1890 
13. Click Next. 1891 
14. Set the schedule of this task according to your organization’s needs. 1892 
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 1893 
15. Click Finish. 1894 

2.13  Tripwire Log Center 1895 

2.13.1  Install Tripwire Log Center Manager 1896 

See the Tripwire Log Center 7.3.1 Installation Guide, which should accompany the installation media, for 1897 
instructions on how to install Tripwire Log Center. Use the Tripwire Log Center Manager installer. 1898 

Notes: 1899 

a. It is recommended that you install Tripwire Log Center on a separate system from Tripwire 1900 
Enterprise. 1901 

b. You will need to install JRE8 and the Crypto library. Instructions are also in the Tripwire Log 1902 
Center 7.3.1 Installation Guide.  1903 

c. .NET Framework 3.5 is required for this installation–install this from the Server Manager. 1904 
d. You may need to unblock port 9898 on your firewall for the Tripwire Enterprise agents.  1905 
e. Do not install PostgreSQL if you wish to use a database on another system–this guide will use a 1906 

local PostgreSQL database, however. 1907 
f. When it finishes installing, there should be a configuration wizard (see below for configuration 1908 

steps). 1909 

2.13.2  Configure Tripwire Log Center Manager 1910 

1. The configuration wizard should start after the installation is complete. 1911 
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 1912 
2. Click Start. 1913 

 1914 
3. Click New Install. 1915 
4. Enter the registration details for your Tripwire Log Center license. 1916 
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 1917 
5. Click Register.  1918 
6. Enter details about the database that Tripwire Log Center should use. 1919 

 1920 
7. Click Next. 1921 
8. Select a directory in which to store log messages, such as C:\Program Files\Tripwire\Tripwire 1922 

Log Center Manager\Logs\AUDIT. 1923 
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 1924 
9. Click Next. 1925 
10. Enter a password and an email. 1926 
11. Change the IP to a hostname if preferred. 1927 

 1928 
12. Click Next.  1929 
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 1930 
13. Click Next. 1931 
14. Select any log sources that you expect to collect with Tripwire Log Center. Examples: Tripwire 1932 

Enterprise, Microsoft Windows 10, Tripwire IP360 VnE, Linux Debian, Ubuntu Linux, Microsoft 1933 
Exchange, Microsoft SQL Server. 1934 

 1935 
15. Click Next. 1936 
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 1937 
16. Click Start. 1938 

 1939 
17. Click Next. 1940 
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 1941 
18. Click Finish. 1942 

2.13.3  Install Tripwire Log Center Console 1943 

Chapter 4 of the Tripwire Log Center 7.3.1 Installation Guide details installation of the Tripwire Log 1944 
Center Console. Use the Tripwire Log Center Console installer. 1945 

You can install this on the same machine as the Tripwire Log Center Manager, if desired. 1946 

2.14  Cisco Web Security Appliance 1947 

This section details installation and some configurations for the Cisco Web Security Appliance (WSA). It 1948 
assumes the use of the WSA virtual machine. 1949 

2.14.1  Network Configuration 1950 

1. Log in to WSA by using the default username and password (admin/ironport). 1951 
2. Use the command sethostname to set the hostname of the machine. 1952 
3. Use the command dnsconfig to set the DNS server. Enter SETUP when prompted, and then 1953 

enter DNS information specific to your organization’s needs. 1954 
4. Use the command interfaceconfig to set the IP of the machine. Enter EDIT when 1955 

prompted, and then enter IP information specific to your organization’s needs. 1956 
5. Use the command passwd to change the default password of the machine. 1957 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 290 

6. Use the command commit to commit all of these changes. 1958 
7. Use the command reboot to reboot the machine. 1959 
8. Use the command loadlicense to either paste the license file contents or select a license 1960 

file uploaded via FTP. You can enable FTP in the interfaceconfig command.  1961 
9. You should be prompted at the console to visit a web page in the browser, usually 1962 

http://<ip_address>:8080. The setup wizard will be here.  1963 

2.14.2  System Setup 1964 

1. In the web console, click System Administration > System Setup Wizard. 1965 
2. Verify that the hostname matches the desired hostname. 1966 
3. Enter the desired DNS servers. 1967 
4. Enter a time server if desired. 1968 
5. Select the time zone. 1969 
6. Select Standard for an on-premise setup. 1970 

 1971 
7. Click Next.  1972 
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 1973 
8. Click Next.  1974 
9. Verify that the interface is correctly configured. 1975 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 292 

 1976 
10. Click Next. 1977 
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 1978 
11. Click Next.  1979 
12. Enter the default gateway and any additional gateways to use for routing.  1980 
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 1981 

13. Click Next.  1982 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 295 

 1983 

14. Click Next. 1984 
15. Set a passphrase for the administrator. 1985 
16. Enter an email address to which alerts should be sent. 1986 
17. Enter the hostname of the email server. 1987 
18. Decide whether to forward alerts and reports to Cisco Customer Support, as well as whether to 1988 

share anonymous statistics based on the needs of your organization.  1989 
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 1990 

19. Click Next.  1991 
20. Select Monitor All Traffic. 1992 
21. Select Block for Action for Suspect Malware Addresses. 1993 
22. Select Block for Action for Detected Malware. 1994 
23. Configure the rest of the malware policy according to your organization’s needs.  1995 
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 1996 

24. Click Next. 1997 
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 1998 

25. Click Install This Configuration. 1999 

2.14.3  Using WSA to Proxy Traffic 2000 

Cisco WSA is intended to act as a proxy between clients and the internet, to prevent malicious traffic 2001 
and software from reaching the client systems before they can do any damage. The appliance must 2002 
have a way of intercepting traffic from the clients to the internet.  2003 

To achieve this, we used a Proxy Auto Config (PAC) file on our DNS server (Windows 2012 DNS), and this 2004 
section details how to set up a simple PAC file to forward all traffic to WSA. This may not be an ideal 2005 
setup for every environment, particularly in environments that use an external DNS server. 2006 
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2.14.3.1  Creating a PAC File 2007 

1. Create a new file named wpad.dat and enter the following JavaScript function: 2008 

 2009 

This is the most basic template for a proxy that directs all traffic to the host coeus.di.ipdr. The 2010 
return value of this function can take the form “PROXY <hostname1>; PROXY 2011 
<hostname2>” if you wish to have fail-over proxies, or “DIRECT” to not use any proxy. You can 2012 
also add rules to allow certain types of traffic through the proxy or direct them to other proxies. For 2013 
more information, see https://findproxyforurl.com. 2014 

For the purposes of our setup, we will simply direct all traffic to Cisco WSA, but be aware that PAC 2015 
files can be more complex and designed according to the needs of the organization. 2016 

2. In the web console, navigate to Security Services > Web Proxy.  2017 

 2018 

function FindProxyForURL(url, host) { 

 return “PROXY coeus.di.ipdr:3128”; 

} 

https://findproxyforurl.com/
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3. Click Edit Settings. 2019 
4. Remove port 80 from HTTP Ports to Proxy (ensure that 3128 is in this field). 2020 

 2021 
5. Click Submit. 2022 
6. Navigate to Security Services > PAC File Hosting. 2023 
7. Click Enable and Edit Settings. 2024 
8. Under PAC Files, click Choose File.  2025 
9. Select the wpad.dat file created earlier.  2026 
10. Click Open. 2027 
11. Click Upload. 2028 
12. Enter 80 for PAC Server Ports. 2029 
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 2030 
13. Click Submit. 2031 
14. Click Commit Changes. 2032 
15. Enter a comment if desired. 2033 
16. Click Commit Changes.  2034 

2.14.3.2  Setting Up Web Proxy Auto Discovery (WPAD) 2035 

1. On the DNS server, open regedit.exe. 2036 
2. Navigate to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services > DNS > 2037 

Parameters. 2038 
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 2039 
3. Double-click GlobalQueryBlockList. 2040 
4. Remove wpad from the list but leave isatap on the list. 2041 

 2042 
5. Click OK. 2043 
6. Open Task Manager. 2044 
7. Click Services. 2045 
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 2046 
8. Restart the DNS Server service. 2047 
9. Open DNS Manager.  2048 
10. Right-click on your enterprise’s domain, and click New Host (A or AAAA). 2049 
11. Enter wpad for Name. 2050 
12. Enter the IP address of WSA.  2051 
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 2052 

13. Click Add Host.  2053 

This will set up the WPAD proxy file as the default proxy–so browsers that are using “Automatically 2054 
detect settings” for their proxy setting will find this file. Be aware that this is not sufficient for a 2055 
secure setup but will allow you to quickly test the proxy’s functionality.  2056 

2.14.3.3  Configure Group Policy to Use Explicit Proxy 2057 

Note that, at this point, WPAD is vulnerable to an attack where the server hosting WPAD is brought 2058 
down and the browser automatically attempts to find the next WPAD proxy, which may be 2059 
controlled by an attacker. 2060 

To mitigate this vulnerability, we explicitly point to this proxy file with any browsers used by clients. 2061 
For Internet Explorer and Google Chrome, it is sufficient to change group policy in Active Directory 2062 
to direct the change across all systems.  2063 

For Mozilla Firefox, see this link (https://support.mozilla.org/en-US/kb/connection-settings-firefox) 2064 
for configuration, including how to set it to “Use system proxy settings.” 2065 

1. In Group Policy Management, right-click the Default Domain Policy and click Edit. 2066 

https://support.mozilla.org/en-US/kb/connection-settings-firefox
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 2067 
2. In Group Policy Management Editor, navigate to User Configuration > Preferences > Control 2068 

Panel Settings > Internet Settings. 2069 
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 2070 
3. Right-click Internet Settings and select New > Internet Explorer 10. 2071 
4. Click the Connections tab. 2072 
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 2073 
5. Click LAN Settings. 2074 
6. Enter the address of the WPAD file for address. This will likely take the form 2075 

http://wpad.my.domain/wpad.dat if you followed these instructions for configuring the proxy 2076 
file. 2077 

7. Press the F8 key to disable all settings in this dialogue box. (Note: This should underline 2078 
everything in the box in red.) 2079 

http://wpad.my.domain/wpad.dat
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 2080 
8. Select the Address you just entered.  2081 
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 2082 
9. Press F6 to enable this setting. (Note: The explicit WPAD address should now be underlined in 2083 

green.) 2084 
10. Click OK. 2085 
11. Click OK. 2086 

This Group Policy Object will update across all Windows systems whenever gpupdate.exe runs. An 2087 
insider or technically capable user could manually disable this to avoid using the proxy, but benign 2088 
clients who do not attempt to circumvent it will be protected from external (internet-based) threats 2089 
by Cisco WSA. Protection from insiders and local threats on the network is provided by other 2090 
products in the architecture, such as the network protection component (CryptoniteNXT). 2091 

2.14.4  Blacklisting 2092 

1. Navigate to Web Security Manager > Custom and External URL Categories. 2093 
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 2094 
2. Click Add Category. 2095 
3. Enter a name for Category Name. 2096 
4. Select Local Custom Category. (The other option, External Live Feed Category, allows WSA to 2097 

use a list of websites hosted somewhere else, potentially externally. For this demonstration we 2098 
will simply enter websites in the Sites field, but note that this other option is available for 2099 
convenience.) 2100 

5. For Sites, enter any sites to blacklist. (Note: Entering .mysite.abc will include any subdomains of 2101 
mysite.abc.) 2102 
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 2103 
6. Click Submit. 2104 
7. Navigate to Web Security Manager > Access Policies. 2105 
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 2106 
8. Click the link under URL Filtering.  2107 
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 2108 
9. Click Select Custom Categories. 2109 
10. For the category just created, select Include in policy under Setting Selection. 2110 
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 2111 
11. Click Apply. 2112 
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 2113 

12. The category should now show under Custom and External URL Category Filtering. Put a 2114 
checkmark in the Block box. (Selecting Allow lets you white-list domains that are being 2115 
incorrectly classified as malicious.) 2116 

13. Click Submit. 2117 
14. Click Commit Changes. 2118 
15. Enter a comment if desired.  2119 
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 2120 
16. Click Commit Changes. 2121 

 2122 

2.15  Symantec Data Loss Prevention 2123 

2.15.1  Install Oracle 12c Enterprise 2124 

1. Unzip the Symantec DLP installation files.  2125 
2. Download the Oracle 12c installation files from https://www.oracle.com if they are not included 2126 

with the Symantec DLP installation files. 2127 
3. Move both sets of installation files to a temporary directory, such as C:\temp.  2128 
4. Copy the Symantec 12.2.0.1_64_bit_Installation_Tools folder to C:\temp\Oracle\tools. 2129 
5. From a command prompt, navigate to C:\temp\Oracle\database, assuming the Oracle 2130 

installation files were unzipped to C:\temp\Oracle. 2131 
6. Run the following command: 2132 

> C:\temp\Oracle\database\setup.exe -noconfig -responsefile 2133 
C:\temp\Oracle\tools\responsefiles\Oracle_12.2.0.1_Enterprise_Edi2134 
tion_Installation_WIN.rsp 2135 

7. Once the wizard opens, you will be asked to configure security updates. If you do not possess a 2136 
My Oracle Support account, leave the box unchecked and provide an email.  2137 

https://www.oracle.com/
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 2138 
8. Click Next. 2139 
9. Select Install database software only. 2140 
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 2141 
10. Click Next.  2142 
11. Select Single instance database installation. 2143 
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 2144 
12. Click Next.  2145 
13. Select Standard Edition. 2146 
14. Click Next.  2147 
15. Select Create New Windows User. 2148 
16. Enter the username and password of a new user for Active Directory. 2149 
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 2150 
17. Click Next.  2151 
18. Select a location to install the software, if desired. 2152 
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 2153 

19. Click Next.  2154 
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 2155 
20. Verify the information and click Install. The installation may take a long time. 2156 
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 2157 
21. Click Close when the installation is complete. 2158 

2.15.2  Create an Oracle Database for Symantec DLP 2159 

1. Set the ORACLE_HOME environment variable by running the following command. Adjust the 2160 
path accordingly if using a version other than 12.2.0. 2161 

> set 2162 
ORACLE_HOME=C:\app\Administrator\virtual\product\12.2.0\dbhome_1 2163 

2. Copy the Oracle database template named Oracle_12.2.0.1_Template_for_64_bit_WIN.dbt 2164 
from the Symantec DLP zip file into 2165 
C:\app\Administrator\virtual\product\12.2.0\dbhome_1\assistants\dbca\templates. 2166 

3. Ensure that the response file Oracle_12.2.0.1_DBCA_WIN.rsp is located in the folder 2167 
C:\temp\Oracle\database\tools\responsefiles. 2168 

4. Run the following command. 2169 

> %ORACLE_HOME%\bin\dbca -createDatabase -progressOnly -2170 
responseFile 2171 
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C:\temp\Oracle\database\tools\responsefiles\Oracle_12.2.0.1_DBCA_2172 
WIN.rsp 2173 

5. Enter a password for the SYS user. (Only the special characters _, #, or $ are allowed.) 2174 
6. Enter a password for the SYSTEM user. (Only the special characters _, #, or $ are allowed.) 2175 
7. Enter a password for the Oracle Home User.  2176 

2.15.3  Configuring the Oracle Listener 2177 

1. Ensure that the database services OracleServicePROTECT and 2178 
DistributedTransactionCoordinator are running. 2179 

2. In the file %ORACLE_HOME%\network\admin\sqlnet.ora, change the line 2180 
SQLNET.AUTHENTICATION_SERVICES=(NTS) to SQLNET.AUTHENTICATION_SERVICES=(none).  2181 

3. Navigate to Start > All Programs > Oracle 12.2.0 > Configuration and Migration Tools > Net 2182 
Configuration Assistant and run the program. 2183 

4. Select Listener configuration. 2184 

 2185 
5. Click Next.  2186 
6. Select Add. 2187 
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 2188 
7. Click Next.  2189 
8. Enter a name for the listener. 2190 
9. Enter a password. 2191 

 2192 
10. Click Next.  2193 
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11. Move the TCP protocol to the Selected Protocols column. 2194 

 2195 
12. Click Next.  2196 
13. Select Use the standard port number of 1521. 2197 

 2198 
14. Click Next. 2199 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 327 

15. Select No. 2200 

 2201 
16. Click Next.  2202 

 2203 

17. Click Next.  2204 
18. Select Local Net Service Name configuration. 2205 
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 2206 

19. Click Next. 2207 
20. Select Add. 2208 

 2209 
21. Click Next. 2210 
22. Enter the word “protect” for the name. 2211 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 329 

 2212 
23. Click Next.  2213 
24. Select TCP. 2214 

 2215 
25. Click Next.  2216 
26. Enter the IP address of the system hosting the Oracle Database. 2217 
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27. Select Use the standard port number of 1521. 2218 

 2219 
28. Click Next.  2220 
29. Select No, do not test. 2221 

 2222 

30. Click Next.  2223 
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 2224 

31. Click Next.  2225 
32. Select No. 2226 

 2227 
33. Click Next.  2228 
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 2229 
34. Click Next. 2230 

 2231 
35. Click Finish. 2232 
36. In an administrative command prompt, run the following command to stop the listener. 2233 
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> lsnrctl stop 2234 

37. Open the file %ORACLE_HOME%\network\admin\listener.ora.  2235 
38. Change (ADDRESS = (PROTOCOL = IPC)(KEY = <key_value>)) to (ADDRESS = (PROTOCOL = 2236 

IPC)(KEY = PROTECT)). 2237 
39. Add the line SECURE_REGISTER_LISTENER=(IPC) to the end of the file. 2238 

 2239 

40. Save the file and exit the editor. 2240 
41. Ensure that OracleServicePROTECT and OracleVssWriterPROTECT services are running in Task 2241 

Manager.  2242 
42. In an administrative command prompt, run the following command to start the listener. Re-2243 

place dilistener with the name given to your listener. 2244 

> lsnrctl start dilistener 2245 

43. Run the following commands to connect the listener to the database using SQL Plus. Replace 2246 
password with the password used for the SYS user. 2247 

> sqlplus /nolog 2248 

> conn sys/password as sysdba 2249 

44. Run the following commands in the SQL prompt. (Note: If errors occur relating to the SPFILE, try 2250 
replacing ORACLE_HOME or ORACLE_base values in %ORACLE_HOME%\dbs\init.ora with the 2251 
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absolute path. Then run CREATE SPFILE FROM PFILE=’%ORACLE_HOME%\dbs\init.ora’ and CRE-2252 
ATE PFILE FROM SPFILE=’%ORACLE_HOME%\dbs\init.ora’. Restart the database after doing 2253 
this.) 2254 

> ALTER SYSTEM SET local_listener = '(DESCRIPTION=(ADDRESS=(PRO-2255 
TOCOL=ipc)(KEY=PROTECT)))' SCOPE=both; 2256 

> ALTER SYSTEM REGISTER; 2257 

> exit 2258 

45. Run the following command to verify the status of the listeners: 2259 

> lsnrctl services 2260 

 2261 

46. Open a new administrative command window. 2262 
47. Navigate to C:\Temp\Oracle\database\tools. 2263 
48. Run the following command: 2264 

> sqlplus /nolog 2265 

> @oracle_create_user.sql 2266 

49. Enter the password for the SYS user. 2267 
50. For sid, enter “protect”. 2268 
51. For a username, enter “protect”. 2269 
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52. Enter a password for the “protect” user. (The special characters &, $, and # are not allowed.) 2270 
53. When this process is finished, open a new administrative command window and run the follow-2271 

ing command. 2272 

> sqlplus /nolog 2273 

54. Log in as the SYS user with the following command (replace “password” with the password for 2274 
the SYS user). 2275 

> connect sys/password@protect as sysda 2276 

55. Verify the version information with the following command. 2277 

> SELECT * FROM v$version; 2278 

 2279 
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2.15.4  Install Symantec DLP 2280 

1. In the folder DLP Installs\DLP 15.1\Symantec_DLP_15.1_Platform_Win-2281 
IN_15.1.0.25021\DLP\15.1\New_Installs\x64\Release, located in the download folder for the 2282 
DLP files, run ServerJRE.msi. 2283 

 2284 

2. Click Next. 2285 
3. Select I agree to the terms in the license agreement. 2286 

 2287 
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4. Click Next. 2288 

 2289 
5. Click Next. 2290 

 2291 
6. Click Install. 2292 
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 2293 
7. Click Finish. 2294 
8. Run SingleTierServer.msi (located in the same folder as ServerJRE.msi). 2295 

 2296 
9. Click Next. 2297 
10. Check the box to accept the license agreement. 2298 
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 2299 
11. Click Next. 2300 

 2301 

12. Click Next. 2302 
13. Select Enabled for FIPS 140-2 Compliant Algorithms. 2303 
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 2304 
14. Click Next. 2305 

 2306 

15. Click Next. 2307 
16. Click on New Users. 2308 
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 2309 
17. Click Next. 2310 
18. Enter a password and optionally a username. 2311 

 2312 
19. Click Next. 2313 
20. Enter a password and optionally a username. 2314 
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 2315 

21. Click Next. 2316 
22. Enter the password used for the “protect” user. 2317 

 2318 

23. Click Next. 2319 
24. Select Initialize Database. 2320 
25. Click Next. 2321 
26. Set the initial password for logging into the Enforce Administrator account. 2322 
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 2323 

27. Click Next. 2324 
28. Select Database. 2325 

 2326 

29. Click Next. 2327 
30. Select None. 2328 
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 2329 
31. Click Next. 2330 

 2331 
32. Click Next. 2332 
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 2333 

33. Click Install. 2334 

 2335 

34. Click Finish. 2336 
35. Ensure that the services are running in Task Manager: 2337 

a. SymantecDLPManager 2338 
b. SymantecDLPIncidentPersister 2339 
c. SymantecDLPNotifier 2340 
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d. SymantecDLPDetectionServer 2341 

2.15.5  Configure Symantec DLP 2342 

1. Navigate to https://127.0.0.1 in the browser to get to the Symantec DLP web console. 2343 
2. Navigate to System > Settings > General and click Configure. 2344 
3. In the Edit General Settings screen, upload your license file provided by Symantec.  2345 
4. Click Save.  2346 
5. In Task Manager, stop the SymantecDLPManager service. 2347 
6. Copy the classpath.txt file located in <DLP Download Home>\DLP\15.1\Solution_Packs\ and 2348 

overwrite the classpath.txt located at C:\Program Files\Symantec\Data Loss 2349 
Prevention\Enforce Server\15.1\Protect\Config\SolutionPackInstaller. 2350 

7. In an administrative command window, use the following commands to import the chosen 2351 
solution pack. For example, to import the financial solution pack, use: 2352 

> cd “C:\Program Files\Symantec\Data Loss Prevention\Enforce 2353 
Server\15.1\protect\bin” 2354 

> .\SolutionPackInstallerexe import “C:\Program 2355 
Files\Symantec\Data Loss Prevention\Financial_v15.1.vsp” 2356 

8. After this is installed, restart the SymantecDLPManager service. 2357 
9. Log on to the Enforce Web Console as Administrator. 2358 
10. Navigate to System > Servers > Overview. 2359 
11. Click Add Server. 2360 
12. Select the type of Detection Server to add. 2361 
13. Click Next. 2362 
14. Enter a name. 2363 
15. Enter the hostname of the DLP server. 2364 
16. Enter 8100 for the port. 2365 
17. Navigate to System > Settings > General. 2366 

 2367 

18. Check the box next to Advanced Process Control. 2368 
19. Specify any configuration options according to the needs of your organization. 2369 
20. Click Save. 2370 
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2.16  Cisco Identity Services Engine 2371 

This section details the installation and some configurations for the Cisco Identity Services Engine (ISE). 2372 
It assumes the use of the ISE virtual machine. 2373 

2.16.1  Initial Setup 2374 

1. When prompted to log in for the first time, enter setup. (You can use the command reset-2375 
config to change these values later.) 2376 

2. Enter the desired hostname for the machine. 2377 
3. Enter the desired IP address for the machine. (Ensure that the specified hostname is associated 2378 

with this IP address in your DNS.) 2379 
4. Enter the netmask for the machine.  2380 
5. Enter the default gateway. 2381 
6. Enter the default DNS domain (the name of your domain). 2382 
7. Enter the primary nameserver (the IP address of your DNS). 2383 
8. Enter a second nameserver if desired.  2384 
9. Enter a Network Time Protocol (NTP) time server. 2385 
10. Enter the timezone. 2386 
11. Enter Y for SSH service. 2387 
12. Enter an administrator username for the machine. 2388 
13. Enter a password twice. 2389 

2.16.2  Inventory: Configure SNMP on Routers/Network Devices 2390 

See the corresponding vendor documentation for the correct way to enable Simple Network 2391 
Management Protocol (SNMP) on your network device. Ensure that the community string you choose is 2392 
considered sensitive, like a password. 2393 

2.16.3  Inventory: Configure Device Detection 2394 

1. Log in to the web client by visiting https://hostname/admin but replace hostname with the 2395 
hostname of the ISE machine.  2396 
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 2397 
2. On the top right, use the small Play button to select Visibility Setup. 2398 

 2399 
3. Click Next.  2400 

 2401 
4. Enter the range of IP addresses to add to ISE’s inventory.  2402 
5. Ensure that Active Scanning is checked. 2403 
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 2404 

6. Click Next.  2405 
7. Click the Add Device Manually link. 2406 
8. Enter a name. 2407 
9. Enter the IP address of the network device you configured for SNMP. 2408 
10. Select 1 for SNMP version. 2409 
11. Enter the community string you created.  2410 

 2411 

12. Click OK. 2412 
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 2413 
13. Click Next. 2414 
14. Enter a display name. 2415 
15. Enter the domain name. 2416 
16. Enter the hostname of Cisco ISE. 2417 
17. Enter a username and password. 2418 
18. Click Test Connection to ensure that this works. 2419 

 2420 
19. Click Next.  2421 
20. Enter a username and password. 2422 
21. Check the box next to Enable Endpoint Logging. 2423 
22. Check the box next to Include Range. 2424 
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 2425 
23. Click Next.  2426 

 2427 
24. Verify the settings and click Done. (This should begin importing endpoints connected to the 2428 

network device, and they will be visible on the ISE dashboard.) 2429 

2.16.4  Policy Enforcement: Configure Active Directory Integration 2430 

1. Navigate to Administration > Identity Management > External Identity Sources > Active 2431 
Directory. 2432 
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 2433 
2. Click Add. 2434 
3. Enter a name.  2435 
4. Enter the domain. 2436 

 2437 
5. Click Submit. 2438 
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 2439 
6. Click Yes. 2440 
7. Enter a username and password to join ISE to the domain. 2441 

 2442 

8. Click OK. 2443 
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 2444 

9. Click Close when the join is finished. 2445 

2.16.5 Policy Enforcement: Enable Passive Identity with AD 2446 

This configuration allows users to use Active Directory usernames/passwords as authentication for the 2447 
portal. The web portal will allow clients to download profiling software to ensure that clients have up to 2448 
date software and can be trusted on the network.  2449 

1. Navigate to Administration > System > Deployment. 2450 
2. Check the box next to ISE. 2451 

 2452 
3. Click Edit. 2453 
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4. Check the box next to Enable Passive Identity Service. 2454 

 2455 
5. Click Save. 2456 
6. Navigate to Administration > Identity Management > External Identity Sources > Active 2457 

Directory. 2458 
7. Click the name of the Active Directory machine. 2459 
8. Check the box next to the join point you just created.  2460 

 2461 
9. Click Edit.  2462 
10. Click the PassiveID tab. 2463 
11. Click Add DCs if there are no domain controllers listed. 2464 
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 2465 
12. Select the Active Directory domain controller. 2466 
13. Click OK. 2467 
14. Check the box next to the selected domain controller. 2468 
15. Click Edit. 2469 
16. Enter credentials for an administrator account. 2470 

 2471 
17. Click Save. 2472 
18. Click Config WMI. 2473 
19. Click OK. 2474 
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 2475 
20. Click OK when this configuration finishes. 2476 
21. Navigate to Administration > System > Settings > Client Provisioning. 2477 
22. Set Enable Automatic Download to Enable. 2478 

 2479 
23. Click Save. 2480 
24. Navigate to Administration > Identity Management > External Identity Sources > Active 2481 

Directory. 2482 
25. Click the Groups tab. 2483 
26. Click Add > Select Groups from Directory. 2484 
27. Click Retrieve Groups. (This should populate the window with the groups from Active 2485 

Directory.) 2486 
28. Select them all. 2487 
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 2488 
29. Click OK. (If you add more groups to Active Directory they can be imported in the same way in 2489 

the future.) 2490 
30. Click the Attributes tab.  2491 
31. Click Add > Select Attributes from Directory. 2492 
32. Enter a username.  2493 
33. Click Retrieve Attributes. (This will populate the window with Active Directory’s available 2494 

attributes, so they can be used for policy in Cisco ISE.) 2495 
34. Click OK. 2496 
35. Select any desired attributes. 2497 
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 2498 
36. Click OK. 2499 
37. Click Save. 2500 

2.16.6  Policy Enforcement: Developing Policy Conditions 2501 

1. Navigate to Policy > Policy Elements > Conditions > Posture. 2502 
2. Expand the Posture section. This will reveal a list of categories for conditions. (Note: These 2503 

conditions allow you to select or define requirements that endpoints should meet. In typical 2504 
enterprises, these conditions can be used as requirements to gain network access–however, 2505 
this strongly depends on the capabilities of your network device.) 2506 

3. As an example, we will require that Cisco AMP be installed on all Windows devices. If you are 2507 
using a different anti-malware software, locate that instead. Click Anti-Malware Condition.  2508 
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 2509 

4. Click Add. 2510 
5. Enter a name. 2511 
6. Enter a description if desired. 2512 
7. Select Windows All for Operating System. 2513 
8. Select Cisco Systems, Inc. for Vendor.  2514 
9. Under Products for Selected Vendor, check the box next to Cisco Advanced Malware 2515 

Protection with the version number you have installed. 2516 
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 2517 
10. Click Submit. 2518 

2.16.7  Policy Enforcement: Developing Policy Results 2519 

1. Navigate to Policy > Policy Elements > Results > Posture > Requirements. 2520 
2. Click one of the black arrows next to the Edit link, and select Insert New Requirement. 2521 
3. Enter a name.  2522 
4. Select Windows All for Operating Systems. 2523 
5. Select 4.x or later for Compliance Module. 2524 
6. Select Temporal Agent for Posture. 2525 
7. Select User Defined Conditions > Anti-Malware Condition > Cisco AMP (substitute Cisco AMP 2526 

with the name of the condition you just created).  2527 
8. Select Message Text Only for the Remediation Action. (Other remediation actions can be 2528 

defined by going to Policy > Policy Elements > Results > Posture > Remediation Actions, but 2529 
there is not an option for Cisco AMP to be installed, so we leave the default for now.) 2530 

9. Enter a Message to inform the user that they must install Cisco AMP.  2531 
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 2532 
10. Click Save.  2533 

2.16.8  Policy Enforcement: Enforcing a Requirement in Policy 2534 

1. Navigate to Policy > Posture. 2535 
2. Click one of the black arrows next to the Edit link, and select Insert New Policy. 2536 
3. Enter a name.  2537 
4. Select Windows All for Operating Systems. 2538 
5. Select 4.x or later for Compliance Module. 2539 
6. Select Temporal Agent for Posture Type. 2540 
7. Select Cisco AMP (substitute Cisco AMP with the name of the requirement you just created).  2541 
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 2542 
8. Click Done. 2543 
9. Ensure that the green checkboxes next to the rules you wish to apply are the only checkboxes 2544 

enabled, as anything enabled will be enforced.  2545 

2.16.9  Policy Enforcement: Configuring a Web Portal 2546 

1. Navigate to Administration > Device Portal Management > Client Provisioning.  2547 
2. Select the Client Provisioning Portal (default). 2548 

 2549 
3. Click Edit. 2550 
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4. Under Portal Settings, go to Configure authorized groups and select the groups that should 2551 
require a Cisco ISE client.  2552 

5. Enter a domain name for FQDN, and add it to your DNS.   2553 

 2554 
6. Click Save. 2555 

2.16.10 Configuring RADIUS with Your Network Device 2556 

Cisco ISE requires a Remote Authentication Dial-In User Service (RADIUS) session for posture to 2557 
function. Posture refers to ISE’s ability to check that a machine complies with a specified policy, which 2558 
may be based on the operating system (OS) and may contain requirements such as installation of 2559 
certain security applications or the presence of configuration files. Machines that are not in compliance 2560 
can be kept separated from the network. The process for setting this up varies widely among machines, 2561 
but the overall requirements have commonalities among systems.  2562 

• The Network Device (i.e., the router or switch) must support RADIUS functions, specifically 2563 
Authentication, Authorization, and Accounting. Furthermore, it must also support CoA, which 2564 
is Change of Authorization. To configure this, you must configure your network device to use 2565 
Cisco ISE as a RADIUS server. What this means is that your network device will forward 2566 
authentication requests to Cisco ISE, and Cisco ISE will respond with an “accept” or “reject.” 2567 

• The Network Device must support some form of 802.1x. Note that this is not supported on 2568 
certain routers, even if RADIUS is supported. 802.1x is a mechanism for authenticating the end 2569 
workstation to the network device, potentially over wireless or through Ethernet.  2570 
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a. This can take various forms, such as a captive web portal, MAC address authentication, 2571 
or user authentication. A captive web portal, if the device supports it, may be ideal for 2572 
configuration without the correct hardware.  2573 

b. There are also many switches that provide direct 802.1x username/password 2574 
authentication. Note that if you choose to use this mechanism, a client is still required, 2575 
and it will not be in the web browser. Windows has a built-in 802.1x client, which can be 2576 
configured on network adapters under the Authentication tab. To enable it, you must 2577 
first start the service Wired AutoConfig, and then the Authentication tab will become 2578 
available for configuration. 2579 

c. Whatever form of 802.1x is chosen, the request for authentication must be forwarded 2580 
to Cisco ISE. Cisco ISE will process the request for authentication.  2581 

• The two steps above detail the authentication phase. Once authenticated, the network device 2582 
must redirect the user to the client provisioning portal (or to a guest portal), depending on the 2583 
setup. The URL for this can be acquired from the active Authorization Profile in ISE.  2584 

• The user will then authenticate to the Guest Portal or Client Provisioning Portal (depending on 2585 
your setup). The portal will prompt the user to download an executable, which will run posture. 2586 

• The executable will first check for the existence of a RADIUS session in Cisco ISE for the user 2587 
who downloaded the executable. It will primarily check the MAC address that visited the ISE 2588 
web portal against the MAC addresses of existing sessions. If and only if a session exists, it will 2589 
run posture based on the policy you set up. You can verify that a session exists by navigating to 2590 
Operations > RADIUS > Live Sessions. 2591 

2.16.11 Configuring an Authentication Policy 2592 

1. Navigate to Policy > Policy Elements > Results > Authentication > Allowed Protocols. 2593 
2. Select the Default Network Access protocol or create your own.  2594 
3. Ensure that any protocols that need to be supported for your network setup are allowed. In 2595 

particular, if using 802.1x, it is likely that you should check the box next to Allow MS-CHAPv2. 2596 
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 2597 
4. Click Save. 2598 
5. Navigate to Policy > Policy Sets. 2599 
6. Select the default policy. 2600 
7. Ensure that the Allowed Protocol selection matches the allowed protocol you just 2601 

created/edited. 2602 
8. Expand the Authentication Policy section, and select the ID stores from which to authenticate 2603 

users. For example, if you set up an Active Directory integration, it may be desirable to 2604 
authenticate users from there. 2605 
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 2606 
9. Click Save. 2607 

2.16.12 Configuring an Authorization Policy 2608 

1. The Authorization Profile is likely dependent on your network device, but it is possible that the 2609 
Cisco_Temporal_Onboard profile will work even for non-Cisco devices. You can edit the 2610 
authorization policy by navigating to Policy > Policy Elements > Results > Authorization > 2611 
Authorization Profiles.  2612 

2. The temporal onboard profile will attempt to redirect the user to a client-provisioning portal. 2613 
This redirection will most likely happen only automatically on compatible Cisco network devices. 2614 
If another device is used, the device may need to manually redirect the user to the client-2615 
provisioning portal after authentication. (We accomplished this in pfSense for our build by using 2616 
a “post-authentication redirection” feature in the Captive Portal.) 2617 

3. Once you are finished configuring the Authorization Profile, navigate to Policy > Policy Sets. 2618 
4. Select the default policy. 2619 
5. Expand the Authorization Policy section. 2620 
6. Note that you can configure this for as many groups and conditions as desired, potentially 2621 

specifying different authorization profiles for various user groups or levels of authentication, 2622 
including unauthenticated access. Under Results > Profiles, you can select the authorization 2623 
profiles you configured. 2624 
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 2625 

7. Click Save.  2626 

2.17  Tripwire IP360 2627 

This section details installation and configuration for Tripwire IP360. 2628 

2.17.1  Installation 2629 

1. Move or copy the Tripwire IP360 Virtual Machine into your virtual environment; start Virtual 2630 
Machine and observe its successful start-up. 2631 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 369 

2. Log in using default admin credentials.2632 

 2633 
3. When prompted after initial login, set a new password and record it in a safe location.2634 

 2635 
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4. Use the command system hostname update <hostname> to update the system’s hostname in 2636 
accordance with your environment’s naming scheme.2637 

 2638 
5. Use command network interface update <interface> <IP>/<Broadcast IP> to update network 

interface information in accordance with your environment’s network.
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6. Use command network route_default create <gateway> to update the system’s default 
gateway information in accordance with your environment’s network.
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7. Use command system nameserver create <nameserver IP> to set up the DNS server.
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2.17.2  Web Portal 2639 

1. From a web browser that can access the newly installed machine’s IP address, navigate to the IP 2640 
address and log in using the updated credentials from the setup process.2641 

 2642 
2. Check the box next to I accept the above User License Agreement. 2643 
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3. Click Next. 2644 
4. Browse to location of downloaded license file.2645 

 2646 
5. Click Install. 2647 
6. Tripwire IP360 should now be installed and running.2648 

  2649 

2.17.3  Scanning 2650 

This section details instructions for using Tripwire IP360 to run a scan on enterprise systems. The 2651 
specific details of the scan will vary based on each enterprise’s security needs. 2652 
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1. Navigate to the web interface and log in.2653 

 2654 
2. Navigate to the Scanning tab. 2655 

 2656 
3. Click Add. 2657 
4. Complete the information regarding the new scan according to the preferences of your 2658 

organization. 2659 
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 2660 
5. Observe successful scan activity. 2661 
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2.18 Integration: Tripwire Log Center and Tripwire Enterprise 2662 

1. Create a user account in Tripwire Log Center by logging into Tripwire Log Center Console. 2663 

 2664 
2. Click the Administration Manager button. 2665 
3. Click User Accounts. 2666 
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 2667 
4. Click the Add button. 2668 
5. Enter the details of the user.  2669 

 2670 
6. Click Add. 2671 
7. Double-click the user account. 2672 
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 2673 
8. Click the Permissions tab. 2674 

 2675 
9. Click Edit list of permissions. 2676 
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10. Select Databases. 2677 

 2678 
11. Check the box next to View System Database. 2679 
12. Select API. 2680 

 2681 
13. Check the box next to Allow REST API Logon. 2682 
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 2683 
14. Click OK. 2684 
15. Click OK. 2685 
16. Log in to the Tripwire Enterprise web console. 2686 
17. Click Settings. 2687 
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18. Go to System > Log Management. 2688 
19. Check the box next to Forward TE log messages to syslog. 2689 
20. Enter the hostname and port of the Tripwire Log Center server. The default port is 1468. 2690 
21. Check the box next to Allow TE to use information from Tripwire Log Center. 2691 
22. Enter the service address like this: https://arcsight-cons.di.ipdr:8091/tlc. Replace the hostname 2692 

with the hostname of your Tripwire Log Center server. 2693 
23. Enter the account information of the account just created for Tripwire Log Center. 2694 
24. You can use Test Connection to verify that the connection is working. 2695 

 2696 
25. Click Apply when finished. 2697 
26. Go back to the Tripwire Log Center Console. 2698 

https://arcsight-cons.di.ipdr:8091/tlc
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 2699 
27. Click Configuration Manager. 2700 
28. Click Resources > Tripwire Enterprise Servers. 2701 

 2702 
29. Click Add. 2703 
30. Enter a name for the server. 2704 
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31. Enter the URL of the Tripwire Enterprise server. 2705 
32. Enter the name of a user account on the Tripwire Enterprise server. The account must have the 2706 

following permissions: create, delete, link, load, update, view. 2707 

 2708 
33. Click Save. 2709 

2.19  Integration: Tripwire Log Center and Tripwire IP360 2710 

2.19.1  Configure IP360 and Log Center 2711 

1. On the Tripwire Log Center Manager machine, navigate to C:\Program Files\Tripwire\Tripwire 2712 
Log Center Manager\Agent Services\config. 2713 

2. Copy bridge_sample.properties to bridge.properties. 2714 
3. Modify the Pre-Shared Key to use a password by changing the following line (be sure to remove the “#” 2715 

sign): 2716 
tw.cap.bridge.registrationPreSharedKey=newpasswordhere 2717 

4. Save the file. 2718 
5. From the command line, run the following two commands: 2719 

> net stop TripwireBridge 2720 
> net start TripwireBridge 2721 

6. On the Tripwire IP360 machine, from the command line, enter the following command to 2722 
specify the hostname of the Tripwire Log Center (TLC) machine: 2723 
> tlc config bridge host update <hostname> 2724 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 385 

7. Enter the following command using the preshared key specified earlier: 2725 
> tlc config bridge password update <password> 2726 

8. Enter the following command to start the TLC service on the IP360 machine (this will use port 2727 
5670 on the TLC machine by default): 2728 
> system service tlc enable 2729 

9. Download the “Content update–June 2018” package from the Tripwire Customer Center. 2730 
10. Open the Tripwire Log Center Console. 2731 
11. Enter the username and password. 2732 

 2733 
12. Click Login. 2734 
13. Click Options > Import TLC Content > Content. 2735 
14. Select Use a custom file. 2736 
15. Click Browse, and locate the zip file downloaded from the Tripwire Customer Center. 2737 
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 2738 
16. Expand the Normalization Rules section. 2739 
17. Check the box next to Tripwire IP360 VnE. 2740 
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 2741 
18. Click Import. 2742 

2.19.2  Collect Tripwire IP360 Operational Logs 2743 

1. Click Configuration Manager. 2744 
2. Click Resources > Managers. 2745 
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 2746 
3. Double-click the Primary Manager. 2747 
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 2748 
4. Click the Installed Modules tab. 2749 
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 2750 
5. Ensure that there is an Advanced File Collector. If not, click the Create new module button, and 2751 

specify a name. Set the type to Advanced File Collector. If there is an Advanced File Collector, 2752 
skip this step. 2753 

6. Click OK. 2754 
7. Click Resources > Asset Groups. 2755 
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 2756 
8. Click Add. 2757 
9. Enter Tripwire VnE Managers in the Name field. 2758 
10. Click the Normalization Rules tab. 2759 

 2760 
11. Click Add. 2761 
12. Expand the Tripwire IP360 VnE group. 2762 
13. Click the Check selected rows button at the top to check the box next to everything in this 2763 

section. 2764 
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 2765 
14. Click OK. 2766 

 2767 
15. Click OK. 2768 
16. Click Resources > Monitored Assets.  2769 
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 2770 

17. Click Add Monitored Asset. 2771 
18. Enter a name. 2772 
19. Select Advanced File Collector for Collector. 2773 
20. Select the IP360 server from the Hostname drop-down. It may appear as an IP address. 2774 
21. Enter the IP address of the server. 2775 
22. Select ips for Asset type. 2776 
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 2777 
23. Click the Asset Groups tab. 2778 
24. Click Add.  2779 
25. Select Tripwire VnE Managers.  2780 

 2781 
26. Click Add. 2782 
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 2783 
27. Click the Output Destinations tab. 2784 
28. Click Add. 2785 
29. Select File–Text File for Input Type. 2786 
30. Select Correlation Engine for Output Destination. 2787 

 2788 
31. Click Add. 2789 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 396 

 2790 
32. Click the Log Sources tab. 2791 
33. Click Add. 2792 
34. Enter a name for the log.  2793 
35. Enter /data/log/ironwood.log for Log file path. 2794 
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 2795 
36. Click OK. 2796 
37. Click Add. 2797 
38. Enter a name for the log. 2798 
39. Enter /data/log/upgrade.log for Log file path.  2799 

 2800 
40. Click OK. 2801 
41. Click Add. 2802 
42. Enter a name for the log. 2803 
43. Enter /var/log/messages for Log file path. 2804 
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 2805 
44. Click OK. 2806 

 2807 
45. Click OK. 2808 
46. Click Resources > Managers. 2809 
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 2810 
47. Select the Primary Manager and click Push Updates to Manager.  2811 

2.19.3  Configure Tripwire IP360 Scan Results Forwarding 2812 

1. Click Configuration Manager. 2813 
2. Click Resources > Manager. 2814 
3. Double-click the Primary Manager. 2815 
4. Click the Advanced Settings tab. 2816 
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 2817 
5. Click Add. 2818 
6. Select Vulnerabilities–IP360 High Value Host Threshold for the Advanced Option.  2819 
7. Enter a number between 0 and 999,999,999 for the Value. This number corresponds to the 2820 

priority level of the host system being scanned. The value entered will be the minimum value 2821 
for a host machine to be considered high priority. Half of this value will be the minimum value 2822 
for a host machine to be considered medium priority. 2823 
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 2824 
8. Click Add. 2825 
9. Select Vulnerabilities–IP360 High Risk Score Threshold for the Advanced Option. 2826 
10. Enter a number between 0 and 999,999,999 for the Value. This number corresponds to the risk 2827 

level of a vulnerability event. The value entered will be the minimum value for an event to be 2828 
considered high risk. Half of this value will be the minimum value for an event to be considered 2829 
medium risk. 2830 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 402 

 2831 
11. Click Apply. 2832 
12. Click OK. 2833 
13. Click Resources > Monitored Assets. 2834 
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 2835 
14. Click Add Asset.  2836 
15. Select TLC File Collector for Collector. 2837 
16. Enter the IP address of the IP360 machine. 2838 
17. Select ips for Asset type. 2839 
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 2840 
18. Click the Asset Groups tab. 2841 
19. Click Add. 2842 
20. Select Tripwire VnE Managers for Host Group. 2843 
21. Click Add. 2844 
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 2845 
22. Click the Output Destinations tab. 2846 
23. Select File–IP360 for Input Type. 2847 
24. Select Events for Output Destination. 2848 

 2849 
25. Click Add. 2850 
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 2851 
26. Click OK. 2852 
27. Click Resources > Managers. 2853 
28. Select the Primary Manager. 2854 
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 2855 
29. Click Push Update to Manager. 2856 
30. Log in to the Tripwire IP360 Web Console. 2857 
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 2858 

31. Click Legacy UI at the top. 2859 
32. On the left, click Administer > System > VnE Manager > Automated Export. 2860 

 2861 
33. Click the Export to File tab.  2862 
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 2863 

34. Click Modify. 2864 
35. Enter the username of a TLC user account for User. 2865 
36. Enter the IP address of the TLC Manager for Host. 2866 
37. Enter “/” for the directory. 2867 
38. Select Active. 2868 
39. Select SSH2 DSA (sftp) for Protocol. 2869 
40. Select XML2 for Format. 2870 

 2871 
41. Click Submit. 2872 
42. Download the generated key by clicking [Inline].  2873 
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43. In TLC Console, click Configuration Manager. 2874 
44. Click Resources > Managers. 2875 

 2876 
45. Double-click the Primary Manager. 2877 
46. Click the File Collector tab. 2878 
47. Ensure that the Collect log messages via FTP and SSH option is enabled. 2879 
48. Enter 22 for the port. (Note: The IP360 Integration Guide says to use a different port, but the 2880 

IP360 system appears to be unable to use a port other than 22.) 2881 
49. Click Add. 2882 
50. Under Users, select the user for whom the key was generated. 2883 
51. Under Key Path, enter the path to the downloaded key. 2884 
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 2885 

52. Click OK. 2886 
53. Select the Primary Manager. 2887 
54. Click Push Updates to Manager. 2888 
55. On the IP360 web console, click Test to ensure that the connection is successful. 2889 

 2890 
56. Any recurring scans will now forward the scan results to Tripwire Log Center. To ensure that a 2891 

scan is recurring, select a scan in Scan Profiles on the main dashboard of the IP360 web console. 2892 
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  2893 
57. Click Edit. 2894 
58. Click Next until the Scan Schedule page. 2895 
59. Select Recurring, and set a schedule for the scan according to the needs of the organization. 2896 

 2897 
60. Click Finish.  2898 

2.20  Integration: Tripwire Enterprise and Backups 2899 

This section details how to back up Tripwire Enterprise configuration data. 2900 

To back up Tripwire Enterprise integrity information, refer to the database vendor’s documentation for 2901 
backing up data. 2902 
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2.20.1  Export Configuration from Tripwire Enterprise 2903 

1. On the Tripwire Enterprise server, navigate to C:\Program Files\Tripwire\TE\Server\bin. 2904 
2. Run the following command to stop Tripwire Services. 2905 

> twservices stop 2906 
3. Run the following command to export the configuration files to a backup (replace config.bak 2907 

with the desired name of the backup). 2908 
> tetool backup config.bak 2909 

4. Run the following command to restart Tripwire Services. 2910 
> twservices start 2911 

2.20.2  Back Up the Tripwire Enterprise Configuration 2912 

The configuration backup will be stored in the file specified in step 3 of the previous section. To back 2913 
this up to the enterprise backup server through a Duplicati client, see the documentation in Section 2914 
2.8.4 for how to set up a Duplicati instance on the Tripwire Enterprise server, and then simply select 2915 
the configuration file.   2916 

2.21  Integration: Cisco ISE and CryptoniteNXT 2917 

This section details an integration between Cisco ISE and CryptoniteNXT, allowing ISE to dictate the 2918 
Cryptonite registration process based on the posture of the client machine. Please see the 2919 
CryptoniteNXT Generic RADIUS Integration Guide for more details about the integration. 2920 

2.21.1  Requirements for Integrating Cisco ISE and CryptoniteNXT 2921 

As described in the ISE installation section, ISE requires RADIUS to be configured to perform posture. As 2922 
such, this guide assumes the use of some sort of switch to provide RADIUS functionality. 2923 

CryptoniteNXT requires the switch to use L2 technologies for the RADIUS server, which means a captive 2924 
portal will not work for this scenario. The feasibility of this depends on your networking setup.  2925 

This integration requires the following: 2926 

1. The switch is bridged to CryptoniteNXT. 2927 
2. Cryptonite is configured to accept RADIUS packets from the switch (detailed below). 2928 
3. Clients on the switch’s Local Area Network (LAN) authenticate to the switch via 802.1x (see your 2929 

switch’s documentation). 2930 
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4. The switch is configured to accept CoA packets from ISE (see ISE installation). 2931 
5. The switch sends RADIUS accounting and authentication packets to Cisco ISE (see ISE 2932 

installation). 2933 
6. ISE sends an authentication response to the switch and then later uses CoA to modify the 2934 

authorization based on posture (see ISE installation). 2935 
7. If the authorization is successful, the switch tells the client and forwards the accounting packets 2936 

to the CryptoniteNXT ACC node (see your switch’s documentation). 2937 

2.21.2  Configuring CryptoniteNXT for RADIUS 2938 

1. Open the CryptoniteNXT GUI and log in. 2939 
2. Navigate to the CryptoniteNXT Nodes tab.  2940 
3. Click Enable Editing. 2941 
4. Select the Endpoint node, which will have your switch attached to it. 2942 
5. Under Endpoint Node-Specific Configuration, select Strict Access for Access Control. 2943 
6. Select After Delay for the Portal/Whitelist Mode. 2944 
7. Enter -1 for Captive Portal delay. 2945 
8. Enter 5 for the Registration delay.  2946 
9. Select the Gateway node. 2947 

 2948 
10. Click Save. 2949 
11. Navigate to the Integration tab.  2950 
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12. Under Built-In RADIUS Configuration, check the box next to Enable Built-In RADIUS Accounting 2951 
Server. 2952 

 
13. Click the plus button to add the IP of the switch as well as a shared secret. You can use 0.0.0.0/0 2953 

as the IP to accept RADIUS Accounting packets from all IPs, however this is not recommended in 2954 
production. 2955 

2.22  Integration: Backups and GreenTec 2956 

This section details integration between the backup capability and GreenTec WORMdisks. Because 2957 
GreenTec WORMdisks provide write protection for files on the disk, they are an ideal place to store 2958 
important backups. There are a couple options for this integration, but before these backups can be 2959 
replicated onto secure storage, it is important to be able to identify the location of backups to be 2960 
replicated. 2961 

2.22.1  Locate Backups with FileZilla and Duplicati 2962 

1. To locate backups in FileZilla, open the FileZilla Server console. 2963 
2. Click Edit > Users. 2964 
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3. Click Shared folders in the left pane. 2965 

 
4. Under Directories is a list of directories in which the selected user can store backups. The one 2966 

marked H is the default home directory.  2967 
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5. The path to the backups from the home directory is specified in the Path on server field in 2968 
Duplicati (see Section 2.8.6).  2969 

 
6. Each backup should have three associated files. An easy way to determine what files belong 2970 

together is to check the Date Modified field. These files are encrypted. 2971 

2.22.2  Back Up to a GreenTec Disk 2972 

The first, most flexible option involves backing up the backup server to a separate server with GreenTec 2973 
WORMdisks. Simply set up a FileZilla server on the GreenTec storage server and a Duplicati client on 2974 
the backup server (see Section 2.8 for these installation processes). When choosing where to store files 2975 
on FileZilla, indicate a folder on the GreenTec WORMdisk. Sectors of the disk can be locked using the 2976 
mechanism in Section 2.6.4, providing firmware-level write security for any backups in the locked 2977 
sectors.  2978 

There are some considerations when doing this. First, if this is done on a schedule and permanent locks 2979 
are used, space will be consumed quickly and the WORMdisks will need replacements as the space 2980 
cannot be reused. The trade-off between space and backup frequency must be considered–a lower 2981 
backup frequency inevitably means more data loss in the event of a restoration, while higher backup 2982 
frequency increases the cost of maintaining secure storage.  2983 

Alternatively, secure storage can be used for specific types of backups, such as “golden disks”–which 2984 
would contain backups of the basic level of functionality required for the enterprise without necessarily 2985 
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utilizing a backup schedule. This would afford protection for some basic functionality but would forfeit 2986 
the secure storage capability for day-to-day data. 2987 

 2988 

In addition to the options above, there are other ways to minimize wasted space on a GreenTec disk. 2989 
Temporary Locks, or TLocks, can be employed after the data is backed up to a GreenTec disk to protect 2990 
data integrity while making less space unavailable for future use. After the drive is full, a permanent lock 2991 
should still be executed. Wasted space can also be minimized with the use of dynamic partitions, or 2992 
with the Force-Field Write-Once File System, which can also reduce the overhead administration of the 2993 
GreenTec disk. 2994 

2.22.3  Configure Network-Accessible GreenTec Disk 2995 

Another option for GreenTec disks is to make them network accessible. This allows them to be used 2996 
specifically in situations where secure storage protection is desired, and it makes them options for 2997 
backup locations even on servers to which they are not necessarily physically connected.  2998 

1. To configure a GreenTec disk to be network accessible, right-click the disk on the GreenTec 2999 
server.  3000 

 
2. Click Share With > Advanced Sharing.  3001 
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3. Click Advanced Sharing.  3002 
4. Check the box next to Share this folder. 3003 
5. Enter a name for the drive if desired. 3004 
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6. Click OK.  3005 
7. Click Close. 3006 
8. The drive should now be accessible at //SERVER-NAME/X. 3007 

2.22.4  Secure Storage for Semperis ADFR 3008 

1. On the Semperis ADFR server, the default backup location is C:\Semperis. 3009 
2. In this folder there is metadata for the backups (C:\Semperis\ADFR) as well as the backups 3010 

themselves (C:\Semperis\BackupStore). 3011 

 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 421 

It is important to consider the limitations of the backup software when considering whether to replicate 3012 
backups to secure storage. Ideally, the replication of backups ensures that they can be used on a 3013 
separate server when the original server is affected by an incident. The replication of backups in this 3014 
case can offer some write protection for these specific backup files, but if the entire server is lost, it is 3015 
not guaranteed that the backups will be usable on a new instance of ADFR. This risk can be mitigated by 3016 
exporting the configuration of the ADFR server for the purpose of building a failover ADFR server. 3017 

Though these backups can be replicated to WORMdisks, this is currently not supported by Semperis 3018 
ADFR. Instead, Semperis ADFR offers a different type of “secure storage” by not joining to the domain, 3019 
allowing the machine to be taken offline and brought online only during creation/application of a 3020 
backup. 3021 

2.23  Integration: Micro Focus ArcSight and FileZilla 3022 

In this section an integration between ArcSight and FileZilla is detailed so that logs from FileZilla are 3023 
forwarded to ArcSight by using an ArcSight syslog file connector.  3024 

2.23.1  Enable Logs in FileZilla 3025 

1. On the server with FileZilla installed, open FileZilla Server. 3026 

 
2. Click Edit > Settings. 3027 
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3. Click Logging.  3028 

 
4. Check the box next to Enable logging to file.  3029 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 423 

 
5. Click OK. 3030 

2.23.2  Install Micro Focus ArcSight  3031 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe. 3032 
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2. Click Next. 3033 
3. Enter C:\Program Files\ArcSightSmartConnectors\Windows. 3034 
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4. Click Next.  3035 

 
5. Click Next. 3036 
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6. Click Install. 3037 
7. Select Add a Connector. 3038 

 

8. Click Next. 3039 
9. Select Syslog File.  3040 
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10. Click Next. 3041 
11. Enter C:\Program Files (x86)\FileZilla Server\Logs\FileZilla Server.log for File Absolute Path 3042 

Name. 3043 
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12. Click Next. 3044 
13. Select ArcSight Manager (encrypted).  3045 
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14. Click Next. 3046 
15. Enter the hostname, port, username, and password for the ArcSight ESM server.  3047 
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16. Click Next. 3048 
17. Enter identifying details about the system (only Name is required). 3049 
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18. Click Next.  3050 
19. Select Import the certificate to connector from destination. 3051 
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20. Click Next.  3052 
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21. Click Next.  3053 
22. Select Install as a service. 3054 
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23. Click Next.  3055 
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24. Click Next.  3056 
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25. Click Next.  3057 
26. Select Exit. 3058 
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27. Click Next.  3059 
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28. Click Done.  3060 

2.24  Integration: Micro Focus ArcSight and Tripwire 3061 

This section details forwarding logs from Tripwire Log Center to Micro Focus ArcSight. This will forward 3062 
Tripwire IP360 and Tripwire Enterprise logs to ArcSight, assuming those logs are being collected by 3063 
Tripwire Log Center.  3064 

2.24.1  Install Micro Focus ArcSight  3065 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe on any server except the one running Tripwire 3066 
Log Center. 3067 
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2. Click Next. 3068 

 
3. Enter C:\Program Files\ArcSightSmartConnectors\Tripwire. 3069 
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4. Click Next. 3070 

 

5. Click Install. 3071 
6. Select Add a Connector. 3072 
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7. Click Next. 3073 
8. Select Syslog Daemon.  3074 
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9. Click Next. 3075 
10. Enter a port for the daemon to run on. 3076 
11. Select Raw TCP for Protocol. 3077 

 
12. Click Next. 3078 
13. Select ArcSight Manager (encrypted).  3079 
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14. Click Next. 3080 
15. Enter the hostname, port, username, and password for the ArcSight ESM server.  3081 
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16. Click Next. 3082 
17. Enter identifying details about the system (only Name is required). 3083 

 
18. Click Next.  3084 
19. Select Import the certificate to connector from destination. 3085 
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20. Click Next.  3086 

 
21. Click Next.  3087 
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22. Select Install as a service. 3088 

 
23. Click Next.  3089 

 



DRAFT 

NIST SP 1800-25C: Identifying and Protecting Assets Against Ransomware and Other Destructive Events 447 

24. Click Next.  3090 

 
25. Click Next.  3091 
26. Select Exit.  3092 
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27. Click Next.  3093 

 

28. Click Done. 3094 
29. Open the Tripwire Log Center Console. 3095 
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30. Go to the Configuration Manager. 3096 

 
31. Select Resources > Managers. 3097 
32. Double-click the Primary Manager. 3098 
33. Click the Advanced Settings tab. 
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34. Click the Add button. 3099 
35. In the Advanced Option box select Log Message Forwarding–Destinations. 3100 
36. In the Value box next to it, type <ip_address>:<port>:tcp with the IP address and port of the 3101 

syslog daemon just created.  3102 

 

37. Click OK. 3103 

 
38. Click OK.  3104 
39. Restart the Tripwire Log Center Manager.  3105 
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2.25  Integration: Micro Focus ArcSight and Cisco WSA 3106 

This integration briefly details how to send logs to an ArcSight syslog collector from Cisco WSA. Please 3107 
see Section 2.24 for instructions for setting up an ArcSight syslog collector. If a server is already 3108 
configured, you do not need to install a new one– simply forward logs to the address of that server. 3109 

2.25.1  Configure Cisco WSA to Forward Logs 3110 

1. In the Cisco WSA web client, navigate to System Administration > Log Subscriptions. 3111 

 
2. Click Add Log Subscription. 3112 
3. Select Access Logs for Log Type. (These are the logs of client web requests that have gone 3113 

through the proxy.) 3114 
4. Enter a name for Log Name. 3115 
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5. Select Syslog Push. 3116 
6. Enter the hostname of the ArcSight syslog collector server. 3117 
7. Select TCP. (Ensure that your syslog collector server is configured to use TCP.) 3118 
8. Enter 8192 or a custom message-size limit. 3119 
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9. Click Submit. 3120 
10. Click Commit Changes. 3121 
11. Enter a comment if desired. 3122 
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12. Click Commit Changes. The server will restart, so the web page connection will be temporarily 3123 

lost. 3124 

2.26  Integration: Micro Focus ArcSight and Cisco ISE 3125 

This integration briefly details how to send logs to an ArcSight syslog collector from Cisco ISE. Please see 3126 
Section 2.24 for instructions for setting up an ArcSight syslog collector. If a server is already configured, 3127 
you do not need to install a new one–simply forward logs to the address of that server. 3128 

2.26.1  Configure Cisco ISE to Forward Logs 3129 

1. In the Cisco ISE web client, navigate to Administration > System > Logging > Remote Logging 3130 
Targets. 3131 
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2. Click Add. 3132 
3. Enter a Name. 3133 
4. Enter the hostname of the ArcSight syslog collector server for Host/IP Address. 3134 
5. Select TCP SysLog for Target Type. (Ensure that your syslog collector server is configured to use 3135 

TCP.) 3136 
6. Enter 514 or the port used on the syslog server. 3137 
7. Enter 8192 or a custom message-size limit for Maximum Length. 3138 
8. Ensure that Status is set to Enabled. 3139 
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9. Click Submit. 3140 

 

10. Click Yes. 3141 
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2.26.2  Select Logs for Forwarding 3142 

1. Navigate to System > Logging > Logging Categories. 3143 

 

2. Select a log file to forward to ArcSight. 3144 
3. Click Edit. 3145 

 
4. Move the ArcSight logging target you just created to the Selected box. 3146 
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5. Click Save. 3147 
6. Repeat steps 1–5 for any log files you wish to forward to ArcSight. 3148 

2.27  Integration: Micro Focus ArcSight and Symantec DLP 3149 

This integration briefly details how to send logs to an ArcSight syslog collector from Symantec DLP. If a 3150 
server is already configured, you do not need to install a new one–simply forward logs to the address of 3151 
that server. It is important to note that DLP requires a UDP server, so a TCP syslog server will not work.  3152 

2.27.1  Install Micro Focus ArcSight  3153 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe on any server except the one running Cisco 3154 
Stealthwatch. 3155 
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2. Click Next. 3156 
3. Enter C:\Program Files\ArcSightSmartConnectors\WindowsUDP. 3157 

 
4. Click Next. 3158 
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5. Click Next. 3159 

 
6. Click Install. 3160 
7. Select Add a Connector. 3161 
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8. Click Next. 3162 
9. Select Syslog Daemon.  3163 

 
10. Click Next. 3164 
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11. Enter an unused port on which the daemon can run. (Ensure that this port is allowed through 3165 
the firewall.) 3166 

12. Select UDP for Protocol. 3167 

 
13. Click Next. 3168 
14. Select ArcSight Manager (encrypted).  3169 
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15. Click Next. 3170 
16. Enter the hostname, port, username, and password for the ArcSight ESM server.  3171 

 
17. Click Next. 3172 
18. Enter identifying details about the system (only Name is required). 3173 
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19. Click Next.  3174 
20. Select Import the certificate to connector from destination. 3175 
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21. Click Next.  3176 

 

22. Click Next.  3177 
23. Select Install as a service. 3178 
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24. Click Next.  3179 
25. Enter a service name and display name. 3180 
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26. Click Next.  3181 

 

27. Click Next.  3182 
28. Select Exit.  3183 
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29. Click Next.  3184 

 
30. Click Done. 3185 

2.27.2  Configure Symantec DLP to Forward Logs 3186 

1. Log in to the Symantec DLP web console. 3187 

 
2. Navigate to Manage > Policies > Response Rules. 3188 
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3. Click Add Response Rule. 3189 
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4. Click Next. 3190 
5. Enter a name for the rule. 3191 
6. Set any conditions for sending syslog messages. If you do not add conditions, all incidents will 3192 

be forwarded. 3193 
7. Select Log to a Syslog Server for Actions. 3194 
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8. Click Add Action. 3195 
9. Enter the IP address of the ArcSight syslog server. 3196 
10. Enter the port of the ArcSight syslog UDP server. 3197 
11. Select variables and format a log message to include all the information desired to be sent to 3198 

the ArcSight server. Below is a sample format for the syslog message, which can potentially be 3199 
parsed according to the needs of your organization. 3200 
 3201 
CEF:0|Symantec|DLP|12.0.1|ruleID|$POLICY$|5|BLOCKED=$BLOCKED$ 3202 
DATAOWNER_NAME=$DATAOWNER_NAME$ DATAOWNER_EMAIL=$DATAOWNER_EMAIL$ 3203 
ENDPOINT_DEVICE_ID=$ENDPOINT_DEVICE_ID$ 3204 
ENDPOINT_MACHINE=$ENDPOINT_MACHINE$ PATH=$PATH$ 3205 
FILE_NAME=$FILE_NAME$ PARENT_PATH=$PARENT_PATH$ 3206 
INCIDENT_ID=$INCIDENT_ID$ INCIDENT_SNAPSHOT=$INCIDENT_SNAPSHOT$ 3207 
MATCH_COUNT=$MATCH_COUNT$ RULES=$RULES$ PROTOCOL=$PROTOCOL$ 3208 
QUARANTINE_PARENT_PATH=$QUARANTINE_PARENT_PATH$ 3209 
RECIPIENTS=$RECIPIENTS$ SCAN=$SCAN$ SENDER=$SENDER$ 3210 
SEVERITY=$SEVERITY$ SUBJECT=$SUBJECT$ TARGET=$TARGET$ 3211 
FNAME=$ATTACHMENT_NAME$ 3212 
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12. Click Save. 3213 

2.28  Integration: Micro Focus ArcSight and CryptoniteNXT 3214 

This integration briefly details how to send logs to an ArcSight syslog collector from CryptoniteNXT. 3215 
Please see Section 2.24 for instructions for setting up an ArcSight syslog collector. If a server is already 3216 
configured, you do not need to install a new one– simply forward logs to the address of that server. 3217 
Ensure that you are using a TCP syslog collector. This section assumes that the collector is already under 3218 
CryponiteNXT’s network protection. 3219 

2.28.1  Configure CryptoniteNXT to Forward Logs to ArcSight 3220 

1. Navigate to the Enclave tab in the CryptoniteNXT ACC GUI. 3221 
2. Under SIEM Configuration, check the box next to SIEM is an internal endpoint. 3222 
3. Select the endpoint running the TCP syslog collector. 3223 
4. Enter the port used. 3224 
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5. Click Save. 3225 

2.29  Integration: Micro Focus ArcSight and Semperis DSP 3226 

This integration briefly details how to send logs to an ArcSight syslog collector from Semperis DSP. 3227 
Please see Section 2.24 for instructions for setting up an ArcSight syslog collector. If a server is already 3228 
configured, you do not need to install a new one–simply forward logs to the address of that server. 3229 

Note: This integration requires Semperis DSP version 2.6.  3230 

2.29.1  Configure Semperis DSP to Forward Logs 3231 

1. In Semperis DSP, navigate to Settings > SIEM Integration. 3232 
2. Check the box next to Enable SysLog. 3233 
3. Under Syslog Server, enter the hostname for the ArcSight syslog collector, as well as the port. 3234 
4. Select TCP. 3235 
5. Enter a value for Change Event Polling Frequency based on the needs of your organization– this 3236 

is how often it will poll for new logs to forward.  3237 
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6. Under Change Event Filtering, select AD Changed Items, and Send Operation Log to SysLog. 3238 
Ensure that All is selected for Partitions. 3239 

7. You can also select any specific operations, classes, and attributes to be forwarded or simply 3240 
leave as All. 3241 

 

8. Click Save.  3242 

 
9. Click Close.  3243 

2.30  Integrations: CryptoniteNXT 3244 

For the architecture, it is necessary to create the following source groups. If your organization’s desired 3245 
architecture is different from the one described in this document, it is necessary to adapt the following 3246 
instructions to avoid loss of network or security function. This section will describe the creation of 3247 
source groups and destination groups used in this enterprise. 3248 
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Create the following destination groups and source groups and apply them to the correct endpoints to 3249 
allow these products and integrations to communicate under CryptoniteNXT. 3250 

2.30.1  Active Directory and DNS 3251 

This guide assumes the use of Active Directory and DNS on the same Windows 2012 server. The 3252 
following ports may vary for other products. 3253 

Destination 
Group Name 

Source Group 
Name 

Protocol Port Range 

ad-dns ad-dns-clients TCP 389 
ad-dns ad-dns-clients UDP 389 
ad-dns ad-dns-clients UDP 53 
ad-dns ad-dns-clients TCP 88 
ad-dns ad-dns-clients UDP 88 
ad-dns ad-dns-clients TCP 25 
ad-dns ad-dns-clients TCP 42 
ad-dns ad-dns-clients TCP 137 
ad-dns ad-dns-clients TCP 139 
ad-dns ad-dns-clients TCP 53 
ad-dns ad-dns-clients TCP 636 
ad-dns ad-dns-clients TCP 3268:3269 
ad-dns ad-dns-clients TCP 445 
ad-dns ad-dns-clients UDP 445 
ad-dns ad-dns-clients TCP 9389 
ad-dns ad-dns-clients TCP 5722 
ad-dns ad-dns-clients TCP 464 
ad-dns ad-dns-clients UDP 464 
ad-dns ad-dns-clients UDP 123 
ad-dns ad-dns-clients UDP 137:138 
ad-dns ad-dns-clients UDP 67 
ad-dns ad-dns-clients UDP 2535 
ad-dns ad-dns-clients UDP 49152:65535 
ad-dns ad-dns-clients TCP 49152:65535 
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Endpoint  Source Groups Destination Groups 
(all endpoints that need access 
to AD/DNS) 

ad-dns-clients  

AD/DNS server  ad-dns 
 

2.30.2  Microsoft Exchange 3254 

This guide assumes the use of Microsoft Exchange. The following ports may vary for other products. 3255 

Destination 
Group Name 

Source Group 
Name 

Protocol Port Range 

exchange exchange-clients TCP 443 
exchange exchange-clients TCP 80 
exchange exchange-clients TCP 25 
exchange exchange-clients TCP 379 
exchange exchange-clients TCP 3268:3269 
exchange exchange-clients TCP 636 
exchange exchange-clients TCP 143 
exchange exchange-clients TCP 993 
exchange exchange-clients TCP 110 
exchange exchange-clients TCP 995 
exchange exchange-clients TCP 119 
exchange exchange-clients TCP 563 
exchange exchange-clients TCP 465 
exchange exchange-clients TCP 443691 
exchange exchange-clients TCP 102 
exchange exchange-clients TCP 135 
exchange exchange-clients TCP 389:390 
exchange exchange-clients TCP 53 
exchange exchange-clients UDP 53 
exchange exchange-clients TCP 2525 
exchange exchange-clients TCP 475 
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Endpoint  Source Groups Destination Groups 
MS Exchange exchange-clients exchange 
(all email clients) exchange-clients  
AD/DNS server exchange-clients  

 

2.30.3  FileZilla  3256 

The default port for FileZilla is 21. 3257 

1. To determine the ports being used for your instance, open the FileZilla console. 3258 
2. Navigate to Edit > Settings > General Settings > Listen on these ports, and allow any ports listed 3259 

here. 3260 
3. If your server listens in passive mode, navigate to Edit > Settings > Passive mode settings > Use 3261 

custom port range, and allow any ports listed here. 3262 
Destination 
Group Name 

Source Group 
Name 

Protocol Port Range 

FileZilla BackupClients TCP 21 (default–see instructions) 
FileZilla BackupClients TCP 51120-511230 (passive mode–see instructions) 

 

Endpoint  Source Groups Destination Groups 
(any endpoints that need to 
perform backups) 

BackupClients  

FileZilla server  FileZilla 
 

2.30.4  GreenTec 3263 

If GreenTec is configured to use a FileZilla server, refer to the above section. If GreenTec is configured to 3264 
use Windows Network Share, see below for ports required. 3265 

Destination 
Group Name 

Source Group 
Name 

Protocol Port Range 

NetworkShare GreenTecClients TCP 80 
NetworkShare GreenTecClients TCP 135-139 
NetworkShare GreenTecClients TCP 445 
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Endpoint  Source Groups Destination Groups 
(any endpoints that need access 
to GreenTec disks) 

GreenTecClients  

GreenTec server  NetworkShare 
 

2.30.5  Tripwire Enterprise 3266 

In Tripwire, the Axon Bridge is used for Tripwire Enterprise to contact endpoints. Therefore, the port 3267 
5670 must be allowed on endpoints to allow TE to initiate communications. Furthermore, TE requires 3268 
MSSQL to function, so it must be granted access to that as well. 3269 

Destination Group 
Name 

Source Group 
Name 

Protocol Port Range 

TripwireEnterprise TEClients TCP 443 
TripwireEnterprise TEClients TCP 8080 
TripwireEnterprise TEClients TCP 9898 
TripwireEnterprise TEClients TCP 1169 
TEAxon TripwireE TCP 5670 
MSSQL MSSQLClients TCP 1433 

 

Endpoint  Source Groups Destination Groups 
(any endpoints that need to be 
monitored by Tripwire 
Enterprise) 

TEClients TEAxon 

Tripwire Enterprise server TripwireE, MSSQLClients TripwireEnterprise 
MSSQL server  MSSQL 

 

2.30.6  ArcSight ESM 3270 

Destination 
Group Name 

Source Group 
Name 

Protocol Port Range 

ArcSight ArcSightConnectors TCP 8443 
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Endpoint  Source Groups Destination Groups 
(any endpoints with an ArcSight 
Connector installed) 

ArcSightConnectors  

ArcSight ESM server  ArcSight 
 

2.30.7  Cisco ISE 3271 

Please see the CryptoniteNXT Generic RADIUS Integration Guide for instructions on how ISE should be 3272 
integrated with CryptoniteNXT. 3273 

To access the web console for ISE, allow port 443 for any machines that should be able to access the ISE 3274 
administrative console.  3275 

To access the portal for ISE, allow port 8443 (default) for any machines that will need to access the 3276 
portal. You can find this value by looking at your portal configuration in ISE. 3277 

Furthermore, if RADIUS is configured for the posture integration, you will need to add any ports used in 3278 
RADIUS for both ISE and the internal switch. The default for these is 1812 (Authentication), 1813 3279 
(Accounting), and 1700 (CoA). RADIUS can be TCP or UDP, so you can restrict this to your organization’s 3280 
configuration. 3281 

Destination 
Group Name 

Source Group Name Protocol Port Range 

ISE ISEConsole TCP 443 
ISE ISEClients TCP 8443 
radius ISESwitch, ISEServer TCP 1812 
radius ISESwitch, ISEServer UDP 1812 
radius ISESwitch, ISEServer TCP 1813 
radius ISESwitch, ISEServer UDP 1813 
radius ISESwitch, ISEServer TCP 1700 
radius ISESwitch, ISEServer UDP 1700 

 

Endpoint  Source Groups Destination Groups 
(any endpoints that need to do 
posture under ISE) 

ISEClients  
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(any endpoints that need to 
access the ISE web console) 

ISEConsole  

ISE server ISEServer ISE, radius 
(internal switches or RADIUS 
servers used for ISE Posture) 

ISESwitch, ISEClients radius 

Cryptonite ACC Node  radius 

2.30.8  Semperis DSP 3282 

Semperis DSP recommends allowing full network access during the initial database sync. After that, the 3283 
following ports should be left open for communication. 3284 

Destination 
Group Name 

Source Group 
Name 

Protocol Port Range 

dsp dsp-admin TCP 443 
dsp dsp-agents TCP 8903 
dsp dsp-agents TCP 135 
dsp dsp-agents TCP 445 
dsp dsp-agents TCP 1024:1034 
ad-dsp dsp-client TCP 8772 
ad-dsp dsp-client TCP 8750 
ad-dsp dsp-client ICMP 0:255 

 

Endpoint  Source Groups Destination Groups 
(any endpoints that need admin 
access to DSP) 

dsp-admin  

Semperis DSP ad-dns-clients, dsp-client, 
exchange-clients 

dsp 

Active Directory server dsp-agents ad-dsp 
 

2.30.9  Symantec DLP 3285 

This largely depends on how distributed the setup of DLP is. See here for a list of ports required by 3286 
Symantec DLP: https://support.symantec.com/us/en/article.tech220846.html. 3287 

https://support.symantec.com/us/en/article.tech220846.html
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For this build, we used a single server that contained the database, so only the agents and 3288 
administrative clients needed to be allowed to communicate through Cryptonite.  3289 

Destination 
Group Name 

Source Group 
Name 

Protocol Port Range 

dlp dlp-admin TCP 443 
dlp dlp-clients TCP 10443 

 

2.30.10 Cisco WSA 3290 

WSA uses a proprietary command line, which means it does not have a way of authenticating to the 3291 
CryptoniteNXT portal. For devices such as this, there are two options.  3292 

1. The device can be left outside CryptoniteNXT. 3293 

2. The device can be placed under CryptoniteNXT on a CryptoniteNXT Endpoint Node with the 3294 
portal disabled.  3295 

To prevent MAC spoofing, by default Cryptonite pins MAC addresses to the port + VLAN (Virtual LAN) to 3296 
which a device is connected, so a malicious device connecting to the end-point node with the same 3297 
MAC as an already connected IP360 would still be required to authenticate. Physical security for the 3298 
end-point node can further mitigate concerns about MAC spoofing. 3299 

If you can find a way to authenticate WSA to CryptoniteNXT or decide to use the disabled portal option 3300 
with strong physical security, we provide the ports below for integration. 3301 

To access the web console for WSA, allow port 8080 for any machines that should be able to access the 3302 
ISE administrative console.  3303 

To access the proxy, allow port 80 and port 3128 for any machines that will need to go through the 3304 
proxy, which will likely be most clients in the enterprise. Port 80 is for the wpad.dat file, and port 3128 3305 
is for the proxy itself. 3306 

Destination 
Group Name 

Source Group Name Protocol Port Range 

wsa wsa-clients TCP 80 
wsa wsa-clients TCP 3128 
wsa wsa-admin TCP 8080 
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Endpoint  Source Groups Destination Groups 
(any endpoints that need to use 
the proxy to connect to the 
internet) 

wsa-clients  

(any endpoints that need to 
access the WSA web console) 

wsa-admin  

Cisco WSA  wsa 
 

2.30.11 Tripwire IP360 3307 

IP360 uses a proprietary command line, which means it does not have a way of authenticating to the 3308 
CryptoniteNXT portal. For devices such as this, there are two options.  3309 

3. The device can be left outside CryptoniteNXT. 3310 
4. The device can be placed under CryptoniteNXT on a CryptoniteNXT Endpoint Node with the 3311 

portal disabled.  3312 
To prevent MAC spoofing, by default Cryptonite pins MAC addresses to the port+VLAN to which a 3313 
device is connected, so a malicious device connecting to the end-point node with the same MAC as an 3314 
already connected IP360 would still be required to authenticate. Physical security for the end-point 3315 
node can further mitigate concerns about MAC spoofing. 3316 

If you can find a way to authenticate IP360 to CryptoniteNXT or decide to use the disabled portal option 3317 
with strong physical security, we provide the ports below for integration. 3318 

To access the web console for IP360, allow port 443 for any machines that should be able to access the 3319 
IP360 administrative console. 3320 

IP360 should have access to all ports of the client machines it needs to scan. Another option is to simply 3321 
add IP360 to all the source groups present in your enterprise, and it will give an overview of the 3322 
vulnerabilities of clients on ports that CryptoniteNXT is not actively protecting. Alternatively, you can 3323 
disable policy enforcement temporarily on the CryptoniteNXT Endpoint Node to which IP360 is 3324 
connected, but you should do this only during scans.  3325 

Destination 
Group Name 

Source Group Name Protocol Port Range 

ip360 ip360admin TCP 443 
scantarget ip360scanner TCP 1:65535 
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scantarget ip360scanner UDP 1:65535 
scantarget ip360scsanner ICMP 0:255 

 

Endpoint  Source Groups Destination Groups 
(any endpoints need to access 
the IP360 web console) 

ip360admin  

(any endpoints to be fully 
scanned by IP360) 

 scantarget 

IP360 ip360scanner ip360 
 

2.30.12 Tripwire Log Center, Tripwire IP360, Tripwire Enterprise, and ArcSight ESM 3326 

The guide details an integration among Tripwire IP360, Tripwire Enterprise, Tripwire Log Center, and 3327 
ArcSight ESM. This section describes the ports needed to allow the integrations through Cryptonite. 3328 

First, traffic must be allowed from Tripwire Log Center to the MSSQL server. To do this, ensure that 3329 
Tripwire Log Center can access 1433 on the MSSQL server. (Note: Tripwire Enterprise also has access to 3330 
this port, as described above in the Tripwire Enterprise section.) 3331 

Then traffic from Tripwire Enterprise to Tripwire Log Center should be allowed on ports 8091 and 1468. 3332 

Traffic from IP360 to Tripwire Log Center should be allowed on port 22 for the SFTP (Secure FTP) 3333 
transfer. Also, traffic from Tripwire Log Center to 5670 on Tripwire IP360 should be allowed. If you 3334 
chose to leave IP360 out of the Cryptonite NXT enclave, Tripwire Log Center will need to be able to 3335 
reach it externally. 3336 

Traffic from Tripwire Log Center to the machine containing the ArcSight TCP syslog container should be 3337 
allowed on the port configured (in the guide, we use port 514). As a last note, the server running the 3338 
ArcSight syslog connector requires an IP and not a hostname for its integration with Tripwire Log 3339 
Center–you must set a static IP for the connector server in Cryptonite and enter this IP in the 3340 
appropriate place in Tripwire Log Center’s configuration. 3341 

Destination Group 
Name 

Source Group Name Protocol Port Range 

MSSQL MSSQLClients TCP 1443 
TLC TLCClients TCP 8091 
TLC TLCClients TCP 1468 
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TLC TLCClients TCP 22 
ArcSightTCPSysConn TCPSysClients TCP 514 
ip360 ip360admin TCP 5670 

 

Endpoint  Source Groups Destination Groups 
Tripwire Log Center TCPSysClients, MSSQLClients, 

ip360admin 
TLC 

Tripwire Enterprise TLCClients  
(server running ArcSight TCP 
syslog connector) 

 ArcSightTCPSysConn 

MSSQL  MSSQL 
IP360 TLCClients ip360 

 

2.30.13 FileZilla and ArcSight 3342 

The guide details an integration between FileZilla and ArcSight ESM to forward logs from FileZilla to 3343 
ArcSight. This section describes the ports needed to allow the integrations through Cryptonite. 3344 

Because this integration involves the use of an ArcSight Connector directly on the FileZilla server, only 3345 
one port is needed. The FileZilla server should be able to directly communicate with 8443 on the 3346 
ArcSight ESM server. 3347 

Destination 
Group Name 

Source Group Name Protocol Port Range 

ArcSight ArcSightConnectors TCP 8443 
 

Endpoint  Source Groups Destination Groups 
FileZilla ArcSightConnectors  
ArcSight ESM  ArcSight 

 

2.30.14 Cisco ISE and ArcSight 3348 

The guide details an integration between Cisco ISE and ArcSight ESM to forward logs from ISE to 3349 
ArcSight. This section describes the ports needed to allow the integrations through Cryptonite.  3350 
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Traffic from Cisco ISE to the machine containing the ArcSight TCP syslog container should be allowed on 3351 
the port configured (in the guide, we use port 514).  3352 

Destination Group 
Name 

Source Group Name Protocol Port Range 

ArcSightTCPSysConn TCPSysClients TCP 514 
 3353 

Endpoint  Source Groups Destination Groups 
Cisco ISE TCPSysClients  
(server running ArcSight TCP 
syslog connector) 

 ArcSightTCPSysConn 

 3354 

2.30.15 Cisco WSA and ArcSight 3355 

The guide details an integration between Cisco WSA and ArcSight ESM to forward logs from WSA to 3356 
ArcSight. This section describes the ports needed to allow the integrations through Cryptonite.  3357 

Traffic from Cisco WSA to the machine containing the ArcSight TCP syslog container should be allowed 3358 
on the port configured (in the guide, we use port 514).  3359 

Destination Group 
Name 

Source Group Name Protocol Port Range 

ArcSightTCPSysConn TCPSysClients TCP 514 
 3360 

Endpoint  Source Groups Destination Groups 
Cisco WSA TCPSysClients  
(server running ArcSight TCP 
syslog connector) 

 ArcSightTCPSysConn 

 3361 

2.30.16 Semperis DSP and ArcSight 3362 

The guide details an integration between Semperis DSP and ArcSight ESM to forward logs from DSP to 3363 
ArcSight. This section describes the ports needed to allow the integrations through Cryptonite.  3364 
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Traffic from Semperis DSP to the machine containing the ArcSight TCP syslog container should be 3365 
allowed on the port configured (in the guide, we use port 514).  3366 

Destination Group 
Name 

Source Group Name Protocol Port Range 

ArcSightTCPSysConn TCPSysClients TCP 514 
 3367 

Endpoint  Source Groups Destination Groups 
Semperis DSP TCPSysClients  
(server running ArcSight TCP 
syslog connector) 

 ArcSightTCPSysConn 

 3368 

2.30.17 Symantec DLP and ArcSight 3369 

The guide details an integration between Symantec DLP and ArcSight ESM to forward logs from DLP to 3370 
ArcSight. This section describes the ports needed to allow the integrations through Cryptonite.  3371 

Traffic from Symantec DLP to the machine containing the ArcSight UDP syslog container should be 3372 
allowed on the port configured (in the guide, we use UDP and port 6514).  3373 

Destination Group 
Name 

Source Group Name Protocol Port Range 

ArcSightTCPSysConn TCPSysClients UDP 6514 
 3374 

Endpoint  Source Groups Destination Groups 
Symantec DLP TCPSysClients  
(server running ArcSight TCP 
syslog connector) 

 ArcSightTCPSysConn 
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Appendix A–List of Acronyms 3375 

ACC Administration Control Center 
AD Active Directory 
ADFR Active Directory Forest Recovery 
CoA Change of Authorization 
DHCP Dynamic Host Configuration Protocol 
DNS  Domain Name System 
DSP Directory Services Protector 
ESM Enterprise Security Manager 
FTP File Transfer Protocol 
FTPS File Transfer Protocol over TLS 
GUI Graphical User Interface 
IIS Internet Information Services 
ISE Identity Services Engine 
IT Information Technology 
JCE Java Cryptography Extension 
JRE Java Runtime Environment 
LAN Local Area Network 
MSSQL Microsoft SQL 
NAT Network Address Translation 
NCCoE National Cybersecurity Center of Excellence 
NIST National Institute of Standards and Technology 
OS Operating System 
PAC Proxy Auto Config 
RADIUS Remote Authentication Dial-In User Service 
SFTP Secure FTP 
SNMP Simple Network Management Protocol 
TE Tripwire Enterprise 
TLC Tripwire Log Center 
VLAN Virtual LAN 
WDV WORM Disk Volume 
WORM Write Once Read Many 
WPAD Web Proxy Auto Discovery 
WSA Web Security Appliance 
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