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DISCLAIMER 1 

Certain commercial entities, equipment, products, or materials may be identified by name or company 2 
logo or other insignia in order to acknowledge their participation in this collaboration or to describe an 3 
experimental procedure or concept adequately. Such identification is not intended to imply special sta-4 
tus or relationship with NIST or recommendation or endorsement by NIST or NCCoE; neither is it in-5 
tended to imply that the entities, equipment, products, or materials are necessarily the best available 6 
for the purpose. 7 
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NATIONAL CYBERSECURITY CENTER OF EXCELLENCE 22 

The National Cybersecurity Center of Excellence (NCCoE), a part of the National Institute of Standards 23 
and Technology (NIST), is a collaborative hub where industry organizations, government agencies, and 24 
academic institutions work together to address businesses’ most pressing cybersecurity issues. This 25 
public-private partnership enables the creation of practical cybersecurity solutions for specific 26 
industries, as well as for broad, cross-sector technology challenges. Through consortia under 27 
Cooperative Research and Development Agreements (CRADAs), including technology partners—from 28 
Fortune 50 market leaders to smaller companies specializing in information technology security—the 29 
NCCoE applies standards and best practices to develop modular, easily adaptable example cybersecurity 30 
solutions using commercially available technology. The NCCoE documents these example solutions in 31 
the NIST Special Publication 1800 series, which maps capabilities to the NIST Cybersecurity Framework 32 
and details the steps needed for another entity to re-create the example solution. The NCCoE was 33 
established in 2012 by NIST in partnership with the State of Maryland and Montgomery County, 34 
Maryland. 35 

To learn more about the NCCoE, visit https://www.nccoe.nist.gov/. To learn more about NIST, visit 36 
https://www.nist.gov. 37 

NIST CYBERSECURITY PRACTICE GUIDES 38 

NIST Cybersecurity Practice Guides (Special Publication 1800 series) target specific cybersecurity 39 
challenges in the public and private sectors. They are practical, user-friendly guides that facilitate the 40 
adoption of standards-based approaches to cybersecurity. They show members of the information 41 
security community how to implement example solutions that help them align more easily with relevant 42 
standards and best practices, and provide users with the materials lists, configuration files, and other 43 
information they need to implement a similar approach. 44 

The documents in this series describe example implementations of cybersecurity practices that 45 
businesses and other organizations may voluntarily adopt. These documents do not describe 46 
regulations or mandatory practices, nor do they carry statutory authority.  47 

ABSTRACT 48 

Ransomware, destructive malware, insider threats, and even honest mistakes present an ongoing threat 49 
to organizations that manage data in various forms. Database records and structure, system files, 50 
configurations, user files, application code, and customer data are all potential targets of data 51 
corruption and destruction. 52 

A quick, accurate, and thorough detection and response to a loss of data integrity can save an 53 
organization time, money, and headaches. While human knowledge and expertise is an essential 54 
component of these tasks, the right tools and preparation are essential to minimizing downtime and 55 

https://www.nccoe.nist.gov/
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losses due to data integrity events. The NCCoE, in collaboration with members of the business 56 
community and vendors of cybersecurity solutions, has built an example solution to address these data 57 
integrity challenges. This project details methods and potential tool sets that can detect, mitigate, and 58 
contain data integrity events in the components of an enterprise network. It also identifies tools and 59 
strategies to aid in a security team’s response to such an event. 60 

KEYWORDS 61 

attack vector; data integrity; malicious actor; malware; malware detection; malware response; 62 
ransomware. 63 
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The Technology Partners/Collaborators who participated in this build submitted their capabilities in 66 
response to a notice in the Federal Register. Respondents with relevant capabilities or product 67 
components were invited to sign a Cooperative Research and Development Agreement (CRADA) with 68 
NIST, allowing them to participate in a consortium to build this example solution. We worked with: 69 

Technology Partner/Collaborator Build Involvement 
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Symantec Security Analytics v8.0.1 

Cisco Systems Cisco Identity Services Engine v2.4, 
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Glasswall Government Solutions Glasswall FileTrust ATP for Email v6.90.2.5 
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Patch 2 
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1 Introduction 213 

The following guides show IT professionals and security engineers how we implemented this example 214 
solution. We cover all of the products employed in this reference design. We do not recreate the 215 
product manufacturers’ documentation, which is presumed to be widely available. Rather, these guides 216 
show how we incorporated the products together in our environment. 217 

Note: These are not comprehensive tutorials. There are many possible service and security 218 
configurations for these products that are out of scope for this reference design. 219 

1.1 Practice Guide Structure 220 

This NIST Cybersecurity Practice Guide demonstrates a standards-based reference design and provides 221 
users with the information they need to replicate the data integrity detection and response solution. 222 
This reference design is modular and can be deployed in whole or in parts. 223 

This guide contains three volumes: 224 

 NIST SP 1800-26a: Executive Summary 225 

 NIST SP 1800-26b: Approach, Architecture, and Security Characteristics – what we built and why 226 

 NIST SP 1800-26c: How-To Guides – instructions for building the example solution (you are 227 
here) 228 

Depending on your role in your organization, you might use this guide in different ways: 229 

Business decision makers, including chief security and technology officers will be interested in the 230 
Executive Summary (NIST SP 1800-26a), which describes the: 231 

 challenges enterprises face in detecting and responding to data integrity events 232 

 example solution built at the NCCoE 233 

 benefits of adopting the example solution 234 

Technology or security program managers who are concerned with how to identify, understand, 235 
assess, and mitigate risk will be interested in NIST SP 1800-26b, which describes what we did and why. 236 
The following sections will be of particular interest: 237 

 Section 3.4.1, Risk, provides a description of the risk analysis we performed. 238 

 Section 3.4.2, Security Control Map, maps the security characteristics of this example solution 239 
to cybersecurity standards and best practices. 240 

You might share the Executive Summary, NIST SP 1800-26a, with your leadership team members to help 241 
them understand the importance of adopting standards-based data integrity solutions. 242 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 2 

IT professionals who want to implement an approach like this will find the whole practice guide useful. 243 
You can use the How-To portion of the guide, NIST SP 1800-26c, to replicate all or parts of the build 244 
created in our lab. The How-To guide provides specific product installation, configuration, and 245 
integration instructions for implementing the example solution. We do not recreate the product 246 
manufacturers’ documentation, which is generally widely available. Rather, we show how we 247 
incorporated the products together in our environment to create an example solution. 248 

This guide assumes that IT professionals have experience implementing security products within the 249 
enterprise. While we have used a suite of commercial products to address this challenge, this guide 250 
does not endorse these particular products. Your organization can adopt this solution or one that 251 
adheres to these guidelines in whole, or you can use this guide as a starting point for tailoring and 252 
implementing parts of a data integrity detection and response solution. Your organization’s security 253 
experts should identify the products that will best integrate with your existing tools and IT system 254 
infrastructure. We hope you will seek products that are congruent with applicable standards and best 255 
practices. Volume B, Section 3.5, Technologies, lists the products we used and maps them to the 256 
cybersecurity controls provided by this reference solution. 257 

A NIST Cybersecurity Practice Guide does not describe “the” solution, but a possible solution. This is a 258 
draft guide. We seek feedback on its contents and welcome your input. Comments, suggestions, and 259 
success stories will improve subsequent versions of this guide. Please contribute your thoughts to ds-260 
nccoe@nist.gov. 261 

1.2 Build Overview 262 

The NCCoE built a hybrid virtual-physical laboratory environment to explore methods to effectively 263 
detect and respond to a data corruption event in various Information Technology (IT) enterprise 264 
environments. NCCoE also explored the issues of analysis and reporting to support incident response. 265 
The servers in the virtual environment were built to the hardware specifications of their specific 266 
software components. 267 

The NCCoE worked with members of the Data Integrity Community of Interest to develop a diverse (but 268 
non-comprehensive) set of use case scenarios against which to test the reference implementation. 269 
These are detailed in Volume B, Section 5.2. For a detailed description of our architecture, see Volume 270 
B, Section 4. 271 

mailto:ds-nccoe@nist.gov
mailto:ds-nccoe@nist.gov
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1.3 Typographical Conventions 272 

The following table presents typographic conventions used in this volume. 273 

Typeface/ Symbol Meaning Example 

Italics filenames and pathnames 
references to documents 
that are not hyperlinks, new 
terms, and placeholders 

For detailed definitions of terms, see 
the NCCoE Glossary. 

Bold names of menus, options, 
command buttons and fields 

Choose File > Edit. 

Monospace command-line input, on-
screen computer output, 
sample code examples, sta-
tus codes 

mkdir 

Monospace Bold command-line user input 
contrasted with computer 
output 

service sshd start 

blue text link to other parts of the 
document, a web URL, or an 
email address 

All publications from NIST’s National 
Cybersecurity Center of Excellence 
are available at http://nccoe.nist.gov 

2 Product Installation Guides 274 

This section of the practice guide contains detailed instructions for installing and configuring all of the 275 
products used to build an instance of the example solution. 276 

2.1 Active Directory and Domain Name System Server 277 

As part of our enterprise emulation, we included an Active Directory server that doubles as a Domain 278 
Name System (DNS) server. This section covers the installation and configuration process used to set up 279 
Active Directory and DNS on a Windows Server 2012 R2 machine. 280 

2.1.1 Install Features 281 

1. Open Server Manager.  282 

http://nccoe.nist.gov/
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 283 
2. Click the link Add roles and features. 284 

 285 
3. Click Next.  286 
4. Select Role-based or feature-based installation. 287 
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 288 
5. Click Next.  289 
6. Select Select a server from the server pool. 290 
7. Select the intended active directory server. 291 
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 292 
8. Click Next.  293 
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 294 
9. Check the box next to Active Directory Domain Services. 295 
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 296 
10. Click Add Features. 297 
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 298 
11. Click Next. 299 
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 300 
12. Click Next. 301 

 302 
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13. Click Next. 303 

 304 
14. Click Install. 305 
15. Wait for the installation to complete. 306 
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 307 
16. Click Close. 308 

 309 
17. Click Promote this server to a domain controller. 310 
18. Select Add a new forest. 311 
19. Enter a Root domain name.  312 
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 313 
20. Click Next. 314 
21. Select Windows Server 2012 R2 for Forest functional level and Domain functional level. 315 
22. Check the box next to Domain Name System (DNS) server. 316 
23. Enter a password. 317 
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 318 
24. Click Next. 319 

 320 
25. Click Next. 321 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 15 

26. Verify the domain name. 322 

 323 
27. Click Next. 324 

 325 
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28. Click Next. 326 

 327 
29. Click Next. 328 

 329 
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30. Click Install. 330 
31. Wait for the installation to complete. 331 
32. The server automatically reboots. 332 

2.1.2 Create a Certificate Authority 333 

1. Open Server Manager. 334 

 335 
2. Click Add roles and features. 336 
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 337 
3. Click Next. 338 
4. Select Role-based or feature-based installation. 339 

 340 
5. Click Next. 341 
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6. Select Select a server from the server pool. 342 
7. Select the intended Active Directory server. 343 

 344 
8. Click Next. 345 

 346 
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9. Check the box next to Active Directory Certificate Services. 347 

 348 
10. Click Add Features. 349 

 350 
11. Click Next. 351 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 21 

 352 
12. Click Next. 353 

 354 
13. Click Next. 355 
14. Check the box next to Certification Authority. 356 
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 357 
15. Click Next. 358 

 359 
16. Click Install. 360 
17. Wait for the installation to complete. 361 
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 362 
18. Click Close. 363 

 364 
19. Click Configure Active Directory Certificate Serves on the destination server. 365 
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 366 
20. Click Next. 367 
21. Check the box next to Certification Authority. 368 

 369 
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22. Click Next. 370 
23. Select Enterprise CA. 371 

 372 
24. Click Next. 373 
25. Select Root CA. 374 

 375 
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26. Click Next. 376 
27. Select Create a new private key. 377 

 378 
28. Click Next. 379 
29. Select RSA#Microsoft Software Key Storage Provider. 380 
30. Set the Key length to 2048. 381 
31. Select SHA512 from the list. 382 
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 383 
32. Click Next. 384 

  385 
33. Click Next. 386 
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34. Set the validity period of the certificate according to the needs of your organization. 387 

 388 
35. Click Next. 389 

 390 
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36. Click Next. 391 

 392 
37. Click Configure. 393 

 394 
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38. Click Close. 395 

2.1.3 Configure Account to Add Computers to Domain 396 

1. Open the Start menu. 397 
2. Enter dsa.msc, and run the program. 398 

 399 
3. Right-click on Users in the left panel. 400 
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 401 
4. Click Delegate Control. 402 

 403 
5. Click Next. 404 
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 405 
6. Click Add to select users or groups. 406 
7. Add users or groups. 407 

 408 
8. Click OK. 409 
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 410 
9. Click Next. 411 
10. Choose Create a custom task to delegate. 412 

 413 
11. Click Next. 414 
12. Choose Only the following objects in the folder. 415 
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13. Check the box next to Computer objects. 416 
14. Check the box next to Create selected objects in this folder. 417 
15. Check the box next to Delete selected objects in this folder. 418 

 419 
16. Click Next. 420 
17. Check the boxes next to Reset password, Read and write account restrictions, Validated write 421 

to DNS host name, and Validated write to service principal name. 422 
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 423 
18. Click Next. 424 

 425 
19. Click Finish. 426 
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2.1.4 Add Machines to the Domain 427 

1. Right-click the network icon in the task bar, on a computer that you wish to add to the domain. 428 
2. Click Open Network and Sharing Center. 429 

 430 
3. Click the name of the internet adapter. 431 
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 432 
4. Click Properties. 433 

 434 
5. Double-click Internet Protocol Version 4 (TCP/IPv4). 435 
6. Select Use the following DNS server addresses. 436 
7. Enter the IP address of the DNS server. 437 
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 438 
8. Click OK. 439 
9. Click OK. 440 

 441 
10. Click Close. 442 
11. Navigate to This PC. 443 
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 444 
12. Right-click in the window, and click Properties. 445 

 446 
13. Click Change Settings. 447 
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 448 
14. Click Change. 449 
15. Select Domain. 450 
16. Enter the domain. 451 

 452 
17. Click OK. 453 
18. Enter the name and password of an account with privileges to add computers to the domain. 454 
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 455 
19. Click OK. 456 

 457 
20. Click OK when prompted to restart the computer. 458 

2.1.5 Configure Active Directory to Audit Account Activity 459 

1. Open the Start Menu. 460 
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 461 
2. Enter Local Security Policy in the search bar, and open the program. 462 
3. Navigate to Local Policies > Audit Policy. 463 
4. Right-click Audit account management. 464 

 465 
5. Click Properties. 466 
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6. Check the boxes next to Success and Failure. 467 

 468 
7. Click OK.  469 

2.1.6 Configure Reverse Lookup Zones 470 

1. Open DNS Manager by right-clicking the DNS server in Server Manager. 471 
2. Click Reverse Lookup Zones. 472 

 473 
3. Click Action > New Zone. 474 
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 475 
4. Click Next. 476 

 477 
5. Click Next. 478 
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 479 
6. Click Next. 480 

 481 
7. Click Next. 482 
8. Enter the first three parts of the IP address of the AD/DNS server (for example, 192.168.1). 483 
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 484 
9. Click Next. 485 

 486 
10. Click Next. 487 
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 488 
11. Click Finish. 489 
12. Click on the newly created reverse lookup zone. 490 

 491 
13. Right-click in the window and select New Pointer (PTR)…. 492 
14. Enter the IP address of the AD/DNS server. 493 
15. Enter the hostname of the AD/DNS server. 494 
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 495 
16. Click OK. 496 

 497 

2.2 Microsoft Exchange Server 498 

As part of our enterprise emulation, we include a Microsoft Exchange server. This section covers the 499 
installation and configuration process used to set up Microsoft Exchange on a Windows Server 2012 R2 500 
machine. 501 
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2.2.1 Install Microsoft Exchange 502 

1. Run Exchange2016-x64.exe. 503 
2. Choose the directory for the extracted files. 504 

 505 
3. Click OK. 506 

 507 
4. Enter the directory and run setup.exe.  508 
5. Select Connect to the Internet and check for updates. 509 
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 510 
6. Click Next. 511 
7. Wait for the check to finish. 512 
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 513 
8. Click Next. 514 
9. Wait for the copying to finish. 515 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 52 

 516 
10. Click Next. 517 
11. Click I accept the terms in the license agreement. 518 
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 519 
12. Click Next.  520 
13. Click Use Recommended Settings. 521 
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 522 
14. Click Next.  523 
15. Check Mailbox role. 524 
16. Check Automatically install Windows Server roles and features that are required to install 525 

Exchange Server. 526 
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 527 
17. Click Next. 528 
18. Specify the installation path for MS Exchange. 529 
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 530 
19. Click Next.  531 
20. Specify the name for the Exchange organization, for example, DI. 532 
21. Decide whether to apply split permissions, based on the needs of the enterprise. 533 
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 534 
22. Click Next.  535 
23. Select No. 536 
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 537 
24. Click Next.  538 
25. Install any prerequisites listed. 539 
26. If necessary, restart the server and re-run setup.exe, completing steps 3-22 again. 540 
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 541 
27. Click Install.  542 

2.3 Windows Server Hyper-V Role 543 

As part of our simulated enterprise, we include a Windows Hyper-V server. This section covers the 544 
instructions for installing Windows Server Hyper-V on a Windows Server 2012 R2 machine. 545 

The instructions for enabling the Windows Server Hyper-V Role are retrieved from 546 
https://technet.microsoft.com/en-us/library/hh846766(v=ws.11).aspx and are replicated below for 547 
preservation and ease of use. 548 

2.3.1 Production Installation 549 

1. In Server Manager, on the Manage menu, click Add Roles and Features. 550 

https://technet.microsoft.com/en-us/library/hh846766(v=ws.11).aspx
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 551 
2. On the Before you begin page, verify that your destination server and network environment are 552 

prepared for the role and feature you want to install.  553 

 554 
3. Click Next. 555 
4. On the Select installation type page, select Role-based or feature-based installation. 556 
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 557 
5. Click Next. 558 
6. On the Select destination server page, select a server from the server pool. 559 

 560 
7. Click Next. 561 
8. On the Select server roles page, select Hyper-V. 562 
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9. To add the tools that you use to create and manage virtual machines, click Add Features. 563 

 564 
10. Click Next. 565 

 566 
11. Click Next. 567 
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 568 
12. Click Next. 569 
13. On the Create Virtual Switches page, select the appropriate options. 570 

 571 
14. Click Next.  572 
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15. On the Virtual Machine Migration page, select the appropriate options. 573 

 574 
16. Click Next. 575 
17. On the Default Stores page, select the appropriate options. 576 

 577 
18. Click Next.  578 
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19. On the Confirm installation selections page, select Restart the destination server automati-579 
cally if required. 580 

 581 
20. Click Install. 582 
21. When installation is finished, verify that Hyper-V installed correctly. Open the All Servers page 583 

in Server Manager, and select a server on which you installed Hyper-V. Check the Roles and 584 
Features tile on the page for the selected server. 585 

2.4 MS SQL Server 586 

As part of both our enterprise emulation and data integrity solution, we include a Microsoft SQL Server. 587 
This section covers the installation and configuration process used to set up Microsoft SQL Server on a 588 
Windows Server 2012 R2 machine. 589 

2.4.1 Install and Configure MS SQL 590 

1. Acquire SQL Server 2014 Installation Media. 591 
2. Locate the installation media in the machine and click on SQL2014_x64_ENU to launch SQL 592 

Server Installation Center. 593 
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 594 
3. On the left menu, select Installation. 595 

 596 
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4. Select New SQL Server stand-alone installation or add features to an existing installation. This 597 
will launch the SQL Server 2014 setup. 598 

5. In the Product Key section, enter your product key. 599 

 600 
6. Click Next. 601 
7. In the License Terms section, read and click I accept the license terms. 602 
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 603 
8. Click Next.  604 
9. In the Install Rules section, note and resolve any further conflicts.  605 

 606 
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10. Click Next. 607 
11. In the Setup Role section, select SQL Server Feature Installation.  608 

 609 
12. Click Next. 610 
13. In the Feature Selection section, select the following: 611 

a. Database Engine Services 612 
b. Client Tools Connectivity 613 
c. Client Tools Backwards Compatibility 614 
d. Client Tools SDK 615 
e. Management Tools – Basic 616 
f. Management Tools – Complete 617 
g. SQL Client Connectivity SDK 618 
h. Any other desired features 619 
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 620 
14. Click Next. 621 
15. In the Instance Configuration section, select Default instance. 622 

 623 
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16. Click Next. 624 

 625 
17. In the Server Configuration section, click Next. 626 
18. In the Database Engine Configuration section, make sure Mixed Mode is selected. 627 
19. Add all desired users as Administrators under Specify SQL Server Administrators by pressing 628 

Add Current User. 629 
a. For Domain accounts, simply type in $DOMAINNAME\$USERNAME into Enter the 630 

object names to select textbox. 631 
b. Click OK. 632 
c. For local computer accounts, click on locations and select the computer's name. 633 
d. Click OK. 634 
e. Type the username into the Enter the object names to select textbox. 635 
f. Once you are finished adding users, click Next. 636 
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 637 

20. In the Ready to install section, verify the installation and click Install. 638 

 639 
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21. Wait for the install to finish.  640 

 641 
22. Click Close. 642 

2.4.2 Open Port on Firewall 643 

1. Open Windows Firewall with Advanced Security. 644 
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 645 
2. Click Inbound Rules. 646 

 647 
3. Click New Rule. 648 
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4. Select Port. 649 
5. Click Next.  650 
6. Select TCP and Specific local ports. 651 
7. Type 1433 into the text field. 652 

 653 
8. Click Next. 654 
9. Select Allow the connection. 655 
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 656 
10. Click Next. 657 
11. Select all applicable locations. 658 
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 659 
12. Click Next.  660 
13. Name the rule Allow SQL Access. 661 
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 662 
14. Click Finish. 663 

2.4.3 Add a New Login to the Database 664 

1. Open SQL Server Management Studio. 665 

 666 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 79 

2. Click Connect to connect to the database. 667 
3. In the Object Explorer window, expand the Security folder. 668 

 669 
4. Right-click on the Logins folder and click New Login…. 670 
5. Input the desired user. 671 

 672 
6. Click OK. 673 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 80 

2.5 Microsoft IIS Server 674 

As part of our enterprise emulation, we include a Microsoft IIS server. This section covers the 675 
installation and configuration process used to set up Microsoft Exchange on a Windows Server 2012 R2 676 
machine. This was conducted on the same machine as section 2.4.  677 

2.5.1 Install IIS 678 

1. Open Server Manager. 679 

 680 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 81 

2. Click Add Roles and Features.681 

 682 
3. Click Next. 683 
4. Select Role-based or feature-based installation.684 

 685 
5. Click Next. 686 
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6. Select MSSQL (or the correct Windows Server name) from the list.687 

 688 
7. Click Next. 689 

 690 
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8. Check the box next to Web Server (IIS).691 

 692 
9. Click Add Features.693 

 694 
10. Click Next. 695 
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11. Ensure that all desired features are selected.696 

 697 
12. Click Next. 698 

 699 
13. Click Next.  700 
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14. Ensure that Default Document, Directory Browsing, HTTP Errors, Static Content, HTTP Logging, 701 
and any other desired Role services are selected.702 

 703 
15. Click Next. 704 

 705 
16. Click Install. 706 
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 707 
17. Wait for the installation to complete.708 

 709 
18. Click Close. 710 
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2.5.2 IIS Configuration 711 

1. Open Windows Explorer and click This PC.712 

 713 
2. Right-click, and select Create Folder. 714 
3. Name the folder www.715 

 716 
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4. Open the Internet Information Services (IIS) Manager.717 

 718 
5. Click the arrow next to MSSQL (or the chosen name of the server). 719 
6. Click Sites. 720 

 721 
7. Click Add Website…. 722 
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 723 
8. Enter the desired site name. 724 

 725 
9. Click … under Physical path:. 726 
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 727 
10. Locate and select the folder created in Step 3.728 

 729 
11. Click OK.  730 
12. Set Type to http and Port to 80. 731 
13. Ensure the IP address and Host name fields are filled in with the correct information for the ma-732 

chine. 733 
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14. Ensure that Start Website immediately is selected.734 

 735 
15. Click OK. 736 

2.6 Semperis Directory Services Protector 737 

This section details the installation of Semperis Directory Services Protector (DSP), a tool used for 738 
monitoring Active Directory environments. This installation requires both a copy of SQL Server Express 739 
as well as the Semperis Wizard. See the Semperis DS Protector v2.5 Technical Requirements document 740 
for specifics on the requirements. For a Windows Server 2012 R2 installation, simply meet the following 741 
requirements:  742 

• .NET Framework Version 3.5 SP1 743 
• .NET Framework Version 4.5.2 or later 744 
• Joined to the Active Directory Domain it is protecting 745 
• Either the installer for SQL Express Advanced or connection information and credentials for a 746 

full version of Microsoft SQL (MSSQL) 747 

2.6.1 Configure Active Directory for Semperis DSP 748 

1. Open Active Directory Users and Computers. 749 
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 750 
2. Right-click Users in the left pane, and select New > User.  751 
3. Enter the information for a new user for the DSP service.  752 

 753 
4. Click Next.  754 
5. Enter a password twice for this user. 755 
6. Set the password policy. 756 
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 757 
7. Click Next. 758 
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 759 
8. Click Finish. 760 
9. Open Group Policy Management. 761 
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 762 
10. Right-click Domains > DI.IPDR > Domain Controllers > Default Domain Controllers Policy, and 763 

click Edit. 764 
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 765 
11. Navigate to Computer Configuration > Policies > Windows Settings > Security Settings > 766 

Advanced Audit Policy Configuration > Audit Policies > Account Management. 767 
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 768 
12. Edit the Audit User Account Management field by double-clicking it. 769 
13. Check the box next to Configure the following audit events. 770 
14. Check the box next to Success. 771 
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 772 
15. Click OK. 773 
16. Go to Audit Policies > DS Access.  774 
17. Double-click Audit Directory Services Changes. 775 
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 776 
18. Check the box next to Configure the following audit events. 777 
19. Check the box next to Success. 778 
20. Click OK. 779 

 780 
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21. Open Active Directory Users and Computers. 781 
22. Ensure View > Advanced Features is enabled. 782 
23. Right-click the domain (for example, DI.IPDR) created earlier, and click Properties. 783 

 784 
24. Click the Security tab. 785 

 786 
25. Click Advanced. 787 
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 788 
26. Click the Auditing tab. 789 
27. Click Add. 790 
28. Enter Everyone. 791 

 792 
29. Click OK. 793 
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 794 
30. Double-click Everyone. 795 
31. Check the boxes next to Write all properties, Delete, Delete subtree, Modify permissions, 796 

Modify owner, All validated writes, All extended rights, Create all child objects, Delete all 797 
child objects. 798 

 799 
32. Click OK. 800 
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 801 
33. Click OK. 802 

2.6.2 Install Semperis DSP 803 

1. If you are using a local SQL Express Advanced server, place the SQLEXPRADV_x64_ENU.exe 804 
installer in a directory called Setup, and ensure that the Semperis Wizard is adjacent to the 805 
Setup folder (not inside it). If a SQL Express Advanced server is not being used, no Setup folder 806 
is required. 807 
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 808 
2. If prompted to restart the computer, do so. 809 
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 810 
3. Click I Agree. 811 
4. Select Evaluation License. 812 
5. Select Active Directory State Management. 813 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 106 

 814 
6. Click the > button. 815 
7. Enter the username and password of the account created earlier.  816 
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 817 
8. Click the > button. 818 

 819 
9. Click OK. 820 
10. Check the box next to Create the following group. 821 
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 822 
11. Click OK. 823 

 824 
12. Click the > button. 825 
13. Select the appropriate database option, and enter any required information. 826 
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 827 
14. Click the > button. 828 

 829 
15. Click OK. 830 
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 831 
16. Click the > button after the installation completes. 832 
17. There should now be a shortcut on the desktop linking to the web console for Semperis DS 833 

Protector. 834 
18. On the login page, enter the full domain as well as the NetBIOS name. 835 
19. Enter the username and password of an administrator on the domain. 836 
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 837 
20. Click Login. 838 
21. Check the box next to the domain controllers that should be monitored by DSP. 839 

 840 
22. Click Run Action. 841 
23. Enter the password for the account. 842 
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 843 
24. Click OK. 844 

 845 
25. Click Close. 846 
26. After the agent finishes deploying, click Login at the top of the page, and log in. 847 
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 848 
27. Click Start Sync. 849 
28. After this completes, click Settings at the top of the page. 850 

 851 
29. Click Audit. 852 
30. Click Run. 853 
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 854 
31. Click Next. 855 

 856 
32. Click Next. 857 
33. Check the boxes next to any Domain Controllers that should be monitored. 858 
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 859 
34. Click Run Action. 860 
35. Enter the password. 861 

 862 
36. Click OK. 863 
37. Wait for the deployment to finish. 864 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 116 

 865 
38. Click Next. 866 

 867 
39. Click Finish. 868 

2.6.3 Roll Back Changes with Semperis DSP 869 

1. Go to Changed Items on the left navigation bar. 870 
2. Check the box next to any undesired Active Directory changes. 871 
3. Click the … button to view more details about the change. 872 
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 873 
4. Click Undo Selected to roll back these changes. 874 

2.6.4 Configure Reporting with Semperis DSP 875 

1. Click Reports on the left sidebar in the Semperis DSP web console. 876 
2. Under Generate Report, reports can be viewed instantly, by selecting a type of report and 877 

clicking Create. 878 

 879 
3. Under Scheduled Reports, click Generate to automatically email specific reports. 880 
4. Select a report type and a schedule. 881 
5. Enter the email addresses of anyone who should receive this report. 882 
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 883 
6. Click Save. 884 

2.6.5 Configure Email Alerts with Semperis DSP 885 

1. Click Settings on the Semperis DSP web console. 886 
2. Expand the Email Alerts section. 887 
3. Click Edit. 888 
4. Enter the information of the organization’s email server as well as an email address from which 889 

to send.  890 

 891 
5. Click Save. 892 
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6. Enter an email address to which to send a test email. 893 

 894 
7. Click Validate & Save. 895 
8. Under Alert Recipients, add any desired recipients of alerts. 896 

 897 
9. Click Add. 898 
10. Configure any schedule settings according to your organization’s needs. 899 
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2.7 Glasswall FileTrustTM for Email 900 

The following sections will detail the installation of Glasswall FileTrustTM for Email, an email security 901 
product, on a new Windows 2012 R2 machine. For the purposes of this guide, we use Microsoft 902 
Exchange as the email service provider.  903 

2.7.1 Install Prerequisites 904 

 Install the IIS web server 905 

1. In Server Manager, click Add Roles and Features. 906 
2. Click Next. 907 
3. Select Role-based or feature-based installation. 908 

 909 
4. Click Next. 910 
5. Select the current server. 911 
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 912 
6. Click Next. 913 
7. Select Web Server (IIS). 914 
8. Click Next. 915 
9. Select .NET Framework 4.5 Features. 916 
10. Click Next. 917 
11. Select the following Role Services: Web Server, Common HTTP Features, Default Document, 918 

Directory Browsing, HTTP Errors, Static Content, Health and Diagnostics, HTTP Logging, 919 
Performance, Static Content Compression, Security, Request Filtering, Client Certificate 920 
Mapping Authentication, Application Development, .NET Extensibility 4.5, ASP.NET 4.5, ISAPI 921 
Extensions, ISAPI Filters, Management Tools, and IIS Management Console. 922 
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 923 
12. Click Next. 924 
13. Check the box next to Restart the destination server automatically if required. 925 
14. Click Install. 926 

 Install Microsoft SQL 2014 Enterprise 927 

Please see Section 2.4 for an installation guide for MS SQL 2014; for simplicity it should be installed on 928 
the same server as Glasswall FileTrust. Ensure that Mixed Mode authentication is selected when 929 
installing. 930 

 Install Microsoft Visual C++ 2015 931 

1. Run the vcredist_x64 installer. 932 
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 933 
2. Check the box next to I agree to the license terms and conditions. 934 

 935 
3. Click Install. 936 
4. After the installation is complete, click Close.  937 
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 938 

2.7.2 Install the Glasswall FileTrust Server Component 939 

 Install Glasswall Hub 940 

1. Run HubInstaller.msi. 941 

 942 
2. Click Next. 943 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 125 

 944 
3. Check the box next to I accept the terms in the License Agreement. 945 
4. Click Next.  946 

 947 
5. Click Next. 948 
6. Enter localhost for the Database Server. 949 
7. Enter HubDatabase for the Database Name. 950 
8. Enter a username and password (and take note of these for later).  951 
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 952 
9. Click Next.  953 
10. Select Windows Authentication. 954 

 955 
11. Click Next. 956 
12. Replace the domain of the management service URL with the address of the current machine, 957 

such as glasswall.di.ipdr. 958 
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 959 
13. Click Next. 960 

 961 
14. Click Install. 962 
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 963 
15. Click Finish. 964 

 Install Glasswall Integration Service 965 

1. Run GlasswallIntegrationService.msi. 966 

 967 
2. Click Next. 968 
3. Check the box next to I accept the terms in the License Agreement. 969 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 129 

 970 
4. Click Next. 971 
5. For Database Server, Database Name, Database User, and Database Password, enter the 972 

information entered in the Glasswall Hub Installer. 973 
6. Create a username and password for API User Name and API Password. 974 
7. Enter an email address to be used for notifications in Notifications Smtp Mail From. 975 
8. Enter the address for the mail server for Notifications Smtp Host. 976 
9. Enter a port (25 is used here) for Notifications Smtp Port. 977 
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 978 
10. Click Next. 979 

 980 
11. Click Install. 981 
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 982 
12. Click Finish. 983 

 Install Glasswall Administrator Console 984 

1. Run AdministratorConsoleInstaller.msi. 985 

 986 
2. Click Next. 987 
3. Check the box next to I accept the terms in the License Agreement. 988 
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 989 
4. Click Next. 990 
5. For Database Server, Database Name, Database User, and Database Password, enter the 991 

information entered in the Glasswall Hub Installer. 992 
6. For Notifications Smtp Mail From, Notifications Smtp Host, Notifications Smtp Port, enter the 993 

information entered in the Glasswall Integration Service Installer. 994 
7. For Notifications Smtp Port Security, select StartTlsWhenAvailable. 995 

 996 
8. Click Next. 997 
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 998 
9. Click Install. 999 

 1000 
10. Click Finish. 1001 

 Add the Server’s Certificate 1002 

1. For the purposes of this build, a self-signed certificate is used, but this is dependent on the 1003 
needs of the organization. Ensure that the certificate used is issued to the domain, such as 1004 
*.di.ipdr. 1005 

2. Open mmc. 1006 
3. Click File > Add/Remove Snap-In…. 1007 
4. Select Certificates from the left pane, and click Add. 1008 
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5. Select Computer Account. 1009 
 1010 

 1011 
6. Click Next. 1012 
7. Select Local computer. 1013 

 1014 
8. Click Finish. 1015 
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 1016 
9. Click OK. 1017 
10. Right-click the Personal certificate store, and select All tasks > Import…. 1018 

 1019 
11. Enter the file name of the certificate. 1020 
12. Click Next. 1021 
13. Enter the password for the certificate. 1022 
14. Check the box next to Mark this key as exportable. 1023 
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 1024 
15. Click Next. 1025 
16. Ensure that the Certificate store says Personal. 1026 
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 1027 
17. Click Next. 1028 

 1029 
18. Click Finish. 1030 
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19. Re-open the certificate import wizard but this time for Trusted Root Certification Authorities. 1031 

 1032 

20. Click Next. 1033 
21. Select the same certificate. 1034 
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 1035 
22. Click Next. 1036 
23. Enter the certificate’s password. 1037 
24. Check the box next to Mark this key as exportable. 1038 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 140 

 1039 
25. Click Next. 1040 

 1041 
26. Click Next. 1042 
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 1043 
27. Click Finish. 1044 
28. Open the Certificate Import Wizard again for the Personal store. 1045 

 1046 
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29. Click Next. 1047 
30. Browse to the GlasswallLicenseValidation certificate. 1048 

 1049 
31. Click Open. 1050 

 1051 
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32. Click Next. 1052 

 1053 
33. Click Next. 1054 
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 1055 
34. Click Finish. 1056 
35. Open IIS Manager by right-clicking the server in Server Manager. 1057 

 1058 
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36. Navigate to the Default Website in the tree. 1059 

 1060 
37. Click Bindings on the right sidebar. 1061 

 1062 
38. Click Add. 1063 
39. Select https for the Type.  1064 
40. Select All Unassigned for IP address. 1065 
41. Select the domain certificate for SSL certificate. 1066 
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 1067 
42. Click OK. 1068 
43. Select the http binding. 1069 

 1070 
44. Click Remove. 1071 

 1072 
45. Click Yes. 1073 
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 1074 
46. Click Close. 1075 
47. Restart the IIS server. The Glasswall FileTrust console should now be accessible through a 1076 

browser. (For example, https://glasswall.di.ipdr/AdministratorConsole). Ensure that there are 1077 
no certificate errors. 1078 

 Install the Smtp Analysis Agent  1079 

1. Run SmtpAnalysisAgentInstaller.msi. 1080 

 1081 
2. Click Next. 1082 
3. Check the box next to I accept the terms in the License Agreement. 1083 
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 1084 
4. Click Next. 1085 
5. For Listening port, enter 25. 1086 
6. For Management service URL, correct the domain to be the web domain of the IIS server (for 1087 

example, glasswall.di.ipdr). 1088 
7. For the Relay endpoints, enter the address of the Exchange server, followed by the port (for 1089 

example, exchange.di.ipdr:25). 1090 
8. For the TLS certificate thumbprint, enter the value from the thumbprint field on the certificate, 1091 

without any spaces. 1092 

 1093 
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9. Click Next. 1094 

 1095 
10. Click Install. 1096 

 1097 
11. Click Finish. 1098 

 Distribute the Glasswall License File 1099 

1. Copy the Glasswall License file to the following locations, assuming Glasswall was installed to 1100 
C:/Program Files/Glasswall. 1101 
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 1102 
2. First copy it to C:/Program Files/Glasswall/ManagementService/bin. 1103 

 1104 
3. Then copy it to C:/Program Files/Glasswall/InboundSmtpAnalysisAgent. 1105 
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 1106 
4. Lastly copy it to C:/Program Files/Glasswall/AdministratorConsole/bin. 1107 

 1108 

2.7.3 Configure Glasswall FileTrust  1109 

Please see https://docs.glasswallsolutions.com/#Configuring/Office%20365%20Integration.htm for an 1110 
example configuration that routes email with attachments from Office365 to Glasswall FileTrust. 1111 
Glasswall then forwards email back to Office365, after processing. Note that this linked configuration 1112 
does not work with on-premise Exchange setups.  1113 

Instead, to achieve the goal of routing email through Glasswall, we redirect local MX records to 1114 
Glasswall FileTrust. We implemented it this way because of limitations of the lab environment, but 1115 
organizations should consult with the vendor for the best solution to route email through the email 1116 
sanitization component, as other options may be available depending on the enterprise. 1117 

https://docs.glasswallsolutions.com/#Configuring/Office%20365%20Integration.htm
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 Create a New Administrator Account 1118 

1. Open Task Manager.  1119 
2. In the Services tab, start the InboundSmtpAnalysisAgent service. 1120 

 1121 
3. Close Task Manager. 1122 
4. Open a browser and navigate to the Glasswall Administration Console (for example, 1123 

http://glasswall.di.ipdr/AdministratorConsole).  1124 
5. If this is the first time logging in, the default account will be admin@glasswallsolutions.com, 1125 

and the password is Welcome1? . 1126 
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 1127 
6. Log in using these credentials. 1128 

 1129 
7. On the left sidebar, click Accounts. 1130 
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 1131 
8. Under Accounts, click Add.  1132 
9. Enter the name and email address of an administrator account from the email server. 1133 
10. Select Principal Administrator for Security Group. 1134 

 1135 
11. Click the checkmark button when finished.  1136 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 155 

 1137 
12. The new administrator account should be created.  1138 

 1139 
13. Check the email inbox of the specified email address for a confirmation email, and click the link 1140 

in the email. 1141 
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 1142 
14. Enter the email address as well as a password for this account. 1143 
15. Log in as this user, and then go to Accounts. 1144 
16. Select the old (default) Administrator account. 1145 

 1146 
17. Click Delete. 1147 
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 1148 
18. This should remove the old administrator account (note: failure to remove this can result in a 1149 

significant vulnerability for this server). 1150 

 Configure Notifications and Policies 1151 

1. Click Configuration on the left sidebar. 1152 
2. Click the Notifications tab. 1153 

 1154 
3. On this page, enter the web domain in the first input box (for example, glasswall.di.ipdr). 1155 
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4. The various input boxes on this page allow you to specify the messages sent when files are 1156 
quarantined, released, or prevented from being released. 1157 

5. Click the Inbound Agents tab. 1158 
6. Select Analysis and Protect for Processing Mode. (This analyzes and quarantines/reconstructs 1159 

files based on policy.) 1160 
7. Select Active for File Preview Mode. (This provides clients with a preview of their received files 1161 

if they were quarantined, so they can determine whether they should request the file be 1162 
released.) 1163 

8. Enter the domain for Allowed Domains (for example, di.ipdr). 1164 

 1165 
9. Click Save. 1166 

 Configure Inbound SMTP Policy 1167 

This section discusses SMTP policy under Glasswall FileTrust. There are several layers of granularity for 1168 
configuring Email policy. Because policy is dependent on the organization’s needs, we will not prescribe 1169 
a policy but will showcase how a policy is formed.  1170 

Policy in Glasswall FileTrust consists of Sender Groups, Receiver Groups, Content Management 1171 
Policies, and ThreatCensor Policy Sets. Receiver groups allow for the specification of users who receive 1172 
email. Sender groups allow for the specification of emails received from specific senders. Content 1173 
Management Policies refer to the default policy on various filetypes. Lastly, ThreatCensor Policy Sets 1174 
allow for the specification of policy on specific error codes; through this it is possible to place policies on 1175 
encrypted email, for example, depending on the organization’s needs. 1176 
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 Create a Receiver Group 1177 

1. On the left sidebar, click Inbound SMTP Policy.  1178 
2. Click Draft Policy Catalogue. 1179 

 1180 
3. Under Receiver Groups, click Add. 1181 

 1182 
4. Under User Defined Mailboxes, click Edit. 1183 
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 1184 
5. Enter the email address(es) of users who should be in this receiver group. 1185 

 1186 
6. Click Add. 1187 
7. When finished, return to the Policy Catalogue page. 1188 
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 1189 

 Create a ThreatCensor Policy Set 1190 

1. Under ThreatCensor Policy Sets, click Add. 1191 

 1192 
2. Under Explicit ThreatCensor Policies, click Edit. 1193 
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 1194 
3. Select the File Type and Action for the rule. 1195 
4. Under Issue, click the magnifying glass to search for an error code. 1196 
5. Return to the Policy Catalogue page when finished. 1197 

 Create a Processing Rule 1198 

1. Under Processing Rules, select the appropriate Sender Group, Receiver Group, Content 1199 
Management Policy, and ThreatCensor Policy Set. 1200 

 1201 
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2. Click Add. 1202 
3. This allows for granular policy for email inspection, quarantine, and reconstruction. 1203 

2.7.4 Configure Intelligence Sharing 1204 

1. Run DataCollectorInstaller.msi. 1205 

 1206 
2. Click Next.  1207 
3. Check the box next to I accept the terms in the License Agreement. 1208 

 1209 
4. Click Next. 1210 
5. Select Hashed for Collection Mode (especially if your data is sensitive; this will prevent the 1211 

release of any identifying information). 1212 
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6. For Integration Service Url replace localhost with the name of the computer running the 1213 
Integration Service. 1214 

7. Enter the username and password.  1215 

 1216 
8. Click Next.  1217 

 1218 
9. Click Install. 1219 
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 1220 
10. Click Finish. 1221 

2.8 Micro Focus ArcSight Enterprise Security Manager 1222 

Micro Focus ArcSight Enterprise Security Manager (ESM) is primarily a log collection/analysis tool with 1223 
features for sorting, filtering, correlating, and reporting information from logs. It is adaptable to logs 1224 
generated by various systems, applications, and security solutions.  1225 

This installation guide assumes a pre-configured CentOS 7 machine with ESM already installed and 1226 
licensed. This section covers the installation and configuration process used to set up ArcSight agents on 1227 
various machines, as well as some analysis and reporting capabilities. 1228 

Installation instructions are included for both Windows and UNIX machines, as well as for collecting 1229 
from multiple machines. Furthermore, integrations with other products in the build are included in later 1230 
sections.  1231 

2.8.1 Install the ArcSight Console 1232 

1. Run ArcSight-7.0.0.2436.1-Console-Win.exe. 1233 
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 1234 
2. Click Next.  1235 
3. Check the box next to I accept the License Agreement. 1236 
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 1237 
4. Click Next. 1238 
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 1239 
5. Click Next. 1240 
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 1241 
6. Click Next. 1242 
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 1243 
7. Click Next. 1244 
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 1245 
8. Click Install. 1246 
9. Select No, I do not want to transfer the settings. 1247 
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 1248 
10. Click Next. 1249 
11. Select Run console in default mode. (This can be changed later according to your organization’s 1250 

compliance requirements.) 1251 

 1252 
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12. Click Next. 1253 

 1254 
13. Click Yes. 1255 
14. Select FIPS 140-2. 1256 

 1257 
15. Click Next. 1258 
16. Enter the hostname of the ESM server for Manager Host Name. 1259 
17. Enter the port that ESM is running on for Manager Port (default: 8443). 1260 
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 1261 
18. Click Next. 1262 
19. Select Use direct connection. 1263 

 1264 
20. Click Next.  1265 
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 1266 
21. Click Next.  1267 
22. Select your preferred browser.  1268 

 1269 
23. Click Next. 1270 
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 1271 
24. Click Next.  1272 
25. Click Finish. 1273 
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 1274 
26. Click Done. 1275 
27. Run ArcSight Console from the start menu.  1276 
28. Enter the username and password.  1277 
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 1278 
29. Click Login. (If you are unable to connect, ensure that the hostname of the ESM server is 1279 

present in your DNS server.) 1280 
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 1281 
30. Click OK. 1282 

2.8.2 Install Individual ArcSight Windows Connectors 1283 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe. 1284 
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 1285 
2. Click Next. 1286 
3. Enter C:\Program Files\ArcSightSmartConnectors\Windows. 1287 
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 1288 
4. Click Next.  1289 
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 1290 
5. Click Next. 1291 
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 1292 
6. Click Install. 1293 
7. Select Add a Connector. 1294 
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 1295 
8. Click Next. 1296 
9. Select Microsoft Windows Event Log – Native.  1297 
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 1298 
10. Click Next. 1299 
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 1300 
11. Click Next. 1301 
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 1302 
12. Click Next.  1303 
13. Select ArcSight Manager (encrypted).  1304 
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 1305 
14. Click Next. 1306 
15. Enter the hostname, port, username, and password for the ArcSight ESM server.  1307 
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 1308 
16. Click Next. 1309 
17. Enter identifying details about the system (only Name is required). 1310 
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 1311 
18. Click Next.  1312 
19. Select Import the certificate to connector from destination. 1313 
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 1314 
20. Click Next.  1315 
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 1316 
21. Click Next.  1317 
22. Select Install as a service. 1318 
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 1319 
23. Click Next.  1320 
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 1321 
24. Click Next.  1322 
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 1323 
25. Click Next.  1324 
26. Select Exit. 1325 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 196 

 1326 
27. Click Next.  1327 
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 1328 
28. Click Done.  1329 

2.8.3 Install Individual ArcSight Ubuntu Connectors 1330 

1. From the command line, run: 1331 
> sudo ./ArcSight-7.9.0.8084.0-Connector-Linux64.bin 1332 

2. Enter the password if prompted. 1333 
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 1334 
3. Click Next.  1335 
4. Enter /root/ArcSightSmartConnectors/Ubuntu. 1336 

 1337 
5. Click Next.  1338 

 1339 
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6. Click Next. 1340 

 1341 
7. Click Install. 1342 
8. Select Add a Connector. 1343 
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 1344 
9. Click Next.  1345 
10. Select Syslog File. 1346 
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 1347 
11. Click Next.  1348 
12. Enter /var/log/syslog for the File Absolute Path Name. 1349 
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 1350 
13. Click Next.  1351 
14. Select ArcSight Manager (encrypted). 1352 
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 1353 
15. Click Next.  1354 
16. Enter the hostname, port, username, and password for ArcSight ESM. 1355 
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 1356 
17. Click Next. 1357 
18. Enter identifying details about the system (only Name is required). 1358 
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 1359 
19. Click Next.  1360 
20. Select Import the certificate to connector from destination. 1361 
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 1362 
21. Click Next.  1363 
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 1364 
22. Click Next.  1365 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 208 

 1366 
23. Click Next.  1367 
24. Select Exit. 1368 
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 1369 
25. Click Next.  1370 

 1371 
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26. Click Done.  1372 

2.8.4 Install a Connector Server for ESM on Windows 2012 R2 1373 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe. 1374 

 1375 
2. Click Next. 1376 
3. Enter C:\Program Files\ArcSightSmartConnectors\Windows. 1377 
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 1378 
4. Click Next.  1379 

 1380 
5. Click Next. 1381 
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 1382 
6. Click Install. 1383 
7. Select Add a Connector. 1384 

 1385 
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8. Click Next. 1386 
9. Select Microsoft Windows Event Log – Native.  1387 

 1388 
10. Click Next. 1389 
11. Check the box next to Use Active Directory. 1390 
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 1391 
12. Click Next. 1392 
13. Enter information about your Active Directory server (it is recommended to create a new 1393 

administrator account for ArcSight to use). 1394 
14. Set Use Active Directory host results for to Replace Hosts. 1395 
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 1396 
15. Click Next.  1397 
16. Check the boxes under any event types that should be forwarded to this connector, for each 1398 

individual host. For example: Security, System, Application. 1399 

 1400 
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17. Click Next. 1401 

 1402 
18. Click Next.  1403 
19. Select ArcSight Manager (encrypted).  1404 

 1405 
20. Click Next. 1406 
21. Enter the hostname, port, username, and password for the ArcSight ESM server.  1407 
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 1408 
22. Click Next. 1409 
23. Enter identifying details about the system (only Name is required). 1410 

 1411 
24. Click Next.  1412 
25. Select Import the certificate to connector from destination. 1413 
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 1414 
26. Click Next.  1415 

 1416 
27. Click Next.  1417 
28. Select Install as a service. 1418 
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 1419 
29. Click Next.  1420 

 1421 
30. Click Next.  1422 
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 1423 
31. Click Next.  1424 
32. Select Exit. 1425 

 1426 
33. Click Next.  1427 
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 1428 
34. Click Done.  1429 
35. Note: Ensure that all machines selected do not block traffic from this device through their 1430 

firewalls.  1431 

2.8.5 Install Pre-Configured Filters for ArcSight 1432 

 Install Activate Base 1433 

1. Go to the ArcSight Content Brain web app (https://arcsightcontentbrain.com/app/) and log in. 1434 
This page allows you to keep track of packages to be installed—which packages should be in-1435 
stalled is dependent on the needs of the organization, but the “activate base” is required for all 1436 
products.  1437 

 1438 
2. Click the Download link for the activate base. (Note: This package should be installed on the 1439 

Arcsight Console, not on the ESM.) 1440 
3. Copy the contents of the zip file to ARCSIGHT_HOME. The default for this is C:\arcsight\Con-1441 

sole\current, assuming a Windows Server. 1442 

https://arcsightcontentbrain.com/app/
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4. In PowerShell, navigate to the ARCSIGHT_HOME directory (C:\arcsight\Console\current), and 1443 
run: 1444 
> .\ActivateBaseInstallAndUpdate2540.bat 1445 

 1446 
5. Enter the hostname of the ArcSight machine, the port (default: 8443), and the username and 1447 

password used to connect to the ESM. 1448 
6. Delete Activate_Base_Updated_2.5.4.0.arb from the ARCSIGHT_HOME directory. 1449 
7. Log in to ArcSight Console.  1450 
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 1451 
8. Under Packages > Shared > All Packages > ArcSight Activate, right-click Activate Base Update 1452 

2.5.4.0, and select Delete Package.  1453 

 Install Packages 1454 

Once the Activate Base is installed, packages can be installed to monitor for specific types of events. As 1455 
an example, find below instructions for the Malware Monitoring package. 1456 

1. Navigate to the ArcSight Content Brain web app. 1457 
2. Select the Level 1 box labeled Malware. 1458 

 1459 
3. In the Track Execution section, under Associated Packages, you can see the list of packages 1460 

used to address the challenge of “Malware Monitoring.” In this case, there is just one package, 1461 
“L1 – Malware Monitoring – Indicators and Warnings.” Click the link to be taken to a download 1462 
page for the package, and download it. (Note: This package should be installed on the Arcsight 1463 
Console, not on the ESM.) 1464 
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4. Copy the contents of the zip file to ARCSIGHT_HOME. The default for this is C:\arcsight\Con-1465 
sole\current, assuming a Windows Server. 1466 

5. In PowerShell, navigate to the ARCSIGHT_HOME directory (C:\arcsight\Console\current), and 1467 
run: 1468 
> .\L1-Malware_Monitoring_1.1.0.1.bat 1469 

 1470 
6. Enter the hostname of the ArcSight machine, the port (default: 8443), and the username and 1471 

password used to connect to the ESM. 1472 

2.8.6 Apply Filters to a Channel 1473 

1. In the ArcSight Console, click File > New > Active Channel.  1474 
2. Enter a name for the channel. 1475 
3. Select a time frame.  1476 
4. For Filter, select one the filters that was imported from the packages you installed.  1477 
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 1478 
5. Click OK. All events that match the filter can be displayed in the newly created channel. Filters 1479 

from imported packages can be found under Filters > Shared > All Filters > ArcSight Activate > 1480 
Solutions. 1481 

2.8.7 Configure Email Alerts in ArcSight 1482 

 Configure a New Destination 1483 

1. In ArcSight Console, click File > New > Destination. 1484 
2. Enter a name for the Destination. 1485 
3. For Destination Type, select Email Address. 1486 
4. For Email Address, enter the email that should be associated with this destination. 1487 
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 1488 
5. Click OK. 1489 
6. Select a place to save the new Destination. 1490 
7. Click OK. 1491 

 Configure a New Rule 1492 

1. Click File > New > Rule > Standard Rule. 1493 
2. Enter a name for the rule. 1494 
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 1495 
3. Click the Conditions tab. 1496 

 1497 
4. Either create a custom condition for the rule or click the Filters button to select a pre-1498 

configured Filter. (Ensure you check the box next to desired filters if you choose to select a pre-1499 
configured filter.) 1500 
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 1501 
5. If you selected a filter, click OK. 1502 
6. Click the Actions tab. 1503 
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 1504 
7. Select the trigger for the notification, and click Add > Send Notification. 1505 
8. Select the Destination Group in which the desired destinations reside. 1506 

 1507 
9. Click OK. 1508 

2.9 Tripwire Enterprise 1509 

Notes: 1510 

This installation requires MSSQL to be installed on a remote server and configured according to the 1511 
instructions in the Tripwire Enterprise 8.6.2 Installation and Maintenance Guide. 1512 
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2.9.1 Install Tripwire Enterprise 1513 

1. Ensure that you have a current version of Oracle Java. You must install both the Java Runtime 1514 
Environment (JRE) and the Java Cryptography Extension (JCE). 1515 

2. Download and run the JRE installer. 1516 

 1517 
3. Click Install. 1518 
4. Download the JCE, and extract the files. 1519 

 1520 
5. Copy the local_policy.jar and US_export_policy.jar files to /lib/security/Unlimited/ and 1521 

/lib/security/Limited in the Java installation directory. 1522 
6. Run install-server-windows-amd64. 1523 
7. Select the Java runtime that was just installed. 1524 

 1525 
8. Click OK. 1526 
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 1527 
9. Click Next.  1528 
10. Select I accept the agreement. 1529 

 1530 
11. Click Next. 1531 
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 1532 
12. Click Next. 1533 
13. The installer should automatically detect the hostname of the system on which Tripwire 1534 

Enterprise is being installed. If it does not, enter the hostname here. 1535 

 1536 
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14. Click Next.  1537 
15. Enter the port numbers to use for each of the HTTPS Web Services port, HTTP EMS Integration 1538 

Port, and Tripwire Enterprise RMI port. The RMI port is used for inbound communication from 1539 
Tripwire agents to the server, so ensure that it is allowed through the firewall. 1540 

 1541 
16. Click Next.  1542 
17. Enter a passphrase to use. 1543 
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 1544 
18. Click Next.  1545 

 1546 
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19. Click Next.  1547 
20. Check the box next to Install Real-time Monitoring.  1548 
21. Enter 1169 for Real-time Port. 1549 

 1550 
22. Click Next.  1551 
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 1552 
23. Click Next.  1553 
24. Check the box next to Open a browser after clicking Finish to continue configuring Tripwire 1554 

Enterprise. 1555 
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 1556 
25. Click Finish.  1557 
26. Once at the web address, enter the Services passphrase chosen earlier. 1558 

 1559 
27. Click Login. 1560 

 1561 
28. Select Microsoft SQL Server for Remote Database Type. 1562 
29. Select SQL Server for Authentication Type. 1563 
30. Enter login details for the account created during the MSSQL setup. 1564 
31. Enter the hostname or IP of the database server. 1565 
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32. Enter the port on which the database is operating. 1566 
33. Enter the name of the database to be used for Tripwire Enterprise. 1567 
34. Select the appropriate setting for SSL according to your organization’s needs. 1568 

 1569 
35. Click Test Database Login to ensure the connection is functional. 1570 

 1571 
36. Click Save Configuration and Restart Console.  1572 
37. After the reboot, enter a new administrator password. 1573 
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 1574 
38. Click Confirm and Continue. 1575 

 1576 
39. Click Configure Tripwire Enterprise. 1577 
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 1578 
40. Click Choose File, and select the Tripwire Enterprise license file, which should be a .cert file. 1579 
41. Check the box next to Change Auditing and Policy Management. 1580 

 1581 
42. Select any available policies desired. 1582 

 1583 
43. Select all the operating systems that you wish to monitor with Tripwire Enterprise (TE).  1584 

 1585 
44. Set up a schedule for running checks and reports according to your organization’s needs. Leave 1586 

the box next to Enable Checks and Reports unchecked for now. 1587 
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 1588 
45. Select Set up the email server at another time. 1589 

 1590 
46. Enter a username and password for a new administrator account for TE Console. 1591 

 1592 
47. Click Preview Configuration. 1593 

 1594 
48. Click Apply Configuration. 1595 
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 1596 
49. Click Continue to Tripwire Enterprise when the installation finishes. 1597 

2.9.2 Install the Axon Bridge 1598 

1. Ensure that TCP traffic on port 5670 is allowed through the firewall. 1599 
2. Navigate to the TE Console installation directory, to the /server/data/config folder. Copy 1600 

bridge_sample.properties to bridge.properties. 1601 
3. In the bridge.properties file, find the line that says: 1602 

#tw.cap.bridge.registrationPreSharedKey= 1603 
Remove the # character. After the = character, enter a password. The password has some 1604 
restrictions, so ensure that it meets the requirements if the connection fails later. 1605 

4. Restart the TE console by running the following command from an administrator command 1606 
prompt, where <te_root> is the TE installation directory: 1607 

> <te_root>/server/bin/twserver restart 1608 

2.9.3 Install the Axon Agent (Windows) 1609 

1. Download the Axon Agent .zip file from the Tripwire customer website 1610 
(https://tripwireinc.force.com/customers), under the Product Downloads tab. 1611 

2. Unzip the file.  1612 
3. To begin the installation, double-click the .msi file in the extracted folder. Note: No installation 1613 

wizard will appear; the installation happens automatically. 1614 
4. After the Axon Agent is installed, navigate to C:\ProgramData\Tripwire\agent\config, and copy 1615 

twagent_sample.conf to twagent.conf. 1616 

https://tripwireinc.force.com/customers
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 1617 
5. Open twagent.conf, and find the line that says bridge.host. Remove the # character, and 1618 

enter the hostname or IP address of the Axon Bridge server. 1619 
6. In a file called registration_pre_shared_key, enter the value of the pre-shared key that was set 1620 

in the Axon Bridge.  1621 
7. Restart the Axon Agent Service by opening a command prompt and running the following 1622 

commands: 1623 
> net stop TripwireAxonAgent 1624 
> net start TripwireAxonAgent 1625 

 1626 

2.9.4 Install the Axon Agent (Linux) 1627 

1. Download the Axon Agent .tgz file from the Tripwire customer website 1628 
(https://tripwireinc.force.com/customers), under the Product Downloads tab. 1629 

2. To install the software, run the following commands: 1630 
RHEL or CentOS: > rpm -ivh <installer_file> 1631 
Debian or Ubuntu: > dpkg -i <installer_file> 1632 

3. Navigate to /etc/tripwire/ and copy twagent_sample.conf to twagent.conf. 1633 
4. Open twagent.conf, and find the line that says bridge.host. Remove the # character, and enter 1634 

the hostname or IP address of the Axon Bridge server. 1635 

https://tripwireinc.force.com/customers
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5. In a file called registration_pre_shared_key.txt, enter the value of the pre-shared key that was 1636 
set in the Axon Bridge.  1637 

6. Restart the Axon Agent Service by opening a command prompt and running the following 1638 
commands: 1639 
RHEL or CentOS: 1640 
> /sbin/service tripwire-axon-agent stop 1641 
> /sbin/service tripwire-axon-agent start 1642 
 1643 
Debian or Ubuntu:  1644 
> /usr/sbin/service tripwire-axon-agent stop 1645 
> /usr/sbin/service tripwire-axon-agent start 1646 

2.9.5 Configure Tripwire Enterprise 1647 

 Terminology 1648 

Node: A monitored system, such as a file system, directory, network device, database, or virtual 1649 
infrastructure component. 1650 

Element: A monitored object, which is a component or property of a node being audited by TE.  1651 

Element Version: A record of an element’s state at specific points in time. Multiple element versions 1652 
create a historical archive of changes made to the element.  1653 

Rule: A rule identifies one or more elements to the TE Console. 1654 

Action: An object that initiates a response to either changes detected by TE or by failures generated 1655 
from policy tests.  1656 

Task: A TE operation that runs on a scheduled or manual basis. 1657 

TE Policy: A measurement of the degree to which elements comply with a policy.  1658 

Policy Test: A determination of whether elements comply with the requirements of a policy. 1659 

Baseline: The act of creating an element that reflects the current state of a monitored object (also 1660 
called the current baseline. When a node’s baseline is promoted, TE saves the former baseline as a 1661 
historic baseline.  1662 

Version Check: A check on monitored objects/elements. It is a comparison of the current state of the 1663 
element against its already recorded baseline for changes. 1664 
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 Tags 1665 

In TE, tags can be used to label and target specific nodes. Tags are not required but allow for targeting 1666 
nodes more granularly than by the operating system. This section will describe how to create and assign 1667 
tags. 1668 

1. Navigate to the TE Console in your browser.  1669 
2. Click Asset View.  1670 

 1671 
3. Click the Manage Tagging tab. 1672 
4. Enter the name of a tag set or use one of the four existing ones (Location, Owner, Platform 1673 

Family, Primary Function). Click Add if adding your own tag set. 1674 

 1675 
5. Under the tag set you wish to add a tag to, enter the name of the tag. 1676 
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 1677 
6. Click Add.  1678 
7. Navigate to Nodes > Asset View > Filter Assets. 1679 
8. Check the boxes next to the nodes to which you wish to add this tag. 1680 
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 1681 
9. Click Edit Tags. 1682 
10. Check the boxes next to any tags you wish to add to these nodes. 1683 

 1684 
11. Click Close.  1685 

 Rules 1686 

This section will describe how to create a rule. 1687 

1. Click Rules. 1688 

 1689 
2. Select or create a rule group in which to put the new rule.  1690 
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 1691 
3. Click New Rule. 1692 
4. Select the type of rule. For monitoring Windows filesystems, we choose Windows File System 1693 

Rule.  1694 
 1695 

 1696 
5. Click OK. 1697 
6. Enter a name and description for the rule. 1698 
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 1699 
7. Click Next. 1700 

 1701 
8. Click New Start Point. 1702 
9. For Path, enter a directory that represents the scope of the scan. It can be limited to the 1703 

documents folder or be wide enough to encompass all the files on a system. Note that the latter 1704 
will take much longer to scan. 1705 

10. Check the box next to Recurse directory if you also wish to scan all subfolders.  1706 
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 1707 
11. Click Next. 1708 
12. Select Windows Content and Permissions. 1709 

 1710 
13. Click Finish. 1711 
14. Click New Stop Point.  1712 
15. Enter the path of any folders or files that should not be included in the scan, and indicate 1713 

whether they should end the recursion. 1714 
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 1715 
16. Click Finish. 1716 
17. Click Next. 1717 
18. Click Next. 1718 
19. Click Finish. 1719 

 Tasks 1720 

This section will describe how to create a task. 1721 

1. Click Tasks. 1722 
 1723 

2. Select a folder for a new task or create one. 1724 

 1725 
3. Click New Task. 1726 
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4. Select Baseline Rule Task or Check Rule Task (Note: Both are needed: baseline creates the 1727 
initial state of the monitored object, and check updates the state and reports any changes). 1728 

 1729 
5. Click OK. 1730 
6. Enter a name and description for the task. 1731 

 1732 
7. Click Next. 1733 
8. Select whether you want all baselines to be updated or to only create new baselines. 1734 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 253 

 1735 
9. Click Next. 1736 
10. Select the systems to be included in the task. You can use tags or select by operating system (or 1737 

other defaults). 1738 

 1739 
11. Click Next. 1740 
12. Select the rule created earlier. 1741 
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 1742 
13. Click Next. 1743 
14. Set the schedule of this task according to your organization’s needs. 1744 

 1745 
15. Click Finish. 1746 

2.10 Tripwire Log Center 1747 

2.10.1 Install Tripwire Log Center Manager 1748 

See the Tripwire Log Center 7.3.1 Installation Guide that should accompany the installation media for 1749 
instructions on how to install Tripwire Log Center. Use the Tripwire Log Center Manager installer. 1750 
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Notes: 1751 

a. It is recommended that you install Tripwire Log Center on a separate system from Tripwire 1752 
Enterprise. 1753 

b. You will need to install JRE8 and the Crypto library. Instructions are also in the Tripwire Log 1754 
Center 7.3.1 Installation Guide.  1755 

c. .NET Framework 3.5 is required for this installation; install this from the Server Manager. 1756 
d. You may need to unblock port 9898 on your firewall for the TE agents.  1757 
e. Do not install PostgreSQL if you wish to use a database on another system; this guide will use a 1758 

local PostgreSQL database, however. 1759 
f. When it finishes installing, there should be a configuration wizard (see below for configuration 1760 

steps). 1761 

2.10.2 Configure Tripwire Log Center Manager 1762 

1. The configuration wizard should start after the installation is complete. 1763 

 1764 
2. Click Start. 1765 
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 1766 
3. Click New Install. 1767 
4. Enter the registration details for your Tripwire Log Center license. 1768 

 1769 
5. Click Register.  1770 
6. Enter details about the database that Tripwire Log Center should use. 1771 
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 1772 
7. Click Next. 1773 
8. Select a directory to store log messages in, such as C:\Program Files\Tripwire\Tripwire Log 1774 

Center Manager\Logs\AUDIT. 1775 

 1776 
9. Click Next. 1777 
10. Enter a password and an email. 1778 
11. Change the IP to a hostname, if preferred. 1779 
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 1780 
12. Click Next.  1781 

 1782 
13. Click Next. 1783 
14. Select any log sources that you expect to collect with Tripwire Log Center. Examples: Tripwire 1784 

Enterprise, Microsoft Windows 10, Tripwire IP360 VnE, Linux Debian, Ubuntu Linux, Microsoft 1785 
Exchange, Microsoft SQL Server. 1786 
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 1787 
15. Click Next. 1788 

 1789 
16. Click Start. 1790 
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 1791 
17. Click Next. 1792 

 1793 
18. Click Finish. 1794 

2.10.3 Install Tripwire Log Center Console 1795 

Chapter 4 of the Tripwire Log Center 7.3.1 Installation Guide details the installation of the Tripwire Log 1796 
Center Console. Use the Tripwire Log Center Console installer. 1797 

You can install this on the same machine as the Tripwire Log Center Manager, if desired. 1798 
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2.11 Cisco Identity Services Engine 1799 

This section will detail the installation and some configurations for the Cisco Identity Services Engine 1800 
(ISE). It assumes the use of the ISE virtual machine. 1801 

2.11.1 Initial Setup 1802 

1. When prompted to log in for the first time, enter setup. (You can use the command reset-1803 
config to change these values later.) 1804 

2. Enter the desired hostname for the machine. 1805 
3. Enter the desired IP address for the machine. (Ensure that the specified hostname is associated 1806 

with this IP address in your DNS.) 1807 
4. Enter the netmask for the machine.  1808 
5. Enter the default gateway. 1809 
6. Enter the default DNS domain (the name of your domain). 1810 
7. Enter the primary nameserver (the IP address of your DNS). 1811 
8. Enter a second nameserver if desired.  1812 
9. Enter an NTP time server. 1813 
10. Enter the timezone. 1814 
11. Enter Y for SSH service. 1815 
12. Enter an administrator username for the machine. 1816 
13. Enter a password twice. 1817 

2.11.2 Inventory: Configure SNMP on Routers/Network Devices 1818 

See the corresponding vendor documentation for the correct way to enable SNMP on your network 1819 
device. Ensure that the community string you choose is considered sensitive, like a password. 1820 

2.11.3 Inventory: Configure Device Detection 1821 

1. Log in to the web client by visiting https://hostname/admin, but replace hostname with the 1822 
hostname of the ISE machine.  1823 

https://hostname/admin
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 1824 
2. On the top right, use the small play button to select Visibility Setup. 1825 

 1826 
3. Click Next.  1827 

 1828 
4. Enter the range of IP addresses to add to ISE’s inventory.  1829 
5. Ensure that Active Scanning is checked. 1830 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 263 

 1831 
6. Click Next.  1832 
7. Click the Add Device Manually link. 1833 
8. Enter a name. 1834 
9. Enter the IP address of the network device you configured for SNMP. 1835 
10. Select 1 for SNMP version. 1836 
11. Enter the community string you created.  1837 

 1838 
12. Click OK. 1839 
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 1840 
13. Click Next. 1841 
14. Enter a display name. 1842 
15. Enter the domain name. 1843 
16. Enter the hostname of Cisco ISE. 1844 
17. Enter a username and password. 1845 
18. Click Test Connection to ensure that this works. 1846 

 1847 
19. Click Next.  1848 
20. Enter a username and password. 1849 
21. Check the box next to Enable Endpoint Logging. 1850 
22. Check the box next to Include Range. 1851 
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 1852 
23. Click Next.  1853 

 1854 
24. Verify the settings, and click Done. (This should begin importing endpoints connected to the 1855 

network device, and they will be visible on the ISE dashboard.) 1856 

2.11.4 Policy Enforcement: Configure Active Directory Integration 1857 

1. Navigate to Administration > Identity Management > External Identity Sources > Active 1858 
Directory. 1859 
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 1860 
2. Click Add. 1861 
3. Enter a name.  1862 
4. Enter the domain. 1863 

 1864 
5. Click Submit. 1865 
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 1866 
6. Click Yes. 1867 
7. Enter a username and password to join ISE to the domain. 1868 

 1869 
8. Click OK. 1870 
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 1871 
9. Click Close when the join is finished. 1872 

2.11.5 Policy Enforcement: Enable Passive Identity with AD 1873 

This configuration allows users to use Active Directory usernames/passwords as authentication for the 1874 
portal. The web portal will allow clients to download profiling software to ensure that clients have up to 1875 
date software and can be trusted on the network. 1876 

1. Navigate to Administration > System > Deployment. 1877 
2. Check the box next to ISE. 1878 

 1879 
3. Click Edit. 1880 
4. Check the box next to Enable Passive Identity Service. 1881 
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 1882 
5. Click Save. 1883 
6. Navigate to Administration > Identity Management > External Identity Sources > Active 1884 

Directory. 1885 
7. Click the name of the Active Directory machine. 1886 
8. Check the box next to the join point you just created.  1887 

 1888 
9. Click Edit.  1889 
10. Click the PassiveID tab. 1890 
11. Click Add DCs if there are no domain controllers listed. 1891 
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 1892 
12. Select the Active Directory domain controller. 1893 
13. Click OK. 1894 
14. Check the box next to the selected domain controller. 1895 
15. Click Edit. 1896 
16. Enter credentials for an administrator account. 1897 

 1898 
17. Click Save. 1899 
18. Click Config WMI. 1900 
19. Click OK. 1901 
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 1902 
20. Click OK when this configuration finishes. 1903 
21. Navigate to Administration > System > Settings > Client Provisioning. 1904 
22. Set Enable Automatic Download to Enable. 1905 

 1906 
23. Click Save. 1907 
24. Navigate to Administration > Identity Management > External Identity Sources > Active 1908 

Directory. 1909 
25. Click the Groups tab. 1910 
26. Click Add > Select Groups from Directory. 1911 
27. Click Retrieve Groups. (This should populate the window with the groups from Active 1912 

Directory.) 1913 
28. Select them all. 1914 
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 1915 
29. Click OK. (If you add more groups to Active Directory, they can be imported in the same way in 1916 

the future.) 1917 
30. Click the Attributes tab.  1918 
31. Click Add > Select Attributes from Directory. 1919 
32. Enter a username.  1920 
33. Click Retrieve Attributes. (This will populate the window with Active Directory’s available 1921 

attributes, so they can be used for policy in Cisco ISE.) 1922 
34. Click OK. 1923 
35. Select any desired attributes. 1924 

 1925 
36. Click OK. 1926 
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37. Click Save. 1927 

2.11.6 Policy Enforcement: Developing Policy Conditions 1928 

1. Navigate to Policy > Policy Elements > Conditions > Posture. 1929 
2. Expand the Posture section. This will reveal a list of categories for conditions. (Note: these 1930 

conditions allow you to select or define requirements that endpoints should meet. In typical 1931 
enterprises these conditions can be used as requirements to gain network access; however, this 1932 
strongly depends on the capabilities of your network device. Furthermore, the network device 1933 

3. As an example, we will require that Cisco AMP be installed on all Windows devices. If you are 1934 
using a different anti-malware software, locate that instead. Click Anti-Malware Condition.  1935 

 1936 
4. Click Add. 1937 
5. Enter a name. 1938 
6. Enter a description if desired. 1939 
7. Select Windows All for Operating System. 1940 
8. Select Cisco Systems, Inc. for Vendor.  1941 
9. Under Products for Selected Vendor, check the box next to Cisco Advanced Malware 1942 

Protection, with the version number you have installed. 1943 
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 1944 
10. Click Submit. 1945 

2.11.7 Policy Enforcement: Developing Policy Results 1946 

1. Navigate to Policy > Policy Elements > Results > Posture > Requirements. 1947 
2. Click one of the black arrows next to the Edit link, and select Insert New Requirement. 1948 
3. Enter a name.  1949 
4. Select Windows All for Operating Systems. 1950 
5. Select 4.x or later for Compliance Module. 1951 
6. Select Temporal Agent for Posture. 1952 
7. Select User Defined Conditions > Anti-Malware Condition > Cisco AMP (substitute “Cisco AMP” 1953 

with the name of the condition you just created).  1954 
8. Select Message Text Only for the Remediation Action. (Other remediation actions can be 1955 

defined by going to Policy > Policy Elements > Results > Posture > Remediation Actions, but 1956 
there is no option for Cisco AMP to be installed, so we leave the default for now.) 1957 

9. Enter a Message to show to the user to inform them that they must install Cisco AMP.  1958 
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 1959 
10. Click Save.  1960 

2.11.8 Policy Enforcement: Enforcing a Requirement in Policy 1961 

1. Navigate to Policy > Posture. 1962 
2. Click one of the black arrows next to the Edit link and select Insert New Policy. 1963 
3. Enter a name.  1964 
4. Select Windows All for Operating Systems. 1965 
5. Select 4.x or later for Compliance Module. 1966 
6. Select Temporal Agent for Posture Type. 1967 
7. Select Cisco AMP (substitute “Cisco AMP” with the name of the requirement you just created).  1968 
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 1969 
8. Click Done. 1970 
9. Ensure that the green checkboxes next to the rules you wish to apply are the only checkboxes 1971 

enabled, as anything enabled will be enforced.  1972 

2.11.9 Policy Enforcement: Configuring a Web Portal 1973 

1. Navigate to Administration > Device Portal Management > Client Provisioning.  1974 
2. Select the Client Provisioning Portal (default). 1975 

 1976 
3. Click Edit. 1977 
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4. Under Portal Settings, go to Configure authorized groups, and select the groups that should 1978 
require a Cisco ISE client.  1979 

5. Enter a domain name for FQDN, and add it to your DNS.  1980 

 1981 
6. Click Save. 1982 

2.11.10 Configuring RADIUS with your Network Device 1983 

Cisco ISE requires a RADIUS session for posture to function. Posture refers to ISE’s ability to check that a 1984 
machine complies with a specified policy, which may be based on the OS and may contain requirements 1985 
such as the installation of certain security applications or the presence of configuration files. Machines 1986 
that are not in compliance can be kept separated from the network. The process for setting this up 1987 
varies widely between machines, but the overall requirements have commonalities between systems.  1988 

1. The Network Device (i.e. the router or switch) must support RADIUS functions, specifically 1989 
Authentication, Authorization, and Accounting. Furthermore, it must also support CoA, which 1990 
is Change of Authorization.  1991 

a. To configure this, you must configure your network device to use Cisco ISE as a Radius 1992 
Server. What this means is that your network device will forward authentication 1993 
requests to Cisco ISE, and Cisco ISE will respond with an “accept” or “reject.” 1994 

2. The Network Device must support some form of 802.1x. Note that this is not supported on 1995 
certain routers, even if RADIUS is supported. 802.1x is a mechanism for authenticating the end 1996 
workstation to the network device, potentially over wireless or through ethernet.  1997 

a. This can take various forms, such as a captive web portal, MAC address authentication, 1998 
or user authentication. A captive web portal, if the device supports it, may be ideal for 1999 
configuration without the correct hardware.  2000 

b. There are also many switches that provide direct 802.1x username/password 2001 
authentication. Note that if you choose to use this mechanism, a client is still required, 2002 
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and it will not be in the web browser. Windows has a built-in 802.1x client that can be 2003 
configured on Network adapters under the Authentication tab. To enable it, you must 2004 
first start the service Wired AutoConfig, and then the Authentication tab will become 2005 
available for configuration. 2006 

c. Whichever form of 802.1x is chosen, the request for authentication must be forwarded 2007 
to Cisco ISE. Cisco ISE will process the request for authentication.  2008 

3. The two steps above detail the authentication phase. Once authenticated, the network device 2009 
must redirect the user to the client provisioning portal (or to a guest portal), depending on the 2010 
setup. The URL for this can be acquired from the active Authorization Profile in ISE.  2011 

4. The user will then authenticate to the Guest Portal or Client Provisioning Portal (depending on 2012 
your setup). The portal will prompt the user to download an executable, which will run posture. 2013 

5. The executable will first check for the existence of a RADIUS session in Cisco ISE for the user 2014 
who downloaded the executable. It will primarily check the MAC address that visited the ISE 2015 
web portal against the MAC addresses of existing sessions. If and only if a session exists, it will 2016 
run posture based on the policy you set up. You can verify that a session exists by navigating to 2017 
Operations > RADIUS > Live Sessions. 2018 

2.11.11 Configuring an Authentication Policy 2019 

1. Navigate to Policy > Policy Elements > Results > Authentication > Allowed Protocols. 2020 
2. Select the Default Network Access protocol, or create your own.  2021 
3. Ensure any protocols that need to be supported for your network setup are allowed. In 2022 

particular, if using 802.1x, you should likely check the box next to Allow MS-CHAPv2. 2023 

 2024 
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4. Click Save. 2025 
5. Navigate to Policy > Policy Sets. 2026 
6. Select the default policy. 2027 
7. Ensure that the Allowed Protocol selection matches the allowed protocol you just 2028 

created/edited. 2029 
8. Expand the Authentication Policy section, and select the ID stores from which to authenticate 2030 

users. For example, if you set up an Active Directory integration, it may be desirable to 2031 
authenticate users from there. 2032 

 2033 
9. Click Save. 2034 

2.11.12 Configuring an Authorization Policy 2035 

1. The Authorization Profile is likely dependent on your network device, but it is possible that the 2036 
Cisco_Temporal_Onboard profile will work even for non-Cisco devices. You can edit the 2037 
authorization policy by navigating to Policy > Policy Elements > Results > Authorization > 2038 
Authorization Profiles.  2039 

2. The temporal onboard profile will attempt to redirect the user to a client provisioning portal–2040 
this redirection will most likely only happen automatically on compatible Cisco network devices. 2041 
If another device is used, the device may need to manually redirect the user to the client 2042 
provisioning portal after authentication. (We accomplished this in PFSense for our build using a 2043 
“Post-authentication redirection” feature in the Captive Portal.) 2044 

3. Once you are finished configuring the Authorization Profile, navigate to Policy > Policy Sets. 2045 
4. Select the default policy. 2046 
5. Expand the Authorization Policy section. 2047 
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6. Note that you can configure this for as many groups and conditions as desired, potentially 2048 
specifying different authorization profiles for various user groups or levels of authentication, 2049 
including unauthenticated access. Under Results > Profiles, you can select the authorization 2050 
profiles you configured. 2051 

 2052 
7. Click Save.  2053 

2.12 Cisco Advanced Malware Protection 2054 

This section assumes the use of the Cisco Advanced Malware Protection (AMP) Console, a cloud-based 2055 
server that connects to clients on individual machines. There is some configuration to be done on this 2056 
cloud-based server, which may impact the installation. Cisco provides best practices guides online for 2057 
AMP configuration. Here is a link to one such guide: 2058 
https://www.cisco.com/c/en/us/support/docs/security/amp-endpoints/213681-best-practices-for-2059 
amp-for-endpoint-excl.html.  2060 

2.12.1 Dashboard Configuration 2061 

1. From the Cisco AMP dashboard, located at https://console.amp.cisco.com/dashboard, click Set 2062 
Up Windows Connector. 2063 

2. The configuration of this will be different for each enterprise, so consult your Cisco 2064 
representative for the proper way to set this up. For the purposes of this build, we accepted the 2065 
default values. 2066 

https://www.cisco.com/c/en/us/support/docs/security/amp-endpoints/213681-best-practices-for-amp-for-endpoint-excl.html
https://www.cisco.com/c/en/us/support/docs/security/amp-endpoints/213681-best-practices-for-amp-for-endpoint-excl.html
https://console.amp.cisco.com/dashboard


DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 281 

2.12.2 Installing the Connector on a Windows Server 2067 

1. On the Cisco AMP dashboard, navigate to Management > Download Connector. 2068 
2. Select the AMP group in which to put the machine. For example, when installing on an Active 2069 

Directory machine, we chose Domain Controller.  2070 
3. Find the correct OS version of the installer, and click Download. 2071 
4. Run the downloaded executable (for example, Domain_Controller_FireAMPSetup.exe). 2072 

 2073 
5. Click Install. 2074 

 2075 
6. Click Next. 2076 
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 2077 
7. Click Close. 2078 

2.12.3 Installing the Connector on a Windows 10 Machine 2079 

1. On the Cisco AMP dashboard, navigate to Management > Download Connector. 2080 
2. Select the AMP group in which to put the machine. For this installation we chose Protect. 2081 
3. Find the correct OS version of the installer, and click Download. 2082 
4. Run the downloaded executable (for example, Protect_FireAMPSetup.exe). 2083 

 2084 
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5. Click Install. 2085 

 2086 
6. Click Next. 2087 

 2088 
7. Click Close. 2089 

2.12.4 Scanning using AMP 2090 

1. If the AMP software does not run automatically, open it from the start menu.  2091 
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 2092 
2. Click Scan Now. 2093 

 2094 
3. Click Full Scan. 2095 
4. A scan should begin.  2096 

2.12.5 Configure AMP Policy 2097 

1. On the web console, navigate to Management > Policies. 2098 
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2. Select a policy to edit; for this example, we choose Domain Controllers. (To edit which policies 2099 
map to which groups, select Management > Groups, and click Edit on the group for which you 2100 
wish to select a policy. You can select a policy for each Operating System (OS) in that group.) 2101 

 2102 
3. Click Edit. 2103 
4. In the Modes and Engines tab, “Conviction Modes” refers to the response taken to various 2104 

detected suspicious activity or files.  2105 
• Audit is a detection/logging approach that does not take any action other than logging 2106 

the activity. 2107 
• Quarantine involves the move of the offending file to its own folder, where it is 2108 

monitored and deleted after a certain amount of time. Quarantining can also be applied 2109 
to processes, in which the process is monitored and prevented from affecting system 2110 
operations. 2111 

• Block involves the deletion of the file or the stopping of the process or network traffic. 2112 
5. “Detection Engines” refer to the actual detection of the suspicious activity.  2113 

• TETRA is intended to be an anti-malware engine and recommends that it not be used 2114 
when other antimalware software is in use.  2115 

• Exploit Prevention refers to an engine that defends endpoints against memory injection 2116 
attacks. 2117 
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 2118 
6. Click Save. 2119 

2.13 Cisco Stealthwatch 2120 

This section will describe the setup and configuration of Cisco Stealthwatch, a network monitoring 2121 
solution. This guide assumes the use of the Stealthwatch virtual machines. 2122 

2.13.1 Configure Stealthwatch Flow Collector, Stealthwatch Management 2123 
Console, Stealthwatch UDP Director and Stealthwatch Flow Sensor 2124 

1. Log in to the console of Stealthwatch Flow UDP Director. 2125 
2. Navigate the menu to highlight Management and Select. 2126 
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 2127 
3. Press Enter. 2128 
4. Enter an IP Address for this machine. 2129 
5. Highlight OK. 2130 

 2131 
6. Press Enter. 2132 
7. Enter a network mask for the IP Address. 2133 
8. Highlight OK. 2134 
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 2135 
9. Press Enter. 2136 
10. Enter the network gateway. 2137 
11. Highlight OK. 2138 

 2139 
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12. Press Enter. 2140 
13. Enter the network broadcast address. 2141 
14. Highlight OK. 2142 

 2143 
15. Press Enter. 2144 
16. Highlight Yes. 2145 
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 2146 
17. Press Enter. 2147 
18. Highlight OK.  2148 

 2149 
19. Press Enter. 2150 
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20. Repeat steps 1-19 for each of the Stealthwatch Management Console, Stealthwatch UDP 2151 
Director, Stealthwatch Flow Sensor, and Stealthwatch Flow Collector. 2152 

2.13.2 Change Default Stealthwatch Console Passwords  2153 

1. In the System Configuration menu, highlight Password and Select. 2154 

 2155 
2. Press Enter. 2156 
3. Enter the original password. 2157 
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  2158 
4. Press Enter. 2159 
5. Enter the new password, and confirm it. 2160 
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 2161 
6. Press Enter. 2162 
7. In the System Configuration menu, highlight Advanced and Select. 2163 
8. Press Enter. 2164 
9. Highlight RootShell and Select. 2165 

 2166 
10. Press Enter. 2167 
11. Log in using the original root shell password. 2168 
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 2169 
12. Enter the command root. 2170 
13. Type the new password, and confirm it. 2171 

. 2172 
 2173 
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 2174 
14. Press Enter. 2175 
15. Repeat steps 1-14 for each console.  2176 

2.13.3 Configure the Stealthwatch Management Console Web Interface 2177 

1. Change the default password by filling in the fields for Current Password, New Password, and 2178 
Confirm New Password. 2179 

 2180 
2. Click Next. 2181 
3. Fill in the fields for IP Address, Subnet Mask, Default Gateway and Broadcast Address 2182 

according to your network topology. 2183 
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 2184 
4. Click Next. 2185 
5. Enter a host name. 2186 
6. Enter the network domain that Stealthwatch is in for Network Domain. 2187 
7. Enter the network domain that Stealthwatch will be monitoring for Stealthwatch Domain. 2188 

 2189 
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8. Click Next. 2190 
9. Enter a DNS Server. 2191 

 2192 
10. Click Next. 2193 
11. Configure the NTP server according to your network topology. 2194 

 2195 
12. Click Next. 2196 
13. Select Restart. 2197 
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 2198 
14. Click Apply. 2199 

 2200 
15. After the restart, click Next. 2201 

2.13.4 Configure the Stealthwatch UDP Director, Stealthwatch Flow Collector 2202 
and Stealthwatch Flow Sensor Web Interfaces 2203 

1. Repeat steps 1-12 from Configure the Stealthwatch Management Console Web Interface. 2204 
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 2205 
2. When prompted to manage this device from an SMC, click Yes. 2206 
3. Enter the IP Address of the Stealthwatch Management Console. 2207 

 2208 
4. Click Save. 2209 
5. Verify the certificate. 2210 
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 2211 
6. Click Yes. 2212 
7. Enter the User ID and Password for the Stealthwatch Management Console. 2213 

 2214 
8. Click Next. 2215 
9. Repeat steps 1-8 for the Flow Collector first and then for the Flow Sensor. The Flow Sensor 2216 

cannot be added to the Management Console until after the Flow Collector is successfully 2217 
added. 2218 
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2.14 Symantec Analytics 2219 

This section details the installation and configuration of Symantec Analytics, a network analysis tool. 2220 
This guide assumes that Symantec Analytics is connected via serial to a terminal. 2221 

2.14.1 Initial Setup 2222 

1. Log in to the Symantec Analytics command line. 2223 
2. Enter the following command to configure the IP for the interface: 2224 

sudo cfg_bond_interface.py -i eth0 -n 192.168.1.42/255.255.255.0 -g 192.168.1.1 2225 

  2226 

3. Navigate to the IP you assigned in a browser. 2227 
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 2228 
4. Enter the username and password to log in. The default is (Admin/Solera). 2229 
5. Check the box next to I have read and agreed to the terms of the End User License Agreement 2230 

on behalf of the end user.  2231 

 2232 
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6. Click Next. 2233 
7. Enter the license key.  2234 
8. If you do not have internet connectivity, follow the instructions under Upload License File. 2235 

Otherwise, click Send Request. 2236 

 2237 
9. Click Update. The device will reboot. 2238 
10. Log in to the web page again. 2239 
11. Click the silhouette in the top right corner and click Account Settings. 2240 

 2241 
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12. Click Change Password.  2242 

 2243 
13. Enter a new password. Click Save. 2244 

 2245 
14. The screen should reflect that the password has been changed. Close out of both windows and 2246 

return to the main web console.  2247 
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 2248 
15. In the top left corner of the web console, click the menu button. (It shows as three horizontal 2249 

bars). 2250 

 2251 
16. Navigate to Settings > Data Enrichment. 2252 
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 2253 
17. Click the red upside-down power symbols next to Symantec Web Reputation Service and 2254 

Symantec File Reputation Service to turn them on. 2255 

 2256 
18. Select Full Data Enrichment (with Anomaly Protection) for the profile under Data Enrichment 2257 

Profiles. 2258 
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 2259 
19. Click Save. 2260 

2.14.2 Capturing Data 2261 

1. Navigate to Capture > Summary in the menu.2262 

 2263 
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2. Begin capturing data on any desired interfaces by clicking Start Capture. 2264 

 2265 

2.15 Symantec Information Centric Analytics 2266 

This section describes the installation and configuration of Symantec Information Centric Analytics 2267 
(ICA). 2268 

2.15.1 Installing MS SQL 2017 2269 

1. Launch the SQL Setup Wizard. 2270 
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 2271 
2. Click Installation. 2272 

 2273 
3. Click New SQL Server stand-alone installation or add features to an existing installation. 2274 
4. Enter a product key. 2275 
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 2276 
5. Click Next. 2277 
6. Check the box next to I accept the license terms. 2278 

 2279 
7. Click Next. 2280 
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 2281 
8. Click Next. 2282 

 2283 
9. Click Next. 2284 
10. Ensure that box next to R and the box next to Analysis Services is checked. 2285 
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 2286 
11. Click Next. 2287 
12. Select Named instance. 2288 
13. Specify a name for the instance. 2289 

 2290 
14. Click Next. 2291 
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 2292 
15. Click Next. 2293 
16. Select Mixed Mode (SQL Server authentication and Windows authentication). 2294 
17. Enter a password. 2295 
18. Add any users who should be administrators of the SQL database. 2296 

 2297 
19. Click Next. 2298 
20. Select Multidimensional and Data Mining Mode. 2299 
21. Add any users who should be administrators of the Analysis Services. 2300 
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 2301 
22. Click Next. 2302 

 2303 
23. Click Accept. 2304 
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 2305 
24. Click Next. 2306 

 2307 
25. Click Install. 2308 
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 2309 
26. Click Close. 2310 

2.15.2 Install Windows Services 2311 

1. Open Server Manager. 2312 

 2313 
2. Click Add Roles and Features. 2314 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 317 

 2315 
3. Click Next. 2316 

 2317 
4. Click Next. 2318 
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 2319 
5. Click Next. 2320 

 2321 
6. Select Web Server (IIS). 2322 
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 2323 
7. Click Add Features. 2324 

 2325 
8. Click Next. 2326 
9. Select all services under .NET Framework 3.5 Features. 2327 
10. Select all services under .NET Framework 4.5 Features. 2328 
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 2329 
11. Click Next. 2330 

 2331 
12. Click Next. 2332 
13. Ensure that the following Role Services are selected: 2333 

a. Common HTTP Features 2334 
i. Default Document 2335 

ii. Directory Browsing 2336 
iii. HTTP Redirection 2337 

b. Health and Diagnostics 2338 
i. HTTP Logging 2339 

c. Performance 2340 
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i. Static Content Compression 2341 
d. Security 2342 

i. Windows Authentication 2343 
e. Application Development 2344 

i. .NET Extensibility 4.5 2345 
ii. ASP.NET 4.5 2346 

iii. ISAPI Extensions 2347 
iv. ISAPI Filters 2348 

 2349 
14. Click Next. 2350 
15. If necessary, specify a path to /Sources/SxS, which is found in the Windows Installation Media. 2351 
16. Check the box next to Restart the destination server automatically if required. 2352 
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 2353 
17. Click Install. 2354 

 2355 
18. Click Close when the installation finishes. 2356 
19. Open Internet Information Services Manager. 2357 
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 2358 
20. Navigate to SERVER-NAME > Sites. 2359 
21. Right-click the Default Web Site, and select Bindings. 2360 
22. Change the port for http to 8080. 2361 

 2362 
23. Click Close. 2363 
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 2364 
24. Click Restart under Manage Website. 2365 

2.15.3 Installing Symantec ICA 2366 

1. In Task Manager, verify that the SQL Server Agent service is running. 2367 
2. Copy the installation media SymantecICASoftware_65.zip onto the server. 2368 
3. Extract the installation media. 2369 

 2370 
4. Run SymantecICAInstaller.exe. 2371 
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 2372 
5. Under Full Install, click Start. 2373 
6. Scroll down and check the box next to I have read, understood, and agree with the terms of 2374 

the license agreement. 2375 

 2376 
7. Click Next. 2377 
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 2378 
8. Click Next. 2379 
9. Enter a username and password with privileges on the domain. 2380 

 2381 
10. Click Next. 2382 
11. Configure any alert settings desired; these can be changed later. 2383 
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 2384 
12. Click Next. 2385 
13. Enter the name of the SQL Server you created in the format <SERVER-DOMAIN-NAME>\<SQL-2386 

SERVER-NAME>. 2387 
14. Click Connect, and verify that there are no connection issues. 2388 
15. Enter the name of the SQL Analysis Services server you created in the format <SERVER-2389 

DOMAIN-NAME>\<SQL-SERVER-NAME>. (It may be the same as the SQL Server). 2390 
16. Click Connect, and verify that there are no connection issues. 2391 
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 2392 
17. Click Next. 2393 

 2394 
18. Click Next. 2395 
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 2396 
19. Click Next. 2397 
20. Check the box next to Activate Offline. 2398 

 2399 
21. Click Next. 2400 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 330 

 2401 
22. Click Install. 2402 

 2403 
23. Click Close. 2404 
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2.15.4 Configuring Symantec ICA for Analysis 2405 

This section will contain instructions for navigating some aspects of the ICA admin console and 2406 
dashboards, though this largely depends on the specific data your organization has identified and is 2407 
trying to analyze. 2408 

 Installing Integration Packs 2409 

1. Download the relevant integration packs to someone on the local system. These are typically 2410 
provided by Symantec, in a zip file. The zip file should be titled in the format of 2411 
BayDynamics.RiskFabric.IntegrationPack.<productName>. 2412 

2. Log in to the Risk Fabric web interface. 2413 
3. Navigate to Admin > Integration. 2414 

 2415 
4. Click Import. 2416 
5. Find the zip file for the integration pack that you downloaded earlier. 2417 
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 2418 
6. Select the file and click Open. 2419 

 2420 

 Create a View 2421 

1. Navigate to Analyzer > New View. 2422 
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 2423 
2. In the field list on the right, manually select or search for the data fields desired. 2424 
3. The fields can be added either by dragging the field onto the screen or by right-clicking on the 2425 

field and selecting where it should be added. Ultimately, which views to select depends on the 2426 
needs and preferences of your organization. 2427 

4. When finished, click Save. 2428 
5. Enter a name for the View Name.  2429 
6. Select the type of View for Type.  2430 
7. Check the box next to This view is accessible by all Users (Public) only if you wish for this view 2431 

to be visible by anyone logged in. 2432 

 2433 
8. Click Save. 2434 

 Open an Existing View 2435 

1. Navigate to Analyzer > Open View. 2436 
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 2437 
2. Begin to search for the view you want by typing a search term into Search Cube Views. (Note: if 2438 

you created a view, it will also be present in this list). 2439 
3. Click the Search icon. 2440 
4. Select a view. 2441 

 2442 
5. Click Open. 2443 
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 Viewing Detailed Analyzer Data 2444 

1. The desired field data can be exported to either a .csv or .excel format, by clicking on the Export 2445 
button in the details tab. 2446 

 2447 
2. Charts can be added or removed using the Charts dropdown menu near the top of the analyzer. 2448 
3. Any data in the Field List on the right side can be added to or removed from the view and will 2449 

be automatically incorporated into its relevant rows or columns. 2450 
4. The entire view format can be exported as a .json file from the Open View option. 2451 

2.16 Integration: Cisco Identity Services Engine and Cisco Stealthwatch 2452 

This section will detail an integration between Cisco Identity Services Engine (ISE) and Cisco 2453 
Stealthwatch, allowing Stealthwatch to apply certain policies to hosts in ISE. Stealthwatch acts as a 2454 
network monitoring solution and can be integrated with ISE to enable mitigation capabilities in 2455 
response to events. Please see Deploying Cisco Stealthwatch 7.0 with Cisco ISE 2.4 using pxGrid for 2456 
details and other potential uses of the integration. 2457 

2.16.1 Configuring Certificates for pxGrid 2458 

1. Log in to the Cisco ISE web console in a browser. 2459 
2. Navigate to Administration > System > Deployment. 2460 
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 2461 
3. Click the hostname of the Cisco ISE machine.  2462 
4. Check the box next to pxGrid. 2463 

 2464 
5. Click Save. 2465 
6. Navigate to Administration > pxGrid Services. 2466 
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 2467 
7. Click Certificates. 2468 
8. Select Download Root Certificate Chain for I want to. 2469 
9. Select the hostname of the Cisco ISE server for Host Names.  2470 
10. Select Certificate in Privacy Enhanced Electronic Mail (PEM) format, key in PLCS8 PEM format 2471 

(including certificate chain) for Certificate Download Format. 2472 

 2473 
11. Click Create. This will download a zip file containing the certificate. 2474 
12. Extract the zip file—it may contain several files—the one we are interested in is the Root CA.  2475 
13. Log in to the Stealthwatch Management Console through the browser. 2476 
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 2477 
14. In the top right corner of the console, hover over the gear icon and select Central Management 2478 

from the submenu.  2479 

 2480 
15. In the table, find the row with the Stealthwatch Management Console (likely labeled as SMC). 2481 

Click the ellipses button in the Actions column.  2482 
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 2483 
16. This will open a submenu. Select Edit Appliance Configurations. 2484 
17. Click the General tab. 2485 
18. Scroll down to the Trust Store section. 2486 

 2487 
19. Click Add New. 2488 
20. Enter a name. 2489 
21. Click Choose File. 2490 
22. Select the Cisco ISE Root certificate from the files downloaded earlier. 2491 
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 2492 
23. Click Add Certificate. 2493 

 2494 
24. Click Apply Settings. 2495 
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 2496 
25. Click Apply Changes if prompted to confirm the changes. 2497 
26. When that finishes, navigate back to the Appliance Configurations section. 2498 
27. In the table, find the row with the Stealthwatch Management Console (likely labeled as SMC). 2499 

Click the ellipses button in the Actions column.  2500 
28. This will open a submenu. Select Edit Appliance Configurations. 2501 

 2502 
29. Click Add New under Additional SSL/TLS Client Identities. 2503 
30. Select 2048 for RSA Key Length.  2504 
31. Enter your organization’s information. 2505 
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 2506 
32. Click Generate CSR.  2507 

 2508 
33. When this finishes, click Download CSR. 2509 
34. Open the CSR in a text file, and copy all the contents. 2510 
35. On the ISE web console, navigate to Administration > pxGrid Services > Certificates > Generate 2511 

pxGrid Certificates. 2512 
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36. Select Generate a single certificate (with certificate signing request) for I want to. 2513 
37. Paste the copied text into the Certificate Signing Request Details.  2514 
38. Enter a description such as SMC for the Description. 2515 
39. Select IP Address for Subject Alternative Name (SAN). 2516 
40. Enter the IP Address of the Stealthwatch Management Console. 2517 
41. Select PKCS12 format (including certificate chain; one file for both the certificate chain and 2518 

key) for Certificate Download Format. 2519 
42. Enter a password, and confirm the password. 2520 

 2521 
43. Click Create. 2522 
44. This will download a zip file. Unzip the file. 2523 
45. On the Stealthwatch Management Console (SMC) web console, under Additional SSL/TLS Client 2524 

Identities (where you downloaded the CSR), click Choose File. 2525 
46. Upload the certificate file from the zip file that has the hostname of the SMC in it; the file 2526 

extension should be .p12. 2527 
47. Enter a name for Friendly Name. 2528 
48. Enter the password used in ISE when generating the certificate. 2529 
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 2530 
49. Click Add Client Identity. 2531 

 2532 
50. Click Apply Settings. 2533 
51. Navigate back to the SMC web console home screen. 2534 
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 2535 
52. Navigate to Deploy > Cisco ISE Configuration. 2536 

 2537 
53. Click Add New Configuration. 2538 
54. Enter a Cisco ISE cluster name. 2539 
55. Select the certificate you just uploaded for Certificate. 2540 
56. Enter the IP Address of Cisco ISE for Primary pxGrid Node. 2541 
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57. Enter a username for the SMC to use. 2542 

 2543 
58. Click Save. 2544 
59. On the Cisco ISE web portal, navigate to Administration > pxGrid Services > All Clients.  2545 

 2546 
60. If the SMC client you just created says Pending, check the box next to it and click Approve. 2547 
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 2548 
61. The SMC Cisco ISE Configuration page will have a green status icon if it can successfully 2549 

authenticate to ISE.  2550 

2.16.2 Configuring Stealthwatch to Quarantine through ISE 2551 

1. Navigate to Operations > Adaptive Network Control > Policy List. 2552 

 2553 
2. Click Add. 2554 
3. Enter a name for a quarantine action. 2555 
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 2556 
4. Select QUARANTINE for the Action. 2557 

 2558 
5. Click Submit. 2559 
6. Navigate to Policy > Policy Sets. 2560 
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 2561 
7. Click the > arrow next to the default policy set. 2562 
8. Expand the Authorization Policy - Global Exceptions section. 2563 
9. Click the + plus sign to add a new policy. 2564 
10. Click the + plus sign under Conditions. 2565 
11. Select the field Session – ANCPolicy. 2566 
12. Select the quarantine action you just created for the Attribute value. 2567 

 2568 
13. Click Use. 2569 
14. Select the Deny Access profile; the profile selected here will be applied to the machine when 2570 

the machine is added to the quarantine group. 2571 
15. Select Quarantined_Systems for Security Groups. 2572 
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 2573 
16. Click Save. 2574 
17. In the SMC web console, click Monitor > Users. 2575 

 2576 
18. Select a user to quarantine. 2577 
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 2578 
19. Click a host to quarantine. 2579 

 2580 
20. Click Edit next to ISE ANC Policy.  2581 
21. From the drop down, select the quarantine action you created earlier. 2582 
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 2583 
22. Click Save. 2584 
23. This will apply the quarantine action to the machine. 2585 

2.17 Integration: Tripwire Log Center and Tripwire Enterprise 2586 

1. Create a user account in Tripwire Log Center by logging into Tripwire Log Center Console. 2587 

 2588 
2. Click the Administration Manager button. 2589 
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3. Click User Accounts. 2590 

 2591 
4. Click the Add button. 2592 
5. Enter the details of the user.  2593 

 2594 
6. Click Add. 2595 
7. Double-click the user account. 2596 
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 2597 
8. Click the Permissions tab. 2598 

 2599 
9. Click Edit list of permissions. 2600 
10. Select Databases. 2601 
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 2602 
11. Check the box next to View System Database. 2603 
12. Select API. 2604 

 2605 
13. Check the box next to Allow REST API Logon. 2606 
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 2607 
14. Click OK. 2608 
15. Click OK. 2609 
16. Log in to the Tripwire Enterprise web console. 2610 
17. Click Settings. 2611 

 2612 
18. Go to System > Log Management. 2613 
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19. Check the box next to Forward TE log messages to syslog. 2614 
20. Enter the hostname and port of the Tripwire Log Center server. The default port is 1468. 2615 
21. Check the box next to Allow TE to use information from Tripwire Log Center. 2616 
22. Enter the service address like this: https://arcsight-cons.di.ipdr:8091/tlc, replacing the 2617 

hostname with the hostname of your Tripwire Log Center server. 2618 
23. Enter the account information of the account just created for Tripwire Log Center. 2619 
24. You can use Test Connection to verify that the connection is working. 2620 

 2621 
25. Click Apply when finished. 2622 
26. Go back to the Tripwire Log Center Console. 2623 

https://arcsight-cons.di.ipdr:8091/tlc
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 2624 
27. Click Configuration Manager. 2625 
28. Click Resources > Tripwire Enterprise Servers. 2626 

 2627 
29. Click Add. 2628 
30. Enter a name for the server. 2629 
31. Enter the URL of the TE server. 2630 
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32. Enter the name of a user account on the TE server. The account must have the following 2631 
permissions: create, delete, link, load, update, view. 2632 

 2633 
33. Click Save. 2634 

2.18 Integration: Symantec ICA and ArcSight ESM 2635 

This section describes the integration of Symantec ICA and ArcSight ESM, to import data from ArcSight 2636 
into ICA for analysis. For the purposes of this build, we did not use ArcSight Logger, a tool which 2637 
provides a web API for other applications. Because of this, the standard integration between ICA and 2638 
ESM was unavailable. However, it is still possible to import CSV files exported from ArcSight into ICA, 2639 
and we will detail the process below. There are a few things to note when doing this import: 2640 

• On the version of Symantec ICA we are using, it is required to replace empty fields in the CSV 2641 
with NULL. This may be unnecessary in future updates. 2642 

• The CSV file should be in a location accessible to the ICA server. You can replace this file with a 2643 
new CSV file on a daily basis, and Symantec ICA has the capability to import the new data.  2644 

• The following integration details how to do it for a subset of fields on Active Directory logging 2645 
events, but the process can be expanded for your organization’s needs. 2646 

2.18.1 Export the CSV File from ArcSight Console 2647 

1. In ArcSight Console, find a connector which you wish to import events from. Right-click it, and 2648 
select Create Channel with Filter.  2649 

2. In the channel, apply any filters desired. 2650 
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 2651 
3. When finished, right-click any of the events in the channel, and select Export > Events in 2652 

Channel…. 2653 
4. Enter a name for the CSV file for File name:. 2654 
5. Select All in Channel for Rows:. 2655 
6. For Columns: either select a custom field-set to determine the output columns or leave the 2656 

default selected. 2657 

 2658 
7. Click OK. 2659 
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8. Move the file to the desired location for ICA to collect. (Ensure that if required for your version 2660 
of Symantec ICA, all empty fields are replaced with "NULL") For the purposes of this 2661 
demonstration, we moved it to C:\Temp\unprocessed on the Symantec ICA server. 2662 

2.18.2 Import the CSV File to Symantec ICA 2663 

1. On the Symantec ICA web console, navigate to Gear Icon > Integration. 2664 
2. Click the Data Sources tab. 2665 

 2666 
3. Select User Defined for Choose Data Source. 2667 
4. Click Create Data Source. 2668 
5. Select File System IW for the Data Source Type. 2669 
6. Enter a name for the data source for Data Source Label. 2670 
7. Enter the hostname of the Symantec ICA server for Server Name.  2671 
8. Select Windows/Active Directory for the Authentication Mode. 2672 
9. Enter the location for the downloaded CSV file for Download Directory (relative to the 2673 

Symantec ICA server). 2674 
10. Enter the location for the CSV file to be downloaded from for Source Folder (relative to the 2675 

Symantec ICA server). 2676 
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 2677 
11. Click Save. 2678 

 2679 
12. Right-click the newly created data source and select Create Query. 2680 
13. Enter a Query Name and Query Description. 2681 
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 2682 
14. If you specified the Source Folder correctly, you will see the CSV file listed. 2683 
15. Check the box next to any CSVs to import. 2684 

 2685 
16. Click Save. 2686 
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 2687 
17. Click OK. 2688 
18. If desired, set a schedule for this import. 2689 

 2690 
19. Click Save. 2691 
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 2692 
20. Click Yes. 2693 

 2694 
21. Click OK. 2695 

2.18.3 Create a Mapping between ArcSight events and Symantec ICA 2696 

1. Navigate to the Data Integrations tab. 2697 
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 2698 
2. Click Create Integration Pack. 2699 
3. Enter a Name and Description. 2700 

 2701 
4. Click Save. 2702 
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 2703 
5. Right-click the newly created Integration Pack, and select Create Import Rule. 2704 
6. Enter a Name and Description. 2705 

 2706 
7. Click Save. 2707 
8. Right-click the newly created Import Rule and select Create Import Rule Mapping. 2708 
9. Enter a Name for the mapping. 2709 
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10. Enter a Description. 2710 
11. Select the Data Source created earlier. 2711 
12. Select the Query created earlier. 2712 
13. Select EP Events for the Entity Type (or explore other Entity Types that may better match the 2713 

events you are importing). 2714 

 2715 
14. Below, the Entity Column refers to the target field in ICA to which a field is being mapped. Map 2716 

event fields from the CSV to fields in the Entity Column. 2717 
15. For example, EventDate in ICA corresponds directly to the End Time in ArcSight, so we select 2718 

that value directly as a Source Column for the mapping. 2719 
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 2720 
16. Formulas can be used to transform columns in the CSV to something more specific in ICA. 2721 

Because we did not export an event ID to our CSV file, we use a formula to create a hash of the 2722 
End Time and use that as the ID. 2723 

17. All Required Fields must be mapped, and you will likely also want to map some optional fields 2724 
to make useful data. 2725 

 2726 
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18. Click Save when finished. 2727 
19. Navigate to the Job Status tab.  2728 

 2729 
20. Select all the jobs and click Start. This is to force a refresh of the ICA processing, allowing the 2730 

data from the CSV to be imported immediately. 2731 

2.18.4 View ArcSight Events in the Analyzer 2732 

1. Once the processing jobs are finished, navigate to the Analyzer. 2733 
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 2734 
2. Drag mapped columns (from the import rule mapping you created) from the list on the right to 2735 

view them in the analyzer. 2736 

2.19 Integration: Micro Focus ArcSight and Tripwire 2737 

This section will detail the forwarding of logs from Tripwire Log Center to Micro Focus ArcSight. This 2738 
will forward Tripwire IP360 and Tripwire Enterprise logs to ArcSight, assuming those logs are being 2739 
collected by Tripwire Log Center.  2740 

2.19.1 Install Micro Focus ArcSight  2741 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe on any server except the one running 2742 
Tripwire Log Center. 2743 
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 2744 
2. Click Next. 2745 

 2746 
3. Enter C:\Program Files\ArcSightSmartConnectors\Tripwire. 2747 
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 2748 
4. Click Next. 2749 

 2750 
5. Click Install. 2751 
6. Select Add a Connector. 2752 
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 2753 
7. Click Next. 2754 
8. Select Syslog Daemon.  2755 

 2756 
9. Click Next. 2757 
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10. Enter a port for the daemon to run on. 2758 
11. Select Raw TCP for Protocol. 2759 

 2760 
12. Click Next. 2761 
13. Select ArcSight Manager (encrypted).  2762 
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 2763 
14. Click Next. 2764 
15. Enter the hostname, port, username, and password for the ArcSight ESM server.  2765 

 2766 
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16. Click Next. 2767 
17. Enter identifying details about the system (only Name is required). 2768 

 2769 
18. Click Next.  2770 
19. Select Import the certificate to connector from destination. 2771 
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 2772 
20. Click Next.  2773 

 2774 
21. Click Next.  2775 
22. Select Install as a service. 2776 
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 2777 
23. Click Next.  2778 

 2779 
24. Click Next.  2780 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 380 

 2781 
25. Click Next.  2782 
26. Select Exit. 2783 

 2784 
27. Click Next.  2785 
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 2786 
28. Click Done. 2787 
29. Open the Tripwire Log Center Console. 2788 
30. Go to the Configuration Manager. 2789 

 2790 
31. Select Resources > Managers. 2791 
32. Double-click the Primary Manager. 2792 
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33. Click the Advanced Settings tab. 2793 

 2794 
34. Click the Add button. 2795 
35. In the Advanced Option box select Log Message Forwarding – Destinations. 2796 
36. In the Value box next to it, type <ip_address>:<port>:tcp with the IP address and port of the 2797 

syslog daemon just created.  2798 

 2799 
37. Click OK. 2800 
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 2801 
38. Click OK.  2802 
39. Restart the Tripwire Log Center Manager.  2803 

2.20 Integration: Micro Focus ArcSight and Cisco AMP 2804 

This section will detail the collection of logs from Cisco AMP’s REST APIs using Micro Focus ArcSight.  2805 

2.20.1 Create API Credentials for ArcSight to access AMP 2806 

1. On the Cisco AMP web console, log in and navigate to Accounts > API Credentials. 2807 

 2808 
2. Click New API Credential.  2809 
3. Enter a name for the credential. 2810 
4. Select Read-only. 2811 
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 2812 
5. Click Create. 2813 
6. This will direct you to a page with an ID and API Key. Keep track of these, as you will need them 2814 

in the setup for the ArcSight Connector, and Cisco AMP may not let you view them again.  2815 

2.20.2 Install Micro Focus ArcSight  2816 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe on any server.2817 

 2818 
2. Click Next. 2819 
3. Enter C:\Program Files\ArcSightSmartConnectors\CiscoAMP. 2820 
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 2821 
4. Click Next. 2822 

 2823 
5. Click Next. 2824 
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 2825 
6. Click Install. 2826 
7. Select Add a Connector. 2827 

 2828 
8. Click Next. 2829 
9. Select ArcSight FlexConnector REST.  2830 
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 2831 
10. Click Next. 2832 
11. Enter Cisco_AMP for the Configuration File. 2833 
12. Enter https://api.amp.cisco.com/v1/events?start_date=$START_AT_TIME for the Events URL. 2834 

(Note: You can see the Cisco AMP REST API documentation for more information on how to 2835 
formulate this URL for things other than events.) 2836 

13. Enter the username and password from the credential generated on Cisco AMP in Section 2837 
2.20.1. 2838 
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 2839 
14. Click Next. 2840 
15. Select ArcSight Manager (encrypted).  2841 

 2842 
16. Click Next. 2843 
17. Enter the hostname, port, username, and password for the ArcSight ESM server.  2844 
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 2845 
18. Click Next. 2846 
19. Enter identifying details about the system (only Name is required). 2847 

 2848 
20. Click Next.  2849 
21. Select Import the certificate to connector from destination. 2850 
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 2851 
22. Click Next.  2852 
23. Click Next.  2853 
24. Select Install as a service. 2854 

 2855 
25. Click Next.  2856 
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26. Enter a service name and display name. 2857 

 2858 
27. Click Next.  2859 

 2860 
28. Click Next.  2861 
29. Select Exit.  2862 
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 2863 
30. Click Next.  2864 

 2865 
31. Click Done. 2866 

2.20.3 Create a Parser for Cisco AMP REST events 2867 

1. Ensure that the ArcSight connector service is not running.  2868 
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2. Create a text file located at 2869 
<ARCSIGHT_HOME>/current/user/agent/flexagent/Cisco_AMP.jsonparser.properties. (Note: 2870 
Replace Cisco_AMP with the name used for “Configuration File” during setup.) 2871 

3. Use the following text to parse some basic information such as the IP, the type of event, and 2872 
links to Cisco AMP’s more detailed descriptions of the event. 2873 

trigger.node.location=/data 2874 
token.count=6 2875 
 2876 
token[0].name=id 2877 
token[0].type=String 2878 
token[0].location=id 2879 
 2880 
token[1].name=timestamp 2881 
token[1].type=String 2882 
token[1].location=date 2883 
 2884 
token[2].name=event_type 2885 
token[2].type=String 2886 
token[2].location=event_type 2887 
 2888 
token[3].name=hostname 2889 
token[3].type=String 2890 
token[3].location=computer/hostname 2891 
 2892 
token[4].name=external_ip 2893 
token[4].type=IPAddress 2894 
token[4].location=computer/external_ip 2895 
 2896 
token[5].name=links 2897 
token[5].type=String 2898 
token[5].location=links 2899 
 2900 
event.deviceReceiptTime=__createOptionalTimeStampFromString(timestamp,"y2901 
yyy-MM-dd'T'HH:mm:ssX") 2902 
event.destinationAddress=external_ip 2903 
event.destinationHostName=hostname 2904 
event.name=event_type 2905 
event.message=links 2906 
event.deviceCustomString1=id 2907 
event.deviceCustomString1Label=__stringConstant("AMP Event ID") 2908 
 2909 

4. This parser will allow for details of Cisco AMP events to be shown in ArcSight. Custom parsers 2910 
are a functionality of ArcSight. For more information on the creation of custom parsers, please 2911 
see the ArcSight FlexConnector Developer’s Guide as well as the FlexConnector REST Developer’s 2912 
Guide. You can start the service for these changes to take effect. 2913 

2.21 Integration: Micro Focus ArcSight and Cisco ISE 2914 

This integration will briefly detail how to send logs to an ArcSight syslog collector from Cisco ISE. Please 2915 
see Section 2.18 (under integrating Tripwire & ArcSight) for instructions for setting up an ArcSight syslog 2916 
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collector. If a server is already configured, you do not need to install a new one—simply use the address 2917 
of that server to which to forward logs. 2918 

2.21.1 Configure Cisco ISE to Forward Logs 2919 

1. In the Cisco ISE web client, navigate to Administration > System > Logging > Remote Logging 2920 
Targets. 2921 

 2922 
2. Click Add. 2923 
3. Enter a name for Name. 2924 
4. Enter the hostname of the ArcSight syslog collector server for Host/IP Address. 2925 
5. Select TCP SysLog for Target Type. (Ensure that your syslog collector server is configured to use 2926 

TCP). 2927 
6. Enter 514 or the port used on the syslog server. 2928 
7. Enter 8192 or a custom message size limit for Maximum Length. 2929 
8. Ensure that Status is set to Enabled. 2930 
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 2931 
9. Click Submit. 2932 

 2933 
10. Click Yes. 2934 

2.21.2 Select Logs for Forwarding 2935 

1. Navigate to System > Logging > Logging Categories. 2936 
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 2937 
2. Select a log file to forward to ArcSight. 2938 
3. Click Edit. 2939 

 2940 
4. Move the ArcSight logging target you just created to the Selected box. 2941 
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 2942 
5. Click Save. 2943 
6. Repeat steps 1-5 for any log files you wish to forward to ArcSight. 2944 

2.22 Integration: Micro Focus ArcSight and Semperis DSP 2945 

This integration will briefly detail how to send logs to an ArcSight syslog collector from Semperis DSP. 2946 
Please see Section 2.18 (under integrating Tripwire & ArcSight) for instructions for setting up an 2947 
ArcSight syslog collector. If a server is already configured, you do not need to install a new one—simply  2948 
use the address of that server to which to forward logs. 2949 

Note: This integration requires Semperis DSP version 2.6.  2950 

2.22.1 Configure Semperis DSP to Forward Logs 2951 

1. In Semperis DSP, navigate to Settings > SIEM Integration. 2952 
2. Check the box next to Enable SysLog. 2953 
3. Under Syslog Server, enter the hostname for the ArcSight syslog collector, as well as the port. 2954 
4. Select TCP. 2955 
5. Enter a value for Change Event Polling Frequency based on the needs of your organization; this 2956 

is how often it will poll for new logs to forward.  2957 
6. Under Change Event Filtering, select AD Changed Items, and Send Operation Log to SysLog. 2958 

Ensure that All is selected for Partitions. 2959 
7. You can also select any specific operations, classes, and attributes to be forwarded or simply 2960 

leave it as All. 2961 
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 2962 
8. Click Save.  2963 

 2964 
9. Click Close.  2965 

2.23 Integration: Micro Focus ArcSight and Symantec Analytics 2966 

This section will first detail the forwarding of logs from Symantec Analytics to Micro Focus ArcSight. 2967 
Please see section 2.18 (under integrating Tripwire & ArcSight) for instructions for setting up an 2968 
ArcSight syslog collector. If a server is already configured, you do not need to install a new one; simply 2969 
use the address of that server to which to forward logs. 2970 

The second part of this section will detail a further integration for ArcSight that allows ArcSight to better 2971 
analyze network packets received from Symantec Analytics. 2972 

2.23.1 Configure Symantec Analytics to Forward Logs 2973 

1. Log in to the Symantec Analytics web console.  2974 
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 2975 
2. Click the menu icon in the top left. 2976 
3. Navigate to Settings > Communication. 2977 
4. Scroll down to the Syslog Settings section. 2978 
5. Select SysLog for Syslog Facility. 2979 
6. Enter the hostname or IP of the ArcSight syslog collector server under Server. 2980 
7. Enter 514 for the port. 2981 
8. Select TCP for the protocol. 2982 

 2983 
9. Click Save. 2984 
10. Click the Advanced tab. 2985 
11. Select the box under Remote Syslog column for any events that you wish to forward to 2986 

ArcSight, for example, System Events, Unclassified Events, Alert Events, Rule Events, Anomaly 2987 
Events. 2988 



DRAFT 

NIST SP 1800-26C: Data Integrity: Detecting and Responding to Ransomware and Other Destructive Events 400 

 2989 
12. Click Save. 2990 

2.23.2 Install Symantec Analytics Package for ArcSight 2991 

1. Navigate to the ArcSight marketplace. Look for the “Blue Coat Security Analytics” package for 2992 
ArcSight. It may be available here: https://marketplace.microfocus.com/arcsight/content/blue-2993 
coat-security-analytics-platform but not please contact your ArcSight representative to get the 2994 
package. The package should be called Blue_Coat_SA_HP_ArcSight-3.0.arb. 2995 

2. Place this package on a system with ArcSight ESM Console installed.  2996 

 2997 
3. Log in to the ArcSight ESM Console with a user that has the privileges to install packages. 2998 

https://marketplace.microfocus.com/arcsight/content/blue-coat-security-analytics-platform
https://marketplace.microfocus.com/arcsight/content/blue-coat-security-analytics-platform
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 2999 
4. In the Navigator pane, click the Packages tab. 3000 

 3001 
5. Click Import. 3002 
6. In the window that it opens, find and select the package you downloaded. 3003 
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 3004 
7. Click Open. 3005 
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 3006 
8. Click OK when the import finishes. 3007 
9. Under the Packages tab in the Navigator pane, navigate to Packages > Shared > All Packages > 3008 

Blue Coat Systems > Blue Coat Security Analytics. 3009 
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 3010 
10. Right-click Blue Coat Security Analytics, and select Install Package. 3011 

 3012 
11. Click OK. 3013 
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 3014 
12. Click OK. 3015 
13. When this completes, you can verify that the installation was successful by the existence of a 3016 

Blue Coat Systems folder when you navigate to Resources > Integration Commands > 3017 
Commands > Shared > All Integration Commands. 3018 

14. In the Resources tab of the Navigation pane, under Integration Commands, select the Targets 3019 
tab. 3020 

15. Navigate to Integration Targets > Shared > All Integration Targets > Blue Coat Systems > Blue 3021 
Coat Security Analytic > Blue Coat Security Analytics. 3022 
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 3023 
16. Right-click Blue Coat Security Analytics, and click Edit Target. 3024 

 3025 
17. Click the Integration Parameters tab. 3026 
18. Replace the SAHost value with the IP address of Symantec Analytics. 3027 
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 3028 
19. Click OK. 3029 
20. To verify the functionality, right-click an event in any channel, and select Integration 3030 

Commands > Blue Coat Security Analytics.  3031 

 3032 
21. Select Security Analytics Investigation. 3033 
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 3034 
22. Click OK. This will open Security Analytics in the browser and perform a packet search based on 3035 

the event parameters.  3036 

2.24 Integration: Micro Focus ArcSight and Glasswall FileTrust 3037 

Glasswall FileTrust for Email stores its logs in C:\Logging, on the server running the Glasswall services.  3038 

2.24.1 Install Micro Focus ArcSight  3039 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe on the same server as Glasswall FileTrust. 3040 
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 3041 
2. Click Next. 3042 
3. Enter C:\Program Files\ArcSightSmartConnectors\Windows. 3043 

 3044 
4. Click Next.  3045 
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 3046 
5. Click Next. 3047 
6. Click Install. 3048 
7. Select Add a Connector. 3049 
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 3050 
8. Click Next. 3051 
9. Select Syslog File.  3052 
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 3053 
10. Click Next. 3054 
11. Enter C:\Logging\gw-inbound-smtp-analysis-agent.current.log for File Absolute Path Name. 3055 
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 3056 
12. Click Next. 3057 
13. Select ArcSight Manager (encrypted).  3058 
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 3059 
14. Click Next. 3060 
15. Enter the hostname, port, username, and password for the ArcSight ESM server.  3061 
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 3062 
16. Click Next. 3063 
17. Enter identifying details about the system (only Name is required). 3064 
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 3065 
18. Click Next.  3066 
19. Select Import the certificate to connector from destination. 3067 
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 3068 
20. Click Next.  3069 
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 3070 
21. Click Next.  3071 
22. Select Install as a service. 3072 
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 3073 
23. Click Next.  3074 
24. Change the service parameters to more appropriate names, because multiple connectors need 3075 

to be installed on this server. 3076 
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 3077 
25. Click Next.  3078 
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 3079 
26. Click Next.  3080 
27. Select Exit. 3081 
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 3082 
28. Click Next.  3083 

 3084 
29. Click Done.  3085 
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30. Repeat steps 1-29 for the other three “current” log files in C:\Logging, with the following 3086 
caveats: 3087 

a. Replace C:\Program Files\ArcSightSmartConnectors\Windows with a different folder 3088 
name for each connector.  3089 

b. Replace C:\Logging\gw-inbound-smtp-analysis-agent.current.log with the appropriate 3090 
log file. 3091 

i. C:\Logging\gw-management-service.current.log 3092 
ii. C:\Logging\gw-file-analysis-process-InboundSMTPAgent-0.current.log 3093 

iii. C:\Logging\gw-administration-console.current.log 3094 
c. Replace the Name of the connector in its identifying details. 3095 
d. Replace the service parameters with different names so that the services do not 3096 

conflict.  3097 

2.25 Integration: Micro Focus ArcSight and Cisco Stealthwatch 3098 

This section will detail the forwarding of logs from Cisco Stealthwatch to Micro Focus ArcSight.  3099 

2.25.1 Install Micro Focus ArcSight  3100 

1. Run ArcSight-7.9.0.8084.0-Connector-Win64.exe on any server except the one running Cisco 3101 
Stealthwatch. 3102 

 3103 
2. Click Next. 3104 
3. Enter C:\Program Files\ArcSightSmartConnectors\WindowsUDP. 3105 
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 3106 
4. Click Next. 3107 

 3108 
5. Click Next. 3109 
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 3110 
6. Click Install. 3111 
7. Select Add a Connector. 3112 

 3113 
8. Click Next. 3114 
9. Select Syslog Daemon.  3115 
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 3116 
10. Click Next. 3117 
11. Enter an unused port for the daemon to run on. (Ensure that this port is allowed through the 3118 

firewall.) 3119 
12. Select UDP for Protocol. 3120 

 3121 
13. Click Next. 3122 
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14. Select ArcSight Manager (encrypted).  3123 

 3124 
15. Click Next. 3125 
16. Enter the hostname, port, username, and password for the ArcSight ESM server.  3126 

 3127 
17. Click Next. 3128 
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18. Enter identifying details about the system (only Name is required). 3129 

 3130 
19. Click Next.  3131 
20. Select Import the certificate to connector from destination. 3132 

 3133 
21. Click Next.  3134 
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22. Click Next.  3135 
23. Select Install as a service. 3136 

 
24. Click Next.  3137 
25. Enter a service name and display name. 3138 
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26. Click Next.  3139 

 
27. Click Next.  3140 
28. Select Exit.  3141 
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29. Click Next.  3142 

 
30. Click Done. 3143 
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2.25.2 Configure Cisco Stealthwatch 3144 

1. Log in to the Cisco Stealthwatch Management Console desktop interface. (This can be 3145 
downloaded from the web interface and run using javaws.exe. You may need to add the site to 3146 
your Java exceptions in Control Panel > Java.)  3147 

2. Click Configuration > Response Management. 3148 

 
3. Click Actions. 3149 
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4. Click Add. 3150 
5. Select ArcSight Common Event Format (CEF). 3151 

 
6. Click OK. 3152 
7. Enter a name for the Action. 3153 
8. Enter a description. 3154 
9. Enter the IP address of the server with the UDP ArcSight Connector that you just created. 3155 
10. Enter the port used in the UDP ArcSight Connector that you just created. 3156 
11. (Optional) Click Test to send a test message to ArcSight, and verify that ArcSight receives the 3157 

message. 3158 
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12. Click OK. 3159 
13. Verify that the action was created properly. 3160 

 
14. Click Rules. 3161 
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15. Click Add. 3162 
16. Select Host Alarm. 3163 

 
17. Click OK. 3164 
18. Enter a name. 3165 
19. Enter a description. 3166 
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20. Click Actions.  3167 

 
21. Click the Add button for the top section; this adds an action when the alarm becomes active. 3168 
22. Select the ArcSight CEF rule you just created. 3169 
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23. Click OK. 3170 

 
24. Click the Add button for the bottom section; this adds an action when the alarm becomes 3171 

inactive. 3172 
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25. Select the ArcSight CEF rule you just created. 3173 

 
26. Click OK. 3174 
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27. Click OK. 3175 

 
28. Click Close.3176 
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Appendix A List of Acronyms 3177 

AD Active Directory 
AMP Advanced Malware Protection 
CEF Common Event Format 
DNS Domain Name System 
DSP Directory Services Protector 
ESM Enterprise Security Manager 
ICA Information Centric Analytics 
IIS Internet Information Services 
ISE Identity Services Engine 
IT Information Technology 
JCE Java Cryptography Extension 
JRE Java Runtime Environment 
MSSQL Microsoft SQL 
NCCoE National Cybersecurity Center of Excellence 
NIST National Institute of Standards and Technology 
OS Operating System 
PEM Privacy Enhanced Mail 
SAN Subject Alternative Name 
SMC Stealthwatch Management Console 
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